none
Problema accesso risorsa condivisa RRS feed

  • Domanda

  • Buongiorno,

    ho un problema con un cliente con la seguente configurazione:

    - Windows Server 2012 Standard con 3 macchine virtuali gestite, un sbs 2011 e 2 server 2012.

    Uno dei due server 2012 è utilizzato come server file e da qualche tempo l'accesso alla condivisione si blocca improvvisamente e non c'è modo di accedervi se non riavviando il server. Il server è configurato con un disco di partenza (standard ide) e uno scsi con dentro i dati condivisi. Se accedo al server lo trovo ancora utilizzabile finchè non entro nel disco che contiene i dati che si blocca. In qualsiasi caso devo effettuare uno spegnimento forzato perchè la macchina non vuole saperne di spegnersi con il classico shutdown. Se guardo il registro trovo costantemente un errore di raid sulla porta 0 ma stranamente non ho nessun raid attivo nella macchina virtuale.

    Ho fatto i seguenti test per capire se potevo risolvere il problema ma con scarso successo:

    - utilizzato un disco a dimensione fissa anzichè dinamica

    - rimosso antivirus

    - suddiviso i dati in due dischi virtuali

    Altro: Nel server è installato un connettore pop3 di terze parti per il download delle mail e la rete a cui è collegato è un teaming di 3 schede di rete utilizzate anche dagli altri server senza problemi.

    Avete suggerimenti? Grazie e buona giornata

    mercoledì 14 gennaio 2015 13:50

Risposte

  • Buongiorno a tutti,

    posso finalmente confermare che il problema è stato causato da un programma di terze parti utilizzato come connettore pop3 per il download della posta. Il programma citato è Examail pop3 downloader, fà bene il suo lavoro ma secondo me non è pienamente compatibile con il 2012. Da quando ho spostato l'installazione dal server 2012 all'sbs i problemi di accesso alle cartelle condivise del file server non si sono verificati.

    Grazie dell'aiuto prestato e buona giornata a tutti

    lunedì 9 marzo 2015 07:33

Tutte le risposte

  • Ciao, guarda non è molto chiaro come hai partizionato il discorso, se ho capito bene, correggimi se sbaglio:

    1 server 2012 che fa solo da hyper-v su cui hai 3 VM

    1 2011 SBS

    2 2012 che sono le licenze del 2012 virtualizzato.

    Di questi uno ha 1 disco ide? In che senso? Fisicamente IDE? Perchè scusa parliamo di dischi che hanno almeno 10 anni, prestazioni bassissime e fuori garanzia da una vita, il problema (se ho capito bene) potrebbe risiedere proprio sull'IDE che spesso viene identificato come disco 0. Partendo dal presupposto che un server deve avere un piano di garanzia attiva come fai ad avere un IDE sopra? 

    Forse ho capito male...facci sapere.

    Ciao.

    A.

    mercoledì 14 gennaio 2015 17:01
    Moderatore
  • Ciao,

    la configurazione è corretta ma forse non mi sono spiegato bene con quella del disco. Il disco è su canale IDE "virtualizzato" poichè le virtual machine di Microsoft non possono fare il boot altrimenti.

    Il server utilizza dei dischi sas sul quale è installato windows server 2012 con hyper-v.

    Spero di aver chiarito. Grazie dell'aiuto.

    Buona giornata

    Luca

    giovedì 15 gennaio 2015 09:59
  • ok, più chiaro ora. Che può freezare un server fisico o virtuale senza possibilità di replica di solito è un problema hardware. Io controllerei molto bene coi tool del raid della macchina che tu non abbia qualcosa che non va sui dischi o che non ce ne sia uno in prefail e contatterei il supporto del brand per un'analisi approfondita intanto. Non è secondo me una cosa che risolviamo via sistema operativo, è ancora prima qui per me il sistema non c'entra, virtuale poi è molto difficile che si blocchi se non ci sono danni hw. Dipende tutto da che tools hai di analisi su quella macchina.

    Ciao.

    A.

    giovedì 15 gennaio 2015 10:13
    Moderatore
  • provo anch'io a vedere se ho capito: il server con il problema è uno dei due virtuali e il problema si verifica solo quando dal server stesso o dalla rete accedi ai dati sul disco (virtuale) scsi. fino a quando non accedi a questo disco il problema non si verifica e il server virtuale funziona. giusto ?

    puoi riportare l'errore che trovi per intero ?


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    venerdì 16 gennaio 2015 11:39
    Moderatore
  • Grazie Alessandro per la risposta,

    per fare una prova e capire se il problema era hardware legato alla scheda o ai dischi ho montato un disco sata 3 (al di fuori della scheda raid) dove ho spostato il disco virtuale ma il problema si ripresenta ugualmente e ogni tanto. La cosa strana è che quando la risorsa di rete non è più accessibile io posso collegarmi al server virtuale e lui funziona. Provo a riavviarlo ma si pianta nello spegnimento e quindi devo forzarlo. L'unica cosa diversa che noto è che questo disco virtuale che si blocca contiene file di autocad che possono essere supreiori ai 100 mb, può creare problemi?

    Grazie e buona giornata

    Luca

    lunedì 19 gennaio 2015 10:10
  • Grazie Edoardo,

    il problema purtroppo accade in modo irregolare (es. 3 volte al giorno oppure 3 volte alla settimana) e a quella cartella gli utenti accedono costantemente. Stamattina è capitato nuovamente e, contrariamente alle volte precedenti) oltre all'errore di Kernel Power dovuto al riavvio forzato non ho trovato altre segnalazioni. La segnalazione che trovavo sempre era la classica di attenzione perchè non riesce ad effettuare il paging sul disco 0. Grazie per l'aiuto.

    Buona giornata

    Luca

    lunedì 19 gennaio 2015 10:21
  • forse non sono ancora riuscito a capire bene la situazione: il disco scsi che crea il problema è fisico o stiamo parlando di un disco virtuale ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 20 gennaio 2015 14:18
    Moderatore
  • Ciao Luca,

    Non abbiamo ricevuto alcun aggiornamento e mi chiedevo se possiamo aiutarti ulteriormente o se il tuo quesito è stato risolto.
    Se così fosse ti saremmo grati di condividere il feedback in questo spazio ricordandoti che altri membri della community potrebbero riscontrare comportamenti simili.

    Grazie in anticipo.


    • Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è e non comporta alcuna responsabilità da parte dell’azienda.

    venerdì 23 gennaio 2015 09:02
  • Ciao Edoardo,

    i dischi sono virtuali per i server virtualizzati. I dischi virtuali sono salvati su un raid 10 formato da 4 dischi, per effettuare le prove e capire se il problema è hardware (quindi legato ai 4 dischi fisici) ho provato ad aggiungere un ulteriore disco (al di fuori del raid) e ho trasferito il file del disco virtuale (.vhdx) contenente le risorse condivise in rete incriminate, il risultato è lo stesso: saltuariamente si blocca. In questi giorni ho trasferito sul server sbs il connettore di posta responsabile del passaggio mail dal server del provider all'exchange per vedere se potesse essere la causa di queste anomalie. Ti aggiorno tra un paio di settimane (dopo un pò di test) per vedere che succede.

    Grazie e buona giornata

    Luca

    martedì 27 gennaio 2015 10:01
  • Non ho ancora aggiornamenti positivi da dare, appena possibile lo farò molto volentieri.

    Buona giornata

    Luca

    martedì 27 gennaio 2015 10:02
  • a me resta il forte dubbio di un problema hardware alla macchina...magari sul controller...io farei un giro di aggiornamento driver\firmware\bios e poi in caso proverei a contattare il supporto hw per una diagnosi...perchè se sia sul raid che sul sata hai il problema non è dovuto all'hyper-v secondo me ma è ad un livello inferiore...quello fisico.

    Ciao.

    A.

    martedì 27 gennaio 2015 10:59
    Moderatore
  • hai provato a farti una copia del vhdx che si pianta e a montarlo su un'altra vm che stia su un host fisico diverso ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    giovedì 29 gennaio 2015 08:22
    Moderatore
  • Buongiorno a tutti,

    posso finalmente confermare che il problema è stato causato da un programma di terze parti utilizzato come connettore pop3 per il download della posta. Il programma citato è Examail pop3 downloader, fà bene il suo lavoro ma secondo me non è pienamente compatibile con il 2012. Da quando ho spostato l'installazione dal server 2012 all'sbs i problemi di accesso alle cartelle condivise del file server non si sono verificati.

    Grazie dell'aiuto prestato e buona giornata a tutti

    lunedì 9 marzo 2015 07:33
  • grazie per aver aggiornato il thread e condiviso la soluzione con la community.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    lunedì 9 marzo 2015 08:02
    Moderatore