none
Exchange 2013 - OWA timeout session RRS feed

  • Domanda

  • Buongiorno,

    per verificare il timeout delle sessioni OWA, ho i seguenti valori:

    Get-OrganizationConfig | FL ActivityBasedAuthenticationTimeout*

    ActivityBasedAuthenticationTimeoutEnabled                 : True
    ActivityBasedAuthenticationTimeoutInterval                : 06:00:00
    ActivityBasedAuthenticationTimeoutWithSingleSignOnEnabled : True

    ***********************************************************

    HKLM:\SYSTEM\CurrentControlSet\Services\MSExchange OWA” -Name PrivateTimeout = 30

    HKLM:\SYSTEM\CurrentControlSet\Services\MSExchange OWA” -Name PublicTimeout = 30

    ***********************************************************

    Get-OwaVirtualDirectory | select name, server,logonp*, *timeout* | fl

    Name                                   : owa (Default Web Site)
    Server                                 : mioserver
    LogonPagePublicPrivateSelectionEnabled : True
    LogonPageLightSelectionEnabled         : False
    UserContextTimeout                     : 60

    ***********************************************************

    Tenendo presente che c'è il parametro "LogonPagePublicPrivateSelectionEnabled" :true, ho notato un differente comportamento del timeout dalla sessioni interne da quelle esterne alla sede del Client.

    Se non ricordo male il valore di default per i private computer è 8h mentre per i public è 15 minuti.

    Nel mio caso, ho trovato le key modificate come sopra.

    Quale è il riferimento reale del timeout? Anche in ottica di modifica.

    Grazie per il supporto

    sabato 10 febbraio 2018 09:24

Tutte le risposte

  • Ciao

    Leggi se può illuminarti

    https://blog.messageware.com/the-public-vs-private-dilemma-in-owa

    sabato 10 febbraio 2018 10:01
  • Il timeout di default è 8 ore per profilo privato e 15 minuti per quello pubblico. Non vedo in realtà necessità di andarli a modificare...ma tant'è...

    ciao.

    A.

    sabato 10 febbraio 2018 10:17
    Moderatore
  • Buongiorno Marco ed Alessandro,

    grazie per le risposte.

    Nel mio caso, essendo profilo privato, il timeout ricade nelle 8h; quindi se la sessione si chiude prima, evidentemente c'è dell' altro al di fuori di exchange.

    E' solo che vendendo i parametri impostati nel registro di configurazione e su Exchange, i conti non tornavano.

    Non devo modificare nulla, al momento; ma in caso di modifica, quale parametro è corretto modificare?

    Grazie ancora

    sabato 10 febbraio 2018 10:27
  • http://techgenix.com/how-configure-public-and-private-computer-settings-owa-2013/

    ciao.

    A.

    sabato 10 febbraio 2018 10:55
    Moderatore
  • Ciao Alessandro,

    grazie per i link; questa la configurazione attuale:

    Il timeout è impostato a 30 minuti.

    In realtà la sessione, in caso di mancato utilizzo, dura molto di più; dall' esterno della Sede, quindi utilizzando una connessione Internet, arriva a quasi 50 minuti e poi si disconnette proponendo la login page.

    Anche internamente, stessa cosa; probabilmente o il firewall esterno o il bilanciatore interno dettano i timeout della sessione modificando di fatto le 8h; ma a questo punto i trenta minuti nel registry?

    Grazie ancora

    sabato 10 febbraio 2018 11:20
  • Guarda, come ti dicevo non paciugo mai con le chiavi di registro sui server exchange: troppo rischioso. Se nessuno ha modificato il server i valori sono quelli suggeriti. se ha comportamenti diversi firewall magari che c'è in mezzo. Ma li mi fermo, se poi hai un balancer, chi lo sa come lavora? non sono domande da forum exchange sono più da mago dell'IT :-) anche perchè penso che sia una problematica che hai da sempre. 

    Più di così non posso aiutarti, non credo che i colleghi possano andare oltre, ma in caso ci proveranno.

    ciao.

    A.

    sabato 10 febbraio 2018 11:54
    Moderatore
  • Ciao Alessandro,

    le info comunicate sono utilissime.

    Ora verifico con i colleghi del network il firewall perimetrale e il balancer cisco interno dove insiste il dag Exchange.

    Comunque, Ti confermo che le sessioni interne ed esterne quando non utilizzate, si disconnettono dopo 46 minuti. Quindi, i parametri del registry non sono "letti" ma vale il valore di default delle 8h per i Private Computer.

    Poi il fatto che sono 46 i minuti, vedo io internamente.

    Per il momento, grazie tanto.


    sabato 10 febbraio 2018 12:18
  • Buonasera Alessandro,

    aggiungo un altro particolare.

    Se accedo ad OWA direttamente da uno dei nodi DAG in https://localhost/owa, il tempo di disconnessione in caso di mancato utilizzo è sempre 46 minuti circa, come l' accesso dall' esterno o come se accedo direttamente dal VIP interno.

    Grazie ancora

    domenica 11 febbraio 2018 18:52