none
Exchange 2010 non riesce a spedire mail a Exchange 2007 durante la fase di migrazione RRS feed

  • Domanda

  • Team,

    ho due server in che coesistono, uno Exchange 2010 e l'altro Exchange 2007  dopo varie prove ho verificato che l'unico problema è l'invio dei messaggi da EX 2010 > EX 2007.

    dopo verie verigiche ho scopero che i messaggi rimangono nella code con il seguente messaggio:"451 4.4.0 Primary target IP Address repsonded with: "421 4.4.2 Connection dropped due to SoketError. "Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts."

    ho trovato discussioni approposito di questo problema ma nessuna riportava una soluzione che per me funzionasse.

    vi allego il log dopo aver attivato il seguente comando:

    Set-TransportServer –Identity NET-xx04 -IntraOrgConnectorProtocolLoggingLevel verbose

    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,2,192.x.y.4:30417,192.x.y.5:25,<,"220 net-xxxx-01.XXXXXXXXXXX.it Microsoft ESMTP MAIL Service ready at Sun, 31 Mar 2013 23:26:14 +0200",
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,3,192.x.y.4:30417,192.x.y.5:25,>,EHLO NET-xx04.XXXXXXXXXXX.it
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,4,192.x.y.4:30417,192.x.y.5:25,<,250-net-xxxx-01..XXXXXXXXXXX.it Hello [192.x.y.4],
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,5,192.x.y.4:30417,192.x.y.5:25,<,250-SIZE,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,6,192.x.y.4:30417,192.x.y.5:25,<,250-PIPELINING,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,7,192.x.y.4:30417,192.x.y.5:25,<,250-DSN,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,8,192.x.y.4:30417,192.x.y.5:25,<,250-ENHANCEDSTATUSCODES,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,9,192.x.y.4:30417,192.x.y.5:25,<,250-STARTTLS,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,10,192.x.y.4:30417,192.x.y.5:25,<,250-X-ANONYMOUSTLS,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,11,192.x.y.4:30417,192.x.y.5:25,<,250-AUTH NTLM,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,12,192.x.y.4:30417,192.x.y.5:25,<,250-X-EXPS GSSAPI NTLM,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,13,192.x.y.4:30417,192.x.y.5:25,<,250-8BITMIME,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,14,192.x.y.4:30417,192.x.y.5:25,<,250-BINARYMIME,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,15,192.x.y.4:30417,192.x.y.5:25,<,250-CHUNKING,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,16,192.x.y.4:30417,192.x.y.5:25,<,250-XEXCH50,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,17,192.x.y.4:30417,192.x.y.5:25,<,250 XRDST,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,18,192.x.y.4:30417,192.x.y.5:25,>,X-ANONYMOUSTLS,
    2013-03-31T21:26:15.725Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,19,192.x.y.4:30417,192.x.y.5:25,<,220 2.0.0 SMTP server ready,
    2013-03-31T21:26:16.272Z,Intra-Organization SMTP Send Connector,08CFFC6ACFDA5132,20,192.x.y.4:30417,192.x.y.5:25,-,,Remote

    domenica 31 marzo 2013 21:33

Risposte

  • Verifica che i receive connector abbiamo come autorizzazioni "Exchange server authentication" sia quello di default che il client.

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP - MCSE http://blogs.sysadmin.it/peppacci/Default.aspx

    • Contrassegnato come risposta Anca Popa martedì 21 maggio 2013 10:00
    martedì 2 aprile 2013 07:01
    Moderatore

Tutte le risposte

  • i due erver si scambiano la posta tramite smto su port 587. Verifica a livello di receive connector sè quello client è abilitato e che non ci siano firewall che controllino il traffico su quella porta.

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP - MCSE http://blogs.sysadmin.it/peppacci/Default.aspx

    lunedì 1 aprile 2013 20:06
    Moderatore
  • Grazie Peppacci,

    ho verificato e non ci sono firewall tra i due server.

    inoltre ti allego il log del server EX2007 che riceve la posta, dal quale si può vedere che viene usata la porta 25 per la comunicazione.

    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,0,192.x.y.5:25,192.x.y.4:10217,+,,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,1,192.x.y.5:25,192.x.y.4:10217,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,2,192.x.y.5:25,192.x.y.4:10217,>,"220 net-xxxx-01.XXXXXXXXXXX.it Microsoft ESMTP MAIL Service ready at Mon, 1 Apr 2013 22:56:11 +0200",
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,3,192.x.y.5:25,192.x.y.4:10217,<,EHLO NET-xx04.XXXXXXXXXXX.it,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,4,192.x.y.5:25,192.x.y.4:10217,>,250-net-xxxx-01.XXXXXXXXXXX.it Hello [192.x.y.4],
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,5,192.x.y.5:25,192.x.y.4:10217,>,250-SIZE,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,6,192.x.y.5:25,192.x.y.4:10217,>,250-PIPELINING,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,7,192.x.y.5:25,192.x.y.4:10217,>,250-DSN,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,8,192.x.y.5:25,192.x.y.4:10217,>,250-ENHANCEDSTATUSCODES,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,9,192.x.y.5:25,192.x.y.4:10217,>,250-STARTTLS,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,10,192.x.y.5:25,192.x.y.4:10217,>,250-X-ANONYMOUSTLS,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,11,192.x.y.5:25,192.x.y.4:10217,>,250-AUTH NTLM,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,12,192.x.y.5:25,192.x.y.4:10217,>,250-X-EXPS GSSAPI NTLM,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,13,192.x.y.5:25,192.x.y.4:10217,>,250-8BITMIME,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,14,192.x.y.5:25,192.x.y.4:10217,>,250-BINARYMIME,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,15,192.x.y.5:25,192.x.y.4:10217,>,250-CHUNKING,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,16,192.x.y.5:25,192.x.y.4:10217,>,250-XEXCH50,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,17,192.x.y.5:25,192.x.y.4:10217,>,250 XRDST,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,18,192.x.y.5:25,192.x.y.4:10217,<,X-ANONYMOUSTLS,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,19,192.x.y.5:25,192.x.y.4:10217,>,220 2.0.0 SMTP server ready,
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,20,192.x.y.5:25,192.x.y.4:10217,*,,Sending certificate
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,21,192.x.y.5:25,192.x.y.4:10217,*,CN=net-xxxx-01.XXXXXXXXXXX.it,Certificate subject
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,22,192.x.y.5:25,192.x.y.4:10217,*,"CN=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx., DC=xxxxxxxxxxxxxxxxxx, DC=it",Certificate issuer name
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,23,192.x.y.5:25,192.x.y.4:10217,*,7CA15D60000200000059,Certificate serial number
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,24,192.x.y.5:25,192.x.y.4:10217,*,DC9460E3D55DD891A8F5CEE360AA7E5A225D4A24,Certificate thumbprint
    2013-04-01T20:56:12.297Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,25,192.x.y.5:25,192.x.y.4:10217,*,net-xxx-01.XXXXXXXXXXX.it,Certificate alternate names
    2013-04-01T20:56:12.844Z,NET-xxxx-01\Default NET-xxxx-01,08CFFD2AA6E6D612,26,192.x.y.5:25,192.x.y.4:10217,-,,Local

    ho poi trovato un forum con il problema IDENTICO al mio ma purtroppo non vi è soluzione.

    Ecco il link http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/d2d3c6ab-5dce-49b6-b035-2e5ba3be96a4/

    ciao e grazie per l'interessamento.

    lunedì 1 aprile 2013 21:12
  • Verifica che i receive connector abbiamo come autorizzazioni "Exchange server authentication" sia quello di default che il client.

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP - MCSE http://blogs.sysadmin.it/peppacci/Default.aspx

    • Contrassegnato come risposta Anca Popa martedì 21 maggio 2013 10:00
    martedì 2 aprile 2013 07:01
    Moderatore
  • Ciao,

    Ad oggi il tuo quesito nel Forum di Exchange Server è ancora aperto per noi.

    Sei riuscito a controllare quanto chiesto da Peppacci, com'è andata?

    Ricorda di tornare di qui per non lasciare il tuo thread "orfano" di una conclusione ;-) magari ci sono in giro altri utenti che si imbattono contro scenari simili.

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    giovedì 11 aprile 2013 14:13