locked
Windows 8.1, non riesco più a eseguire come amministratore RRS feed

  • Domanda

  • Salve a tutti. Premetto che per un po' dopo l'aggiornamento a Windows 8.1 non ho avuto problemi. Da un paio di settimane invece accade che il mio utente sembra aver perso i privilegi di amministratore, ossia non riesce più ad eseguire nulla con diritti di amministratore (tasto destro / esegui come amministratore) né sembra avere accesso ai menu di amministrazione del pannello di controllo.

    Quando provo a lanciare un'applicazione che richiede l'autorizzazione dell'amministratore, invece del consueto dialog box che mi chiede se voglio procedere ho (dopo un paio di minuti circa di nulla) un messaggio di errore:

    "<nome programma>

    Impossibile trovare l'opzione d'ambiente specificata."

    Inutile dire che questo mi impedisce i vari giochini accessibili da una shell elevata (che NON posso lanciare) o da secpol.msc. Dato che non mi sembra di aver fatto niente di particolare, come posso risolvere questo problema?

    Grazie mille in anticipo,

    Emanuele

    PS dimenticavo: da quando è iniziato il fattaccio, sono scomparse diverse icone dalla barra di avvio (presumo tutte quelle che andavano in admin mode).

    giovedì 9 gennaio 2014 21:09

Risposte

  • dunque, per la cronaca ho quasi risolto. Il problema fondamentale era la mancanza, nelle variabili d'ambiente, degli alias per i percorsi più comuni (tipo Program Files).

    La risposta buona è qui, per quanto la lista di variabili da inserire sia per win64 e non 32, e in sostanza si tratta di inserire a manina a registro le entrate perse per chissà quale motivo (malware, disinstallazioni scriteriate, chi lo sa). In rete non c'è nulla sulla versione italiana del messaggio, cioè "Impossibile trovare l'opzione d'ambiente specificata", e l'unico successo l'ho avuto per l'originale:

    The system could not find the environment option that was entered

    Ho ancora qualche strascico, tipo che non riesco a rinominare/rimuovere directory da Gestione Risorse (mi tocca aprire la shell e funziona, quindi presumo sia qualche altro alias mancante). Qualcuno per caso ha la lista completa di opzioni d'ambiente per windows 8.1 32 bit?

    • Contrassegnato come risposta Emacs77 lunedì 10 marzo 2014 14:02
    lunedì 10 marzo 2014 14:01

Tutte le risposte

  • Ciao, io punto sul malware, strano perchè W8 è poco bersagliato ancora..ma potrebbe anche essere un problema di permessi dopo un'update. Ti giro un link con alcune soluzioni

    http://answers.microsoft.com/en-us/windows/forum/windows8_1-system/no-administrator-rights-on-windows-8-or-windows-81/58575911-e009-408b-a6ea-f980d9295888

    se però dovessi darti un consiglio secco ti direi fai uno start del sistema col DVD di installazione o col recovery mode premendo F8 all'avvio e ripristina il sistema a PRIMA che ti succedesse usando un punto di ripristino, se funziona risolvi in fretta senza impazzire.

    Ciao!

    A.

    • Contrassegnato come risposta Anca Popa mercoledì 15 gennaio 2014 14:54
    • Contrassegno come risposta annullato Anca Popa lunedì 20 gennaio 2014 14:52
    venerdì 10 gennaio 2014 15:51
  • Ciao Emanuele,

    Nel frattempo, ho evidenziato l'intervento di Alessandro (penso che potrebbe tornare valido per molti scenari simili).

    Se c'e' un'altra soluzione che vorresti condividere, puoi lasciare il tuo contributo in questo spazio (sarà sicuramente utile per gli altri membri del forum).

    Grazie a tutti della partecipazione nel Forum di Windows 8 :-)


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    mercoledì 15 gennaio 2014 14:54
  • ciao, rispondo in ritardo perché sono stato fuori città per lavoro....

    Dunque, purtroppo ciascuna delle soluzioni prospettate nei link richiedono diritti di amministratore, quindi non ho potuto utilizzarle (compreso il Ripristino da dentro il sistema).

    Riguardo al ripristino da DVD, non ho il dvd perché ho fatto l'upgrade da file acquistato online. Ho provato F8 all'avvio ma non sembra succedere nulla, il che mi sembra strano perché mi pare che in un passato non lontano l'ho utilizzato.

    AVG free trova una "hidden application" che non riesce a rimuovere perché "data is invalid" o qualcosa di simile, e parla di minaccia rilevata con l'anti-rootkit il che mi spaventa molto. Il Microsoft Security Scanner non riesco nemmeno a installarlo per i motivi di cui sopra.

    Vi viene in mente qualcos'altro? :)

    domenica 19 gennaio 2014 11:21
  • In un modo o nell'altro un supporto DVD bisogna che te lo procuri, anche solo per la reinstallazione o per salvaguardarti in caso di failure del disco fisso. Se non hai supporto non riesci nemmeno a fare operazioni a freddo quindi chiama in MS o il produttore del tuo Notebook e fatti inviare un supporto, naturalmente avrà un costo. Di solito quella di fare subito un supporto DVD "salvavita" è la prima opreazione che si fa su un pc che ne è privo, basterebbe anche un 8.0 non per forza un 8.1. Più di questo se sei tagliato fuori amministrativamente non puoi fare mi spiace. Ciao. A.
    domenica 19 gennaio 2014 12:00
  • Ma potresti creare uno o più cd di Antivirus/Antimalware avviabili come quelli di Avira:

    http://www.avira.com/it/download?product=avira-rescue-system

    Oppure Kaspersky:

    http://support.kaspersky.com/4162

    Bit Defender:

    http://www.bitdefender.com/support/how-to-create-a-bitdefender-rescue-cd-627.html

    Con quei cd potrai avviare il sistema , effettuare le scansioni e ripulire per quanto possibile.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    domenica 19 gennaio 2014 13:35
  • Il consiglio di Franco è ottimo, occhio solamente che se poi il programma AV rimuove qualcosa che non deve se non hai il supporto di avvio...:)
    domenica 19 gennaio 2014 13:46
  • Il consiglio di Franco è ottimo, occhio solamente che se poi il programma AV rimuove qualcosa che non deve se non hai il supporto di avvio...:)

    Chiaramente..

    Se molti file di sistema risultano infetti e vengono "ripuliti" semplicemente rimuovendoli l'avvio ed il sistema potrebbero essere compromessi.

    Hai almeno creato un'unità di ripristino in un pendrive? (verrà formattato)

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    domenica 19 gennaio 2014 13:52
  • allora innanzitutto grazie a tutti per l'attenzione e poi vi aggiorno...

    Sono riuscito a entrare in modalità provvisoria (ho letto che nelle ultime versioni di OS è stato disattivato F8 ma ho fortunatamente imparato a usare le modalità alternative) e ho verificato che da lì il mio utente riesce a eseguire come amministratore. Il ripristino non funziona, dice che non riesce ad accedere a un file necessario (dopo diverso tempo). Ho però potuto lanciare Microsoft Safety Care che ha trovato il Win32/Sefnit.L, non riuscendo a rimuoverlo del tutto - mi dice "rimosso parzialmente" sul file di virus principale. Ora non so se accontentarmi o provare qualche altro metodo per rimuoverlo del tutto. Da questo punto di vista MS Security Essentials può darmi qualcosa in più di MSC? secondo un articolo MS dovrebbe bastare uno dei due, ma dato che il secondo non ha funzionato appieno posso provare il primo...

    Che dite?

    E poi: sì, devo crearmi l'unità di ripristino. Me lo dico sempre :)

    lunedì 20 gennaio 2014 13:29
  • ma e se dalla provvisoria ti crei un'altro utente admin? ti mette in lock anche quello? Scarica Malwarebytes antimalware, dovrebbe rimuovere tutto e va anche senza riavvio.
    lunedì 20 gennaio 2014 13:34
  • Se accedi alla modalità provvisoria con rete:

    Segui i suggerimenti 1-2-3-4-7 del tutorial:

    Il computer è infettato da malware, come devo procedere per risolvere il problema?

    (Courtesy of MVP Vincenzo di Russo)

    Eliminando tutto quello che viene trovato.

    Se ancora hai problemi segui i suggerimenti 5 e 6.

    Sempre eliminando tutto ciò che viene trovato.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    lunedì 20 gennaio 2014 13:35
  • OK, temo di dover cedere. Ho fatto tutto il possibile. Serenamente, mi tocca fare un clean install con formattazione.

    A questo punto però vi chiedo come...

    Io ho acquistato windows 8 online facendo l'upgrade dal 7. Ho una product key windows 8. Ho aggiornato gratuitamente a windows 8.1 ma NON mi hanno mandato una product key 8.1 (o almeno non capisco dove dovrei prenderla) però poco male nel senso che posso aggiornare in un secondo momento.

    Però se io vado a scaricare di nuovo l'upgrade assistant mi dice che non va bene per una installazione da zero, ma solo con windows in esecuzione sotto. Cosa che vorrei evitare perché il succo di tutto ciò è fare piazza pulita del problema che mi sta impedendo di usare metà delle funzioni di sistema.

    Quindi, come posso fare a ottenere una installazione pulita di windows 8 o 8.1 senza dover ricomprare il tutto?

    (Altra domanda ma immagino che questa abbia risposta scontata... ho scoperto ora di avere un processore 64 e non 32, ma il sistema operativo che ho installato è 32. Immagino di non poter fare il cambio a costo zero con un 64...? OK, insultatemi pure).

    Ciao e grazie a tutti.

    mercoledì 12 febbraio 2014 11:14
  • Ciao, per come ti sei "assettato" ti tocca:

    -installare windows 7

    -installare l'upgrade ad 8 col tuo codice fornito

    -fare upgrade ad 8.1 (non serve codice)

    altri modi non ne hai, tantomeno cambiare versione di sistema da x32 ad x64. Imho facevi meglio a prendere una 8 full x64 quando dovevi upgradare, costava poco di più ma avevi risolto tutti i problemi...mi spiace.

    Ciao.

    A.

    mercoledì 12 febbraio 2014 11:19
  • Mmmmh brutta cosa. Anche perché in origine avevo Vista quindi dovrei fare due major update ma non so se ritrovo Windows 7.

    Ma ho nuovi aggiornamenti. Il MS Defender Offline ha spazzato via, contrariamente alle aspettative, il Sefnet. Tutto contento, rientro nel sistema col mio utente ma... non è cambiato nulla, ho gli stessi sintomi di cui sopra. Allora ho notato altre cosine. Tanto per cominciare, se provo a rinominare o cancellare qualcosa da Gestione Risorse mi dice che non trova il file. Se apro invece una shell e faccio da lì non ci sono problemi, sia rename che delete. Ho letto da qualche parte che l'errore che vi dicevo all'inizio, ovvero che "non trova la variabile nel contesto specificato", esce fuori se viene rimosso qualche cosa di fondamentale dal path (tipo il c:\windows) o in generale se explorer non riesce a trovare le native. Mi viene da pensare di aver cancellato qualcosa che non dovevo con il Wise Program Uninstaller, che avevo usato molto a dicembre preso dal sacro fuoco della pulizia.

    Allora sono andato in modalità provvisoria e ho attivato l'admin built-in. Ho riavviato e, loggandomi con quello, miracolo, funziona tutto comprese le applicazioni in modalità amministratore, 

    TRANNE

    le funzionalità di gestione utenti (creazione, rimozione, gestione altri account etc). Solo che non mi danno errori, sta lì un bel po' a girare finché non si ferma da solo e non fa nulla. Avevo intenzione di ricreare gli utenti, e penso che potrei ancora farlo magari solo da shell, ma vorrei capire che cos'altro ha 'sto maledetto.

    Ogni aiuto è most appreciated!!! Scusate se mi sono dilungato ma ormai è una telenovela.

    PS ho risolto l'enigma dei 32/64bit... originariamente avevo un processore 32 bit, poi da un annetto ho cambiato motherboard e processore e non ho pensato minimamente a cambiare sistema operativo.

    martedì 18 febbraio 2014 09:03
  • dunque, per la cronaca ho quasi risolto. Il problema fondamentale era la mancanza, nelle variabili d'ambiente, degli alias per i percorsi più comuni (tipo Program Files).

    La risposta buona è qui, per quanto la lista di variabili da inserire sia per win64 e non 32, e in sostanza si tratta di inserire a manina a registro le entrate perse per chissà quale motivo (malware, disinstallazioni scriteriate, chi lo sa). In rete non c'è nulla sulla versione italiana del messaggio, cioè "Impossibile trovare l'opzione d'ambiente specificata", e l'unico successo l'ho avuto per l'originale:

    The system could not find the environment option that was entered

    Ho ancora qualche strascico, tipo che non riesco a rinominare/rimuovere directory da Gestione Risorse (mi tocca aprire la shell e funziona, quindi presumo sia qualche altro alias mancante). Qualcuno per caso ha la lista completa di opzioni d'ambiente per windows 8.1 32 bit?

    • Contrassegnato come risposta Emacs77 lunedì 10 marzo 2014 14:02
    lunedì 10 marzo 2014 14:01