none
Blue Screen Ripristino Backup 2012 Foundation su nuovi dischi RRS feed

  • Domanda

  • Buongiorno Amici, mi sono imbattuto in un problema alquanto strano. Ho un server nuovo della Fusjitsu con CPu Xeon, 8Gb di Ram e due dischi Sata in Raid 1. Con l'apposito tool fornito da Fujitu ho installato Windows Server 2012 R2 Foundation e installato tutti gli update. Dopodichè ho provveduto ad effettuare un bakcup completo con windows server backup su un disco esterno. A questo punto ho spento il server e ho simulato una recovery:
    - staccato i dischi originali (Seagate da 1Tb) 
    - montato 2 dischi Toshiba da 1Tb
    - Creato l'array in raid 1
    - avviato la recovery di windows server da apposito cd fornito a corredo del server
    - ripristinato il backup di tutto il server dall'unità esterna senza errori.

    Il problema e che al riavvio del server compare la maschera di run di windows server ma dopo poco il server va in bluescreen  e l'errore restituito è 0x000021a. Ho provato anche in modalità provvisoria, ma niente. Stesso errore. Se ricollego i dischi originali il sistema riparte regolarmente.

    Avete avuto già una problematica simile?
    Grazie
    sabato 10 dicembre 2016 10:03

Risposte

  • Sei in produzione oppure puoi fare qualche test?

    Il problema potrebbe essere l'ISO utilizzata. Se puoi scarica una ISO demo e rifai tutta l'attività di installazione, backup e restore (lascia perdere l'update).

    sabato 10 dicembre 2016 17:02
    Moderatore
  • Ciao,

    fai in tempo a controllare gli eventi? (o esportarli su usb)

    https://msdn.microsoft.com/en-us/library/windows/hardware/ff560177%28v=vs.85%29.aspx


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    sabato 10 dicembre 2016 19:37
  • Spesso questo tipo di problemi sono causati da una differenza nel partizionamento (MBR/GPT). Ad esempio è stato eseguito un backup di una partizione installata in modalità UEFI/GPT e si esegue il ripristino su MBR. Prova a vedere per prima cosa se è presente una differenza di questo tipo tra i due array.
    domenica 11 dicembre 2016 16:42
    Moderatore
  • Personalmente non ho mai riscontrato problemi di file corrotti con il baremetal di Windows Server Backup: il software è in grado di copiare tutti i dati del sistema operativo tramite il servizio VSS.
    Dal punto di vista hardware (dischi, RAM) hai eseguito qualche test?

    martedì 13 dicembre 2016 16:24
    Moderatore
  • Non sono mai stato un fautore dell'utilizzo dell'utility di backup interno perché ho sempre utilizzato programmi di terze parti specifici. Ma questo non significa che non debba funzionare, anche perché si basa sulla logica delle snap di sistema che sono parte integrante del sistema operativo. Decisamente, così come ha già scritto Fabrizio, non ho mai visto o letto di problemi similari.

    Quindi le cose che ti consiglio di fare sono tre:
    1) Procurati una trial di un qualsiasi produttore ed esegui un backup/restore
    2) Utilizzare una ISO differente da quella fornita dal Brand. Anche se sembra strano capita di averle bacate...

    3) Chiedi al tecnico di documentarti il bug e poi, se è in grado di farlo, con le sue indicazioni apri un ticket a pagamento al supporto. Se è colpa di Microsoft non paghi niente... Ma dubito che Fujitsu ti darà un riscontro in tal senso.

    Saluti
    Nino

    martedì 13 dicembre 2016 18:12
    Moderatore

Tutte le risposte

  • Ciao Marcello, il backup è stato eseguito con l'opzione "Bare Metal"? https://blogs.technet.microsoft.com/askcore/2011/05/12/bare-metal-restore/

    Saluti
    Nino

    sabato 10 dicembre 2016 16:27
    Moderatore
  • Ciao Nino,

    il backup è stato eseguito con l'opzione Bare Metal.

    sabato 10 dicembre 2016 16:49
  • Sei in produzione oppure puoi fare qualche test?

    Il problema potrebbe essere l'ISO utilizzata. Se puoi scarica una ISO demo e rifai tutta l'attività di installazione, backup e restore (lascia perdere l'update).

    sabato 10 dicembre 2016 17:02
    Moderatore
  • Ciao,

    fai in tempo a controllare gli eventi? (o esportarli su usb)

    https://msdn.microsoft.com/en-us/library/windows/hardware/ff560177%28v=vs.85%29.aspx


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    sabato 10 dicembre 2016 19:37
  • Buongiorno Nino,

    il deploy è stato fatto utilizzando i supporti forniti dalla Fujitsu. Mi trovo in ambiente di test in quanto il server ancora non è stato consegnato al cliente.

    Domani provo con dei supporti differenti. Anche se la cosa mi sembra molto strana.

    Ho controllato il tipo di errore, ma è molto generico. A questo punto potrebbe essere anche la coppia di dischi, anche se il sistema operativo carica il driver e a livello fisico il raid risulta on line.


    Marcello Russo

    domenica 11 dicembre 2016 10:40
  • Spesso questo tipo di problemi sono causati da una differenza nel partizionamento (MBR/GPT). Ad esempio è stato eseguito un backup di una partizione installata in modalità UEFI/GPT e si esegue il ripristino su MBR. Prova a vedere per prima cosa se è presente una differenza di questo tipo tra i due array.
    domenica 11 dicembre 2016 16:42
    Moderatore
  • Buonasera amici, ho effettuato alcune verifiche di cui sopra senza esito. Ho contattato un tecnico del supporto Fujitsu e mi ha riferito che il backup di Windows Server probabilmente non copia tutti i file quando il server è in linea. E mi ha suggerito un software di terze parti per eseguire il backup totale. Ad onor del vero l'errore restituito dalla BSOD (0xc000021a) viene imputato ad alcuni file corrotti. Infatti come workaround viene proposto l'sfc scannow per riparare eventuali file corrotti. Ora sto provando con una versione trial di windows servre 2012 scaricata dal sito Microsoft. Comunque voglio vederci chiaro. Considerazioni a riguardo?

    Grazie


    Marcello Russo

    martedì 13 dicembre 2016 16:14
  • Personalmente non ho mai riscontrato problemi di file corrotti con il baremetal di Windows Server Backup: il software è in grado di copiare tutti i dati del sistema operativo tramite il servizio VSS.
    Dal punto di vista hardware (dischi, RAM) hai eseguito qualche test?

    martedì 13 dicembre 2016 16:24
    Moderatore
  • Non sono mai stato un fautore dell'utilizzo dell'utility di backup interno perché ho sempre utilizzato programmi di terze parti specifici. Ma questo non significa che non debba funzionare, anche perché si basa sulla logica delle snap di sistema che sono parte integrante del sistema operativo. Decisamente, così come ha già scritto Fabrizio, non ho mai visto o letto di problemi similari.

    Quindi le cose che ti consiglio di fare sono tre:
    1) Procurati una trial di un qualsiasi produttore ed esegui un backup/restore
    2) Utilizzare una ISO differente da quella fornita dal Brand. Anche se sembra strano capita di averle bacate...

    3) Chiedi al tecnico di documentarti il bug e poi, se è in grado di farlo, con le sue indicazioni apri un ticket a pagamento al supporto. Se è colpa di Microsoft non paghi niente... Ma dubito che Fujitsu ti darà un riscontro in tal senso.

    Saluti
    Nino

    martedì 13 dicembre 2016 18:12
    Moderatore