none
Cambio URL RD Web Access RRS feed

  • Domanda

  • Salve,

    stò effettuando dei test in lab per utilizzare ( in seguito ) da un cliente il VDI , ho un problema che non riesco a risolvere , ovvero l'accesso alla mia macchina virtuale dall'esterno .

    All'interno funziona tutto, ma dall'esterno riesco a collegarmi all'RDWEB , inserisco le mie credenziali , visualizzo il pool delle macchine... viene generato il file .rdp , ma poi la sessione non si collega , dicendomi " impossibile collegarsi al pc remoto, verificare che il Remote Desktop sia attivato.... etc etc... .

    Ho notato che è presente un url locale , ma non riesco a trovare il modo per modificarlo , ho seguito una marea di guide , ma tutte senza risolvere il problema...

    Ho seguito questi due link...

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/67dfab70-7e10-4e0b-a3c8-63ce776f2355/how-do-i-change-the-url-to-the-remote-web-access-server-in-windows-server-2012?forum=winserverTS

    http://gallery.technet.microsoft.com/Change-published-FQDN-for-2a029b80

    Grazie Mille.

    Maurizio



    lunedì 21 luglio 2014 06:42

Risposte

  • E' un problema noto dell'App per iPad. Per eseguire la connessione con il client in RDP è necessario inserire l'FQDN completo del server: ad esempio SERVER1.DOMINIO.LOCAL

    Verifica quindi che i DNS siano impostati correttamente nella connessione VPN: solitamente è sufficiente inserire l'indirizzo di un DC in prima posizione e non includere altri DNS esterni.





    martedì 22 luglio 2014 08:42
    Moderatore
  • Risolto...

    il problema sembra essere lo split-dns della vpn , in realtà non risolveva con il server locale , ma con quello della navigazione...la cosa strana che mi rimane è che la vpn non mi funzionava dall'ipad , ma fatta con un pc era tutto ok... mah!...

    Grazie a tutti per l'aiuto...

    mercoledì 23 luglio 2014 15:56

Tutte le risposte

  • Insieme all'RDWeb utilizzi un gateway desktop remoto? Se la risposta è si, probabilmente dovrai inserire l'FQDN esterno nelle impostazioni in IIS (DefaultTSGateway).

    http://ryanmangansitblog.com/2013/08/07/configure-connect-to-a-remote-computer-in-rdweb-2012/

    Se invece non utilizzi un gateway desktop remoto, probabilmente la porta TCP per l'RDP è bloccata nel firewall. In tal caso si sconsiglia di sbloccare direttamente la porta RDP verso l'esterno, ma eseguire la connessione ad RDWeb solo tramite VPN.


    lunedì 21 luglio 2014 07:52
    Moderatore
  • Ciao,

    ho fatto quello che mi hai consigliato, ovvero , ho chiuso tutto dall'esterno ed ho attivato una vpn.

    Risultato :

    Tramite PC tutto perfetto...

    Tramite Ipad, mi continua a dare il solito messaggio di configurare FQDN

    da Ipad utilizzo l'app RD Client passando da vpn, per escludere un problema di risoluzione nomi tramite vpn ho fatto una prova collegando direttamente al server in RD con nome locale e tutto ok, ma quando tento di collegarmi all' rdweb dei client mi segnala l'errore...

    Maurizio

    martedì 22 luglio 2014 06:49
  • E' un problema noto dell'App per iPad. Per eseguire la connessione con il client in RDP è necessario inserire l'FQDN completo del server: ad esempio SERVER1.DOMINIO.LOCAL

    Verifica quindi che i DNS siano impostati correttamente nella connessione VPN: solitamente è sufficiente inserire l'indirizzo di un DC in prima posizione e non includere altri DNS esterni.





    martedì 22 luglio 2014 08:42
    Moderatore
  • Niente da fare...uguale, ho controllato i dns e sono giusti..ho solo il mio server locale.
    martedì 22 luglio 2014 18:28
  • Potresti riportare esattamente la procedura che segui su iPad e l'esatto messaggio di errore restituito?

    Riporta inoltre la procedura che esegui da pc e che invece ti funziona.

    mercoledì 23 luglio 2014 09:16
    Moderatore
  • Su PC:

    https://serverhv.dominio.locale/rdweb

    credenziali dominio\utente e password

    pool vdi , scarico file rdp e connessione

    Su ipad

    apro applicazione RD Client

    configuro la parte remote source il collegamento al server stesso link 

    mi appare il pool 

    inizia il collegamento ed appare errore 

    "Unable to connect to remote PC. pPlease provide the fully-qualified name or the ip address of the remote PC, and then try again. "

    Stamani ho provato con il wireless dell'ufficio ( per escludere eventuali problemi di VPN) stesso risultato.


    mercoledì 23 luglio 2014 09:29
  • Potresti inserire l'output del log del client RDP in una connessione eseguita localmente?

    Qui trovi tutte le indicazioni necessarie: http://technet.microsoft.com/en-us/library/dn473013.aspx

    mercoledì 23 luglio 2014 10:06
    Moderatore
  • Potresti inserire l'output del log del client RDP in una connessione eseguita localmente?


    Scusami, non riesco a capire come fare...
    mercoledì 23 luglio 2014 11:12
  • Seleziona "Send log via email" in "Settings".

    mercoledì 23 luglio 2014 13:32
    Moderatore
  • Risolto...

    il problema sembra essere lo split-dns della vpn , in realtà non risolveva con il server locale , ma con quello della navigazione...la cosa strana che mi rimane è che la vpn non mi funzionava dall'ipad , ma fatta con un pc era tutto ok... mah!...

    Grazie a tutti per l'aiuto...

    mercoledì 23 luglio 2014 15:56