none
Hyper-V Integration services come se non fossero installati RRS feed

  • Domanda

  • Buongiorno a tutti,

    vi scrivo in quanto ho un problema con gli Integration Services di Hyper-V di win 2012 R2 come HOST.

    Purtroppo ho dovuto convertire una VM GEST cont win2003 SP2 da vmware ad Hyper-v. Ho utlizzato disk2vhd di sysinternals. La conversione è andata a buon fine, sono riuscito ad agganciare il vhdx alla vm su hyper-v, sono riuscito ad accenderla ed è partita al primo tentativo.

    Procedo quindi con l'installazione degli Integrations Services ma noto con mio stupore che anche dopo l'installazione, in sistema operativo non riconosce la scheda di rete (non la vede nemmeno tra i devices) e l'integrazione del mouse in console non funziona.

    La cosa strana è che potrei installare gli Integration Services all'infinito.. come se non fossero mai state installate. Inserisco il cd virtuale, parte l'installazione, riavvio la vm e stop. Punto a capo, se riprovo ad installare i services, anzichè propormi la disistallazione o avvisarmi che sono già installati, il sistema si comporta come se non fossero mai installate.

    Ho dovuto mettere la scheda di rete Legacy.. ma è una soluzione che non mi soddisfa affatto..

    Avete idee su come posso risolvere il problema? le ho provate veramente tutte senza successo. Leggendo qua è là ho il sospetto che non venga riconosciuto l'HAL corretto, infatti la vm si comporta come si fosse un vecchio pc cha va spento manualmente con l'avviso di windows "ora si può spegnere il computer".

    Nelle gestione periferiche anzichè esserci "PC con multiprocessore ACPI" c'è "PC con multiprocessore MPS". Può dipendere da questo?

    Grazie mille a tutti

    sabato 28 febbraio 2015 16:57

Risposte

  • Ciao Marco, se hai la possibilità di eseguire una nuova migrazione potresti provare con Microsoft Virtual Machine Converter 3.0 oppure con 5nine V2V Easy Converter 5.2.

    La versione 3.0 di VMC non include Windows Server 2003 tra i sistemi operativi uficialmente supportati, ma potrebbe funzionare lo stesso.

    Se l'hardware è notevolmente differente comunque potresti riscontrare problemi di migrazione. Puoi descrivere l'ambiente di partenza e di destinazione (VMWare versione? Hardware?).


    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    sabato 28 febbraio 2015 19:55
    Moderatore
  • Purtroppo le migrazioni con Windows Server 2003 sono sempre un po' problematiche.

    Secondo me dovresti provare solo con tool di conversione V2V in modo da ripulire meglio il VMDK prima di eseguire l'esportazione (operazione non eseguita dalla maggior parte dei tool P2V). E' vero che spesso con sistemi operativi recenti funzionano comunque i tool P2V, ma Server 2003 e XP sono più fragili al cambio di hardware (anche se virtuale) ed eseguire le dovute modifiche manualmente può farti perdere del tempo (non basta disinstallare solo i servizi VMWare).

    Virtual Machine Manager 2008 e 2008 R2 dovrebbero essere in grado di eseguire una conversione V2V di questo tipo: https://technet.microsoft.com/it-it/library/cc793147.aspx?f=255&MSPPError=-2147217396

    (Puoi utilizzare anche una versione trial)

    In alternativa puoi provare ad utilizzare dei software di terze parti, ad esempio:

    - StarWind V2V Converter

    - 5nine V2V Easy Converter (come consigliato anche da NinoRCTN)

    domenica 1 marzo 2015 10:11
    Moderatore

Tutte le risposte

  • cosa viene registrato nel registro eventi della vm quando vai ad installare gli integration services ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    sabato 28 febbraio 2015 17:30
    Moderatore
  • nessun errore purtroppo.. dico purtroppo perchè mi aiuterebbe a debuggare il tutto:

    Avvio di una transazione di Windows Installer: F:\support\x86\Windows5.x-HyperVIntegrationServices-x86.msi. ID processo client: 3936.

    Product: Hyper-V Integration Services (version 6.2.9600.16384) -- Configuration completed successfully.

    Windows Installer: riconfigurazione del prodotto completata. Nome prodotto: Hyper-V Integration Services (version 6.2.9600.16384). Versione prodotto: 3.9600.16384. Lingua prodotto: 1033. Riconfigurazione riuscita o stato di errore: 0.

    Completamento di una transazione di Windows Installer: F:\support\x86\Windows5.x-HyperVIntegrationServices-x86.msi. ID processo client: 3936.

    sabato 28 febbraio 2015 17:46
  • Ciao Marco, se hai la possibilità di eseguire una nuova migrazione potresti provare con Microsoft Virtual Machine Converter 3.0 oppure con 5nine V2V Easy Converter 5.2.

    La versione 3.0 di VMC non include Windows Server 2003 tra i sistemi operativi uficialmente supportati, ma potrebbe funzionare lo stesso.

    Se l'hardware è notevolmente differente comunque potresti riscontrare problemi di migrazione. Puoi descrivere l'ambiente di partenza e di destinazione (VMWare versione? Hardware?).


    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    sabato 28 febbraio 2015 19:55
    Moderatore
  • ciao Nino,

    con Virtual Machine Converter 3.0 ho provato ma senza successo, non ricordo l'errore ma forse appunto era dovuto al fatto che l'os non era supportato.. posso provare con l'altro software che mi hai indicato. Ti ringrazio molto

    La macchina era ospitata inizialmente su un vecchio esxi (non cluster) 3.5.. Server fisico HP/Compaq ML350G3 (veramente obsoleto).

    Googleando mi sono accorto che non sono l'unico ad avere questo problemi, però non ho trovato una soluzione efficace.. quelle proposte (tra cui elimiare i file sys del windows driver framework) non hanno funzionato :(

    sabato 28 febbraio 2015 23:20
  • Domanda scontata perchè sicuramente l'avrai già fatto, ma anche vmware ha un pacchetto simile agli integration services di hyper-v se non erro(vmware tools mi pare...), e prima di migrare deve essere disinstallato
    sabato 28 febbraio 2015 23:38
  • si, sono le VMWare tools esatto.. le ho tolte ma nulla :(
    sabato 28 febbraio 2015 23:49
  • Sei un po' vecchiotto con la 3.5. Dai una lettura al seguente thread https://social.technet.microsoft.com/Forums/windowsserver/en-US/7ea051c7-ac94-4f34-b6f6-8d75f4225173/integration-services-cannot-upgrade-hal in particolare la risposta di payne80.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    domenica 1 marzo 2015 00:15
    Moderatore
  • Purtroppo avevo già letto quel thread ma la soluzione di payne80 non ha risolto il problema.. ho provato la conversione con l'altro software (5nine) ma anche in questo caso non è cambiato nulla :(
    domenica 1 marzo 2015 09:30
  • La cosa che mi lascia perplesso è che se aggiungo per esempio una scheda di rete virtuale NON legacy, quindi quella normale di hyper-v, non mi compare nemmeno nell'hardware.. un conto comparire ma non essere riconosciuta per via dei drivers non presente, un conto è non comparire proprio.. veramente strano
    domenica 1 marzo 2015 09:32
  • Purtroppo le migrazioni con Windows Server 2003 sono sempre un po' problematiche.

    Secondo me dovresti provare solo con tool di conversione V2V in modo da ripulire meglio il VMDK prima di eseguire l'esportazione (operazione non eseguita dalla maggior parte dei tool P2V). E' vero che spesso con sistemi operativi recenti funzionano comunque i tool P2V, ma Server 2003 e XP sono più fragili al cambio di hardware (anche se virtuale) ed eseguire le dovute modifiche manualmente può farti perdere del tempo (non basta disinstallare solo i servizi VMWare).

    Virtual Machine Manager 2008 e 2008 R2 dovrebbero essere in grado di eseguire una conversione V2V di questo tipo: https://technet.microsoft.com/it-it/library/cc793147.aspx?f=255&MSPPError=-2147217396

    (Puoi utilizzare anche una versione trial)

    In alternativa puoi provare ad utilizzare dei software di terze parti, ad esempio:

    - StarWind V2V Converter

    - 5nine V2V Easy Converter (come consigliato anche da NinoRCTN)

    domenica 1 marzo 2015 10:11
    Moderatore
  • Ciao Marco,
    Ad oggi il tuo quesito nel Forum di Virtualizzazione è ancora aperto per noi.
    Se i consigli ricevuti ti sono stati utili, ricorda di evidenziare la soluzione cliccando su "Segna come Risposta". Se invece hai trovato un'altra soluzione nel frattempo, ti saremmo grati di condividerla anche qui, a beneficio degli altri utenti che seguono il thread.
    Grazie.

    • Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è e non comporta alcuna responsabilità da parte dell’azienda.

    martedì 3 marzo 2015 09:45