none
ritardo invio e ricezione mail RRS feed

  • Domanda

  • Ciao a tutti,
    ho un problema abbastanza bizzarro con exchange 2016 installato su un windows server 2016.
    nel senso che quando accedo all'owa, e invio una mail verso un indirizzo gmail, automaticamente la mail finisce nella cartella bozze e resta lì per un po' di ore. dopo diverse ore la vedo arrivare su gmail. stessa cosa se da gmail mando una mail al mio indirizzo exchange la mail finisce correttamente nella posta inviata ma dopo diverse ore la ricevo anche su exchange.
    a cosa può essere dovuto questo ritardo?
    grazie, saluti
    venerdì 27 ottobre 2017 19:36

Risposte

  • e quindi? non cambia niente? 

    Ricapitoliamo: 

    - se spedisci verso qualsiasi dominio tranne gmail le mail arrivano correttamente nei tempi giusti

    - l'spf l'hai configurato (giusto o sbagliato non lo so...non ci hai detto come..)

    - se una mail da gmail viene inviata ad un account del tuo exchange arriva nei tempi giusti

    Ora che può fare questo è o un indirizzo ip in blacklist da qualche parte (hai controllato le rbl?) o i filtri del firewall. Quindi ti rinnovo la domanda..hai tirato giù il pfsense e magari al suo posto ci hai messo qualcos'altro? Hai fatto un tracking di un messaggio verso un dominio diverso da gmail? quello lo vedi uscire nelle queue? Hai usato il message tracking?

    https://technet.microsoft.com/it-it/library/bb124926%28v=exchg.160%29.aspx?f=255&MSPPError=-2147217396

    ciao

    A.

    domenica 5 novembre 2017 14:12
    Moderatore

Tutte le risposte

  • Ciao, serve sapere:

    - se exchange è pubblicato coi record mx o con connettori pop o smarthost smtp

    - se hai sistemi di antispam di terze parti

    - che marca di firewall perimetrale hai

    questo perchè sembra un problema non di routing dei messaggi se il tuo exchange invia normalmente agli altri indirizzi,ma solo verso Gmail.

    ciao.

    A.

    sabato 28 ottobre 2017 06:37
    Moderatore
  • ciao,

    grazie per la risposta.

    è pubblicato con record mx che punta a mail.miodominio.com

    l'unico antispam è quello di exchange

    e il firewall perimetrale è pfsense.

    ho solo provato a spedire mail da mio dominio > gmail e viceversa. non ho provato con altri domini esterni.

    p.s. ho provato adesso a mandarmi una mail sul mio account di lavoro e si verifica lo stesso problema

    sabato 28 ottobre 2017 10:58
  • se guardi nel tool dei queue di exchange vedi uscire subito il messaggio? se ti esce subito la prima prova che ti direi di fare è di saltare pfsense...personalmente non lo conosco, ma non sono un fan dei prodotti opensource per la security, ed una delle poche cose che possono ritardare una mail è proprio il firewall. È la prima prova da fare. 

    ciao.

    A.

    sabato 28 ottobre 2017 13:35
    Moderatore
  • non penso sia il firewall in quanto le stesse regole con un exchange 2013 funzionava benissimo.

    comunque ho provato a mandare una mail da exchange, poi ho eseguito questo comando: Get-Queue -Identity Submission ma non penso abbia trovato niente

    sabato 28 ottobre 2017 13:44
  • Guido, mi fa piacere che non pensi sia il firewall, ma in questi casi devi eliminare punti di fallimento, o fai passare tutto il traffico su pfsense senza limitazioni o lo stoppi per un test, se non lo elimini fisicamente il "pensare che non sia lui" non è un dato reale.

    Per le code intendo il queue viewer nel toolbox di exchange. Controlla che esca subito il messaggio, se esce subito allora puoi scartare Exchange e devi andare a cercare il problema sulle periferiche di altro tipo: firewall, antispam a monte ecc..

    ciao.

    A.

    domenica 29 ottobre 2017 08:22
    Moderatore
  • il queue viewer non mi vede neanche la mail che cerco di inviare. deduco che il problema sia exchange
    domenica 29 ottobre 2017 19:29
  • il queue viewer non mi vede neanche la mail che cerco di inviare. deduco che il problema sia exchange

    perdonami..non è possibile questo. :). Forse è molto veloce..ma la mail in uscita la devi vedere. Prova da OWA e non dal client outlook.

    A.

    martedì 31 ottobre 2017 09:36
    Moderatore
  • sto provando solo da owa.

    comunque, forse dico una cavolata,  ma potrebbe essere questo il problema?

    Unable to relay recipient in non-accepted domain

    martedì 31 ottobre 2017 21:52
  • scusa ma hai messo il dominio negli accepted domain??

    mercoledì 1 novembre 2017 19:32
    Moderatore
  • si, miodominio.com di tipo autorevole
    mercoledì 1 novembre 2017 19:53
  • mettici un * negli accepted e intando vediamo se ti escono i messaggi correttamente che qualcosa non mi è chiaro..poi al massimo lo togli..ma almeno capiamo...spf l'hai messo? 

    ciao.

    A.

    sabato 4 novembre 2017 16:29
    Moderatore
  • ho messo sia * che il record spf
    domenica 5 novembre 2017 01:57
  • e quindi? non cambia niente? 

    Ricapitoliamo: 

    - se spedisci verso qualsiasi dominio tranne gmail le mail arrivano correttamente nei tempi giusti

    - l'spf l'hai configurato (giusto o sbagliato non lo so...non ci hai detto come..)

    - se una mail da gmail viene inviata ad un account del tuo exchange arriva nei tempi giusti

    Ora che può fare questo è o un indirizzo ip in blacklist da qualche parte (hai controllato le rbl?) o i filtri del firewall. Quindi ti rinnovo la domanda..hai tirato giù il pfsense e magari al suo posto ci hai messo qualcos'altro? Hai fatto un tracking di un messaggio verso un dominio diverso da gmail? quello lo vedi uscire nelle queue? Hai usato il message tracking?

    https://technet.microsoft.com/it-it/library/bb124926%28v=exchg.160%29.aspx?f=255&MSPPError=-2147217396

    ciao

    A.

    domenica 5 novembre 2017 14:12
    Moderatore