none
SCCM Query – All Computers with a specific program install RRS feed

  • Domanda

  • Ciao a tutti,

    da un pò di tempo a questa parte ho qualche difficoltà a fare delle query in quanto mi restituiscono sempre risultato zero o comunque risultati non propriamente coerenti.

    La versione di SCCM è l'ultima ( Ver 2010 - 5.00.9040.1000 )

    Volevo creare una collection per sapere quali computer, ad esempio , hanno Fortigate installato e le ho sempre fatte così :

    select SMS_R_System.ResourceId, SMS_R_System.ResourceType, SMS_R_System.Name, SMS_R_System.SMSUniqueIdentifier, SMS_R_System.ResourceDomainORWorkgroup, SMS_R_System.Client from  SMS_R_System inner join SMS_G_System_INSTALLED_SOFTWARE on SMS_G_System_INSTALLED_SOFTWARE.ResourceID = SMS_R_System.ResourceId where SMS_G_System_INSTALLED_SOFTWARE.ARPDisplayName = "%forticlient%"

    Risultato Zero.

    Stessa cosa se metto il product name :

    select SMS_R_System.ResourceId, SMS_R_System.ResourceType, SMS_R_System.Name, SMS_R_System.SMSUniqueIdentifier, SMS_R_System.ResourceDomainORWorkgroup, SMS_R_System.Client from  SMS_R_System inner join SMS_G_System_INSTALLED_SOFTWARE on SMS_G_System_INSTALLED_SOFTWARE.ResourceID = SMS_R_System.ResourceId where SMS_G_System_INSTALLED_SOFTWARE.ProductName = "%forticlient%"


    Nel tempo è cambiato il sistema delle query, oppure sbaglio qualcosa io, oppure SCCM si è rotto ? Altre query ovviamente funzionano, come il brand di un PC, piuttosto che un modello, piuttosto che un servizio.

    Cosa potrei verificare per farlo tornare agli albori di un tempo ?




    venerdì 2 aprile 2021 07:32

Risposte

Tutte le risposte