none
Exchange 2016 , activesync e errore http 200 RRS feed

  • Domanda

  • salve, ho configurato Exchange 2016 e migrato tutte le cartelle.

    ho decommisionato Exchange 2010 e ora vede come server Exchange correttamente com unico exchnage quest'ultimo in versione 2016.

    ho installato il certificato SSL e la webmail e gli Outlook interni correttamente prendono il certificato.

    ho un problema con ActiveSync però ; i cellulari non si sincronizzano . la nat sul firewall è corretta

    il test connectivity di microsoft da come errore :

    The Microsoft Connectivity Analyzer couldn't find MS-Server-ActiveSync and MS-ASProtocolVersions header.
    HTTP Response Headers:
    Allow: OPTIONS, TRACE, GET, HEAD, POST
    request-id: d1459aba-ebe4-421a-9a3f-ed7e3901c3d8
    X-CalculatedBETarget: ex2k16.dominiointerno.corp
    Public: OPTIONS, TRACE, GET, HEAD, POST
    X-FEServer: EX2K16
    Content-Length: 0
    Cache-Control: private
    Date: Mon, 16 Oct 2017 15:47:26 GMT
    Set-Cookie: X-BackEndCookie=S-1-5-21-1358860356-3491353967-3496087889-500=u56Lnp2ejJqBzpnMnc+dmczSz8+bxtLLm8fI0sadncjSnpmczc+bysnJyprNgYHNz87I0s7O0s7Kq87KxcvIxc3J; expires=Wed, 15-Nov-2017 15:47:26 GMT; path=/Microsoft-Server-ActiveSync; secure; HttpOnly
    Server: Microsoft-IIS/8.5
    X-AspNet-Version: 4.0.30319
    X-Powered-By: ASP.NET
    Elapsed Time: 65 ms.

    se da shell do il comando :

    Test-ActiveSyncConnectivity -URL https://webmail.dominio.it/Microsoft-Server-ActiveSync

    da questo errore :

    Il comando OPTIONS ha restituito HTTP 200, ma non è stata restituita l'intestazione di Exchange ActiveSync (MS-Server-ActiveSync). È probabile che la richiesta non abbia raggiunto un server Accesso client per uno dei seguenti motivi: - È intervenuto un server proxy (controllare che una delle intestazioni che seguono non sia stata restituita da un proxy). - Non è stato possibile raggiungere la directory virtuale: https://webmail.dominio.it/Microsoft-Server-ActiveSync. - La directory virtuale non punta a un server Accesso client: https://webmail.dominio.it/Microsoft-Server-ActiveSync. Intestazioni di risposta HTTP: Allow: OPTIONS, TRACE, GET, HEAD, POST request-id: ec3766a8-f395-4df5-ad2c-4e4eeaa3c2a1 X-CalculatedBETarget: ex2k16.legeanet.corp Public: OPTIONS, TRACE, GET, HEAD, POST X-FEServer: EX2K16 Content-Length: 0 Cache-Control: private Date: Mon, 16 Oct 2017 15:43:20 GMT Set-Cookie: X-BackEndCookie=S-1-5-21-1358860356-3491353967-3496087889-5119=u56Lnp2ejJqBzpnMnc+dmczSz8+bxtLLm8fI0sadncjSnpmczc+bysnJyprNgYHNz87I0s7O0s7Kq87KxcvMxc3P; expires=Wed, 15-Nov-2017 15:43:20 GMT; path=/Microsoft-Server-ActiveSync; secure; HttpOnly Server: Microsoft-IIS/8.5 X-AspNet-Version: 4.0.30319 X-Powered-By: ASP.NET

    ho rimosso la directory virtuale con

    Remove-ActiveSyncVirtualDirectory -Identity Microsoft-Server-ActiveSync (Default Web Site)

    ricreata con

    New-ActiveSyncVirtualDirectory -WebSiteName “Default Web Site” -ExternalUrl https://webmail.dominio.it/Microsoft-Server-ActiveSync -InternalUrl https://webmail.dominio.it/Microsoft-Server-ActiveSync

    nel ECP nella gestione delle directory virtuali è correttamente spuntato autenticazione di base e ignora certificati client

    che devo fare più?

    grazie

    M.

    lunedì 16 ottobre 2017 15:57

Risposte

  • risolto il problema !!!

    in pratica l'errore era la configurazione AD della cartella ActiveSync Exchange Back End

    sono entrato sul domain controller e tramite l'adsiedit ho rimosso il puntamento

    poi sotto la shell di exchange l'ho ricreata con questo script :

    New-ActiveSyncVirtualDirectory -WebSiteName “Exchange Back End”

    e la posta sul mobile ha iniziato a funzionare correttamente !!!

    spero possa servire anche ad altri come soluzione

    grazie a tutti

    M.

    martedì 17 ottobre 2017 08:52

Tutte le risposte

  • Ciao, prima di tutto i test falli da dentro, elimini un point of failure, tanto se non va internamente non andrà mai da fuori. Seconda cosa, il certificato com'è? terze parti o con CA interna?

    I test sulle mailbox ed i mobile andrebbero fatti PRIMA di migrare tutto il server..perchè poi se ci sono problemi diventa abbastanza complicato andare a risolverli quando hai tutto su...

    Dopo che hai modificato le vdir hai riavviato iis? controlla anche nei log application se ti hai errori e soprattutto quando provi ad agganciare un dispositivo che errore da?

    dai un occhio qui

    https://social.technet.microsoft.com/Forums/ie/en-US/b3bfb757-37b8-410f-9c71-0465993ea78e/activesync-not-working-for-any-users-with-exchange-2016?forum=Exch2016CM

    comunque il tuo errore è classico di quando non riesce a raggiungere il server, quindi il test da dentro è la prima cosa.

    ciao.

    A.

    lunedì 16 ottobre 2017 16:17
    Moderatore
  • ciao,

    il test oltre che farlo da fuori, se vedi nel primo post, l'ho fatto anche da dentro

    se da shell do il comando :

    Test-ActiveSyncConnectivity -URL https://webmail.dominio.it/Microsoft-Server-ActiveSync

    da questo errore :

    Il comando OPTIONS ha restituito HTTP 200, ma non è stata restituita l'intestazione di Exchange ActiveSync (MS-Server-ActiveSync). È probabile che la richiesta non abbia raggiunto un server Accesso client per uno dei seguenti motivi: - È intervenuto un server proxy (controllare che una delle intestazioni che seguono non sia stata restituita da un proxy). - Non è stato possibile raggiungere la directory virtuale: https://webmail.dominio.it/Microsoft-Server-ActiveSync. - La directory virtuale non punta a un server Accesso client: https://webmail.dominio.it/Microsoft-Server-ActiveSync. Intestazioni di risposta HTTP: Allow: OPTIONS, TRACE, GET, HEAD, POST request-id: ec3766a8-f395-4df5-ad2c-4e4eeaa3c2a1 X-CalculatedBETarget: ex2k16.legeanet.corp Public: OPTIONS, TRACE, GET, HEAD, POST X-FEServer: EX2K16 Content-Length: 0 Cache-Control: private Date: Mon, 16 Oct 2017 15:43:20 GMT Set-Cookie: X-BackEndCookie=S-1-5-21-1358860356-3491353967-3496087889-5119=u56Lnp2ejJqBzpnMnc+dmczSz8+bxtLLm8fI0sadncjSnpmczc+bysnJyprNgYHNz87I0s7O0s7Kq87KxcvMxc3P; expires=Wed, 15-Nov-2017 15:43:20 GMT; path=/Microsoft-Server-ActiveSync; secure; HttpOnly Server: Microsoft-IIS/8.5 X-AspNet-Version: 4.0.30319 X-Powered-By: ASP.NET

    ovviamente quando ho rimosso e rifatto le vdir ho sempre riavviato IIS

    il certificato SSL è quello di COMODO

    ho già fatto l'ereditarietà , ma niente

    nei log invece quando provo da un device non trovo errori classici di ActiveSync, zero proprio

    che mi consigli?

    grazie

    M.

    martedì 17 ottobre 2017 07:40
  • aggiungo : ho provato ad aprire https://webmail.dominio.it/Microsoft-Server-ActiveSync

    mi chiede correttamente utente e password, poi mi da questo errore, dove mi dice che mi manca questo file :

    effettivamente  la cartella microsoft server activesync non c'è... strano, no?

    martedì 17 ottobre 2017 08:31
  • risolto il problema !!!

    in pratica l'errore era la configurazione AD della cartella ActiveSync Exchange Back End

    sono entrato sul domain controller e tramite l'adsiedit ho rimosso il puntamento

    poi sotto la shell di exchange l'ho ricreata con questo script :

    New-ActiveSyncVirtualDirectory -WebSiteName “Exchange Back End”

    e la posta sul mobile ha iniziato a funzionare correttamente !!!

    spero possa servire anche ad altri come soluzione

    grazie a tutti

    M.

    martedì 17 ottobre 2017 08:52