none
SBS standard 2008 - OWA RWW Default site errore istanza COM 80070032 RRS feed

  • Domanda

  • SBS 2008, DC, Exchange 2007

    Ho aumentato il livello del dominio DC da 2003 a 2008 e da subito il sito locale non funzionava ma l'owa si! l'rww ha sempre dato

    problemi. Ora anche l'owa non funziona come vedete nell'immagine

    Impossibile creare un'istanza del componente COM con .... 80070032

    Cosa è successo?

    E' colpa dell'elevamento del dominio?

    Devo dire che IIS ora richiede le credenziali ma quelle dell'amministratore non funzionano. Devo togliere e rimettere IIS?

    C'è pericolo che perda i dati?

    Cosa devo fare o dove trovo le soluzioni?

    Grazie Emanuele

    giovedì 9 febbraio 2012 20:03

Tutte le risposte

  • Ciao, facciamo una cosa alla volta e non andare nel panico :-). Non riesco a capire cosa c'entri il fatto di elevare il livello di dominio con l'owa che non va più. Tu hai SOLO un sbs2008 vero? non hai fatto l'errore di mettere altri server DC nella struttura vero? Passando oltre, cosa vuol dire "IIS richiede le credenziali" quando accedi al sito locale? Comunque, l'IIS lo gestisci dalla sua console in strumenti di amministrazione IIS7. Controlla che i siti siano su e che ci sia abilitato sia l'http che l'https perchè alcune volte si disabilità facendo certe operazioni.

    Se disinstalli e reinstalli IIS in ogni caso non perdi dati, ci mancherebbe, al massimo perdereai la funzionalità owa. Ma le mailbox ed i MAPI client non avranno problemi perchè l'iis gestisce solo il ruolo CAS del server.

    Comunque, prima di fare una cosa del genere controlla l'IIS. Poi vediamo.

    P.s il server dopo l'elevamento del livello l'hai riavviato vero? (domanda stupida..ma devo farla).

    A.

    venerdì 10 febbraio 2012 14:01
    Moderatore
  • Questo è avvenuto dopo l'elevamento, come il problema di non riuscire a far connettere xp al dominio. L'IIS ci sono andato sopra dallo strumenti amministratore e cliaccando sopra il nodo, nella schermata del servizio IIS, mi chiede le credenziali.

    Ho un solo DC ma i siti interni sono down. Questa è l'immagine dalla console. Ora ho reinstallato Sharepoint ma non ho ancora riavviato. Ovviamente con l'elevamento ho fatto il riavvio.

    Come si vede dall'immagine tutti i siti interni sono down. Quello importante è owa visto che RWW non ha funzionato, ossia non sono riuscito ad installarlo mentre quello interno non viene usato.

    Grazie Emanuele


    Quello che mi chiede IIS

    Questo è quello che mi chiede IIS con l'errore su detto. Comunque sto provvedendo a togliere i ruoli web IIS e a rimetterli. Speriamo si risistemi tutto

    La causa può essere lo spostamento dei dati sharepoint da C: ad un'altra partizione? poiché in C: non c'era più spazio sono stato costretto a farlo. Poi ho ricavato lo spazio in un qualche modo e non sono riuscito a far tornare i dati sharepoint su c: tramite comando di console.

    Grazie Emanuele

    • Modificato emanuele coscia sabato 11 febbraio 2012 06:36 aggiornamento info
    venerdì 10 febbraio 2012 16:36
  • Togliendo i servizi web iis mi ha detto che per un errore di aggiornamento non è stato possibile effettuare l'operazione che è stata annullata e mi ritrovo punto e d'accapo.

    Va detto che ho deselezionato la richiesta di rimozione degli aggiornamenti sharepoint e di un altro (casella 1 e 3 della domanda posta verso la fine del processo di selezione per la rimozione) sono impreciso poiché stavo pensando ad altro e non ho tenuto traccia di quello che stava chiedendo, scusate.

    Grazie Emanuele

    PS

    da quanto leggo qua potrebbe il tutto essere prodotto dall'aver spostato i dati sharepoint?

    http://support.microsoft.com/kb/248033/en-us

    strano perché l'ho spostati ma non ha dato problemi ora mi ritrovo dopo due settimane di perfetto funzionamento con dei problemi.

    Grazie

    sabato 11 febbraio 2012 07:34
  • non modificare nient'altro perchè rischi di peggiorare la situazione.

    quali errori trovi nel registro eventi dell'sbs, sezioni system e applications ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    domenica 12 febbraio 2012 08:38
    Moderatore
  • Non so se sono tutti ma li ho filtrati per 24 ore, credo siano sufficienti, in grassetto l'ID

    Sharepoint 27745 e mi dice che è impossibile trovare descrittore evento poiché il componente che ha generato l'evento non è installato

    SQL  24583 Encountered Calling ICommandText ... 0x80040e14

    MSSQL$Microsoft 18210 il componente che ha generato l'evento non è installato

    Sharepoint 10036 errore di database

    DistributedCOM 10010 Il server {752073A1-23F2-4396-85F0-8FDB879ED0ED} non si è registrato con DCOM entro il timeout richiesto

    MSExchangeFBPublish 8206  impossibile preparare una tabella dei messaggi oer l'elaborazione del thread di polling sulla macchina virtuale MIOSERVER. Numero errore 0x80040115 Assicurarsi che il servizio archivio informazioni di Exchange sia in esecuzione

    ID 7001 il Gateway di TS dipendente dal servizio Pubblicazione sul web non si è avviato perché avvio del gruppo o del servizio di dipendenza non è riuscito

    Sharepoint 6772 Errore interno processo timer {FD730E80-C470-4D92-B0E5-F57C98ABDF4A} per il servizio {00000000-0000-0000-0000-000000000000}

    Sharepoint 6398 Eccezione generata dal metodo Execute della definizione di percorso. Microsoft.Sharepoint.Administration.SPConfiguration.RefreshJobDefinitio {ID 0850f062-0d47-48eb-94a8-f30f14587aa7}. Cannot open database "SharePoint_Config_0981774d-c345-4712-8b65-fc58c29d0262" requested by the login The login failed for NT AUTHORITY\Servizio di rete

    Sharepoint 5586 Errore di livello di trasporto mentre si stava inviando una richiesta al server

    Sharepoint 5215 Impossibile connettersi al database

    WAS 5036 Errore durante l'inizializzazione di Gestione configurazione per il servizio Attivazione processo Windows

    Servicing 4385 Manutenzione Pacchietti Windows: impossibile completare processo di impostaione dello stato Assente per l'aggiornamento ...

    Servicing 4375 Manutenzione pacchetti windows: impossibile completare il processo di impostazione dello stato Installate per pacchetto ...

    Sharepoint 3760 impossibile trovare il database di SQL Server 'Sharepoint_Config_...' nell'istanza di SQL server

    Sharepoint 3355 Impossibile connettersi a SQL Server Impossibile trovare np:\\pipe\MSSQL$microsoft##SSEE\sql\query

    Sharepoint services 3 search 2424 impossibile trovare aggiornamento. origini contenuto inaccessibili.

    MSExchange RPC Over HTTP AUtoconfig 2002 Si è verificato un errore improvviso

     " " " " " 2001  Si è verificato un errore.

    MSSQL$SMONITORING 1827 Istruzione CREATE DATABASE o ALTER DATABASE non riuscita

     "" ""  "" 1105 Impossibile allocare spazio per l'oggetto 'dbo.WMICollectedData'.'PK_WMICollectedData' nel database 'SBSMONITORING' il filegroup 'PRIMARY' è pieno. Liberare spazio su disco eliminando i file non necessari, eliminando ..

    Application Error 1000 lo ha generato rotatelogs.exe versione 6.2.0.13, timestamp 0x4c6fc190 modulo ntdll.dll vers 6.0.6002.18541 timpestamp 0x4ec3e855 eccezione 0xc000007b offset errore ... ID 0x1668 ...

    SQLVDI   1  SCANMAIL

    CertificationAutority   44

    TermDD 50

    DatacollectorSVC 0

    Grazie Emanuele

    domenica 12 febbraio 2012 16:43
  • scusa ma la quantità di errori è tale che secondo me qui non ha mai funzionato nulla.

    sei sicuro che tutto sia nato solo dopo l'elevamento del functional level ?

    di tutto quello che c'è a bordo di questo sbs cosa ti è possibile disinstallare ?

    hai dei backup integrali di questo server ?

    hai dei backup di tutti i database di sql server ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    lunedì 13 febbraio 2012 11:15
    Moderatore
  • Ho ereditato la gestione di questo server quindi mi ritrovo a dover far quello che altri non hanno fatto. L'elevamento è l'ultima cosa che ho fatto, a parte cambiare alcune chiavi di registro perché mi dava errori nel back-up a causa di copie shadow.

    Non so cosa posso togliere. Presumo Sharepoint 3.0 visto che ad oggi non lo hanno configurato e, quando ho provato mi dava un errore sul default.aspx

    E' un SBS 2008 essential, con Exchange 2007, Sharepoint 3.0

    Ho fatto il backup su un hd esterno dalla utility della microsoft, dopo aver spostato spazio nelle partizioni visto che in c: c'erano rimasti meno di 1 gb e quindi le email non arrivavano. Ho prima compresso ma, per una corretta gestione ho fatto questo spostamento di spazio, spostando anche i dati di sharepoint che stavano su c:. Da qui ho messo il back-up e poi ho elevato il functional level, anche perché necessitavo di controlli sugli accessi che non venivano effettuati con il livello 2003.

    Non so se i backup sono integrali o se posso metter mano al NAS (la cui user e password non funzionano) e recuperare da li. Temo la cancellazione di dati con il recupero. Ho provato il restore di Exchange e di Sharepoint ma non ha sortito effetto.

    Non so se ci sono i backup dei database sul NAS quindi sono costretto a dire di no visto l'impossibilità ad accedere al NAS

    Ho provato togliendo IIS e ci sono riuscito solo che ora non mi permette di rimetterlo. Avrei tanta voglia di formattare (scherzo) ... però non riesco ad individuare la ragione e temo, questa è una sensazione, che ci sia più di una motivazione ossia che due o più servizi non funzionino contemporaneamente ... come se uno si legasse all'altro.


    lunedì 13 febbraio 2012 15:11
  • L'elevamento pensavo fosse un problema a causa del fatto che CompanyWeb era offline da subito dopo. I computer con XP sono stati buttati fuori (ma l'utente ha optato per acquistare macchine con Win7 per mia fortuna). dopo 15-20 gg anche OWA è scomparso e dalla console ho visto l'errore sulla classe come da figura. Ecco perché ho parlato dell'elevamento come potenziale colpevole del problema
    lunedì 13 febbraio 2012 15:20
  • Ho ripristinato c:\ anche se non mi permette di ripristinarla tutta a meno di non farlo su una unità esterna, facendo sovrascrivere i file nella speranza che torni allo stato d'origine del back-up dove tutto funzionava. Il fatto è che il DC era 2003 e non 2008, spero di non aver fatto casini, comunque sono riuscito ad avere accesso al NAS che è gestito da Symantec (brutta bestia preferivo altri software ma ho questo).

    A questo punto devo ripristinare il tutto e mi chiedo

    Dato che le partizioni sono differenti rispetto ai relativi backup, posso fare comunque il recover dal backup o mi devo attendere un errore di incongruenza?

    Sulla console di backup microsoft mi dice che posso fare il ripristino del software, e non ha sortito effetto, delle unità e mi dice che devo fare questa su una diversa da quella selezionata e dei file che funziona a meno di non selezionarli tutti nel qual caso dice che non posso farlo.

    Esistono alternative magari con script su powershell dove posso dire di ripristinare il tutto, bit per bit se necessario?

    Grazie Emanuele

    martedì 14 febbraio 2012 10:35
  • da quello che hai scritto negli ultimi tre post ho l'impressione che tu ti stia muovendo totalmente a casaccio ed io ti avevo già suggerito di esaminare bene la situazione e vagliare tutte le possibilità chiedendo molti consigli prima di effettuare qualsiasi operazione con il rischio di compromettere una situazione che ritengo già irrimediabilmente compromessa.

    l'ultima operazione poi, di ripristinare uno stato di un dc 2003 su una macchina con sbs2008 è una follia assoluta.

    ti consiglio di prendere in esame seriamente la possibilità di dovr rifare tutto il dominio e di verificare cosa effettivamente si possa recuperare da quel NAS, in particolare i database di exchange e i database di sql server che stavano alle spalle del server sharepoint.

    già che ci sono, ti consiglio anche vivamente di farti assistere da un sistemista esperto sulla piazza in cui ti trovi che conosca bene sbs, exchange e sharepoint.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    martedì 14 febbraio 2012 11:07
    Moderatore
  • Grazie e hai ragione. comunque voglio sistemare i casini.

    Detto ciò penso che tutto dipenda da 2 fattori del quale uno dipendente dall'altro. Per un motivo a me sconosciuto IIS mi chiede le credenziali e non riconosce l'amministratore come colui che ha le credenziali dandomi l'errore in figura 2. A questo punto devo ripristinare IIS ma non so come fare. Andando a disinstallarlo come un normale programma? L'ho tolto, presumo, dalle funzionalità di windows server ma è rimasto nei ruoli. Ho provato a rimetterlo ma sembra impossibile farlo.

    Se IIS è responsabile di tutto devo in qualche modo eliminarlo e rimetterlo. Oggi ho visto che il Processo Attivazione WAS ha un errore. Non posso fermarlo con "net stop" e quindi non posso attivarlo. Credo che siano questi due i problemi.

    Se dovessi mettere il dvd di windows 2008 sbs esiste la funzione di "Ripristino del sistema" come con Windows Xp? ossia ... e già penso sia impossibile essendoci un Dominio ... posso far partire la macchina da dvd e cercare nel medesimo il sistema per tentare il ripristino di eventuali disfunsioni?

    Proverò a cercare ancora cosa e perché. Unico problema è recuperare le email di quel buco della settimana ... credo che esporterò tutte in un pst e deframmenterò il db ... anche se non lo mai fatto ma leggerò tutte le guide possibili e immaginabili.

    Esiste, infine, un qualche libro con un How To dove ci sono i maggiori problemi o le strategie per gestire un server?

    Ho preso i libri di amministrazione ma di questi problemi sto diventando cieco a leggerli a monitor ...

    Grazie Emanuele

    mercoledì 15 febbraio 2012 08:01
  • ripeto: il miglior consiglio che posso darti è quello di farti aiutare da un esperto.

    in bocca al lupo.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    mercoledì 15 febbraio 2012 14:57
    Moderatore
  • Hai ragione. Comunque credo di aver individuato l'arcano ... e da qui dovrò farmi aiutare visto che non so come agire.

    Il problema è il database MSSQL che è pieno. Un errore che trovo è che il database ha raggiunto il limite di 4096 MB della licenza.

    Forse abbassando questo, con una frammentazione o altro, sarà possibile, per lo meno, riuscire a ricevere tutte le email e ripristinare owa

    mercoledì 15 febbraio 2012 19:00