none
SQLServerManagementStudio - schede

    Domanda

  • Buongiorno a tutti,
    mi rendo conto che la domanda sia da newbe, ma proprio non ho trovato la soluzione.

    Sul buon, vecchio, Win7, aprendo la prima volta ssms all'avvio del PC, ogni file *.sql si apriva come una nuova scheda su quel singolo processo.

    Con Windows 10 non riesco, mi apre millemila processi, tutti da una scheda. Posso trascinare i file nel programma, in questo modo funziona, ma mi rallenta.

    Avete idea di come si risolva? :-(
    Capisco possa sembrare banale, ma mi rallenta molto.

    Grazie mille

    martedì 30 gennaio 2018 12:16

Tutte le risposte

  • Ciao Andrea,

    Riusciresti a postare uno screenshot?

    Regards

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon

    venerdì 2 febbraio 2018 16:20
  • Buongiorno Simon,
    ecco qua:

    lunedì 5 febbraio 2018 09:52
  • Ciao Andrea,

    Prova così:

    Impostazioni

    Personalizzazione

    Barra delle applicazioni

    Combina i pulsanti della barra delle applicazioni: Mai

    Regards

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon

    lunedì 5 febbraio 2018 15:32
  • Mai, sempre, solo quando necessario, partono sempre due processi.

    lunedì 5 febbraio 2018 15:39
  • Ciao Andrea,

    Ho trovato una possibile soluzione https://social.msdn.microsoft.com/Forums/sqlserver/en-US/9a8b2558-364e-4919-88f5-82663e124e14/multiple-sql-files-opening-in-multiple-ssms-instances?forum=sqltools

    controlla che queste chiavi abbiano il seguente valore

    HKEY_CLASSES_ROOT\ssms.sql.12.0\Shell\Command

    valore: "C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\ManagementStudio\ssms.exe" "%1" /dde

    HKEY_CLASSES_ROOT\.sql

    valore: ssms.sql.12.0

    Vai nel percorso di ssms.exe, nelle tab compatibilità delle proprietà dell'eseguibile togli la spunta da "esegui questo programma da amministratore.

    Fammi sapere come va.

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon

    lunedì 5 febbraio 2018 16:50
  • Ciao Simon,
    e grazie per il pronto riscontro. Ho scaricato le chiavi, ho un livello 17 di ssms:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\ssms.sql.14.0\Shell\Open\Command]
    @="\"C:\\Program Files (x86)\\Microsoft SQL Server\\140\\Tools\\Binn\\ManagementStudio\\ssms.exe\" /dde"

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.sql]
    "PerceivedType"="text"
    @="SQLFile"

    [HKEY_CLASSES_ROOT\.sql\PersistentHandler]
    @="{5e941d80-bf96-11cd-b579-08002b30bfeb}"

    Te le incollo, non le ho modificate. Per le compatibilità, credo che già sia così, ho controllato:

    Grazie per il tuo tempo, apprezzo davvero tanto.

    martedì 6 febbraio 2018 11:39
  • Sulla prima chiave prima del /dde puoi mettere "%1"  ? incluso le virgolette , fai un riavvio della macchina dopo.

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon


    • Modificato Simon.Rech martedì 6 febbraio 2018 15:50
    martedì 6 febbraio 2018 15:50
  • Ancora KO, ecco la chiave:
    "C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\ManagementStudio\ssms.exe" "%1" /dde

    Grazie

    giovedì 8 febbraio 2018 08:30
  • Simon buongiorno,
    qualche altra idea per me? :-(

    Grazie mille
    domenica 11 febbraio 2018 12:03
  • Ciao Andrea,

    Fai questo test da riga di comando... ovviamente al posto di samplequery.sql metti il percorso del tuo file

    "C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\ManagementStudio\ssms.exe\"  "D:\ Sample Query.sql" /dde

    Fammi sapere!

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    domenica 11 febbraio 2018 20:51
  • Ciao Simon, grazie, purtroppo apre ancora due processi distinti.

    Grazie per il tuo tempo
    lunedì 12 febbraio 2018 08:35
  • Ciao Andrea,

    Ho replicato il tuo problema sul mio Windows 10. Appena ho cambiato la chiave di registro Computer\HKEY_CLASSES_ROOT\ssms.sql.14.0\Shell\Open\Command in "C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\ManagementStudio\ssms.exe" "%1" /dde 

    Le schede adesso mi si aprono in un singolo SSMS.

    Prova a controllare il tuo registro!

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    lunedì 12 febbraio 2018 23:05