none
Permessi minimi per cassetta postale sala o attrezzatura (room mailbox) RRS feed

  • Domanda

  • Ciao a tutti,

    ho migrato da poco ad exchange 2010 e convertito le cassette postali delle sale riunione in modo appropriato.

    Ho una difficoltà riportata solo da alcuni utenti che usano outlook 2007:

    quando provano a prenotare una sala, gli veniva risposto: "Sala riunione xxxx" è stato contrassegnato come risorsa. Impossibile pianificare una riunione con "Sala riunione xxxx" perchè non si dispone delle autorizzazioni appropriate per l'account specificato. ......."

    allora ho messo un utente dentro gli utenti a cui è permesso fare schedulazioni fuori criterio, nelle proprietà della sala riunione. Il messaggio di errore è cambiato in: "Operazione non  riuscita. Impossibile trovare un oggetto. Impossibile prenotare direttamente una risorsa per la riunione specificata."

    Cosa può essere?

    di seguito alcuni dati che possono esser utili:

    [PS] C:\>Get-MailboxPermission -Identity beccaria_sr | fl user, access* User : NT AUTHORITY\SELF AccessRights : {FullAccess, SendAs, ExternalAccount, ReadPermission} User : XXXX\besadmin AccessRights : {FullAccess} User : XXXX\Domain Admins AccessRights : {FullAccess} User : XXXX\Enterprise Admins AccessRights : {FullAccess} User : XXXX\Organization Management AccessRights : {FullAccess} User : XXXX\Administrator AccessRights : {FullAccess} User : XXXX\Exchange Servers AccessRights : {FullAccess} User : XXXX\Exchange Domain Servers AccessRights : {FullAccess} User : XXXX\Organization Management AccessRights : {ReadPermission} User : XXXX\Public Folder Management AccessRights : {ReadPermission} User : NT AUTHORITY\SYSTEM AccessRights : {FullAccess} User : NT AUTHORITY\NETWORK SERVICE AccessRights : {ReadPermission} User : XXXX\Exchange Domain Servers AccessRights : {ReadPermission} User : XXXX\Exchange Servers AccessRights : {ReadPermission} User : XXXX\Delegated Setup AccessRights : {ReadPermission} User : XXXX\Organization Management AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner} User : XXXX\Exchange Trusted Subsystem AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner} User : XXXX\Administrator AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner} User : XXXX\Enterprise Admins AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner} User : XXXX\Domain Admins AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}

    [PS] C:\>Get-MailboxFolderPermission -Identity beccaria_sr


    RunspaceId   : abfefed9-b95c-42cb-a142-ssssxxxxx5e
    FolderName   : Top of Information Store
    User         : Predefinito
    AccessRights : {None}
    Identity     : Predefinito
    IsValid      : True

    RunspaceId   : abfefed9-b95c-42cb-a142-ssssxxxxx5e
    FolderName   : Top of Information Store
    User         : Anonimo
    AccessRights : {None}
    Identity     : Anonimo
    IsValid      : True

     



    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    mercoledì 30 maggio 2012 09:27

Risposte

  • Ciao Diego,

    Proverei (la dove non fosse stato già fatto e in aggiunta a quanto fatto finora) a controllare le proprietà di seguito:

    PR_SCHDINFO_AUTO_ACCEPT_APPTS - "Automatically accept meeting requests and process cancellations"    
    PR_SCHDINFO_DISALLOW_OVERLAPPING_APPTS - "Automatically decline conflicting meeting requests"    
    PR_SCHDINFO_DISALLOW_RECURRING_APPTS - "Automatically decline recurring meeting requests"

    ovvero a togliere la spunta da Outlook e ad impostare su "False" da MFCMapi, come da qui: SetAA – Tweak Auto Accept Settings Across Mailboxes e qui: How to Upgrade Outlook Direct Booking Resource Mailboxes to Exchange 2007 (in base alle mie ricerche, si applica anche per la versione 2010 del server).

    Spero che questo ti aiuti a risolvere, scusa se posso riprendere l'argomento solo da martedi, essendo fuori ufficio questi giorni.

    In bocca al lupo e tienici aggiornati quando puoi,


    Anca Popa Follow ForumTechNetIt on Twitter

    La Conferenza Italiana sulla Virtualizzazione

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    • Modificato Anca Popa martedì 5 giugno 2012 14:27 typo
    • Contrassegnato come risposta Anca Popa martedì 5 giugno 2012 14:28
    giovedì 31 maggio 2012 13:37
  • Ecco, trovata la soluzione....

    Dunque:

    1. riabilitato l'utente da DSA.MSC (di default gli utenti delle cassette postali risorsa sono disabilitati)
    2. lanciato un outlook con le credenziali (da una shell: runas /utente:DOMINIO\Nome_utente cmd -> viene chiesta la PW e poi si può navigare nelle directory per lanciare outlook)
    3. andato su File-Opzioni-calendario-pianificazione risorse....
    4. tolto la spunta su accetta automaticamente convocazioni riunione..... (vedi immagine)
    5. OK-OK-OK-chiudu Outlook
    6. Ri-disabilitato l'utente in DSA.msc
    7. lanciato comando da Exchange EMS: Set-MailboxFolderPermission -Identity <Sam_Name_della_sala>:\calendar -user predefinito -AccessRights none
    8. FATTO!

    Adesso tutti possono schedulare di nuovo riunioni...

    La faccenda risiede nel fatto che con exchange 2003 la prenotazione della sala era "diretta" (inserivi proprio un qualcosa nel calendario della sala) e poi l'evento veniva accettato o rifiutato mediante l'auto-accept agent.

    Con Exchange 2010, invece, si deve fare in modo che outlook invii davvero la mail senza inserire niente nel calendario, come se fosse un partecipante senziente che deve decidere se aderire o meno... (ovviamente va invitato come risorsa/sala e non come partecipante obbligatorio o facoltativo).

    Rilevando l'impostazione di accettare atuomaticamente, exchange istruiva l'outlook 2007 o precedente a tentare di fare nel "vecchio modo" che però non funziona più. Tolto la spunta e i permessi predefiniti e tutto è tornato a funzionare.

    Ricordate, quindi: Dopo la migrazione da exchange 2003 a exchange 2007* o 2010 e dopo aver trasformato le caselle di posta in "risorsa", va seguita questa procedura, per far funzionare client più vecchi di 2010.

    Ciao!!!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Contrassegnato come risposta Diego Castelli lunedì 4 giugno 2012 16:32
    lunedì 4 giugno 2012 16:31

Tutte le risposte

  • Ciao Diego,

    Proverei (la dove non fosse stato già fatto e in aggiunta a quanto fatto finora) a controllare le proprietà di seguito:

    PR_SCHDINFO_AUTO_ACCEPT_APPTS - "Automatically accept meeting requests and process cancellations"    
    PR_SCHDINFO_DISALLOW_OVERLAPPING_APPTS - "Automatically decline conflicting meeting requests"    
    PR_SCHDINFO_DISALLOW_RECURRING_APPTS - "Automatically decline recurring meeting requests"

    ovvero a togliere la spunta da Outlook e ad impostare su "False" da MFCMapi, come da qui: SetAA – Tweak Auto Accept Settings Across Mailboxes e qui: How to Upgrade Outlook Direct Booking Resource Mailboxes to Exchange 2007 (in base alle mie ricerche, si applica anche per la versione 2010 del server).

    Spero che questo ti aiuti a risolvere, scusa se posso riprendere l'argomento solo da martedi, essendo fuori ufficio questi giorni.

    In bocca al lupo e tienici aggiornati quando puoi,


    Anca Popa Follow ForumTechNetIt on Twitter

    La Conferenza Italiana sulla Virtualizzazione

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    • Modificato Anca Popa martedì 5 giugno 2012 14:27 typo
    • Contrassegnato come risposta Anca Popa martedì 5 giugno 2012 14:28
    giovedì 31 maggio 2012 13:37
  • Ciao Anca,
    la configurazione è tutta corretta:

    auto-accetta è attivato
    disallow overlapping è attivato
    disallow recurring è disattivato

    La procedura descritta nel primo articolo non fa altro che aiutarti nel caso in cui tu debba abilitarlo su più caselle di posta... però io l'ho già fatto in GUI per tutte le caselle di posta necessarie ed ho verificato: tutto OK (anche perchè ad altri l'errore non capita e le caselle rispondono correttamente accettato o rifiutato).

    La procedura descritta nel secondo articolo è la medesima seguita per convertire le mailbox migrate a resource mailbox di tipo room.

    Purtroppo sono ai passi di partenza ...
    ..ma adesso provo a fare una cosa furba... se funziona torno qui e posto.


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    lunedì 4 giugno 2012 10:19
  • Ecco, trovata la soluzione....

    Dunque:

    1. riabilitato l'utente da DSA.MSC (di default gli utenti delle cassette postali risorsa sono disabilitati)
    2. lanciato un outlook con le credenziali (da una shell: runas /utente:DOMINIO\Nome_utente cmd -> viene chiesta la PW e poi si può navigare nelle directory per lanciare outlook)
    3. andato su File-Opzioni-calendario-pianificazione risorse....
    4. tolto la spunta su accetta automaticamente convocazioni riunione..... (vedi immagine)
    5. OK-OK-OK-chiudu Outlook
    6. Ri-disabilitato l'utente in DSA.msc
    7. lanciato comando da Exchange EMS: Set-MailboxFolderPermission -Identity <Sam_Name_della_sala>:\calendar -user predefinito -AccessRights none
    8. FATTO!

    Adesso tutti possono schedulare di nuovo riunioni...

    La faccenda risiede nel fatto che con exchange 2003 la prenotazione della sala era "diretta" (inserivi proprio un qualcosa nel calendario della sala) e poi l'evento veniva accettato o rifiutato mediante l'auto-accept agent.

    Con Exchange 2010, invece, si deve fare in modo che outlook invii davvero la mail senza inserire niente nel calendario, come se fosse un partecipante senziente che deve decidere se aderire o meno... (ovviamente va invitato come risorsa/sala e non come partecipante obbligatorio o facoltativo).

    Rilevando l'impostazione di accettare atuomaticamente, exchange istruiva l'outlook 2007 o precedente a tentare di fare nel "vecchio modo" che però non funziona più. Tolto la spunta e i permessi predefiniti e tutto è tornato a funzionare.

    Ricordate, quindi: Dopo la migrazione da exchange 2003 a exchange 2007* o 2010 e dopo aver trasformato le caselle di posta in "risorsa", va seguita questa procedura, per far funzionare client più vecchi di 2010.

    Ciao!!!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Contrassegnato come risposta Diego Castelli lunedì 4 giugno 2012 16:32
    lunedì 4 giugno 2012 16:31
  • ... che poi era la stessa cosa scritta da me sopra, ma con meno parole :-)

    Grazie del feedback,


    Anca Popa Follow ForumTechNetIt on Twitter

    La Conferenza Italiana sulla Virtualizzazione

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    martedì 5 giugno 2012 14:28