none
PROBLEM WITH WINDOWS 2003 CLUSTER RRS feed

  • Domanda

  • Hello,

    I have a problem with my cluster in windows 2003 r2 enterprise. I have 2 node in cluster and when I attach resources on the secondary node, I don't view resources to cluster.

    An example: if I have resources in cluster node 1 and I move resourcer in cluster node 2 I have the following situation:

    \\nameserver : I view the shared disk

    \\namecluster : I don't view shared disk

    An idea?????

    Thank you.

    venerdì 13 luglio 2012 15:31

Tutte le risposte

  • ciao Mattia, spicca pure in italiano tanto qui siamo su un forum localizzato ;-)

    hai un cluster di cosa ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    sabato 14 luglio 2012 13:49
    Moderatore
  • Ok edoardo!! effettivamente si capiva che non sono inglese!!

    Comunque..ho un cluster costituito da 2 macchine fisiche windows 2003 enterprise e uno storage condiviso dall macchine.

    Se io assegno le risorse al nodo primario le vedo tranquillamente anche facendo \\nomecluster, mentre se le assegno al nodo secondario le vedo solo sfogliando le risorse del nodo, mentre su \\nomecluster no...

    cose posso fare??

    lunedì 16 luglio 2012 07:36
  • Strana sta cosa... Hai un solo gruppo di risorse nel cluster o più di uno ? Sicuro che (sempre che esista) viene spostato sul nodo 2 solo il gruppo di risorse del servizio ospitato dal cluster mentre il l'altro gruppo che contiene l'ip e altro rimane sul nodo 1 ? (ripeto ipotesi buttata li)
    Se apri la mmc di gestione del file server e punti a \\nomecluster le vedi le share ? Sia che le risorse siano su un nodo che su un altro ?

    martedì 17 luglio 2012 12:25
  • Nel cluster ho 3 gruppi di risorse, un gruppo gestisce ip, quorum, nome cluster, ecc....gli altri 2 gruppi gestiscono le sharing.

    Ho verificato e quando faccio sposta gruppo viene spostato solo il gruppo selezionato, gli altri restano sul nodo primario.

    Le risorse le vedo mappate su \\nomecluster solo quando risiedono sul nodo primario, mentre quando le sposto sul secondario no, ed è questo il mio problema......

    Se non sono stato abbastanza chiaro chiedetemi pure....

    martedì 17 luglio 2012 13:59
  • Nel cluster ho 3 gruppi di risorse, un gruppo gestisce ip, quorum, nome cluster, ecc....gli altri 2 gruppi gestiscono le sharing.

    Ho verificato e quando faccio sposta gruppo viene spostato solo il gruppo selezionato, gli altri restano sul nodo primario.

    Le risorse le vedo mappate su \\nomecluster solo quando risiedono sul nodo primario, mentre quando le sposto sul secondario no, ed è questo il mio problema......

    Se non sono stato abbastanza chiaro chiedetemi pure....


    OK, è giusto che se fai il "move group" di un solo gruppo sposti solo quello, per spostare tutto devi farlo per tutti e tre i gruppi.
    Le risorse hanno come possibili owner entrambi i nodi del cluster ?
    martedì 17 luglio 2012 14:58
  • Si, le risorse hanno come possibili owner entrambi i nodi del cluster, però io mi aspetto che spostando una risorsa sul nodo secondario il cluster la veda lo stesso, sbaglio??

    se ti può esser d'aiuto ti dico anche questo: prima il cluster era funzionante su una san direct attached in fibra ai nodi, ora invece (causa guasto della controller in fibra della san), è collegata su una san iscsi. questo per dirti che temporaneamente il cluster aveva perso il secondo nodo cusa guasto controller, ora però lo vede correttamente. C'è magari qualche operazione di riconfigurazione da fare per far funzionare il cluster???

    Non so veramente più dove metter mano...

    martedì 17 luglio 2012 15:08
  • Si, le risorse hanno come possibili owner entrambi i nodi del cluster, però io mi aspetto che spostando una risorsa sul nodo secondario il cluster la veda lo stesso, sbaglio??

    se ti può esser d'aiuto ti dico anche questo: prima il cluster era funzionante su una san direct attached in fibra ai nodi, ora invece (causa guasto della controller in fibra della san), è collegata su una san iscsi. questo per dirti che temporaneamente il cluster aveva perso il secondo nodo cusa guasto controller, ora però lo vede correttamente. C'è magari qualche operazione di riconfigurazione da fare per far funzionare il cluster???

    Non so veramente più dove metter mano...

    No, non sbagli.
    i due nodi vedono correttamente i dischi della san ? Da esplora risorse sul nodo del cluster riesci e sfogliare il contenuto dei dischi ?
    Per aveva perso il secondo nodo intendi che l'heartbeat del cluster dava picche e che nel cluster manager vedevi uno dei due nodi con la croce rossa oppure con il triangolino giallo ? Ora entrambi i nodi, nel cluster manager, hanno entrambi l'iconcina del "pc semplice" ?

    martedì 17 luglio 2012 15:12
  • Si, i due nodi vedono entrambi correttamente i dichi della san, ovviamente riesco a sfogliare le risorse solo sul nodo in cui la risorsa è attiva.

    Prima il nodo secondario aveva la croce rossa, non avevo più la posibilità di spostare le risorse, in quanto il nodo non trovava più i dischi della san. Attualmente entrambi i nodi nel cluster manager sono visti enza errori. Tutte le risorse sono viste senza errori e nemmeno da event viewer viene registrato qualcosa di anomalo.......

    martedì 17 luglio 2012 15:23
  • Si, i due nodi vedono entrambi correttamente i dichi della san, ovviamente riesco a sfogliare le risorse solo sul nodo in cui la risorsa è attiva.

    Prima il nodo secondario aveva la croce rossa, non avevo più la posibilità di spostare le risorse, in quanto il nodo non trovava più i dischi della san. Attualmente entrambi i nodi nel cluster manager sono visti enza errori. Tutte le risorse sono viste senza errori e nemmeno da event viewer viene registrato qualcosa di anomalo.......


    Nel cluster.log non c'è niente di strano? Hai provato a guardare?
    martedì 17 luglio 2012 15:28
  • Si ho guardato...ma ho visto che è un file indecifrabile......
    martedì 17 luglio 2012 15:31
  • Se lo apri con blocconote si...

    Prova con questo :-)

    http://technet.microsoft.com/en-us/library/aa996161(v=exchg.65)

    http://www.microsoft.com/en-us/download/confirmation.aspx?id=18479


    Mattia scusa l'indiscrezione (non è per cattiveria) però nell'ottica "risolviamo il problema" prima di farti perdere tempo a guardare il cluster.log ti faccio una domanda...
    Ripeto non è per cattiveria o per critica o altro è solo per farti risolvere il problema...
    Come le hai create le share sul cluster ???
    mercoledì 18 luglio 2012 08:27
  • Ho creato prima la share sui dischi di rete....e successivamente aggiunta al cluster, creando prima una risorsa disco e poi una risorsa condivisione.

    Cosi facendo la risorsa viene vista correttamente....ma non sul cluster quando è agganciata al nodo 2...

    mercoledì 18 luglio 2012 09:55
  • Ho creato prima la share sui dischi di rete....e successivamente aggiunta al cluster, creando prima una risorsa disco e poi una risorsa condivisione.

    Cosi facendo la risorsa viene vista correttamente....ma non sul cluster quando è agganciata al nodo 2...

    Aspetta, prima crei la cartella, poi imposti i permessi NTFS (tasto destro->proprietà->Sicurezza), poi crei la risorsa cluster e da qui crei/gestisci  la share...
    Ti giro un paio di KB
    http://support.microsoft.com/kb/224967/en-us

    http://technet.microsoft.com/en-us/library/cc787828(v=ws.10).aspx (più sentico e rapido)

    mercoledì 18 luglio 2012 10:04
  • Esatto, la gestisco così...per adesso everyone full control per evitare problemi anche sulle permission..

    ti posto i log che ho trovato con il cluster diag se ti possono esser d'aiuto..

    764:684.07/16[12:21:33.402](000000) INFO Physical Disk <Disco M:>: DiskCleanup returning final error 0
    764:684.07/16[12:21:33.402](000000) INFO Physical Disk <Disco M:>: Offline, Returning final error 0.
    2f0:5f0.07/16[12:51:00.149](1104435) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 2.
    2f0:5f0.07/16[12:51:00.149](1104435) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 1.
    764:1f0.07/16[12:51:00.195](1104437) WARN Physical Disk <Disco Q:>: [PnP] RemoveDisk: WatchedList is empty
    764:f30.07/16[12:51:00.195](1104437) INFO Physical Disk <Disco Q:>: DiskCleanup returning final error 0
    764:898.07/16[12:51:24.665](1104455) WARN Physical Disk <Disco M:>: [DiskArb] Assume ownership of the device.
    764:898.07/16[12:51:36.446](1104456) INFO Physical Disk <Disco M:>: Online, returning final error 0   ResourceState 2  Valid 1
    2f0:d18.07/16[12:53:16.947](1104462) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Picking node for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef [Servizi], suggested node 1...
    2f0:d18.07/16[12:53:16.947](1104462) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Node 1 for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef is user preferred...
    2f0:d18.07/16[12:53:16.947](1104462) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Selected node 1 for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef...
    2f0:d18.07/16[12:53:16.947](1104462) INFO [FM] FmpRmOfflineResource: RmOffline() for e5737557-0f66-4c7c-af0c-f35942c70780 returned error 997
    2f0:9a4.07/16[12:53:16.963](1104465) INFO [FM] FmpRmOfflineResource: RmOffline() for 1f31facd-e0b0-4d4f-b8a7-cc9a58403bd5 returned error 997
    764:324.07/16[12:53:17.041](1104470) INFO Physical Disk <Disco M:>: DiskCleanup returning final error 0
    764:324.07/16[12:53:17.041](1104470) INFO Physical Disk <Disco M:>: Offline, Returning final error 0.
    764:d7c.07/16[13:48:10.432](1104581) WARN Physical Disk <Disco M:>: [DiskArb] Assume ownership of the device.
    764:d7c.07/16[13:48:22.026](1104582) INFO Physical Disk <Disco M:>: Online, returning final error 0   ResourceState 2  Valid 1
    2f0:598.07/16[14:28:56.293](1104704) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 2.
    2f0:598.07/16[14:28:56.293](1104704) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 1.
    2f0:b7c.07/16[15:00:33.206](1104723) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Picking node for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef [Servizi], suggested node 1...
    2f0:b7c.07/16[15:00:33.206](1104723) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Node 1 for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef is user preferred...
    2f0:b7c.07/16[15:00:33.206](1104723) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Selected node 1 for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef...
    2f0:b7c.07/16[15:00:33.206](1104723) INFO [FM] FmpRmOfflineResource: RmOffline() for e5737557-0f66-4c7c-af0c-f35942c70780 returned error 997
    2f0:9a4.07/16[15:00:33.221](1104726) INFO [FM] FmpRmOfflineResource: RmOffline() for 1f31facd-e0b0-4d4f-b8a7-cc9a58403bd5 returned error 997
    764:664.07/16[15:00:33.284](1104731) INFO Physical Disk <Disco M:>: DiskCleanup returning final error 0
    764:664.07/16[15:00:33.284](1104731) INFO Physical Disk <Disco M:>: Offline, Returning final error 0.
    764:82c.07/16[15:01:17.659](1104766) WARN Physical Disk <Disco M:>: [DiskArb] Assume ownership of the device.
    764:82c.07/16[15:01:29.347](1104769) INFO Physical Disk <Disco M:>: Online, returning final error 0   ResourceState 2  Valid 1
    764:ab8.07/16[15:02:33.692](1104778) INFO Majority Node Set <rrr>: Delete share 22720348-aa06-470a-8ab0-061daa262baf$ err 0
    764:ab8.07/16[15:02:33.692](1104778) INFO Majority Node Set <rrr>: xFsRemove: '22720348-aa06-470a-8ab0-061daa262baf$' err 0x0
    764:ab8.07/16[15:02:33.692](1104778) INFO Majority Node Set <rrr>: xFsRemove: 'crs.log' err 0x0
    764:ab8.07/16[15:02:33.692](1104778) INFO Majority Node Set <rrr>: Delete tree \??\C:\WINDOWS\cluster\MNS.22720348-aa06-470a-8ab0-061daa262baf$ err 0
    764:ab8.07/16[15:02:33.692](1104778) INFO Majority Node Set <rrr>: Delete tree \??\C:\WINDOWS\cluster\MNS.22720348-aa06-470a-8ab0-061daa262baf$ err 0
    764:ab8.07/16[15:02:33.692](1104778) INFO Majority Node Set <rrr>: Delete ResourceId = rrr err 0.
    2f0:5f0.07/16[15:02:33.848](1104780) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 2.
    2f0:5f0.07/16[15:02:33.848](1104780) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 1.
    2f0:b7c.07/16[15:04:30.818](1104782) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 2.
    2f0:b7c.07/16[15:04:30.818](1104782) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 1.
    2f0:b7c.07/16[15:04:37.053](1104785) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 2.
    2f0:b7c.07/16[15:04:37.053](1104785) INFO [FM] Group dd85adba-30be-4fb0-83ef-1980d5730c8b preferred owner 1.
    2f0:82c.07/17[01:40:42.728](1105039) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[02:20:26.125](1105055) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[05:20:26.422](1105127) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[06:40:33.472](1105159) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[07:00:37.771](1105167) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:f14.07/17[08:16:35.855](1105197) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Picking node for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef [Servizi], suggested node 1...
    2f0:f14.07/17[08:16:35.855](1105197) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Node 1 for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef is user preferred...
    2f0:f14.07/17[08:16:35.855](1105197) INFO [FM] FmpPickNodeFromPreferredListAtRandom: Selected node 1 for group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef...
    2f0:f14.07/17[08:16:35.855](1105197) INFO [FM] FmpRmOfflineResource: RmOffline() for e5737557-0f66-4c7c-af0c-f35942c70780 returned error 997
    2f0:9a4.07/17[08:16:35.855](1105200) INFO [FM] FmpRmOfflineResource: RmOffline() for 1f31facd-e0b0-4d4f-b8a7-cc9a58403bd5 returned error 997
    764:a90.07/17[08:16:35.934](1105205) INFO Physical Disk <Disco M:>: DiskCleanup returning final error 0
    764:a90.07/17[08:16:35.934](1105205) INFO Physical Disk <Disco M:>: Offline, Returning final error 0.
    2f0:82c.07/17[16:54:45.597](1105592) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[17:00:30.523](1105594) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/18[00:10:50.563](1105766) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/18[02:46:33.284](1105828) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/18[04:21:46.952](1105868) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/18[06:22:29.521](1105916) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:b7c.07/18[07:23:37.830](1105941) INFO [FM] Group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef preferred owner 2.
    2f0:b7c.07/18[07:23:37.830](1105941) INFO [FM] Group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef preferred owner 1.
    764:d64.07/18[07:23:37.846](1105941) ERR  IP Address <ipcluster>: Unable to open node parameters key, status 2.
    2f0:ebc.07/18[07:24:10.596](1105946) INFO [FM] Group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef preferred owner 2.
    2f0:ebc.07/18[07:24:10.596](1105946) INFO [FM] Group 3eee5028-02e5-4eb9-a384-c04d3f8dc6ef preferred owner 1.
    2f0:82c.07/18[07:37:41.015](1105952) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/18[09:45:01.660](1106002) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/18[10:03:29.765](1106010) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    764:3d8.07/18[10:16:38.434](1106032) WARN Physical Disk <Disco M:>: [DiskArb] Assume ownership of the device.
    764:3d8.07/18[10:16:50.278](1106033) INFO Physical Disk <Disco M:>: Online, returning final error 0   ResourceState 2  Valid 1

    mercoledì 18 luglio 2012 10:19
  • Dunque:

    2f0:82c.07/17[01:40:42.728](1105039) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[02:20:26.125](1105055) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[05:20:26.422](1105127) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[06:40:33.472](1105159) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864
    2f0:82c.07/17[07:00:37.771](1105167) WARN [EVT] ElfWriteClusterEvents failed: status = 3221225864

    764:d64.07/18[07:23:37.846](1105941) ERR  IP Address <ipcluster>: Unable to open node parameters key, status 2.

    Il Disco M citato nel log è quello del quorum del cluster ?
    Sul nodo 2 il servizio di "cluster service" parte regolarmente ?
    Se riavvii il nodo 2, con le risorse in carico al nodo 1, hai errori nell'event viewer sotto system ?

    mercoledì 18 luglio 2012 11:28
  • No, il disco M è la condivisione che io sposto dal nodo uno al nodo due. Il quorum è assegnato alla lettera Q: e risiede sul nodo 1.

    Sul nodo 2 il servizio di cluster parte regolarmente, mentre se riavvio il nodo 2 non ho nessun errore sull'event viewer....completamente pulito...

    mercoledì 18 luglio 2012 12:11
  • No, il disco M è la condivisione che io sposto dal nodo uno al nodo due. Il quorum è assegnato alla lettera Q: e risiede sul nodo 1.

    Sul nodo 2 il servizio di cluster parte regolarmente, mentre se riavvio il nodo 2 non ho nessun errore sull'event viewer....completamente pulito...


    Come il quorum risiede sul nodo 1... risiede sul nodo 1 se anche tutte le altre risorse sono sul nodo 1 e viceversa... altrimenti poi è un disastro trovare dov'erano le risorse su che nodo ha scritto i log etc...
    Ci sono errori di scrittura su disco però... dicevi che se ti colleghi a \\nomecluster vedi le share solo se le risorse sono in carico al nodo 1, mentre se sono in carico al nodo 2 per vedere le share devi utilizzare \\nodo2. In entrambe le situazione riesci a visualizzare le share ma anche a scriverci dentro ???
    Prova a creare un'altra share ex-novo e vedi se questa funziona su entrambi i nodi
    mercoledì 18 luglio 2012 12:32
  • Si, sia una share sul nodo 1 o sul nodo 2 riesco lo stesso a leggere e scrivere....a creare una share da zero ho già provato ma nulla..stesso malfunzionamento...ho già creato anche un gruppo da zero.....ma una cosa...io non posso spostare solo qualche share sul nodo 2 lasciando il quorum sul nodo 1?? dovrebbe vederle correttamente lo stesso...sbaglio??

    mercoledì 18 luglio 2012 12:47
  • Si, sia una share sul nodo 1 o sul nodo 2 riesco lo stesso a leggere e scrivere....a creare una share da zero ho già provato ma nulla..stesso malfunzionamento...ho già creato anche un gruppo da zero.....ma una cosa...io non posso spostare solo qualche share sul nodo 2 lasciando il quorum sul nodo 1?? dovrebbe vederle correttamente lo stesso...sbaglio??


    Si, certo che puoi tenere parte delle risorse da una parte e parte dall'altra, funziona lo stesso però diciamo che non propriamente così che dovrebbe essere :-)
    Con la share ex-novo stesso problema... mmmm
    Problemi lato san ??? Non hai evidenza di qualche problema di comunicazione tra il nodo 2 e i dischi sulla san ? Sicuro che le schede iscsi sui due nodi siano configurate con gli stessi parametri ?
    Prova drastica... porta tutte le risorse sul nodo 2, metti in pausa il nodo 1 dal cluster administrator e riavvia il nodo 2.

    mercoledì 18 luglio 2012 13:09
  • Eh si...sarebbe la prova da fare.....peccato che è tutto in produzione vorrebbe dire mettere offline 3 sedi...
    mercoledì 18 luglio 2012 13:19
  • Eh si...sarebbe la prova da fare.....peccato che è tutto in produzione vorrebbe dire mettere offline 3 sedi...

    Capisco la situazione... se puoi farlo fuori orario o magari schedulare il riavvio... non so... però io proverei
    mercoledì 18 luglio 2012 13:31
  • Ho  un aggiornamento....ho appena creato un nuova nuova risorsa indirizzo ip....e messa nel gruppo dove ho configurato le share....e così funziona correttamente su entrambi i nodi!!! però se vado a spostare la risorsa nel gruppo dove c'è il quorum ancora niente........non capisco.....
    mercoledì 18 luglio 2012 13:42
  • Ho  un aggiornamento....ho appena creato un nuova nuova risorsa indirizzo ip....e messa nel gruppo dove ho configurato le share....e così funziona correttamente su entrambi i nodi!!! però se vado a spostare la risorsa nel gruppo dove c'è il quorum ancora niente........non capisco.....

    aspetta aspetta... 2 cose:
    che indirizzo ip hai messo nella risorsa ?
    Nel gruppo dove c'è il quorum c'è già una risorsa indirizzo ip? che indirizzo ip ha ?
    mercoledì 18 luglio 2012 14:02
  • Ho messo un ip libero che avevo sulla rete....ora se sposto di pari passo ip e risorse sembra girare correttamente....però se lascio la risorsa ip da una parte...e la share  dall'altra no....

    nel gruppo del quorum c'è già una risorsa ip ed anche una risorsa nome...che è quella che rappresenta il cluster....

    mercoledì 18 luglio 2012 14:20
  • Ho messo un ip libero che avevo sulla rete....ora se sposto di pari passo ip e risorse sembra girare correttamente....però se lascio la risorsa ip da una parte...e la share  dall'altra no....

    nel gruppo del quorum c'è già una risorsa ip ed anche una risorsa nome...che è quella che rappresenta il cluster....

    Dovresti avere una risorsa indirizzo ip che ha impostato l'indirizzo ip del cluster, che non è l'indirizzo IP di nessuno dei due nodi.
    E una risorsa "network name" che ha come nome il nome del account computer che ha il cluster.

    Mi confermi che è così ?

    mercoledì 18 luglio 2012 14:26
  • Esatto confermo....ho una truttura cosi impostata:

    • gruppo cluster: risorsa ip, network name, spooler, quorum
    • gruppo 1: share su san
    • gruppo 2: share su san

    Ora sono andato a creare un altro gruppo:

    • gruppoprova: risorsa ip (come se fosse un nuovo ip del cluster), share

    Se sposto gruppo prova da un nodo all'altro, vedo correttamente le risorse allocate sulla risosrsa ip che ho creato nel gruppo, ma continuo a non vederle sulla risorsa ip di gruppo cluster quando sono allocate sul nodo secondario.....

    mercoledì 18 luglio 2012 14:33
  • Esatto confermo....ho una truttura cosi impostata:

    • gruppo cluster: risorsa ip, network name, spooler, quorum
    • gruppo 1: share su san
    • gruppo 2: share su san

    Ora sono andato a creare un altro gruppo:

    • gruppoprova: risorsa ip (come se fosse un nuovo ip del cluster), share

    Se sposto gruppo prova da un nodo all'altro, vedo correttamente le risorse allocate sulla risosrsa ip che ho creato nel gruppo, ma continuo a non vederle sulla risorsa ip di gruppo cluster quando sono allocate sul nodo secondario.....

    Se ho capito bene:
    ip nodo1 10.100.200.1
    ip nodo2 10.100.200.2
    gruppo cluster: ip 10.100.200.3 + nome + quorum
    gruppoProva: ip 10.100.200.4 + share

    Se sposti gruppo cluster + gruppo 1 e 2 dal nodo 1 al nodo 2 non vedi le share puntando a \\nomelcuster
    Mentre  se sposti gruppoProva dal nodo 1 al nodo 2 e punti \\ipGruppoProva funziona
    Giusto ?

    mercoledì 18 luglio 2012 15:08
  • Quasi completamente giusto...nel senso che non mi aspetto di riuscire a migrare da un nodo all'altro gruppo 1 e gruppo 2 in quanto la san su cui risiedono ha una controller guasta verso nodo2...però mi aspetto che gruppo prova (configurato su nuova san) migri correttamente il tutto, compresa l'opzione di lasciare l'ip su un nodo e le risorse sull'altro...

    riassumento...se migro gruppo prova (ossia ip e share) gira correttamente...mentre se suddivido ip e share su 2 gruppi differenti e ne metto uno per nodo...non funziona......why?????

    mercoledì 18 luglio 2012 15:14
  • Quasi completamente giusto...nel senso che non mi aspetto di riuscire a migrare da un nodo all'altro gruppo 1 e gruppo 2 in quanto la san su cui risiedono ha una controller guasta verso nodo2...però mi aspetto che gruppo prova (configurato su nuova san) migri correttamente il tutto, compresa l'opzione di lasciare l'ip su un nodo e le risorse sull'altro...

    riassumento...se migro gruppo prova (ossia ip e share) gira correttamente...mentre se suddivido ip e share su 2 gruppi differenti e ne metto uno per nodo...non funziona......why?????


    Allora...
    crea un nuvo gruppo oltre e spostadi dentro la share che c'è in gruppo prova.
    Fai la move solo del nuovo gruppo sull'altro nodo e prova a collegarti a \\ipGruppoProva
    mercoledì 18 luglio 2012 15:35
  • Provato....e non va....devo spostare anche l'ip per farlo funzionare.....
    mercoledì 18 luglio 2012 16:01
  • Provato....e non va....devo spostare anche l'ip per farlo funzionare.....

    Dovrebbe funzionare anche metà e metà... mmmmm
    Io voto sempre per il riavvio spostando le risorse sul nodo 2 e mettendo in pausa il nodo 1
    Tenterei questa strada...
    Se no sposta nei due nuovi gruppi le risorse dei gruppi "originali" e vedi che succede se sposti le risorse sul nodo 2 visto che coi nuovi gruppi funziona...

    giovedì 19 luglio 2012 08:50
  • Già fatto...ma resta il problema che per farlo funzionare devo spostare anche l'ip...mi manca magari qualche dipendenza?????????

    giovedì 19 luglio 2012 09:33
  • Già fatto...ma resta il problema che per farlo funzionare devo spostare anche l'ip...mi manca magari qualche dipendenza?????????

    Le dipendenze necessarie sono:
    La share dipende dalle risorse disco "physical disk" e dal nome cluster "network name", in modo tale che prima di far partire il servizio di file sharing siano attivi la risorsa "nome" per la risoluzione netbios e i dischi siano disponibili  per evitare che fallisca l'attivazione delle share.
    A sua volta il nome dle cluster, al risorsa "network name" dipende dalla risorsa "ip address".
    Prova a controllare che ci siano queste...

    giovedì 19 luglio 2012 09:56
  • Ma...come faccio a far dipendere una share dal network name se per migrarle separatamente devo gestirle su 2 nodi differenti????
    giovedì 19 luglio 2012 10:42
  • Ma...come faccio a far dipendere una share dal network name se per migrarle separatamente devo gestirle su 2 nodi differenti????

    Già è vero hai 2 gruppi di risorse distinti... bhe poco male tanto le dipendenze servono per essere certi che determinati servizi partano solo se altri sono già attivi...

    Torniamo a bomba,
    1 cluster a 2 nodi. Il nodo 1 ha il controller in fibra verso la san e il nodo 2 ha un controller iscsi verso la stessa san.
    Se sposti tutte le risorse dal nodo 1 al nodo 2, riesci a visualizzarle solo da \\nodo2 e non da \\nomecluster.
    Il disco con il quorum del cluster è raggiungibile/visibile da entrambi i nodi.
    Problema:
    Se il gruppo di risorse con i componenti core del cluster (ip, nome, quorum) resta sul nodo 1 e i due gruppi con le share vengono spostati sul nodo 2 l'unico modo per visualizzare le condivisioni è da \\nodo2.
    l problema si presenta sia che venga spostato uno solo o entrambi i gruppi di risorse share sul nodo2, lasciando il gruppo con le risorse cluster sul nodo1.

    Ho dimenticato qualcosa ?

    giovedì 19 luglio 2012 12:57
  • No, è esattamente così...ragionala pure in ottica di avere i 2 server collegati iscsi....

    però il problema è esattamente quello che hai postato adesso...

    giovedì 19 luglio 2012 13:19
  • No, è esattamente così...ragionala pure in ottica di avere i 2 server collegati iscsi....

    però il problema è esattamente quello che hai postato adesso...


    iscsi o hba, cambia il protocollo... non c'è molta differenza. Però con i nodi collegati in fibra andava dicevi... strano sto fatto..
    Il quorum sta sempre sulla stessa san ???
    giovedì 19 luglio 2012 13:36
  • Allora...facciamo un passo indietro....

    sulla san in fibra non funziona piu perchè è guasta la controller sul nodo 2....

    quella iscsi è un'altra san...alla quale sono collegati entrambi i nodi iscsi.....ora sto lavorando sulla san iscsi dove ho 2 gruppi:

    • cluster group: risorsa quorum, ip, nome
    • gruppo 1: contenente le sharing

    il concetto cluster funziona se sposto entrambi i gruppi...ma se ne lascio uno per nodo....non va......

    giovedì 19 luglio 2012 13:47
  • Allora...facciamo un passo indietro....

    sulla san in fibra non funziona piu perchè è guasta la controller sul nodo 2....

    quella iscsi è un'altra san...alla quale sono collegati entrambi i nodi iscsi.....ora sto lavorando sulla san iscsi dove ho 2 gruppi:

    • cluster group: risorsa quorum, ip, nome
    • gruppo 1: contenente le sharing

    il concetto cluster funziona se sposto entrambi i gruppi...ma se ne lascio uno per nodo....non va......

    ok, per cui:

    cluster group su nodo 1 e gruppo1 su nodo 2, puntando a \\nomecluster non vedi le share
    e
    cluster group su nodo 2 e gruppo1 su nodo 1, puntando a \\nomecluster non vedi le share

    Giusto ???

    giovedì 19 luglio 2012 14:24
  • Esatto!!! non capisco come risolvere....

    giovedì 19 luglio 2012 14:29
  • Esatto!!! non capisco come risolvere....


    Non mi viene in mente altro... provo a vedere se trovo qualcosa
    venerdì 20 luglio 2012 12:59
  • Ciao Mattia,

    scusa se ti chiedo ulteriori informazioni che possono sembrare banali:

    1. L'ordine dei binding e uguale su tutti i nodi?

    2. ci sono stati cambiamenti sullo stack di rete, a partire dal livello fisico? (schede di rete, configurazione ip, etc..)

    3. Ha mai funzionato?

    4. sei in multicast o unicast mode?

     

    venerdì 20 luglio 2012 18:14
  • Ciao Mattia,

    scusa se ti chiedo ulteriori informazioni che possono sembrare banali:

    1. L'ordine dei binding e uguale su tutti i nodi?

    2. ci sono stati cambiamenti sullo stack di rete, a partire dal livello fisico? (schede di rete, configurazione ip, etc..)

    3. Ha mai funzionato?

    4. sei in multicast o unicast mode?


    Ciao Alessandro,
    scusa se mi permetto ma provo a dare due indicazioni in più a Mattia sulle verifiche da te richieste...
    Dunque:

    1.
    Verifica del bindind - > apri "connessioni di rete" dal pannello di controllo dalla barra dei menu scegli "Avanzate" -> "impostazioni avanzate". nella finestra che si apre vai su "Schede e bindig" e sposta con le frecce l'ordine delle connessioni che rispondono ai servizi erogati dal cluster. In cime metti il teaming.

    2 e 3 direi di no, ma Mattia lo può confermare meglio di me

    4. Leggi qua: http://technet.microsoft.com/en-us/library/cc782694(v=ws.10).aspx

    lunedì 6 agosto 2012 12:49