locked
Errore installazione .NET Framework Windows Server 2016 Essentials RRS feed

  • Domanda

  • Buongiorno abbiamo windows server essentials 2016 dovremmo installare il .net framework ma all'atto dell'installazione dopo alcuni step la stessa si blocca e ci rimanda l'errore %1 non è un'applicazione di win32 valida.

    Come possiamo fare? 

    Grazie mille per chi ci potrà aiutare.

    Buon lavoro 

    Marco



    • Modificato MarcoFore mercoledì 19 giugno 2019 11:41
    • Modificato NinoRCTNModerator domenica 23 giugno 2019 06:31 Formattazione titolo
    mercoledì 19 giugno 2019 11:41

Tutte le risposte

  • Che versione di .NET framework? Se si tratta di una versione tra 4 e 4.7 scarica e installa questo file:
    https://www.microsoft.com/it-it/download/details.aspx?id=55167

    Nel caso elenca esattamente tutti i passaggi che esegui.

    mercoledì 19 giugno 2019 14:46
    Moderatore
  • ho provato a caricare la versione 4.8 online e mi rilascia il seguente errore

    OS Version = 10.0.14393, SP = 0.0, Platform 2
    OS Description = Future OS - x64 
    MSI = 5.0.14393.2791
    Windows servicing = 10.0.14393.0
    CommandLine = D:\acf69472cbac29957a63e76f84\\Setup.exe /x86 /x64 /web
    TimeZone = ora legale Europa occidentale
    Initial LCID = 1040
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4.8 Setup
    Package Version = 4.8.03761
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 7
    Final Result: Installation failed with error code: (0x000000C1) (Elapsed time: 0 00:03:38).

    sabato 22 giugno 2019 08:46
  • con la 4.7.2 invece mi da questo file log

    OS Version = 10.0.14393, SP = 0.0, Platform 2
    OS Description = Future OS - x64 Unkonw Edition (ProductType=50) 
    MSI = 5.0.14393.2791
    Windows servicing = 10.0.14393.0
    CommandLine = D:\381cfcac551800991d\\Setup.exe /x86 /x64 /web
    TimeZone = ora legale Europa occidentale
    Initial LCID = 1040
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4.7.2 Setup
    Package Version = 4.7.03081
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 7
    Final Result: Installation failed with error code: (0x000000C1) (Elapsed time: 0 00:01:50).

    sabato 22 giugno 2019 08:58
  • sabato 22 giugno 2019 17:05
    Moderatore
  • Ciao Marco, dai una lettura al seguente thread https://social.msdn.microsoft.com/Forums/vstudio/en-US/ae4eaa00-3043-4e69-9b62-512da1a89f55/net-framework-4-installation-failed-with-quot1-is-not-a-valid-win32-applicationquot?forum=netfxsetup

    Saluti
    Nino


    www.testerlab.it

    domenica 23 giugno 2019 06:29
    Moderatore
  • Provato ma nulla.... il problema permane....:-(

    mercoledì 26 giugno 2019 06:33
  • Prova ad eseguire questo strumento:
    https://blogs.msdn.microsoft.com/astebner/2008/10/13/net-framework-setup-verification-tool-users-guide/

    Quindi riporta gli errori che ti vengono restituiti nel file di log:
    %temp%\setupverifier_errors_*.txt

    mercoledì 26 giugno 2019 07:40
    Moderatore
  • Ciao Fabrizio, 

    ti allego link al file richiesto, nel frattempo ti ringrazio.

    https://1drv.ms/t/s!Ajsi3rYfdGRPwnxL0Wvh6bTsuTxN

    Buon lavoro e grazie 

    Marco

    mercoledì 26 giugno 2019 12:28
  • Potresti allegare anche il log "setupverifier_errors"?
    mercoledì 26 giugno 2019 14:15
    Moderatore
  • È quello. Se cerchi nel percorso %temp%, trovi il file setupverifier_errors. Lo apri ed è quello che ti ho inviato

    mercoledì 26 giugno 2019 15:08
  • Io vedo solo il log "setupverifier_main". Comunque da quest'ultimo non noto particolari errori: sei sicuro che il .net framework non sia effettivamente già installato nel sistema?
    Il tuo sistema operativo dovrebbe essere un OEM, quindi è possibile che il produttore del server abbia già preinstallato alcune caratteristiche.

    mercoledì 26 giugno 2019 20:52
    Moderatore
  • Non è installato. Vedo installati, ma non visibili in “programmi e funzionalità” il netframework 4.7.1

    Per quanto concerne il sistema OEM di Dell, dubito che sia stato inserito un prodotto che è uscito notevolmente dopo l’installazione del server

    giovedì 27 giugno 2019 06:53
  • La situazione è anomala perché come ti dicevo anche l'installazione della 4.7.2 non mostra errori, non vorrei che ci sia un conflitto con una installazione di una versione precedente del .net framework.
    Visto che è un sistema OEM secondo me dovresti provare a chiedere anche al supporto Dell (i sistemi operativi OEM, poiché personalizzati dal produttore, non sono supportati direttamente da Microsoft) oppure provare ad eseguire direttamente una reinstallazione di una immagine "pulita".
    giovedì 27 giugno 2019 08:05
    Moderatore