none
Foundation 2012 R2 e Terminal Server RRS feed

  • Domanda

  • Salve a tutti,

    mi trovo ad implementare su uno scenario esistente degli accessi terminal server dei quali ho ridotta esperienza.

    Il server attuale, configurato come workgroup, è un WS 2012 R2 ed ospita solamente un db postgree e ci accedono 2 client.

    Si deve installare un nuovo software gestionale che "a detta dell'assistenza tecnica" lavora esclusivamente via TS. Pertanto chiedono di predisporre il sistema prima dell'installazione.

    Installo il ruolo, installano stò benedetto programma, e pare che funziona tutto con i 120 gg di prova. Quindi acquisto le licenze. Attivate correttamente ma il sistema mi dice che non sono configurate correttamente. Vado a cercare di configurarle ed esce il delirio: pare che sia necessario un DC, ma Foundation non può essere DC, allora pare che le CAL "device" non necessitino di DC, quindi trovo la possibilità di convertire le CAL "User" acquistate in "Device", ma prima di procedere vorrei delle conferme circa la fattibilità!

    Ma possibile che con la prova di 120 gg tutto ok e vado a mettere le licenze e mi fa tutte ste storie?

    lunedì 28 settembre 2015 12:34

Tutte le risposte

  • Ciao Fabio, potresti indicare l'infrastruttura nel suo insieme e le attività che dovresti svolgere per convertire le RDS CAL.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    lunedì 28 settembre 2015 14:10
    Moderatore
  • Allora situazione Attuale:

    - WS 2012 R2 Foundation

    - 2 client accedono ad un postgree sql senza problemi con un applicativo client

    - 4 client accedono al proprio utente TS senza problemi utilizzando un altro applicativo sullo stesso server e con le licenze di prova a 120 gg.

    Acquistate le licenze, attivate, ma per configurarle il delirio. A me basta che funziona come è adesso, solo che anziche le licenze di prova vada con quelle definitive.

    Per convertire le RDS cal ho trovato un wizard direttamente nella gestione licenze di RDS, solo che prima di procedere vorrei avere il parere di chi ne sa più di me. L'idea è venuta googlando e scoprendo che le "device CAL" non necessitano di DC, mentre le "user CAL" si. Mi domando il perchè di queste complicazioni, dal momento che il sistema funziona con le licenze di prova.
    lunedì 28 settembre 2015 14:23
  • segui questo blogpost

    http://ryanmangansitblog.com/2013/10/30/deploying-a-rdsh-server-in-a-workgroup-rds-2012-r2/

    ciao.


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 29 settembre 2015 09:39
    Moderatore
  • Forte dei gg di prova rimanenti ho atteso un pò prima di provare la tua soluzione.

    Tuttavia ci ho provato, credo di avere avere fatto tutti passi regolarmente, ma l'errore di licensing RDS continua, le licenze RDS disponibili (nel pannello di gesione licenze) sono sempre 5, quando invece dovrebbero calare mano a mano che gli utenti si collegano.

    Non sò se questo accdrà solo al reale termine delle licenze di prova, ma dovrei averne la certezza, non posso aspettare che finiscano i gg di prova, se poi alla scadenza non fa più accedere gli utenti è un delirio.

    Hai/avete altri suggerimenti?

    Grazie.

    mercoledì 28 ottobre 2015 14:59
  • scusa ma non capisco la tua replica.

    io ti ho postato il link su come pubblicare un RDS Server in workgroup senza dominio, cosa che avevi chiesto nel primo post.

    cosa centra il discorso dei giorni di prova ?


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org


    mercoledì 28 ottobre 2015 16:52
    Moderatore
  • Ciao Edoardo, e grazie per il tuo reply.

    SI è esatto un RDS Server senza dominio (hai scritto RES ma immagino sia un errore di battitura).

    Come dicevo ho eseguito letteralmente la procedura indicata nel tuo link.

    Il fatto è che "sembrava" aver funzionato, ovvero entrando come utente in RDS non viene più segnalato l'errore di licensing, ma entrando come amministratore, sia in RDS sia fisicamente sulla macchina il problema persiste. Dice che le licenze non sono configurate correttamente, che mancano tot gg alla scadenza della versione di prova, di "cliccare qui" per risolvere il problema. Cliccando sparisce tutto e non riesco più a trovare la segnalazione. Andando manualemnte nella gestione licenze RDS sono sempre tutte presenti e nessuna "in uso". Inoltre le impostazioni RDS tramite l'account administartor non sono modificabili in quanto mi dice che non sono loggato ad un dominio, pertanto non ho modo di fare nulla.

    Insomma non so se il problema è risolto o meno, a naso direi di no, tuttavia prima lo stesso errore di licensing mi veniva segnalato anche dopo l'accesso RDS degli utenti, ora compare solo con Administrator.

    mercoledì 4 novembre 2015 11:56
  • precisato che le licenze definitive vengono usate quando sono definitivamente trascorsi i giorni utili per quelle di prova, se sei in questa situazione e ti colleghi con un utente non admin, vedi licenze in uso sul server delle licenze ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    giovedì 5 novembre 2015 15:31
    Moderatore
  • Purtroppo no, quando gli utenti (standard users) sono connessi, nel pannello di gestione licenze RDS queste sono ancora tutte disponibili (5). Il fatto è che al momento mancano 18 giorni al termine delle licenze di prova. Tutto sta funzionando benissimo, ma ho il sentore che alla scadenza delle licenze di prova non funzionerà più nulla e sarà un grosso problema perchè non ho idea di come risolvere.
    lunedì 21 dicembre 2015 21:30
  • scusa ma non hai scritto che accedendo come utente l'errore non compare più ?

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    martedì 22 dicembre 2015 15:49
    Moderatore
  • Forse mi sono spiegato male. Riassumo:

    Preciso che si tratta di un WS 2012 R2 Foundation.

    Accedendo come Amministratore, sia localmente sulla macchina che in RDS, appena effettuato il logon una notifica nel pannello icone mi segnala che le licenze non sono configurate correttamente, premi qui per risolvere. Cliccando sulla notifica sparisce tutto. Andando manualemnte nella gestione licenze nessuna risulta in uso e le 5 acqistate sono tutte disponibili.

    Accedendo come Utente, in RDS, non viene segnalato alcun errore ed il sistema pare funzionate, ma se io, loggato come amministartore direttamente sul server, interrogo la gestione licenze, queste sono comunque tutte disponibili, come se non si fosse loggato nessun utente.

    Adesso il dubbio è: Al termine delle licenze di prova che succede? Iniziano a scalare le licenze acquistate disponibili (come dovrebbe essere) oppure si pianta tutto e nessuno entra più?

    martedì 22 dicembre 2015 22:21

  • Adesso il dubbio è: Al termine delle licenze di prova che succede? Iniziano a scalare le licenze acquistate disponibili (come dovrebbe essere) oppure si pianta tutto e nessuno entra più?

    da quanto mi risulta dovrebbero cominciare a scalare le licenze acquistate disponibili.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    lunedì 28 dicembre 2015 11:26
    Moderatore
  • E purtroppo oggi sono scadute le licenze di prova e nessuno entra più.

    Spippolando ho trovato questo errore: "Set the licensing mode on the Remote Desktop Session Host server to either Per User or Per Device. Use RD Licensing Manager to install the corresponding licenses on the license server".

    Ovviamente io non ho il "remote desktop session host" perchè per installarlo mi chiede di essere loggato ad un dominio, ed io non ho un dominio.

    Credevo di poter risolvere temporaneamente fornendo a due utenti credenziali amministrative, quindi almeno 2 alla volta dovrebbero entrare con le licenze incluse in WS. Invece no, non entrano utenti "promossi" ad amministratore e neanche "l'amministratore".

    Sono un pò disperato, non ho idea di come poter risolvere il problema e l'azienda ora sta lavorando accedendo fisicamente al server.

    Il dover mettere due server (Uno DC ed uno RDS, con tutti icosti di licenze che ne conseguono) per fare ciò che con le licenze di prova funzionava EGREGIAMENTE è assurdo.

    Vi prego, trovatemi una soluzione!


    martedì 19 gennaio 2016 13:45
  • nei commenti al blogpost che ti ho indicato è precisato quanto segue

    Francois  October 19, 2014 at 3:49 pm
    Hi Ryan,
    
    I installed RDS on a Windows 2012 R2 server in a workgroup (no AD) following the instructions from Microsoft kb2833839 article. Besides the fact that I have no RDMS, everything seems to work fine. The licensing mode has been set to Per User (mode 4).
    
    I can connect RDS clients with no message about the 120 days grace period. But I notice in RDS Licence server that the User CALs are not issued when RDS clients are connected to the server.
    
    Will I run into a problem when the 120 days grace perios will end? Thank’s in advance for your expertise,
    
    François
    
    Reply
    Ryan.Mangan  October 19, 2014 at 3:50 pm
    You can only use device licenses with work group configurations
    
    Reply
    Ryan.Mangan  October 19, 2014 at 3:52 pm
    Point to note, you will need to manage rds using wmi and group policy as rdms is not available with out the connection broker which needs a domain.

    quindi la domanda, visto anche l'errore che ottieni, è:

    hai configurato l'utilizzo di licenze per device ?


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    giovedì 21 gennaio 2016 09:50
    Moderatore
  • E purtroppo oggi sono scadute le licenze di prova e nessuno entra più.

    Spippolando ho trovato questo errore: "Set the licensing mode on the Remote Desktop Session Host server to either Per User or Per Device. Use RD Licensing Manager to install the corresponding licenses on the license server".

    Ovviamente io non ho il "remote desktop session host" perchè per installarlo mi chiede di essere loggato ad un dominio, ed io non ho un dominio.

    inoltre vedo che non hai seguito esattamente il blogpost che ho postato perchè viene esplicitamente affermato che anche nel deploy di un rds server in workgroup si installa ugualmente il Remote Desktop Session Host. 

    Ti invito a rileggere attentamente e a seguire passo passo l'articolo che avevo linkato.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    giovedì 21 gennaio 2016 09:54
    Moderatore
  • Grazie Edoardo della celere risposta.

    Allora mi sono espresso male, RDSH è installato (come puoi vedere dallo screen del post precedente) solo che non me lo fa configurare in alcun modo. Le uniche due schermate dove posso accedere sono il license diagnoser ed il licensing manager, tutto il resto se provo ad aprirlo mi dice che devo essere loggato al dominio.

    Tuttavia ho rifatto daccapo la procedura da te postata, prestando estrema attenzione ad ogni singolo punto. Non posso giurare di averlo fatto correttamente: nel punto dove c'è bisogno di entrare in console sono andato incontro ad errori, che poi ho risolto notando che mancavano delle "\" in un punto del comando da copia-incollare. Una volta corretto l'operazione (a detta della console) è andata a buon fine.

    Quanto al problema delle CAL "Device" ne ero a conoscenza, infatti il dubbio iniziale era se convertire o meno queste licenze in device (una delle pochissime oprazioni che mi permette di fare). Tuttavia 2 dei 5 utenti che si connettono "dovrebbero" restare CAL User (in quanto vorrebbero effettuare l'accesso con il loro utente da più dispositivi (mobile, home, office)), gli altri 3 accedono da un solo dispositivo quindi il problema non si porrebbe. Ovviamente se non c'è altra strada convertirò tutto in Device e gli metterò un teamviewer permanente sul PC ufficio, col fastidio di doverlo lasciare sempre acceso.

    Contattando il vendor delle licenze RDS mi dice di "aver sentito dire" che la soluzione "potrebbe essere" una particolare implementazione delle Group Policy, ho provato a dare un occhio ma NON HO IDEA di come intervenire, e consultando il support Microsoft si torna a parlare di DC, quindi punto e a capo.

    Altra cosa assurda in RDS non eentrano più nenache gli amministratori, eppure 2 accessi RDS simultanei per utenti amminitratori dovrebbero essere inclusi nella licenza del SO.

    Ora provo a seguire una guida per resettare le licenze di prova di 120 gg, ho visto che è fattibile, perchè lavorare in 5 persone su un server che è in uno sgabuzzino crea parecchie occhiatacce al responsabile IT.

    giovedì 21 gennaio 2016 10:55
  • Grazie Edoardo della celere risposta.

    Allora mi sono espresso male, RDSH è installato (come puoi vedere dallo screen del post precedente) solo che non me lo fa configurare in alcun modo. Le uniche due schermate dove posso accedere sono il license diagnoser ed il licensing manager, tutto il resto se provo ad aprirlo mi dice che devo essere loggato al dominio.

    Tuttavia ho rifatto daccapo la procedura da te postata, prestando estrema attenzione ad ogni singolo punto. Non posso giurare di averlo fatto correttamente: nel punto dove c'è bisogno di entrare in console sono andato incontro ad errori, che poi ho risolto notando che mancavano delle "\" in un punto del comando da copia-incollare. Una volta corretto l'operazione (a detta della console) è andata a buon fine.

    Quanto al problema delle CAL "Device" ne ero a conoscenza, infatti il dubbio iniziale era se convertire o meno queste licenze in device (una delle pochissime oprazioni che mi permette di fare). Tuttavia 2 dei 5 utenti che si connettono "dovrebbero" restare CAL User (in quanto vorrebbero effettuare l'accesso con il loro utente da più dispositivi (mobile, home, office)), gli altri 3 accedono da un solo dispositivo quindi il problema non si porrebbe. Ovviamente se non c'è altra strada convertirò tutto in Device e gli metterò un teamviewer permanente sul PC ufficio, col fastidio di doverlo lasciare sempre acceso.

    non ho capito se fermandoti qui (parte quotata) funziona tutto oppure ancora no


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    martedì 26 gennaio 2016 08:34
    Moderatore