none
Problema con Site RRS feed

  • Domanda

  • Ciao a tutti,

    tempo fa fu eliminato l'utente amministratore di un sito del nostro SharePoint 2010. Dovevo creare una nuova raccolta nel sito ma in alcun modo riesco ad aggiungermi come utente amminstratore del sito.

    HO provato anche con degli script powershell trovati in giro, ma nulla in ogni caso ho sempre l'errore:

    Le impostazioni attuali impediscono
    l'aggiunta di elementi al sito Web.
    Per risolvere il problema, rivolgersi
    all'amministratore.

    Qualcuno riesce a darmi qualche indicazione?

    Raffaele


    Raffaele

    venerdì 15 gennaio 2016 14:36

Risposte

  • Ciao Raffaele

    Secondo me fai prima ad accedere alla Central Administration->Application Management->Change Site Collection Administrations.

    Quindi selezioni la site collection da modificare e reimposti l'amministratore.

    Se non dovesse funzionare.. non è che per caso il content db è in read only?

    mercoledì 27 gennaio 2016 22:43

Tutte le risposte

  • Ciao,

    Hai provato anche questo -

    http://soreddymanjunath.blogspot.bg/2014/03/addupdate-site-collection-administrator.html

    Non riesci a farlo dal Gestione di Applicazioni in Central Administration?

    https://technet.microsoft.com/en-us/library/ff631152(v=office.14).aspx


    Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    venerdì 15 gennaio 2016 15:48
  • Ho provato con la console ma nulla.

    COn lo script mi da questo:

    Add-PSSnapin : Impossibile aggiungere lo snap-in di Windows PowerShell Microsof
    t.SharePoint.PowerShell perché è stato già aggiunto. Verificare il nome dello s
    nap-in e riprovare.
    In C:\Users\custode\Desktop\Speriamo2.ps1:3 car:13
    + Add-PSSnapin <<<<  "Microsoft.SharePoint.PowerShell"
        + CategoryInfo          : InvalidArgument: (Microsoft.SharePoint.PowerShel
       l:String) [Add-PSSnapin], PSArgumentException
        + FullyQualifiedErrorId : AddPSSnapInRead,Microsoft.PowerShell.Commands.Ad
       dPSSnapinCommand

    Eccezione durante l'impostazione di "IsSiteAdmin": "La proprietà può essere imp
    ostata solo da un amministratore della raccolta siti."
    In C:\Users\custode\Desktop\Speriamo2.ps1:15 car:14
    +    $NewAdmin. <<<< IsSiteAdmin = $true
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyAssignmentException

    Eccezione durante la chiamata di "Update" con "0" argomento/i: "Accesso negato.
     (Eccezione da HRESULT: 0x80070005 (E_ACCESSDENIED))"
    In C:\Users\custode\Desktop\Speriamo2.ps1:17 car:20
    +    $NewAdmin.Update <<<< ()
        + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
        + FullyQualifiedErrorId : DotNetMethodException

     Site Collection Admin Successfully Added
    PS C:\Users\custode\Desktop>

    Il risultato sembra corretto ma non va comunque, resta l'utente vecchi sulla site collection.

    Raffaele


    Raffaele

    sabato 16 gennaio 2016 06:39
  • Ciao Raffaele,

    potresti controllare la lista di amministratori con PowerShell? -

    https://social.technet.microsoft.com/Forums/sharepoint/en-US/9f3974e9-501d-4aba-bf13-e00c961309cc/powershell-sp-bug-spsiteowner-and-spsitesecondarycontact-are-null?forum=sharepointadminprevious


    Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    venerdì 22 gennaio 2016 11:14
  • Se tu sei Farm admin o local admin del SharePoint server puoi eseguire  stsadm -o siteowner commandi per cambiare owner del Sito:
    stsadm -o siteowner -url http://yourserver/yoursite -ownerlogin "domain\user1"

    Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    martedì 26 gennaio 2016 09:53
  • Ciao Raffaele

    Secondo me fai prima ad accedere alla Central Administration->Application Management->Change Site Collection Administrations.

    Quindi selezioni la site collection da modificare e reimposti l'amministratore.

    Se non dovesse funzionare.. non è che per caso il content db è in read only?

    mercoledì 27 gennaio 2016 22:43
  • Ciao Raffaele

    Non abbiamo ricevuto alcun aggiornamento e mi chiedevo se possiamo aiutarti ulteriormente o se il tuo quesito è stato risolto.
    Se così fosse ti saremmo grati di condividere il feedback in questo spazio ricordandoti che altri membri della community potrebbero riscontrare comportamenti simili.

    Grazie in anticipo.


    Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    lunedì 1 febbraio 2016 09:54