none
Connessione VPN in automatico al login RRS feed

  • Domanda

  • Salve a tutti, espongo molto velocemente il mio problema, ho un PC Windows 10 PRO che si connette ad un dominio da remoto utilizzando una connessione VPN, ho configurato la connessione ed aggiunto il PC al dominio senza problemi, però devo connettermi automaticamente ad ogni login mentre io vorrei che la connessione avvenga in automatico alla login, soprattutto perché vengono utilizzate le stesse credenziali di accesso, come posso fare?
    mercoledì 13 gennaio 2016 23:08

Risposte

  • Non so se possa funzionare su 10, su 8 avevo usato questo http://blog.lan-tech.ca/2013/03/02/windows-8-connect-to-vpn-before-logon/ Se finisci l'articolo sotto trovi anche la soluzione si Gastone DOPO però il login...da quel che capisco ti potrebbe andare bene prima. È da provare. Ciao! A.
    • Contrassegnato come risposta AlessandroS75 venerdì 15 gennaio 2016 07:59
    giovedì 14 gennaio 2016 21:31
    Moderatore

Tutte le risposte

  • Di solito si può usare rasdial.exe con i parametri opportuni ... crei un batch che userai in esescuzione automatica o "schedulato"

    http://blog.lan-tech.ca/2013/06/08/rasdial-automate-vpn-connections/

    https://social.technet.microsoft.com/Forums/en-US/69abd1ea-0b30-40f7-b3d3-72aa5129832a/how-to-start-a-network-connection-at-windows-10-startup-automatically?forum=win10itprogeneral


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    mercoledì 13 gennaio 2016 23:26
    Moderatore
  • Grazie per la risposta, ma mettere le credenziali d'accesso in chiaro in un file .bat non è che mi faccia impazzire di gioia...
    giovedì 14 gennaio 2016 00:35
  • ma dall'altra parte cosa c'è? un server rras che aspetta la connessione oppure anche un UTM che magari ha un client sslvpn...perchè potresti anche far partire in automatico il client del firewall hw e risolvi il problema comunuque...ed a livello sicurezza è un altro paio di maniche...

    Ciao.

    A.

    giovedì 14 gennaio 2016 13:01
    Moderatore
  • Dall'altra parte ho un server Windows 2008 R2 con configurata la VPN per accettare connessioni L2TP ikev2, se sulla porta viene richiesta una connessione apre il tunnel, verifica le credenziali e se corrette da accesso al client sul dominio AD, per connettersi si utilizzano le stesse credenziali degli utenti (autorizzati alla VPN) presenti nel dominio, se le credenziali coincidono e la macchina è quella corretta allora tutto parte, diversamente viene chiusa la connessione.

    Nel mezzo c'è un server NAS con server VPN che controlla la prima fase (userid e pwd) prima di passare il tutto al server Windows.

    Il problema è impostare in automatico la connessione sul client remoto, ovvero quando si logga l'utente all'interno del dominio (perché sulla stessa macchina possono esserci anche altri utenti locali, ed in questo caso non mi serve aprire la VPN verso il server aziendale) passi le credenziali alla connessione VPN automaticamente e non come ora che devo lanciare la connessione dopo aver effettuato il login, anche se poi le credenziali va a prendere quelle dell'utente corrente e del relativo dominio. Ultimo appunto/dettaglio, ogni 30 giorni è impostato il cambio password, quindi in ogni caso inserire le credenziali in un file .bat non è fattibile perché poi il tutto verrà messo nelle mani dell'utOnto di turno e hai voglia a spiegare cosa dovrebbe modificare ogni 30 giorni...
    giovedì 14 gennaio 2016 16:55
  • Non so se possa funzionare su 10, su 8 avevo usato questo http://blog.lan-tech.ca/2013/03/02/windows-8-connect-to-vpn-before-logon/ Se finisci l'articolo sotto trovi anche la soluzione si Gastone DOPO però il login...da quel che capisco ti potrebbe andare bene prima. È da provare. Ciao! A.
    • Contrassegnato come risposta AlessandroS75 venerdì 15 gennaio 2016 07:59
    giovedì 14 gennaio 2016 21:31
    Moderatore
  • Ti ringrazio per la segnalazione ma purtroppo su W10PRO non funziona, se seguo quanto descritto ottengo solamente che non funziona più nemmeno la connessione di rete "normale" :-(

    Ho provato anche a creare un collegamento alla connessione VPN sul desktop ma non funziona, ovvero facendo doppio click non fa connettere, non fa proprio nulla se non comunicarmi che la risorsa non è disponibile.

    Certo che è proprio disarmante non riuscire a fare una cosa così semplice che su linux posso impostare direttamente nella configurazione della VPN :-(

    giovedì 14 gennaio 2016 22:00
  • Non ho capito molto del tuo ambaradam, certo non semplifichi la vita agli utonti ... ti dirò che mi sento molto utonto anch'io, dopo aver letto il tuo ultimo post.

    Per risolvere senza annegare credenziali in batch vari (con rasdial è possibile anche usare il nome della connessione se hai salvato in precedenza le credenziali, ma ogni 30 gg bisognerebbe rifare la connessione... )

    Quindi bisogna necessariamente usare un sistema di Single Sign On dove le credenziali possano essere usate in automatico, nel link trovi come fare per win7, spero che abbiano mantenuto la cosa anche sull'erede  http://www.windowsnetworking.com/articles-tutorials/windows-7/VPN-Single-Sign-On-Windows-7.html

    ciao


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    giovedì 14 gennaio 2016 22:10
    Moderatore
  • No, è la stessa cosa dell'articolo di prima, solo che hanno usato più parole per raccontare la storia delle connessioni VPN da XP a 7.... :-(

    Resto comunque sbalordito dal fatto che io sia l'unico ad avere queste necessità che, tra le altre cose, reputo anche abbastanza basilari per avere un minimo di sicurezza sui dati, però posso anche ammettere di essere paranoico...

    giovedì 14 gennaio 2016 22:28
  • Non rieco a capire perchè  l'articolo del SSO non vada bene ,accedi al vpn e in automatico le credenziali vengono usate per il logon, (ok, sono invertiti i fattori, ma il risultato è quello che vuoi) si automatizza il logon in base alla connessione vpn e hai raggiunto il tuo scopo, connessione sicura e attiva per gli utenti di dominio.

    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    giovedì 14 gennaio 2016 23:55
    Moderatore
  • No, forse mi ero spiegato male io, non era il concetto a non andar bene, era il procedimento che su W10PRO non riuscivo a replicare, questa notte ho insistito e sono riuscito a trovare la via per creare la connessione nel modo "tradizionale" e non come proposto da W10PRO, creandola così si è presentato lo scenario degli articoli e quindi la SSO che fa quello che chiedo, scusatemi se ho risposto solamente ora ma questa mattina alle 4 avevo in mente solo di andare a letto!!!!

    Grazie per le risposte.



    venerdì 15 gennaio 2016 07:58
  • molto bene, se magari la condividi col forum la segnamo come risposta così in futuro gli altri potranno fruirne.

    Grazie! Ciao!

    A.

    venerdì 15 gennaio 2016 08:15
    Moderatore
  • Ciao, nulla di complesso, al posto di creare la VPN da start => Impostazioni => Rete e Internet (modalità "semplificata" per gestire W10) bisogna andare da Pannello di Controllo => Rete e Internet => Centro connessioni di rete e condivisioni e da li creare la VPN con "Configura nuova connessione o rete", da qui si segue quanto descritto nel link postato.

    L'inghippo, se così possiamo chiamarlo, sta nel fatto che in W10 per accedere a "Pannello di controllo" bisogna fare click destro sul menù start, stupidamente avevo pensato che il percorso "semplificato" avesse sostituito la modalità "classica", in sostanza colpa della mia ignoranza sul sistema.
    venerdì 15 gennaio 2016 16:06
  • "e' bene tutto ciò che finisce bene" data la possibiltà di fare una vpn con SSO doveva nadare ...

    Ciao Gas


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    venerdì 15 gennaio 2016 21:10
    Moderatore