none
backup robocopy da server 2003 a nas sinology RRS feed

  • Domanda

  • ciaoo a tutti, al lavoro dovrei fare una copia di sicurezza dei dati su un nas sinology ds211j. purtroppo questo nas non ha la funzione di rsync così mi sono limitato ad usare uno script .bat con robocopy.

    lo script è il seguente: robocopy "D:\Dati\Archivio" "S:\Archivio" /MIR /SEC /B

    però al momento dell'esecuzione dal prompt dei comandi mi da un errore 1317 (0x00000525) copying ntfs security to destination directory l'utente specificato non esiste.

    Cosa vuol dire? Ho sbagliato qualcosa nello script?

    lunedì 27 ottobre 2014 18:38

Risposte

  • si si... adesso ho lanciato il robocopy solo con il paramtreo /MIR alla fine e sembra che vada.. vediamo..
    martedì 28 ottobre 2014 10:10
  • Se posso consigliarti ecco come limitare i problemi:

     robocopy "D:\Dati\Archivio" "S:\Archivio" /MIR /r:1 /w:1 /xj /copy:dt

    /r:1 ritenta una volta, se non specificato il default è 1000000 !!!!!!! Da usare sempre!

    /w:1 aspetta un secondo (opzionale)

    /xj evita i junction point (per copie da SO nuovo, può essere utile...)

    /copy:DT copia solo data e ora (non le security) utile per le NAS capricciose :) (es: con samba molto datato) o se le security non sono necessarie.

    In alcuni casi per come è stato progettato robocopy, conviene copiare tutto senza security, poi eseguire un secondo robocopy che setta le security sui file precedentemente "robocopiati"

    > ROBOCOPY /Mir <Source> <Target> /w:1 /r:1
    > ROBOCOPY /E /Copy:S /IS /IT <Source> <Target>
    /w:1 /r:1

    http://blogs.technet.com/b/filecab/archive/2008/07/31/robocopy-mir-switch-mirroring-file-permissions.aspx


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere



    mercoledì 29 ottobre 2014 00:16
    Moderatore

Tutte le risposte

  • Ciao Guido, per cortesia puoi indicare la versione del sistema operativo ed eseguire un semplice test.

    Crea una nuova cartella "test", all'interno crea (non copiarli) due/tre nuovi file con estensione differente (.doc, .txt, .pdf, etc.) ed esegui la copia con gli stessi switch che hai indicato.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    lunedì 27 ottobre 2014 19:16
    Moderatore
  • il sistema operativo è windows server 2003, è scritto nel titolo
    lunedì 27 ottobre 2014 19:38
  • il sistema operativo è windows server 2003, è scritto nel titolo

    Hai ragione, mi sono concentrato sul testo è non ho riletto il titolo...

    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    lunedì 27 ottobre 2014 20:34
    Moderatore
  • quindi cosa mi consigli di fare??
    lunedì 27 ottobre 2014 21:15
  • Potresti fare quel test che ti ho chiesto? Vorrei verificare se l'eventuale presenza di SID orfani possano causare l'errore. Per essere sicuri dovresti controllare, nel TAB  sicurezza, che la presenza di SID orfani. Se in questo caso la copia va a buon fine il problema potrebbe essere quello.

    * Aggiungo una screen presa da (https://gallery.technet.microsoft.com/scriptcenter/Remove-orphaned-SIDs-from-2231b1f0)

    Saluti
    Nino

     

    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.



    martedì 28 ottobre 2014 06:09
    Moderatore
  • sul server windows 2003 ho creato una cartella test con dentro due file, poi ho lanciato il robocopy di copia della cartella sul nas sinology e mi ha dato lo stesso errore..
    martedì 28 ottobre 2014 08:39
  • Ok, ma quel NAS supporta l'accesso? E' stata creata la cartella di destinazione con le corrette credenziali (e permessi lettura/scrittura) accessibili attraverso una chiamata \\cartella_condivisa?  

    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    martedì 28 ottobre 2014 09:15
    Moderatore
  • si si... adesso ho lanciato il robocopy solo con il paramtreo /MIR alla fine e sembra che vada.. vediamo..
    martedì 28 ottobre 2014 10:10
  • Se posso consigliarti ecco come limitare i problemi:

     robocopy "D:\Dati\Archivio" "S:\Archivio" /MIR /r:1 /w:1 /xj /copy:dt

    /r:1 ritenta una volta, se non specificato il default è 1000000 !!!!!!! Da usare sempre!

    /w:1 aspetta un secondo (opzionale)

    /xj evita i junction point (per copie da SO nuovo, può essere utile...)

    /copy:DT copia solo data e ora (non le security) utile per le NAS capricciose :) (es: con samba molto datato) o se le security non sono necessarie.

    In alcuni casi per come è stato progettato robocopy, conviene copiare tutto senza security, poi eseguire un secondo robocopy che setta le security sui file precedentemente "robocopiati"

    > ROBOCOPY /Mir <Source> <Target> /w:1 /r:1
    > ROBOCOPY /E /Copy:S /IS /IT <Source> <Target>
    /w:1 /r:1

    http://blogs.technet.com/b/filecab/archive/2008/07/31/robocopy-mir-switch-mirroring-file-permissions.aspx


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere



    mercoledì 29 ottobre 2014 00:16
    Moderatore
  • Ciao guido-bruciamonti,

    Non abbiamo ricevuto alcun aggiornamento e mi chiedevo se possiamo aiutarti ulteriormente o se il tuo quesito è stato risolto.
    Se così fosse ti saremmo grati di condividere il feedback in questo spazio ricordandoti che altri membri della community potrebbero riscontrare comportamenti simili.

    Grazie in anticipo,

    Maria


    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    giovedì 30 ottobre 2014 09:47
  • alla fine ho usato il comando solo con il parametro /MIR..
    giovedì 30 ottobre 2014 19:49
  • Ciao Guido,

    Ti ringrazio di aver aggiornato il thread con le ultime notizie e sono
    lieta di sapere che tu abbia risolto.

    Saluti,

    Maria


    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    venerdì 31 ottobre 2014 14:30