locked
Internet Explorer 8 su Windows XP non riesce a creare una connessione HTTP1.1 keep-alive RRS feed

  • Domanda

  • Titolo originale:
    Internet Explorer v8 su Windows XP NON riesce a creare una connessione HTTP1.1 keep-alive(necessaria al sistema di autenticazione NTLM) con un server Windows Server 2008 R2 quando di mezzo c'è un Proxy ISA Server 2006.

    -----

    Sistema operativo:Windows XP

    Versione di Internet Explorer:Internet Explorer 8

    Internet Explorer v8 su Windows XP NON riesce a creare una connessione HTTP1.1 keep-alive (necessaria al sistema di autenticazione NTLM) con un server Windows Server 2008 R2 quando di mezzo c'è un Proxy ISA Server 2006.
    Se invece Internet Explore v8 gira su Windows Vista o Seven, nella stessa situazione descritta prima, riesce a stabilire la connessione HTTP1.1, autenticandosi al server via NTLM senza alcun problema.
    Inoltre la concorrenza (Mozilla FireFox o Chrome) riesce a creare la connessione keep-alive HTTP1.1 su tutti sistemi operativi Microsoft (XP, Vista e Seven) senza alcuna difficoltà, riuscendo così a portare a termine l'autenticazione NTLM con il server.
    domenica 30 gennaio 2011 17:40

Risposte

  • - su XP, autenticazione NTLM fallita con risposta del Server "HTTP/1.1
    400 Bad Request".

    Hmmmm....

    "Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL"

    ma a parte quanto sopra... che potrebbe essere una delle cause del
    problema; direi che dovresti iniziare ricontrollando le impostazioni
    proxy
    del sistema; considera che FireFox e compagnia cantante ignorano
    bellamente eventuali GPO relative alle impostazioni proxy, esclusioni
    dello stesso etc... inoltre, le GPO agiscono anche su WinHTTP

    http://msdn.microsoft.com/en-us/library/aa384273%28VS.85%29.aspx

    e non vorrei fosse quest'ultimo la vera causa dei problemi riscontrati
    ad ogni modo, NON credo che il problema sia relativo ad IE o, per
    lo meno, non in senso stretto

    martedì 1 febbraio 2011 16:53

Tutte le risposte