none
Sysprep Windows 10 Creators Update non funziona RRS feed

  • Domanda

  • buongiorno a tutti,

    chiedo cortesemente aiuto riguardo la creazione di immagini con sysprep su sistema operativo Windows 10 pro version 1703 (build 15063.540).

    in particolare, non riesco a creare l'immagine con sysprep su notebook dell xps13:

    dopo avere installato, aggiornato il s.o. ed installato alcuni sw, ho lanciato sysprep.exe da c:\windows\system32\sysprep (run ad administrator) con opzioni oobe, generalize e shutdown.

    il sysprep non va in errore, anzi sembra completare l'operazione ed il pc si riavvia correttamente,

    ma all'accensione (dopo alcuni minuti sul messaggio "get device ready") compare la prima schermata di scelta lingua ed opzioni regionali, vado avanti e compare il messaggio:

    "why did my pc restart? there's a problem thats keeping us from getting your pc ready to use.."

    proponendo di risolvere il problema tramite un update previa connessione del pc ad internet.

    nella schermata successiva inserisco quindi la pwd della mia wifi, il pc si riavvia ma torna sistematicamente alla stessa schermata ""why did my pc restart?..."

    ho dapprima provato la soluzione proposta qui ma senza successo:

    --https://support.microsoft.com/en-us/help/2769827/sysprep-fails-after-you-remove-or-update-windows-store-apps-that-inclu

    poi anche l'esecuzione di questi 2 comandi prima di lanciare il sysprep:

    Get-AppXPackage -AllUser | % {if ($_.PackageUserInformation.InstallState -eq "Staged"){$_.PackageFullname}}
    get-appxpackage | remove-appxpackage

    qualcuno ha esperienza di soluzioni riguardo questo problema ??

    grazie a tutti,

    alessandro


    giovedì 17 agosto 2017 16:50

Risposte

  • Probabilmente il problema era stato causato proprio l'immagine di Windows 10 non pulita, io personalmente con la 1703 non ho rilevato particolari problemi (il provisioning dei pacchetti prima del sysprep era necessario anche con le versioni precedenti di Windows 10). In ogni caso mai utilizzare installazioni sulle quali era stato eseguito un aggiornamento in-place per creare immagini: in realtà sarebbe meglio non aggiornare proprio una release senza reinstallazione in un contesto aziendale.

    domenica 20 agosto 2017 19:49
    Moderatore

Tutte le risposte

  • Scusa mi sfugge qualcosa, stai facendo il sysprep sul tuo computer per poi continuare a usarlo, mi sfugge qualcosa...

    Comunque sembra ci sia qualche problema con il sysprep sulla 1703:

    https://social.technet.microsoft.com/Forums/windows/en-US/7198405a-46ac-48e3-a657-97102be47e0c/windows-10-1703-sysprep-imaging-issues?forum=win10itprosetup

    Ciao


    Andrea Sistarelli
    Blog
    Datacen srl - Consulenza informatica

    venerdì 18 agosto 2017 08:15
  • ciao, grazie per la risposta.

    sto facendo sysprep su pc di un cliente per ottenere la configurazione che poi mi servirebbe replicare su altri n pc, senza ogni volta installare tutto manualmente..

    ovviamente se il sysprep funzionasse salverei l'immagine del pc syspreppato su un supporto esterno

    venerdì 18 agosto 2017 10:19
  • comunque dopo 3 giorni di frustranti prove sono riuscito a risolvere..

    nel mio caso sono inanzitutto dovuto partire dal sistema operativo non upgradato, quindi version 1703 pulita (build 15063.332) con la connessione internet disattiva.

    dopo avere configurato il sistema ed installato i sw che mi interessavano ho:

    - disinstallato le app "metro" da settings > apps > apps & features (quelle già preinstallate di default tipo 3dbuilder, remote desktop, ecc..)

    - lanciato i 2 comandi di pulizia app:

    Get-AppXPackage -AllUser | % {if ($_.PackageUserInformation.InstallState -eq "Staged"){$_.PackageFullname}}

    get-appxpackage| remove-appxpackage

    - eliminata la chiave di registro "upgrade" da hklm > system > setup

    - lanciato sysprep.exe da c:\windows\system32\sysprep (run ad administrator) con opzioni oobe, generalize e shutdown

    - salvata immagine del sistema

    spero che in futuro questo magari possa essere d'aiuto ad altri,

    grazie

    ciao

    alessandro

    venerdì 18 agosto 2017 11:17
  • Probabilmente il problema era stato causato proprio l'immagine di Windows 10 non pulita, io personalmente con la 1703 non ho rilevato particolari problemi (il provisioning dei pacchetti prima del sysprep era necessario anche con le versioni precedenti di Windows 10). In ogni caso mai utilizzare installazioni sulle quali era stato eseguito un aggiornamento in-place per creare immagini: in realtà sarebbe meglio non aggiornare proprio una release senza reinstallazione in un contesto aziendale.

    domenica 20 agosto 2017 19:49
    Moderatore