none
PHP 5.6 non riesco ad abilitare TSL 1.2 RRS feed

  • Domanda

  • Ciao a tutti,
    sto aggiornando PHP dalla versione 5.3 alla versione 5.6 su un Windows 2008 con IIS.

    l'aggiornamento è indispensabile per l'upgrade di TSL da 1.0 TLS 1.2

    Visualizzando phpinfo() la configurazione sembra essere corretta tanto che vedo le seguenti voci:

    cURL ver. 7.59.0
    OpenSSL support enabled
    OpenSSL Library Version OpenSSL 1.0.2o 27 Mar 2018
    OpenSSL Header Version OpenSSL 1.0.2o 27 Mar 2018

    Ma facendo il seguente test il risultato è: "Your TSL version is: no TLS support".

    PHP:
    <?php
    $ch 
    curl_init();
    curl_setopt($chCURLOPT_URL"https://www.howsmyssl.com/a/check");
    curl_setopt($chCURLOPT_SSLVERSION6);
    curl_setopt($chCURLOPT_RETURNTRANSFERtrue);
    $response curl_exec($ch);
    curl_close($ch);
    $tlsVer json_decode($responsetrue);
    echo 
    "<h1>Your TSL version is: <u>" . ( $tlsVer['tls_version'] ? $tlsVer['tls_version'] : 'no TLS support' ) . "</u></h1>";
    ?>

    Riuscite a dirmi cosa potrebbe mancare


    Lorenzo

    martedì 10 luglio 2018 13:04

Risposte

Tutte le risposte