none
VM Hyper-V non parte più RRS feed

  • Domanda

  • Ciao,

    su un server mi sono trovato in questa condizione assurda, una VM era sparita, riavvio il server (W2012 SE),
    intendo riavvio regolare ovviamente e la macchina riappare nella console di HV.

    Faccio per lanciarla e mi becco questa schermata:

    Non mi era mai capitato prima, cosa posso fare?

    aggiungo, quello che vedo nella cartella virtual disks è questo:

    grazie 10000 per l'aiuto

    massimo


    giovedì 18 settembre 2014 07:14

Risposte

  • il supporto MS (dalla Germania) con una sessione di 3 ore è riuscito a ricostruire la macchina virtuale alla data corretta, ottimo!

    cmq e' veramente complesso ricostruire la macchina virtuale quando hai diversi snapshot come nel mio caso

    massimo

    mercoledì 12 novembre 2014 10:51

Tutte le risposte

  • Ciao Marco, prova a cominciare con questo documento http://blogs.msdn.com/b/dave_crooks_dev_blog/archive/2013/01/09/recover-corrupt-hyper-v-virtual-machine.aspx

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    giovedì 18 settembre 2014 11:35
    Moderatore
  • :-(

    e' ripartita, ma quando tento di loggarmi mi dice:

    La relazione di trust tra questa workstation e il dominio primario non e' riuscita.

    Se non erro questa cosa viene fuori quando ad un computer joinato in dominio per un chissà quale motivo salta il SID.

    Sono andato in utenti e gruppi di AD e ho fatto (tasto dx -> ripristina) sul nome computer, ma nada
    ora non riesco nemmeno piu' ad entrarci, inoltre la macchina aveva un IP statico, ora la vedo nella
    scope DHCP (e' andata in ip dinamico)        massimo   (ragazzi l'editor del forum ha problemi, ora per es. non riesco a fare prendere gli invii!!!  io uso IE11, non chrome! ;-)

    giovedì 18 settembre 2014 21:03
  • Probabilmente i file AVHDX risultano ora scollegati dal disco principale, quindi la macchina virtuale è tornata nello stato del template originario (per questo la relazione di trust con il dominio fallisce).

    Dovrebbe essere possibile risolvere il problema eseguendo un merge manuale nel file VHDX primario.

    Prova a seguire le indicazioni contenute in questa pagina: http://social.technet.microsoft.com/wiki/contents/articles/6257.manually-merge-avhd-to-vhd-in-hyper-v.aspx




    venerdì 19 settembre 2014 06:43
    Moderatore
  • arrivato alla schermata del "percorso disco" non mi fa continuare (il tasto avanti e' disabilitato)
    e mi dice "non modificare un disco rigido virtuale associato a una macchina virtuale per la quale sono presenti snapshot, per la quale ecc..

    :-(


    ho provato a rinominare il avhdx piu' nuovo e piu' grande in vhdx, una volta datogli in pasto il vhdx piu' recente, nella pagina successiva non mi propone il merge, ma solo il riconnetti

    ragazzi questo link mi sembra troppo generico :(

    sono nella cacca

    massimo


    venerdì 19 settembre 2014 07:23
  • ragazzi quest'articolo è terribile, Vi prego di non consigliarlo più a nessuno
    mancano degli step, non dice quale vhdx selezionare nel pannello

    questo che ha creato l'articolo aveva in mente la sua situazione, ma non l'ha spiegata
    al 100%, mancano degli screenshot, mancano indicazioni di importanza cruciale

    massimo


    venerdì 19 settembre 2014 07:42
  • ragazzi a me non propone da nessuna parte il merge, ma sempre connetti
    alla fine della procedura non si capisce a quale disco .vhdx devo fare puntare la vm
    se faccio puntare la VM al vhdx originale (che non e' variato nelle dimensioni) non parte proprio :(

    io ho 3 avhdx e 1 vhdx, non si capisce se devo sommare il 4 al 3, il 3 al 2 e il 2 all'1 pero' all'ultimo
    se devo sommarli anche al vhdx originale

    sono nella cacca :(

    non faro' mai piu' snapshot :(

    massimo
    venerdì 19 settembre 2014 08:24
  • Purtroppo il problema di fondo è che ti si è corrotta la macchina virtuale, quindi devi ricostruire manualmente il VHDX partendo dal primo all'ultimo AVHDX delle differenze.

    Se hai difficoltà con le indicazioni contenute nella pagina precedente puoi provare a seguire quest'altro:

    http://workinghardinit.wordpress.com/2014/08/29/manually-merging-hyper-v-checkpoints/

    La somma ovviamente la devi fare partendo prima dai più vecchi fino ad arrivare allo snapshot più recente (quindi originale + 1 poi risultante + 2 poi risultante + 3, ecc...).

    Inutile dire che prima di fare qualsiasi operazione sui file VHDX e AVHDX è vivamente consigliato eseguire un backup.


    venerdì 19 settembre 2014 10:23
    Moderatore
  • il bkup ce l'ho grazie al cielo

    riproviamo, dall'articolo in inglese avevo capito dal piu' nuovo verso il piu' vecchio

    probabilmente e' li' l'inghippo

    ho 3 avhdx su alcune non mi da l'errore sull'ID, su una mi da l'errore sull'ID
    "errore nel server durante il tentativo di modificare il disco virtuale
    impossibile impostare il nuovo elemento padre per il disco virtuale l'id del disco rigido virtuale differenze non corrisponde a quello del disco padre"

    devo sommarla lo stesso?

    massimo



    venerdì 19 settembre 2014 11:34
  • riagganciando tutti e 3 gli avhdx a il disco "padre" vhdx ("id ok e id non ok") mi da sempre "la relazione di trust tra questa workstation e...." al logon

    ragazzi sono nella cacca, cosa posso fare?
    il problema e' che ho 3 avhdx secondo me qualcosa di questi 3 non e' da ri-agganciare
    ma come faccio a capire quale e' da ri-agganciare e quale no?

    La somma ovviamente la devi fare partendo prima dai più vecchi fino ad arrivare allo snapshot più recente (quindi originale + 1 poi risultante

    cosa vuol dire "risultante" cioe' come faccio a vedere qual è il risultante?
    il risultante va sempre nel vhdx originale, oppure viene generato un altro file?

    e' la prima volta che mi succede (e l'ultima perché non usero' mai piu' gli snapshot, le VM devono essere un unico file, altrimenti perde il significato della tecnologia, la semplificazione e' che hai un solo file con dentro un server, se si frammenta in piu' file, allora tanto vale installare un server hardware)

    massimo



    venerdì 19 settembre 2014 11:42
  • ragazzi,scusate l'ignoranza, io sono ancora impantanato su questa situazione
    c'e' un n. di telefono MS che posso contattare per supporto tecnico?

    grazie 1000 ciao

    massimo

    mercoledì 24 settembre 2014 09:40
  • Servizio Clienti: 0238591444

    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    mercoledì 24 settembre 2014 09:55
    Moderatore
  • Puoi aprire un ticket a pagamento qui:

    http://support.microsoft.com/select/default.aspx?target=assistance

    In ogni caso se l'immagine del sistema non è ancora aggiornata probabilmente qualche snapshot è mancante o non è stato collegato bene al VHDX padre.

    mercoledì 24 settembre 2014 09:56
    Moderatore
  • avevo un bkup da parte su un nas della macchina virtuale composto da soli 2 files vhxd e avhxd
    ho provato a sommare i 2 files (questi erano solo 2 quindi doveva essere una cosa molto semplice)
    quando faccio ripartire la macchina virtuale mi da sempre "la relazione di trust tra questa workstation e il dominio primario non e' riuscita"

    com'e' possibile con soli 2 files?
    ho sommato il "avhxd" al vhxd padre (con la funzione connetti)
    e sono sempre fermo allo stesso punto

    la cosa non ha logica

    massimo


    • Modificato massimo-2014 mercoledì 24 settembre 2014 11:12
    mercoledì 24 settembre 2014 11:10
  • ciao,

    "Purtroppo il problema di fondo è che ti si è corrotta la macchina virtuale"

    con questi intendi che il vhdx "padre" quello quindi corrotto devo eliminarlo e sommare i 3 avhdx in ordine dal piu' vecchio al piu' nuovo?

    (chiaramente rinominando il piu' vecchio .avhdx in .vhdx, giusto?)

    massimo

    mercoledì 24 settembre 2014 12:44
  • riesci a riavviare la macchina virtuale in modalità provvisoria con rete e dissociarla dal dominio per riassociarla successivamente ?

    in fondo è solo un problema di resettare la password dell'account computer...


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    mercoledì 24 settembre 2014 12:59
    Moderatore
  • la macchina virtuale riconosce dominio, utente e password, se metto una password sbagliata mi dice che la password e' sbagliata

    inoltre ora la macchina e' in dhcp quando era funzionante aveva un ip statico
    quindi c'e' dell'altro

    io non ho ancora capito un concetto,il disco .vhdx va cancellato e poi sommati i *solo* 3 .avhdx?

    ciao e grazie

    massimo

    mercoledì 24 settembre 2014 13:36
  • aggiungo una cosa, se vado dentro da modalita' provvisoria, e' come se tornassi indietro a febbraio
    al giorno dell'installazione, server completamente privo di dati e applicazioni
    solo presente il sistema operativo joinato al dominio e fine della fiera

    massimo
    mercoledì 24 settembre 2014 14:38
  • E' normale, come ti dicevo ti mancano le modifiche apportate successivamente, che sono salvate nei file AVHDX. Per ricostruire l'ultimo stato dell'hard disk virtuale devi prendere il VHDX originario (questo) e unirlo mano a mano con tutti i child disk creati dagli snapshot.
    mercoledì 24 settembre 2014 16:09
    Moderatore
  • il supporto MS (dalla Germania) con una sessione di 3 ore è riuscito a ricostruire la macchina virtuale alla data corretta, ottimo!

    cmq e' veramente complesso ricostruire la macchina virtuale quando hai diversi snapshot come nel mio caso

    massimo

    mercoledì 12 novembre 2014 10:51
  • io sinceramente non darei tanti voti, perché ottimo che mi abbiamo ripristinato la VM
    però il merge dei dischi differenze rimane un'operazione troppo complessa
    uso le VM perché dovrebbero semplificarmi la gestione, non complicarmela
    scusate...

    (come sempre detto da simpatizzante di MS)

    massimo


    venerdì 14 novembre 2014 12:18