Extended REFS partition but new size/free space doesn't show in Explorer


  • We have a large ReFS partition on a Server 2012 R2 machine that we came close to running out of space on.  It sits on an LSI Raid-6 volume (which we have several dozen in production, never have issues with them).  We decided to increase the size and extend the volume.  

    We expanded the Raid volume, and after it completed the additional space showed up in Administrative Tools\Computer Management\Disk Management.  We extended the volume, and the space expanded successfully.  And this is where it gets weird....  When we go to Windows Explorer the new total space / free space values do not show up.  Nor do they show up in DiskPart.

    We need to properly extend this volume, and with approximately 27 TB of data on the volume it's not feasible to move it somewhere else.  What can we do to have the new space configuration show up properly?  Please see below for an image of what I'm seeing.  Thanks!  Rick

    lunedì 1 febbraio 2016 13:12

Tutte le risposte

  • You wrote that "Disk Management" showed the additional space but not diskpart.  In the screenshot you provided, both diskpart and Disk Management are showing the disk as having ~49TB.  Is 49TB the new size or is it even larger than this?  If larger, have you tried executing "rescan" from DISKPART to see if the disk size increases?
    lunedì 1 febbraio 2016 15:09
  • 49TB is the new size after extending the volume.  In explorer, the total size (and free space) does not reflect the increase in the size of the volume.

    49TB - new extended volume, represented in DiskPart and Computer Management

    32TB - the old size before extending the volume that is still represented in Windows Explorer.

    The issue is that Explorer isn't representing the space available, so it cannot be used.

    lunedì 1 febbraio 2016 21:20
  • I tried a similar test and it worked for me.  I did press <F5> to refresh explorer but it then showed the new available space.  Have you checked this thread.

    lunedì 1 febbraio 2016 22:03
  • Situation is present after multiple restarts (and even if I tried F5).  Your link refers to cluster size, which is not relevant with ReFS as it uses 64kb by default (which is also what the Raid array uses).
    lunedì 1 febbraio 2016 22:08
  • Hi CFT Rick Wohleber,

    This is not the first time I see such an issue that the size is not changed in Properties while enlarge the size for the partition. It is a little bit strange. And as normally, the command shows the same size with diskmanagement, it should have been extended in reality. Your problem may be more seem to be related to the hard driver.  Please also make sure all firmware updates to the lastest then have a check.

    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    martedì 2 febbraio 2016 06:20
  • Just checked - firmware and driver are up to date, no issues there.  

    Did some research and found that there is a bug in Windows where you can extend volumes fine, but problems present themselves if they are extended to the full capacity and exhibit these symptoms.  The solution is to extend in small increments (say, 20%), then during the final extension leave about 1% free at the end.

    Thing is, I've already extended the volume.  Normally I would shrink the volume, then go back and slowly extend again in smaller increments.  So I try to shrink the volume (ReFS) and it won't let me.  Apparently it is not possible to shrink an ReFS volume?  In any event, I need a resolution to this that doesn't involve me wiping out this partition.


    martedì 2 febbraio 2016 15:30
  • I could really use some help here, any ideas?
    mercoledì 3 febbraio 2016 00:02
  • Is there a status update on this issue?  Lemme know, thanks!


    mercoledì 3 febbraio 2016 23:46
  • Hi CFT Rick Wohleber,

    Thank you for your reply. Since the question seems to be a little be  strange, I couldn't reproduce the issue.
    I am trying to involve someone familiar with this topic to further look at this issue. 

    Thanks for your support and understanding.

    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    venerdì 5 febbraio 2016 06:52
  • Hi Mary,

    Thanks much!  I'm in a bit of a hurt here.... 


    venerdì 5 febbraio 2016 16:22
  • Hi Rick,

    After discussing with our senior engineer, you could follow the steps below to have a try to see the result.

    1.    Take the volume/server back up and execute check disk in read only mode.
    a.    Open “cmd” and type “chkdsk X /f”;
    Note: X means drive letter.

    b.    Chkdsk finishes by displaying a report, please send us output in the text file;

    c.    After chkdsk is completed, restart the server.

    NOTE: If you use chkdsk /f on a very large disk or a disk with a very large number of files (for example, millions of files), chkdsk /f might take a long time to complete. If it encounters errors, chkdsk pauses and displays messages. Chkdsk finishes by displaying a report that lists the status of the disk. You cannot open any files on the specified drive until chkdsk finishes.

    I would like to suggest that you schedule a proper downtime to do this if this is in production environment.

    2.    Extend file system.
    a.    Open a command line with administrator privilege and type: Diskpart;

    b.    Type “list volume”;
    Mark the volume number of the problematic volume.

    c.    Type “select volume *” (Not partitaion);

    d.    Type “extend filesystem”.

    Besides, is it a SAN disk or Local disk?

    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    lunedì 8 febbraio 2016 11:45
  • Hi Mary,

    Thanks for the reply.  As you may or may not be aware, this is an ReFS partition so chkdsk is not available.  Regardless, here is the output:

    C:\Windows\system32>chkdsk e: /f
    The type of the file system is REFS.
    The ReFS file system does not need to be checked.



    I then restarted (not needing to, but I follow instructions)


    I then attempted to extend the file system (again, I've done this already but let's see the results), here is the output:


    Microsoft DiskPart version 6.3.9600

    Copyright (C) 1999-2013 Microsoft Corporation.
    On computer: CFT-HERCULES

    DISKPART> list volume

      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     E   ReFS Storag  ReFS   Partition     49 TB  Healthy
      Volume 1         System Rese  NTFS   Partition    350 MB  Healthy    System
      Volume 2     C                NTFS   Partition    464 GB  Healthy    Boot

    DISKPART> select volume 0

    Volume 0 is the selected volume.

    DISKPART> extend filesystem

    Virtual Disk Service error:
    There is not enough usable space for this operation.



    So we still have the issue - the volume lists as 49 TB in DiskPart but only ~33 TB in Explorer (which makes sense as we extended the volume via Computer Management by adding 16 TB of additional space to the underlying RAID array).

    We know that Windows is being presented the correct size, because Windows lists it in DiskPart.  Our problem is that the space is not available in Explorer.


    martedì 9 febbraio 2016 21:39
  • Any update Mary? 


    venerdì 12 febbraio 2016 17:03
  • Hi CFT Rick Wohleber,

    Sorry for the delay reply.

    First, please check if you have restarted the server. If not, please restart the server.

    Then, please do you have a soft quota on the disk volume? Check if the quota service is running. If yes, we can perform the following steps to stop quota.

    Run the command below:
    Net stop quota

    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    lunedì 15 febbraio 2016 01:12
  • Hi Mary,

    I've restarted the server and the same situation is still present.  I've checked to see if there are soft quotas in the system and there are none.  When I ran the command in an elevated command window I received the result:


    Microsoft Windows [Version 6.3.9600]
    (c) 2013 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>net stop quota
    The service name is invalid.

    More help is available by typing NET HELPMSG 2185.



    What's next?


    lunedì 15 febbraio 2016 11:34
  • Hi Mary,

    I could really use some help - it's been 2 weeks since I requested support on this item, I really need to get this server operational.  Can you please enlist some additional resources for this? 

    I'm doing my own research and find that there is a bug in the Windows Extend file system command where, if you choose all available space, it will not actually be available in Explorer.  The suggested solution (that which works in nearly all cases) is to then shrink the filesystem, and then extend in smaller increments but leave about 1% unused.  Seeing as ReFS cannot be "shrunk", what are my options here? 

    I'm  really in a jam and need to get this fixed.  Seeing as it's a bug that has been reported to Microsoft since Server 2008 R2 (and is quite easily documented in multiple Microsoft Forum posts), I need Microsoft to come up with a solution.  Please note, NO 3rd party utilities have been used to extend this partition so this is totally all Microsoft up to this point.


    mercoledì 17 febbraio 2016 12:51
  • Hi Rick,

    Pease perform the following action plan:
    Apply the latest refs file system hotfix and restart the server.

    Package: refs.sys
    KB Article Number (s) : 3108319  
    Language: All (Global)  
    Platform: x64  
    Location: ( )

    Please list filter drivers by running ‘fltmc’ command, then capture a screenshot and post.


    Thanks for your time and efforts, please feel free to let me know if you have any concerns.

    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    giovedì 18 febbraio 2016 08:14
  • Hi Mary,

    I've applied the hotfix and restarted.  The total capacity as being reported by Windows Explorer has not increased to the true size of the volume as reported by Disk Management.  I've run the fltmc command as requested, please see screenshot below of current status. 

    So... what's next?


    giovedì 18 febbraio 2016 19:01
  • Hi Rick,

    You might try do the following steps after dicussed with our senior engineer

    1. please check the tool fsextend.exe

    2. Run the following command:

    cd c:\tool
    fsextend <driver letter>


    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    martedì 23 febbraio 2016 06:43
  • Hi Mary,

    The link you've referred to is applicable to Server 2008.  Our server in question is running Server 2012 R2.  Are you SURE you want me to run a Vista / 2008 tool on our Server 2012R2 machine?


    martedì 23 febbraio 2016 11:10
  • Hi,

    You might could try to download from the one drive.

    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    mercoledì 24 febbraio 2016 07:51
  • Hi Mary,

    You didn't answer my question.  That tool you reference is outdated (and in fact REPLACED by the EXTEND command by Server 2012+).  Downloading the file is not a problem - I can get it anywhere.  This issue is that I am not comfortable running a discontinued utility in a critical large-scale server.  Also, your answers seem to reflect that you are unfamiliar with the problem when in fact Microsoft has been aware of this issue for years, yet has not resolved it.  I've now been able to replicate the problem with both NTFS and ReFS partitions using multiple systems.  The solution that have been reported to work are:

    1.  Extend the file systems slowly, eventually leaving the last ~1% of unallocated space unused

    2.  If the file system has already been extended but is not visible in File Explorer, then shrink the file system and then go back to #1, working your way slowly up.  THIS IS NOT AN OPTION WITH ReFS. it cannot be shrunk.

    3.  Add an additional drive to the array, then working your way up 99% capacity (see #1)

    4.  Delete the entire partition and start from scratch (not an option with nearly 25 TB of data on the partition comprising over 25m files).

    Mary, you've been very helpful but it's clear I need a more advanced level of support.  We've been going back and forth with significant delays in response for over 3 weeks now.   What are my options for getting either live chat or live phone support?  I'm running out of space, I need to now classify this as coming close to a server-down scenario based on the significant time delays in getting responses.

    Please advise.


    mercoledì 24 febbraio 2016 10:38
  • Mary,

    Here are some links detailing Microsoft being aware of this issue however it has been unresolved now for 8 years:

    If I could simply shrink the ReFS partition then re-extend slowly to get around the reporting error to the Windows file system then I'd be fine OR run CHKDSK /F to resolve the issue I'd be good.  However neither is an option with ReFS, hence my asking Microsoft how to fix the problem.  It's a bug in Microsoft's OS, so this is in your court not mine to resolve.  I've followed all the appropriate steps using ONLY Microsoft software so....

    Let's work the problem and, because it's a production server, do this in a far faster fashion.  Thank you for your help.


    mercoledì 24 febbraio 2016 10:54
  • Hi Mary,

    It has now been almost 2 days since I sent you the 2 emails (reference above) requesting escalated support solutions or options.  Please respond with the requested information.  Thank you in advance, and have a nice day!


    venerdì 26 febbraio 2016 11:50
  • Hi Rick,

    I also report the problem to our senior IT engineer. It may take sometime for discussing the problem. Any new information or conclusion for the problem, I'll update as soon as possible.

    Thanks for your understanding and support. Have a nice weekend!  :)

    Best Regards,

    Mary Dong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    sabato 27 febbraio 2016 09:36
  • Hi Mary,

    What does "sometime for discussing the problem" mean?  This is a production server, not a lab environment.  Please direct me to the appropriate department or phone # to call for a support engineer.  I understand that this may be billable, but I do not have a choice.  Monday will mark 4 weeks of this situation with no resolution in sight, and quite frankly I cannot keep my boss at bay any longer.  

    My primary question here is:  What phone # do I call for server-level support regarding a file system issue with Server 2012 R2?

    Thank you.


    domenica 28 febbraio 2016 02:29
  • Hi Rick,

    Sorry to hear that this issue has not been solved till now. Firstly, please understand that we are trying our best to help you solve this issue, building testing environment, doing test, involving senior engineer and so on. However, as you said, this issue is related with a production server, the issue may be related with many factors, and it is also difficult for us to repro. In addition, forum is an opening platform for us to provide help to many customers and every customer, we have the detailed process to follow, for example, initial respond time, follow-up time and so on. Please understand the limitation of our support resource in our side.

    You can also contact Microsoft to get further help according to your location:

    If you have anything further we can help, please feel free let me know.

    Appreciate your understanding!

    Lany Zhang

    lunedì 29 febbraio 2016 02:14
  • Hey Rick...  Do you have space to expand the volume at all?  I just ran in to the same issue and a colleague reminded me of an old windows bug when expanding volumes that if you took the entire available space it wouldn't show up in explorer. 

    I just had the same issue with ReFS on Sever 2016.  I just added a little more space but didn't allocate all of it when expanding the volume (left 500 mb unallocated) and it expanded the volume including the previous space i tried to expand to that wasn't showing in explorer.

    Hope that helps.


    • Proposto come risposta guowu martedì 5 dicembre 2017 12:21
    giovedì 1 giugno 2017 20:25
  • Thank you Brent! This bothered me for a while but your solution works for me!
    martedì 5 dicembre 2017 12:21
  • This problem has been perplexing me, too.  I was almost ready to replace all ReFS with NTFS so I did some tests that you all might find interesting.

    I did try expanding a 2 GB original volume by another 2 GB and that worked perfectly every time.  I would try a 6 GB expansion after the original volume creation and it would fail.

    I expanded the original 2 GB partition by another 2 GB and that worked.  I then expanded that new 4 GB volume by 6 GB and it worked.

    I was then able to expand the new 10 GB partition by 15 GB and that worked.

    It makes no sense.  It only seems to work with any reliability if I expand by a couple of small increments before going for the big expansion.  I used Diskpart, Expand, File and Storage Services, and Disk Manager.  I haven't used Powershell so that is my next experiment.


    Tom Stone

    • Modificato mctstone giovedì 12 luglio 2018 18:48
    giovedì 12 luglio 2018 16:35
  • I found this Microsoft PartnerSupport discussion that explains the problem and the limits of ReFS.  It is giving a clue but it is incorrect.

    "ReFS does have an internal atomicity limit per extend operation in Windows Server 2012 R2 – the extend volume size cannot be larger than 3x of the pre-extend volume size. For a 10GB initial volume size, 30GB would be the maximum, then 90GB, etc."

    My tests show that it only allows an initial 2 GB extension.  The second extension seems to be limited to 6 GB.  After that, you can go to the end.

    • Modificato mctstone giovedì 12 luglio 2018 19:27
    giovedì 12 luglio 2018 19:26