none
Impossibile registrare i record di risorsa (RR) puntatore (PTR) per la scheda di rete Event id 8014 RRS feed

  • Domanda

  • Dopo migrazione a win 10 pro di client win 7 connessi al dominio su alcuni client si verifica l'errore in oggetto.

    Pur essendo configurato correttamente il DNS nella scheda di rete del client (10.0.0.1) il server risponde al ping (ping mioserver) con l'indirizzo ip della seconda scheda di rete (192.168.0.10). L'indirizzo del client è nella classe 10 quindi non riceve risposta. Aggiungendo un secondo ip nella scheda di rete del client (in classe 192.168) il (ping mioserver) funziona perfettamente.

    Il dns del client risulta registrato correttamente. La postazione funzionava perfettamente prima della migrazione.

    Non capisco se il problema riguarda i driver della scheda di rete dopo l'aggiornamento, la gestione dns del dominio su cui è montato win server 2012 r2 oppure è un problema di win10. Su altri client non ho questo problema. Il problema si verifica dopo alcuni giorni di funzionamento appena migrati il ping mioserver risponde correttamente.

    Allego configurazione postazione con secondo ip già aggiunto che mi consente di raggiungere il mioserver:

    ping mioserver

    Esecuzione di Ping mioserver.miodominio.LOCALE [192.168.0.10] con 32 byte di dati:
    Risposta da 192.168.0.10: byte=32 durata<1ms TTL=128
    Risposta da 192.168.0.10: byte=32 durata<1ms TTL=128
    Risposta da 192.168.0.10: byte=32 durata<1ms TTL=128
    Risposta da 192.168.0.10: byte=32 durata<1ms TTL=128

    Statistiche Ping per 192.168.0.10:
        Pacchetti: Trasmessi = 4, Ricevuti = 4,
        Persi = 0 (0% persi),
    Tempo approssimativo percorsi andata/ritorno in millisecondi:
        Minimo = 0ms, Massimo =  0ms, Medio =  0ms

    C:\WINDOWS\system32>nslookup
    1.0.0.10.in-addr.arpa
            primary name server = localhost
            responsible mail addr = nobody.invalid
            serial  = 1
            refresh = 600 (10 mins)
            retry   = 1200 (20 mins)
            expire  = 604800 (7 days)
            default TTL = 10800 (3 hours)
    Server predefinito:  UnKnown
    Address:  10.0.0.1


    C:\WINDOWS\system32>ipconfig /all

    Configurazione IP di Windows

       Nome host . . . . . . . . . . . . . . : ambulatorio47
       Suffisso DNS primario . . . . . . . . : miodominio.LOCALE
       Tipo nodo . . . . . . . . . . . . . . : Ibrido
       Routing IP abilitato. . . . . . . . . : No
       Proxy WINS abilitato . . . . . . . .  : No
       Elenco di ricerca suffissi DNS. . . . : miodominio.LOCALE

    Scheda Ethernet Connessione alla rete locale (LAN):

       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Indirizzo fisico. . . . . . . . . . . : 90-1B-0E-93-7A-01
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì
       Indirizzo IPv6 locale rispetto al collegamento . : fe80::45e7:6044:1a83:1f43%3(Preferenziale)
       Indirizzo IPv4. . . . . . . . . . . . : 10.0.0.138(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.0
       Indirizzo IPv4. . . . . . . . . . . . : 192.168.0.9(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.0
       Gateway predefinito . . . . . . . . . : 10.0.0.16
       IAID DHCPv6 . . . . . . . . . . . : 244325134
       DUID Client DHCPv6. . . . . . . . : 00-01-00-01-1F-08-14-CA-90-1B-0E-93-7A-01
       Server DNS . . . . . . . . . . . . .  : 10.0.0.1
       NetBIOS su TCP/IP . . . . . . . . . . : Attivato

    Scheda Tunnel isatap.{6E8774F9-D237-42D8-8FC2-B0377F34C46F}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì



    C:\WINDOWS\system32>route print
    ===========================================================================
    Elenco interfacce
      3...90 1b 0e 93 7a 01 ......Realtek PCIe GBE Family Controller
      1...........................Software Loopback Interface 1
      4...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
    ===========================================================================

    IPv4 Tabella route
    ===========================================================================
    Route attive:
         Indirizzo rete             Mask          Gateway     Interfaccia Metrica
              0.0.0.0          0.0.0.0        10.0.0.16       10.0.0.138    266
             10.0.0.0    255.255.255.0         On-link        10.0.0.138    266
           10.0.0.138  255.255.255.255         On-link        10.0.0.138    266
           10.0.0.255  255.255.255.255         On-link        10.0.0.138    266
            127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
            127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
      127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
          192.168.0.0    255.255.255.0         On-link        10.0.0.138    266
          192.168.0.9  255.255.255.255         On-link        10.0.0.138    266
        192.168.0.255  255.255.255.255         On-link        10.0.0.138    266
            224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
            224.0.0.0        240.0.0.0         On-link        10.0.0.138    266
      255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      255.255.255.255  255.255.255.255         On-link        10.0.0.138    266
    ===========================================================================
    Route permanenti:
       Indirizzo rete             Mask   Indir. gateway Metrica
              0.0.0.0          0.0.0.0        10.0.0.16  Predefinito
    ===========================================================================

    IPv6 Tabella route
    ===========================================================================
    Route attive:
     Interf Metrica Rete Destinazione      Gateway
      1    306 ::1/128                  On-link
      3    266 fe80::/64                On-link
      3    266 fe80::45e7:6044:1a83:1f43/128
                                        On-link
      1    306 ff00::/8                 On-link
      3    266 ff00::/8                 On-link
    ===========================================================================
    Route permanenti:
      Nessuna

    DETTAGLI ERRORE (allego errore di altra postazione con identico problema)

    - System

      - Provider

       [ Name]  Microsoft-Windows-DNS-Client
       [ Guid]  {1C95126E-7EEA-49A9-A3FE-A378B03DDB4D}
     
       EventID 8014
     
       Version 0
     
       Level 4
     
       Task 1028
     
       Opcode 0
     
       Keywords 0x4000000000000000
     
      - TimeCreated

       [ SystemTime]  2016-07-08T04:39:08.719386700Z
     
       EventRecordID 1891
     
       Correlation
     
      - Execution

       [ ProcessID]  256
       [ ThreadID]  1708
     
       Channel System
     
       Computer ambulatorio47.miodomimio.LOCALE
     
      - Security

       [ UserID]  S-1-5-20
     

    - EventData

      AdapterName {6E8774F9-D237-42D8-8FC2-B0377F34C46F}
      HostName ambulatorio47
      AdapterSuffixName miodomimio.LOCALE
      DnsServerList 10.0.0.1
      Sent UpdateServer <?>
      Ipaddress 10.0.0.138
      ErrorCode 10054

    Grazie per le possibili risposte

    Alessandro

    sabato 9 luglio 2016 03:06

Tutte le risposte

  • Non ho ben capito perché hai sulla stessa scheda di rete due classi di ip diverse, la lan principale che indirizzi ha?

    Il server poi che ip ha 10.0.0.1 o 192.168.0.10?

    Ciao


    Andrea Sistarelli
    Blog
    Datacen srl - Consulenza informatica

    sabato 9 luglio 2016 04:35
  • Il server ha due schede di rete.

    Una con indirizzo 10.0.0.1 l'altra con indirizzo 192.168.0.10.

    Il client ha come DNS 10.0.0.1 ma su ping (ping mioserver) mi risponde solo l'ip 192.168.0.10 sono costretto a mettere anche il secondo ip sul client altrimenti non risolve il nome mioserver. Come avevo scritto nelle prime righe del tread.

    Questo è il comportamento anomalo che ho riscontrato dopo migrazione a win 10. I client prima della migrazione funzionavano perfettamente.

    Ciao

    domenica 10 luglio 2016 02:43
  • Ciao Alessandro, perché sul server utilizzi due IP? Un DC con due schede può portare ad avere problemi, come ad esempio il tuo.

    Saluti

    Nino

    domenica 10 luglio 2016 20:11
    Moderatore
  • Puoi spiegare meglio come è strutturata la tua rete avendo sul server due schede di rete su due subnet diverse mentre sul client c'è una sola scheda di rete con doppio IP? Quindi le due schede di rete del sever in realtà fanno parte della stessa rete fisica.

    Oltretutto usare due schede di rete su un DC non è consigliato.

    Ciao


    Andrea Sistarelli
    Blog
    Datacen srl - Consulenza informatica

    lunedì 11 luglio 2016 06:08
  • E' una rete unica. Il server ha due schede di rete. La scheda 1 ip 10.0.0.1 scheda 2 192.168.0.10.

    Sui client lavoriamo con la classe 10. Configurazione tipica funzionante sul client prima della migrazione a windows 10 e perferttamente funzionante su win 7:

    IP 10.0.0.x

    sub 255.255.255.0

    DNS 10.0.0.1

    Ora sono costretto a inserire un ip aggiuntivo in configurazione avanzate sul client nella classe 192.168.0.x perchè il server al ping mioserver risponde solo con ip 192.168.0.10 e non più con 10.0.0.1

    Ciao

    sabato 23 luglio 2016 02:01
  • Non ho mai avuto problemi con windows 7. Solo dopo aggiornamento a win 10 e solo dopo alcuni giorni penso dopo alcuni ulteriori aggiornamenti automatici effettuati dal client attraverso win update.

    Dopo la migrazione il client funziona correttamente e registra il record. Non capisco se il problema dipenda dal server o dai drivers del client. I client con win 7 stanno lavorando perfettamente anche con questa configurazione con due ip diversi uno su ogni scheda di rete nel server.

    ciao

    domenica 24 luglio 2016 02:25
  • Il non avere, magari apparentemente, problemi non è una risposta.

    Ripeto la domanda. Perché il server ha due scheda di rete con due classi di indirizzamento differenti? C'è un prerequisito tecnico? Un software o un dispositivo che gira su quella classe? Dal nome del client mi viene il sospetto che sulla rete sia presente un diagnostico con la classe 192.168.0.0.

    Saluti

    Nino


    domenica 24 luglio 2016 08:17
    Moderatore
  • Abbiamo un rete wifi con dei palmari che lavorano su quella classe.

    Tutto sulla stessa rete fisica. Sui palmari gira un software gestito da terzi che punta su altro server ma che ha bisogno di comunicare con il nostro per leggere sul db sql. Tutto qui.

    Ripeto sono 2 anni che la rete funziona egregiamente con questa configurazione. Dopo migrazione e solo dopo qualche giorno i client migrati mi danno l'errore in allegato al mio messaggio e il ping mioserver risponde con il secondo ip ovviamente dando rete di destinazione non raggiungibile. Sul registro eventi comincia ad appararire l'errore.

    Non capisco se è un problema di drivers della scheda non perfettamente compatibili o un problema di dns.

    Se eseguo il ping usando l'ip il server risponde.

    Posso sfogliare con esplora risorse la rete e vedo anche il "mioserver".

    Se aggiungo la seconda classe ip sulla scheda del client ping mioserver ritorna a funzionare perferttamente.

    Saluti

    lunedì 25 luglio 2016 01:59
  • Ok, era solo per capire se la configurazione era necessaria o se era possibile intervenire.

    Hai la possibilità di installare una VM W10?

    Su un client elimina il secondo IP, gli eventi ed esegui ipconfig /flushdns dopo ipconfig /registerdns. Aspetta 10/15 min e verifica gli eventi. Riporta errori.

    lunedì 25 luglio 2016 05:39
    Moderatore
  • Eseguiti comandi come da suggerimento stesso errore nel registro eventi.

    Record srv correttamente registrato con priorità 0 su 10.0.0.1. Ping mioserver risponde sempre il secondo ip.

    Una VM w10 protrei installarla su una vecchio pc con win7 ma a che scopo?
    martedì 26 luglio 2016 04:47
  • Nel thread hai scritto che il problema si presenta dopo alcuni giorni dall'installazione di Windows 10. Quindi per riprodurre il problema dovresti utilizzare una VM pulita con Windows Update disattivato.

    Dai una lettura al seguente articolo, una soluzione potrebbe essere quella di modificare la metrica sulla seconda interfaccia di rete del server (192.168.0.0) http://consek-blog.azurewebsites.net/network-card-priority-and-ip-routing-using-two-or-more-cards-on-one-host/

     
    martedì 26 luglio 2016 07:15
    Moderatore
  • Ultime prove effettuate. Ho due macchine di test migrate da win 7 a win 10. Entrambe collegate al dominio.

    Una con gli update abilitati l'altra no. Alla migrazione tutto fuziona regolarmente su entrambe le macchine. Dopo un paio di giorni sulla macchina con gli aggiornamenti abilitati si presenta l'evento 8014 e smette di funzionare il ping mioserver. Sulla seconda tutto funziona perfettamente.

    Marca e modello pc sono identici.

    Sul pc non funzionante provo a caricare varie versione dei driver della scheda di rete prendendo come esempio pc identici che stanno funzionando anche se l'update è attivo. L'errore rimane e quindi escludo sia un problema della scheda di rete o dei suoi drivers.

    Ho provato a loggarmi con differenti utenti, a cambiare il nome macchina ma la cosa non ha sortito alcun effetto. Non riesco a capire cosa generi il problema.

    lunedì 1 agosto 2016 09:49
  • Riesci a girare l'elenco delle KB installate?

    In questi casi una delle strade è quella di creare una VM allineata alla versione iniziale ed installare manualmente un gruppo di KB alla volta (5/10) e di effettuare delle snap.

    Saluti
    Nino

    lunedì 1 agosto 2016 13:30
    Moderatore
  • Ultime prove. L'installazione delle kb3173428 e kb3152599 ha azzerarto il registo eventi. E' quasi una installazione completa con il classico timer a percentuale (disco di avanzamento) visto nella migrazione qualche settimana fa. Ha azzerato anche la cronologia aggiornamenti.

    Sul server ho fatto un tentativo sulle zone di ricerca diretta sul miodominio\proprietà \server di nomi\ modifica ho spostato in alto l'IP in classe 10 che risultava in seconda posizione. Ho presunto che il client desse la priorità all'altro IP in classe 198 (cosa che con win 7 non avveniva).

    Magia il ping mioserver ha cominciato a funzionare nonostante l'evento 8014 comunque ancora si presenti nel pc di test.

    Nelle mie innumerevoli prove ho notato che se tolgo il gateway (che punta al router di cui ho bisogno per navigare) il ping mioserver funziona.

    Qualcosa comunque non sta funzionando correttamente nel client per quanto concerne il DNS. Altra ipotesi che avevo fatto era che sulle macchine in produzione essendo presente già un profilo utente loggato al dominio, il problema potesse dipendere da quello. Nelle macchine di test il profilo utente con connessione al dominio non c'era, sono macchine pulite con solamente win 7 installato e migrate a win 10. Solo successivamente ho effettuato la connessione al dominio. Qualcosa non va nello scambio di credenziali tra l'utente \ pc loggato e il server dns.

    Da un certo aggiornamento in poi e sicuramente dal kb3152599 la gestione dei dns cambia con il fatidico evento 8014. Per ora mi fermo qui il problema sembra risolto vedrò se il comportamento dei client rimarrà stabile nel tempo. Sarebbe interessante capire perchè e cosa crei il problema e di conseguenza trovare soluzioni certe.

    ciao

    mercoledì 3 agosto 2016 05:03
  • Ciao,

    ci sono molte cose che possono essere fatte per investigare.

    Ho letto il thread ma non ho visto usare nslookup, arp, ping -a  etc..

    Se vuoi andare a fondo dovresti considerare quegli strumenti e magari network monitor



    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    mercoledì 3 agosto 2016 09:07