none
Non funziona la ricerca nelle mailbox RRS feed

  • Domanda

  • buongiorno a tutti
    Ho un problema con la ricerca di contenuti nelle mailbox.
    Ringrazio fin d'ora chi vorrà leggere questo articolato messaggio.
     
    Il sistema di posta è così configurato:
    1 server -Backend - exch 2010 sp3 ruolo mailbox con Sistema Operativo win 2k8 r2 sp3
    1 server -Frontend- exch 2010 sp3 ruoli hub transport e Client Access con  Sistema Operativo win 2k8 r2 sp3

    Exchange è con licenza std
    Abbiamo 4 db ed 1 public folder
    I server sono in rete locale e inviano posta tramite smarthost

    Da circa 1 mese abbiamo sostituito L'Antivirus "ForeFront for Exchange" con il modulo "Kaspersky Endpoint security 10".
    Abbiamo installato solo il modulo file level.
    La sostituzione dell'antivirus è avvenuta nel modo seguente:
    - prima sul Front-end
    - poi,dopo alcuni giorni, dopo avere verificato che funzionasse bene (non abbiamo verificato le ricerca...) sul Backend

    Sembra che dallo stesso periodo le ricerche dei contenuti nelle mailbox non si aggiornino piu'.
    Quindi se un utente, tramite Owa effettua una ricerca nella sua mailbox, ottiene questi risultati:
    - se la mailbox insiste nei db ai quali ho tentato di ricostruire l'indice, la ricerca non resituisce niente
    - se la mailbox insiste nei db ai quali NON ho tentato di ricostruire l'indice, la ricerca restituisce risultati compatibili solo alla data
      che  conincide (sembra) con quella di sostituzione dell'antivirus sul server di front-end.


    Il parametro IndexEnabled è impostato a true su ogni database

    Il comando Get-MailboxDatabaseCopyStatus resituisce:
    database a    Healthy
    database b    Healthy
    database c    Healthy
    database d    Crawling

    la "folder index catalog" del database d non si aggiorna mai.Nemmeno dopo alcuni giorni.

    Ho effettuato diverse prove:
    1) ricostruito gli indici in modo manuale, cioe'
       a)stop  service MSExchangeSearch
       b)delete folder index catalog
       c)start MSExchangeSearch
    2) ricostruito gli indici tramite lo script resetsearchindex.ps1 -force <dbname>
    Il risultato di queste 2 prove è stato che il contenuto delle folder index catalog è di 19 file e non si aggiorna mai.Nemmeno dopo giorni.
    Chiaramente la ricerca non resitutuisce niente.

    3) disattivato KAV su entrambi i server exchange e ricostruito gli indici di 2 database
    Il risultato è stato che:
    1 folder index catalog non si aggiorna
    1 folder index catalog si è aggiornata:ha raggiunto i 1,5 mbyte dimensione in circa 24 ore, contro i 3 gb circa che mi aspettavo.  
    Chiaramente la ricerca non resitutuisce niente.
     
    4) ho anche :
       a) creato un db exechange.Chiamamolo E.
       b) inserito una nuova mailbox.
       la mailbox viene alimentata da uno script che gli tx msg di testo ogni 10 minuti.
       c) abilitato il parametro indexEnabled  solo del DB appena creato e disabilitato negli altri db  
       d) stop MSExchangeSearch
       e) Delete Folder Index del db E
       f) start MSExchangeSearch
    risultato:folder index catalog non si aggiorna.Contiene 19 file ed il suo DataModified corrisponde alla dataOra di creazione.
    L'event viewer segnala in sequenza gli eventi
    109:new search index
    108:enabled indexing
    110:search indexer completed
    il tutto nell'arco di 30 secondi.Veloce ? Si ma deve ricreare l'indice di un db che 1 solo mailbox che contiene circa 100 msg di solo testo.

    Il comando Get-MailboxDatabaseCopyStatus resituisce:
    database E    Healthy

    Va inoltre precisato che,con il parametro indexEnabled impostato a True su tutti i database,il DataModified delle folder index catalog non ricostruite si aggiorna, ma i risultati delle ricerche non sono corretti.

    Ulteriore considerazione:
    Quando, come normalmente è, sono abilitati gli IndexEnabled di ogni Db, l'event viewer mostra il warning sottostante alcune volte al giorno:
    err 107 source: MSExchange Search Indexer
    Exchange Search Indexer has temporarily disabled indexing of the Mailbox Database xxxxxxxxxxxxx
     due to an error (Microsoft.Exchange.Msfte.BatchTimeoutException: Timeout detected for
    batch Database Guid:xxxxxxxxxxxxxxxxxxxxxx; NumberOfFailedDocuments:0;
    ShouldIsolateError: False; SubmitTickCount:370518250; BatchKind:Notifications; Number of entries:1).

    detto tutto questo, cosa fare per far funzionare di nuovo le ricerche ?

    grazie in anticipo a chi vorrà darmi chiarimenti
    domenica 25 settembre 2016 14:03

Risposte

Tutte le risposte

  • ciao, prima di tutto una domanda. Sono Kaspersky Silver Partner, mi spieghi perchè metti una suite fileserver su un exchange quando

    1) Kaspersky ti fa la suite apposta "for Exchange mailserver" che ASSOULTAMENTE non comprende il fileserver

    2) il tuo server non è pubblicato, quindi non ha shares e il fileserver non fa l'inspection dei messaggi.

    non si mette su l'av file su un server exchange...tantomeno se non è il suo, secondo me è andato ad intervenire su delle cache dove non doveva.

    Mi sono letto i tuoi passi, sono giusti, ma se ancora non indicizza la situazione è complessa e non poco e 4db sono tanti (se non erro è il limite della standard) ti consiglio di contattare il supporto a pagamento, difficilmente qui possiamo tirare fuori dal cilindro una soluzione senza vedere la struttura a questo punto soorattutto perchè hai fatto già talmente tante prove che diventa molto rischioso consigliare senza fare più danno del dovuto.

    ciao.

    A. 

    domenica 25 settembre 2016 17:40
    Moderatore
  • Grazie per il tuo interessamento. Contatto il nostro supporto Kaspersky.

    lunedì 26 settembre 2016 08:17
  • no supporto Kaspersky...supporto MICROSOFT. Kaspersky non c'entra nulla se non installi la versione giusta sul server...
    lunedì 26 settembre 2016 09:17
    Moderatore
  • Ciao,
    concordo con Alessandro, l'antivirus può essere che stia lavorando su qualche directory che andrebbe inserita nelle exclusion dell'antivirus, tipo la directory dove vengono scritti i transaction log di exchange...
    Facci sapere!
    lunedì 26 settembre 2016 16:34
  • Il ns supporto ha risolto registrando le dll:

    MapiProtocolHandlerStub

    msfte

    msftepxy

    Grazie a tutti


    stefano

    venerdì 14 ottobre 2016 10:59