none
Outlook 2016, Exchange 2010, Win 10 Home e certificati RRS feed

  • Domanda

  • Un cliente ha fatto il classico acquisto d'impulso, compranto un notebook equipaggiato con Windows 10 Home invece del Pro.

    Ovviamente non si può registrare sotto dominio, ma questo è un problema secondario (per certi versi...). Il problema principale è che non riesco a collegare il suo Office 2016 al server Exchange. Non so se la cosa derivi dalla versione di Windows, fatto sta che carico il certificato, eseguo la procedura di aggiunta dell'account in modalità avanzata per dare i parametri a mano, ma dopo la verifica arrivo sempre ad una bella maschera che mi dice che c'è un errore di connessione, con la sola possibilità di riprovare o annullare.

    L'IP al pc viene asseganto dal server, quindi escludo DNS sbagliati. Resta l'incognita del certificato che, seppur visto correttamente da Explorer e Edge (non chiedono nulla entrando via OWA), non viene riconosciuto da Chrome e Firefox, quindi mi viene il dubbio che anche Outlook 2016 non lo riconosca. Il certificato è autoprodotto.

    Ci sono altri pc in quella ditta, equipaggiati con Office 2016 (ma con Windows Pro) che si collegano senza problemi

    lunedì 19 marzo 2018 09:37

Tutte le risposte

  • Ciao Skywalker

    Dal pc con windows home vai su 

    https://mail.domain.com/EWS/Exchange.asmx

    metti le credenziali dell'utente e prova a vedere cosa ti restituisce.

    Prova anche ad inserire questi record nel file host della macchina

    xxx.xxx.xxx.xxx        Externalsmtpdomainname.
    xxx.xxx.xxx.xxx        autodiscover.yoursmtpdomain.com

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    martedì 20 marzo 2018 21:31
  • Ciao Sky, scusa ma nel momento in cui tu metti la mail dell'utente e la password anche se è fuori dominio l'autodiscover e di conseguenza l'autoconfig devono funzionare anche se è un Home. 

    Se questo non avviene qualcosa non è correttamente configurato a livello di record o certificato.

    Poi mi parli di "autoprodotto" cosa vuol dire? che usi l'autofirmato? e da fuori come fai? Per il 2016 (outlook) sei obbligato ad usare almeno una CA interna ed un certificato emesso da quella CA..tra le altre cose nell'autofirmato di exchange  c'è solo il record fqdn, ma siccome non sei agganciato a dominio quando va a fare ricerca l'autodiscover non sta usando AD perchè la macchina non è agganciata ad AD quindi come fai a fargli raggiungere anche solo manualmente il server?

    Andrebbe sistemato così almeno:

    - CA interna

    - Request di certificato alla CA con FQDN, record esterno ed autodiscover

    - emissione del certificato

    - installazione sui client off domain della catena della CA e del certificato

    in questo modo funziona tutto.

    In altro modo...acquisto di un upgrade alla versione pro, aggancio a dominio...e li secondo me non ci sono più problemi. 

    Domanda di fine riflessione..ma su quel 2010 l'autodiscover è configurato? perchè se parli di autofirmato...boh.

    ciao.

    A.


    mercoledì 21 marzo 2018 09:01
    Moderatore