none
Non riesco a visualizzare i rapporti del WSUS RRS feed

  • Domanda

  • Buongiorno a tutti.

    Ho recentemente virtualizzato una versione standard di Win 2012 srv per creare un server WSUS.

    Non riesco a visualizzare i report nonostante abbia installato, dopo aver chiuso la console, Microsoft Report Viewer Redistributable 2008.

    In pratica quando clicco su un host per controllare la situazione mi viene fuori il messaggio sotto riportato.

    Vi sarei grato se poteste aiutarmi a risolvere il problema.

    Buona giornata.

    Massimo



    mercoledì 19 settembre 2018 07:55

Risposte

  • Ciao Massimo,

    Questo articolo spiega il problema e la soluzione. 

    Installation of Windows Server 2012 Beta WSUS is a easy and straight forward task, which you can do via Server Manager or remotely by adding the required Role.

    clip_image002

    After I installed WSUS it worked immediately without any issues, but when I tried to open one of the computer reports I got following message.

    clip_image003

    So I thought no problem. I download report viewer from Microsoft website and I will install it. http://www.microsoft.com/en-us/download/details.aspx?id=577

    But when I tried to install it told me I need .Net Framework 2.0 . But you can’t install .Net framework redistributable bits on Windows Server 2012 Beta , since .Net Framework 4 is already installed. And when you try to install the redistributable files Windows will tell you that you should add it via roles and features.   So what to do ?

    Here is the solution. You will need the Windows 2012 Server Beta Installation sources. In my case in Drive D:

    clip_image005

     

    Starting  Command prompt as Administrator

    clip_image007

     

    Dism /online /enable-feature /featurename:NetFX3 /featurename:NetFx3ServerFeatures /Source:D:\sources\sxs
    Note: D: is the drive letter of DVD drive on the computer, adjust it accordingly.

    clip_image009

    clip_image011

    after running successful .Net Installation via DSIM you can run the installation of Report Viewer tools without a problem

    clip_image013

    clip_image014

    clip_image016

    Now Reports works fine Smile!

    clip_image018

    clip_image020

    clip_image022

    mercoledì 19 settembre 2018 09:02
    Moderatore
  • Aggiornamento.

    Buongiorno a tutti.

    Ho risolto il problema.

    Spiego in modo che se qualcuno si trovasse nelle stesse condizioni provando questa soluzione potrebbe risolvere.

    In pratica avevo già installato il "Microsoft Report Viewer Redistributable", però versione 2010, l'ho disinstallato tramite pannello di controllo, ho aperto un prompt dei comandi con privilegi amministrativi, ho nuovamente fatto partire l'istallazione del .Net Frameword con questo comando "Dism /online /enable-feature /featurename:NetFX3 /featurename:NetFx3ServerFeatures /Source:D:\sources\sxs" e ho nuovamente installato il "Microsoft Report Viewer Redistributable 2008".

    Ho controllato se riuscivo a vedere i rapporti e tutto ha funzionato alla perfezione.

    Grazie a Nikola Kochmalarski per la preziosa collaborazione.


    giovedì 20 settembre 2018 06:33

Tutte le risposte

  • Ciao Massimo,

    Questo articolo spiega il problema e la soluzione. 

    Installation of Windows Server 2012 Beta WSUS is a easy and straight forward task, which you can do via Server Manager or remotely by adding the required Role.

    clip_image002

    After I installed WSUS it worked immediately without any issues, but when I tried to open one of the computer reports I got following message.

    clip_image003

    So I thought no problem. I download report viewer from Microsoft website and I will install it. http://www.microsoft.com/en-us/download/details.aspx?id=577

    But when I tried to install it told me I need .Net Framework 2.0 . But you can’t install .Net framework redistributable bits on Windows Server 2012 Beta , since .Net Framework 4 is already installed. And when you try to install the redistributable files Windows will tell you that you should add it via roles and features.   So what to do ?

    Here is the solution. You will need the Windows 2012 Server Beta Installation sources. In my case in Drive D:

    clip_image005

     

    Starting  Command prompt as Administrator

    clip_image007

     

    Dism /online /enable-feature /featurename:NetFX3 /featurename:NetFx3ServerFeatures /Source:D:\sources\sxs
    Note: D: is the drive letter of DVD drive on the computer, adjust it accordingly.

    clip_image009

    clip_image011

    after running successful .Net Installation via DSIM you can run the installation of Report Viewer tools without a problem

    clip_image013

    clip_image014

    clip_image016

    Now Reports works fine Smile!

    clip_image018

    clip_image020

    clip_image022

    mercoledì 19 settembre 2018 09:02
    Moderatore
  • Gentile Nikola, ti ringrazio per la risposta, ho seguito la procedura e l'installazione del  .Net Framework 2.0 è andata a buon fine.

    Purtroppo però il problema di mancata visualizzazione persiste e mi chiede comunque l'installazione del Microsoft Report Viewer Redistributable 2008.

    Come posso rimediare.

    Grazie in anticipo.

    mercoledì 19 settembre 2018 11:54
  • Aggiornamento.

    Buongiorno a tutti.

    Ho risolto il problema.

    Spiego in modo che se qualcuno si trovasse nelle stesse condizioni provando questa soluzione potrebbe risolvere.

    In pratica avevo già installato il "Microsoft Report Viewer Redistributable", però versione 2010, l'ho disinstallato tramite pannello di controllo, ho aperto un prompt dei comandi con privilegi amministrativi, ho nuovamente fatto partire l'istallazione del .Net Frameword con questo comando "Dism /online /enable-feature /featurename:NetFX3 /featurename:NetFx3ServerFeatures /Source:D:\sources\sxs" e ho nuovamente installato il "Microsoft Report Viewer Redistributable 2008".

    Ho controllato se riuscivo a vedere i rapporti e tutto ha funzionato alla perfezione.

    Grazie a Nikola Kochmalarski per la preziosa collaborazione.


    giovedì 20 settembre 2018 06:33