none
Invio posta Exchange 2010 RRS feed

  • Discussione generale

  • Ho un problema alquanto sciocco da risolverre ma sono tre giorni che ci sbatto la testa arrivo al dunque:

    server 2008 r2 con un software gestione installato sopra e insieme c'è exchange 2010

    La cfg di exch 2010 è funzionale invia e riceve posta  (quindi connettore di invio configurato verso SMTP della connessione, connettore di ricezione attivato)

    Nel gestionale è presente un modulo per l'invio della posta, quindi si configura sia il server smtp che l'auth.

    Come devo configurare opportunamente il connettore di ricezione in modo da permettere l'invio dallo stesso server? sembra banale e sicuramente è così ma ricevo messaggi di errore del tipo client non autenticato

    Cosa posso fare?

    Grazie

    • Tipo modificato Anca Popa venerdì 19 novembre 2010 10:02 attesa di feedback/ ricerca di soluzione
    • Modificato Anca Popa venerdì 19 novembre 2010 10:04 formattazione
    domenica 7 novembre 2010 22:04

Tutte le risposte

  • Ciao Giovanni,

    Per impostazione predefinita Exchange 2010 è configurato per accettare solo posta elettronica SMTP dai domini per cui è autorevole e per l'inoltro della stessa su altri domini solamente per gli utenti autenticati localmente.

    Ne consegue che dovrai impostare un connettore configurato adhoc.

    Segui questo articolo: http://www.andreagallazzi.com/2009/10/smtp-auth.html


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 8 novembre 2010 07:49
  • Ho fatto come mi hai consigliato con l'unico problema che il programma non permette di settare la porta per cui ho dovuto usare la porta 25.

    Il messaggio di errore è il seguente:

    5.7.1. Client does not have permission to send as this sender

     

     

    sabato 13 novembre 2010 11:44
  • Chiaramente volendo utilizzare la porta 25 sarà necessario attribuire alla NIC un ulteriore indirizzo IP in modo da far lavorare il connettore aggiuntivo solo sull'ip preposto.

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    sabato 13 novembre 2010 11:58
  • è quello che ho fatto altrimenti il binding non si può fare.

    nella scheda delle connessioni remote possibili c'è l'ip del server stesso

    ma cmq non fuinziona

    sabato 13 novembre 2010 14:31
  • Posta l'output di 

    Get-ReceiveConnector -Identity tuoconnettore |FL

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    sabato 13 novembre 2010 14:49
  • è quello che ho fatto
    sabato 13 novembre 2010 17:49
  • questo è quello che mi chiedevi

    RunspaceId                              : bef33122-a866-4aa1-9a5c-d4f262ffadef
    AuthMechanism                           : Tls, BasicAuth, ExchangeServer
    Banner                                  :
    BinaryMimeEnabled                       : True
    Bindings                                : {10.174.15.78:25}
    ChunkingEnabled                         : True
    DefaultDomain                           :
    DeliveryStatusNotificationEnabled       : True
    EightBitMimeEnabled                     : True
    DomainSecureEnabled                     : False
    EnhancedStatusCodesEnabled              : True
    LongAddressesEnabled                    : False
    OrarEnabled                             : False
    SuppressXAnonymousTls                   : False
    AdvertiseClientSettings                 : False
    Fqdn                                    : vm0210.xxxxxx.local
    Comment                                 :
    Enabled                                 : True
    ConnectionTimeout                       : 00:10:00
    ConnectionInactivityTimeout             : 00:05:00
    MessageRateLimit                        : unlimited
    MessageRateSource                       : IPAddress
    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 20
    MaxInboundConnectionPercentagePerSource : 2
    MaxHeaderSize                           : 64 KB (65,536 bytes)
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 10 MB (10,485,760 bytes)
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200
    PermissionGroups                        : ExchangeUsers, ExchangeServers, ExchangeLegacyServers, Partners, Custom
    PipeliningEnabled                       : True
    ProtocolLoggingLevel                    : Verbose
    RemoteIPRanges                          : {10.174.15.78, 10.174.15.74}
    RequireEHLODomain                       : False
    RequireTLS                              : False
    EnableAuthGSSAPI                        : False
    LiveCredentialEnabled                   : False
    Server                                  : VM0210
    SizeEnabled                             : Enabled
    TarpitInterval                          : 00:00:05
    MaxAcknowledgementDelay                 : 00:00:30
    AdminDisplayName                        :
    ExchangeVersion                         : 0.1 (8.0.535.0)
    Name                                    : Mesa
    DistinguishedName                       : CN=Mesa,CN=SMTP Receive Connectors,CN=Protocols,CN=VM0210,CN=Servers,CN=Excha
                                              nge Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First
                                              Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=goldstores
                                              ,DC=local
    Identity                                : VM0210\Mesa
    Guid                                    : 390cbdb4-058c-4eea-847c-0d4bfd9b4423
    ObjectCategory                          : goldstores.local/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
    ObjectClass                             : {top, msExchSmtpReceiveConnector}
    WhenChanged                             : 13/11/2010 12:42:35
    WhenCreated                             : 03/11/2010 15:38:52
    WhenChangedUTC                          : 13/11/2010 11:42:35
    WhenCreatedUTC                          : 03/11/2010 14:38:52
    OrganizationId                          :
    OriginatingServer                       : vm0210.xxxx.local
    IsValid                                 : True

    sabato 13 novembre 2010 18:05
  • Perdonami ma sembra proprio che quello che non hai fatto è seguire le istruzioni del mio articolo:

    > AuthMechanism                           : Tls, BasicAuth, ExchangeServer

    Invece dovrebbe essere : AuthMechanism                           : BasicAuth

    > PermissionGroups                        : ExchangeUsers, ExchangeServers, ExchangeLegacyServers, Partners, Custom

    Invece dovrebbe essere: ExchangeUsers o al massimo anche AnonymousUsers

    Dopo aver configurato correttamente il connettore passa il seguente cmdlet:

    Get-ReceiveConnector MESA | Add-ADPermission -ExtendedRights:ms-Exch-SMTP-Accept-Any-Sender -user "NT AUTHORITY\Authenticated Users"


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    sabato 13 novembre 2010 19:22
  • Ok scusa per prima ma adesso ho fatto quello che dici e ora mi ritoran

    5.7.1. unable to relay

    Allego connettore

     

    RunspaceId                              : e4174229-9ce7-46ec-a643-b987c09317b1
    AuthMechanism                           : BasicAuth
    Banner                                  :
    BinaryMimeEnabled                       : True
    Bindings                                : {10.174.15.78:25}
    ChunkingEnabled                         : True
    DefaultDomain                           :
    DeliveryStatusNotificationEnabled       : True
    EightBitMimeEnabled                     : True
    DomainSecureEnabled                     : False
    EnhancedStatusCodesEnabled              : True
    LongAddressesEnabled                    : False
    OrarEnabled                             : False
    SuppressXAnonymousTls                   : False
    AdvertiseClientSettings                 : False
    Fqdn                                    : vm0210.XXXXXX.local
    Comment                                 :
    Enabled                                 : True
    ConnectionTimeout                       : 00:10:00
    ConnectionInactivityTimeout             : 00:05:00
    MessageRateLimit                        : unlimited
    MessageRateSource                       : IPAddress
    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 20
    MaxInboundConnectionPercentagePerSource : 2
    MaxHeaderSize                           : 64 KB (65,536 bytes)
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 10 MB (10,485,760 bytes)
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200
    PermissionGroups                        : AnonymousUsers, ExchangeUsers, Custom
    PipeliningEnabled                       : True
    ProtocolLoggingLevel                    : Verbose
    RemoteIPRanges                          : {10.174.15.78, 10.174.15.74}
    RequireEHLODomain                       : False
    RequireTLS                              : False
    EnableAuthGSSAPI                        : False
    LiveCredentialEnabled                   : False
    Server                                  : VM0210
    SizeEnabled                             : Enabled
    TarpitInterval                          : 00:00:05
    MaxAcknowledgementDelay                 : 00:00:30
    AdminDisplayName                        :
    ExchangeVersion                         : 0.1 (8.0.535.0)
    Name                                    : Mesa
    DistinguishedName                       : CN=Mesa,CN=SMTP Receive Connectors,CN=Protocols,CN=VM0210,CN=Servers,CN=Excha
                                              nge Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First
                                              Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=goldstores
                                              ,DC=local
    Identity                                : VM0210\Mesa
    Guid                                    : 390cbdb4-058c-4eea-847c-0d4bfd9b4423
    ObjectCategory                          : goldstores.local/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
    ObjectClass                             : {top, msExchSmtpReceiveConnector}
    WhenChanged                             : 13/11/2010 22:04:21
    WhenCreated                             : 03/11/2010 15:38:52
    WhenChangedUTC                          : 13/11/2010 21:04:21
    WhenCreatedUTC                          : 03/11/2010 14:38:52
    OrganizationId                          :
    OriginatingServer                       : vm0210.xxxxx.local
    IsValid                                 : True

     

     

    sabato 13 novembre 2010 21:12
  • Posta questi dati:

    IP del Server Exchange

    IP del sw che deve inviare

    Configurazione del SW che deve inviare. (se possibile screenshot)

    Prova a fare una sessione telnet sul server Exchange per testare le credenziali:

    http://www.andreagallazzi.com/2007/05/come-testare-il-servizio-smtp-simple.html


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    domenica 14 novembre 2010 09:14
  • ip se server:

    Configurazione IP di Windows

       Nome host . . . . . . . . . . . . . . : vm0210
       Suffisso DNS primario . . . . . . . . : xxxxx.local
       Tipo nodo . . . . . . . . . . . . . . : Ibrido
       Routing IP abilitato. . . . . . . . . : No
       Proxy WINS abilitato . . . . . . . .  : No
       Elenco di ricerca suffissi DNS. . . . : xxxxxx.local

    Scheda Ethernet Lan Interna:

       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Red Hat VirtIO Ethernet Adapter #2
       Indirizzo fisico. . . . . . . . . . . : 52-54-00-B1-15-63
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì
       Indirizzo IPv6 locale rispetto al collegamento . : fe80::59f7:a508:cb10:207e%16(Preferenziale)
       Indirizzo IPv4. . . . . . . . . . . . : 10.174.15.74(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.0
       Indirizzo IPv4. . . . . . . . . . . . : 10.174.15.78(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.0
       Gateway predefinito . . . . . . . . . : 10.174.15.77
       IAID DHCPv6 . . . . . . . . . . . : 441603072
       DUID Client DHCPv6. . . . . . . . : 00-01-00-01-13-C3-60-04-54-52-00-4C-6B-AB
       Server DNS . . . . . . . . . . . . .  : 10.174.15.74
       NetBIOS su TCP/IP . . . . . . . . . . : Attivato

    Scheda Ethernet LAN Esterna:

       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Red Hat VirtIO Ethernet Adapter
       Indirizzo fisico. . . . . . . . . . . : 54-52-00-4C-6B-AB
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì
       Indirizzo IPv6 locale rispetto al collegamento . : fe80::593b:5e53:9a5c:e1a%11(Preferenziale)
       Indirizzo IPv4. . . . . . . . . . . . : 95.xxx.xxx.74(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.248
       Indirizzo IPv4. . . . . . . . . . . . : 95.xxx.xxx.75(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.248
       Indirizzo IPv4. . . . . . . . . . . . : 95.xxx.xxx.76(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.248
       Gateway predefinito . . . . . . . . . : 95.xxx.xxx.73
       IAID DHCPv6 . . . . . . . . . . . : 240407040
       DUID Client DHCPv6. . . . . . . . : 00-01-00-01-13-C3-60-04-54-52-00-4C-6B-AB
       Server DNS . . . . . . . . . . . . .  : ::1
                                               127.0.0.1
       NetBIOS su TCP/IP . . . . . . . . . . : Attivato

    Scheda Tunnel isatap.{721E772D-6449-4BC2-AE4D-57049F835AD2}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì

    Scheda Tunnel 6TO4 Adapter:

       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Scheda Microsoft 6to4
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì
       Indirizzo IPv6 . . . . . . . . . . . . . . . . . : 2002:5fae:f4a::5fae:f4a(Preferenziale)
       Indirizzo IPv6 . . . . . . . . . . . . . . . . . : 2002:5fae:f4b::5fae:f4b(Preferenziale)
       Indirizzo IPv6 . . . . . . . . . . . . . . . . . : 2002:5fae:f4c::5fae:f4c(Preferenziale)
       Gateway predefinito . . . . . . . . . : 2002:c058:6301::c058:6301
       Server DNS . . . . . . . . . . . . .  : ::1
                                               127.0.0.1
       NetBIOS su TCP/IP . . . . . . . . . . : Disattivato

    Scheda Tunnel Teredo Tunneling Pseudo-Interface:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì

    Scheda Tunnel isatap.{9A133F2D-C466-4D90-9444-2C33D2628C54}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter #3
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì

     

     

    Il connettore ascolta su ip  10.174.15.78:25

    Il programma è sul server stesso e come parametri offre server,user e pwd.

    Inserndo un smtp esterno con auth basic funziona regolarmente ma inserndo come server 10.174.15.78 e user e password quelle di administrator ad esempio mi dice che non riesce a fare relay.

    Provando con telnet funziona perfettamente anche avendo abilitato anonymous funziona bene (sempre con telnet)

    martedì 16 novembre 2010 16:53
  • Se con telnet funziona a questo punto non è più un problema di Exchange Server.

    Prova ad inserire le credenziali nel formato  dominio\user. Se non dovessi risolvere abilita il protocol logging sul connettore e analizza i logs. 

    http://technet.microsoft.com/en-us/library/aa997624.aspx

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    martedì 16 novembre 2010 17:19
  • Ciao Giovanni,

    Non ho ricevuto alcun aggiornamento e mi chiedo se posso aiutarti ulteriormente o se il problema è stato risolto. Se così fosse ti prego di fornirci il tuo feedback ricordantoti che in questo thread è stato investito molto tempo e che sarebbe davvero utlile per tutta la community se potessimo arrivare ad una conclusione.

    Certo della tua comprensione, ti ringrazio per la tua partecipazione nel Forum di Exchange Server.

    A presto


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    domenica 28 novembre 2010 21:13
  • Se inserisco nella configurazione del gestionale un smtp esterno con autenticazione funziona benissimo.

    Se continuo ad utilizzare come smtp exchange 2010 ho questi errori

    Purtroppo sono arrivato ad un vicolo cieco e non posso dare che colpa (per mia incapacità ) ad exchange, in quanto dopo aver fatto quelle modifiche da te suggerite non riesco a creare un open relay vincolato all'indirizzo ip sorgente.

    ricapitolando

    il gestionale tramite un account smtp esterno funziona

    Il gestionale tramite smtp exchange non funziona

    Da telnet funziona invio con exchange

    uhmmmm. non so spiegarmi perchè

     

    domenica 28 novembre 2010 21:40
  • Un chiarimento ..

    Dal gestionale puoi settare un smtp senza autenticazione?


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    domenica 28 novembre 2010 21:44
  • Posso provare a non specificare user e pwd ma non so se funziona...se mi puoi indicare un smtp esterno che non accetta più autenticazioni ci provo
    domenica 28 novembre 2010 21:49
  • Fai questi test:

    Passa questo comando in EMS:

    Get-ReceiveConnector MESA | Add-ADPermission -ExtendedRights:ms-Exch-SMTP-Accept-Any-Sender -user "NT AUTHORITY\ANONYMOUS LOGON"

    Prova a settare il gestionale con e senza autenticazione. Verifica se una delle 2 configurazioni lavora correttamente.

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    domenica 28 novembre 2010 22:02