none
vpn RRS feed

  • Domanda

  • Salve a tutti vorrei chiedervi un aiuto sperando di non essere ot,
    Ho un server win 2008 con i servizi radius per permettere accessi vpn alla ns sede, i client utilizzano pptp , tutto funziona regolarmente ad eccezione di internet, nel senso che quando il client si connette alla vpn non riesce ad usare internet sul suo pc a causa della vpn, volevo chiedervi dove si setta per permettere al client vpn quando è connesso di usare internet senza passare per il tunnel vpn?

    Grazie...

    venerdì 9 marzo 2018 09:56

Risposte

  • Non capisco per quale motivo il suggerimento di  Marco non funzioni o quello di Alessandro (che è lo stesso di Marco :). Potresti fare una prova con delle route statiche:

    appena connesso in vpn setti la navigazione internet  nella lan locale e con il secondo comando la navigazione verso il vpn

    ROUTE ADD 0.0.0.0  MASK 0.0.0.0  ip-default-gateway-lan 
    ROUTE ADD ip-assegnato-vpn MASK 255.255.255.0 0.0.0.0

    se non hai tante reti dietro il vpn puoi settare una route statica

    route ADD 192.168.123.0 MASK 255.255.255.0 ip-assegnato-vpn

    Prova i comandi non è una soluzione, se poi ci aggiungi un route print con e senza vpn
    cerchiamo di capire

    ciao Gas


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere



    venerdì 9 marzo 2018 18:47
    Moderatore
  • Grazie a tutti per l'aiuto,
    alla fine ho optato per:
    "usa gateway predefinito sulla rete remota" disable
    aggiunto rotta statica per la remote site

    Così funziona tutto.

    Saluti Francesco

    sabato 10 marzo 2018 13:43

Tutte le risposte

  • In gestioni schede

    Tasto destro proprietà sulla connessione vpn

    Networking

    Doppio click su ipv4

    Avanzate

    Use default gateway on remote network

    Cambialo come ti serve. Nel tuo caso disattivarlo .

    Marco

    venerdì 9 marzo 2018 10:02
  • Ciao Marco, grazie per l'attenzione
    ho provato ma così non raggiungo la lan...e nemmeno internet...

    venerdì 9 marzo 2018 11:14
  • Ok .

    Tu hai il 2008 per i servizi radius.

    Quindi ti autentichi sul gtw ok?

    Ma il problema si è  presentato sempre?


    venerdì 9 marzo 2018 11:43
  • Si é sempre stato così
    venerdì 9 marzo 2018 13:21
  • ciao, devi abilitare lo split tunnel. Prova a guardare qui.

    http://best-tech-articles.blogspot.it/2008/10/how-to-enable-split-tunneling-for-vpn.html

    A.

    venerdì 9 marzo 2018 14:07
    Moderatore
  • Ciao grazie...

    Ma se ho visto bene l'articolo é l'impostazione che ho già provato e descritta anche sopra...così facendo non raggiungo più la LAN aziendale e non riesco nemmeno a navigare

    venerdì 9 marzo 2018 15:07
  • Non capisco per quale motivo il suggerimento di  Marco non funzioni o quello di Alessandro (che è lo stesso di Marco :). Potresti fare una prova con delle route statiche:

    appena connesso in vpn setti la navigazione internet  nella lan locale e con il secondo comando la navigazione verso il vpn

    ROUTE ADD 0.0.0.0  MASK 0.0.0.0  ip-default-gateway-lan 
    ROUTE ADD ip-assegnato-vpn MASK 255.255.255.0 0.0.0.0

    se non hai tante reti dietro il vpn puoi settare una route statica

    route ADD 192.168.123.0 MASK 255.255.255.0 ip-assegnato-vpn

    Prova i comandi non è una soluzione, se poi ci aggiungi un route print con e senza vpn
    cerchiamo di capire

    ciao Gas


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere



    venerdì 9 marzo 2018 18:47
    Moderatore
  • Ciao Gastone grazie anche per l'attenzione,
    purtroppo neanche io capisco perchè :-(

    con vpn attiva e "usa gateway predefinito sulla rete remota" enable

    lan remota ok, internet ko

    trace verso google

    1 hop server vpn..

    resto persi

    route print

    ===========================================================================
    Route attive:
         Indirizzo rete             Mask          Gateway     Interfaccia Metrica
              0.0.0.0          0.0.0.0      192.168.1.1      192.168.1.9   4280
              0.0.0.0          0.0.0.0         On-link           10.10.1.55     46
          10.10.10.55      255.255.255.255         On-link       10.10.1.55    301
       ip pubblico sede    255.255.255.255      192.168.1.1      192.168.1.9   4281
            127.0.0.0        255.0.0.0         On-link         127.0.0.1   4556

    -----------------------------------------------------------------------

    con vpn attiva e "usa gateway predefinito sulla rete remota" disable

    lan remota ko, internet ok

    trace verso server lan interno

    1 hop modem di casa (192.168.1.1)

    resto ok

    route print

    ===========================================================================

    Route attive:
         Indirizzo rete             Mask          Gateway     Interfaccia Metrica
              0.0.0.0          0.0.0.0      192.168.1.1      192.168.1.9     55
             10.0.0.0        255.0.0.0      10.10.1.1      10.10.1.69     46
          10.10.1.69  255.255.255.255         On-link       10.10.1.69    301
       ip publico vpn  255.255.255.255      192.168.1.1      192.168.1.9     56
            127.0.0.0        255.0.0.0         On-link         127.0.0.1    331

    sabato 10 marzo 2018 10:05
  • Ok.

    Mi fai un get-remoteaccessradius sul server e posti 

    Marco 

    sabato 10 marzo 2018 10:25
  • Grazie a tutti per l'aiuto,
    alla fine ho optato per:
    "usa gateway predefinito sulla rete remota" disable
    aggiunto rotta statica per la remote site

    Così funziona tutto.

    Saluti Francesco

    sabato 10 marzo 2018 13:43