none
processo w3wp.exe (PID=xxxxxxxx). Richiesta WCF RRS feed

  • Domanda

  • Come da oggetto, dopo aver disabilitato i servizi exchange mi viene notificato con alta frequenza questo errore:

    Processo w3wp.exe (PID=xxxxx). Richiesta WCF (Get Servers for server.local) al servizio Topologia di Active Directory di Microsoft Exchange  sul server (TopologyClientTcpEndpoint (localhost)) non riuscita. Verificare che il servizio sia in esecuzione e che le porte di rete utilizzate dal servizio Topologia di Active Directory di Microsoft Exchange non siano bloccate da un firewall. La chiamata WCF è stata ritentata 3 volte. Dettagli errore 

     System.ServiceModel.EndpointNotFoundException: Impossibile connettersi a net.tcp://localhost:890/Microsoft.Exchange.Directory.TopologyService

    Capisco che l'application pool cerca la topologia, che ho fermato...come si può fermare questa segnalazione?

    mercoledì 13 novembre 2013 09:17

Risposte

  • Ciao,

    Negli ultimi tempi non ho seguito attentamente il forum perché sono perennemente in giro ma adesso vedo questo follow-up del tuo post per fermare i servizi di Exchange.

    Riassunto:

    Fase 1) Fermi tutti i servizi di Exchange mettendoli in disable (che equivale all'uso di una clava). Definirlo "La soluzione più veloce ed efficace" è come pensare di fare neurochirurgia con un machete.
    Fase 2) Data la prima clavata l'Event Viewer ti si riempie di errori. Pur sapendo che la causa del problema è stata la tua clava, decidi di risolvere la questione con un altro bel colpo (non si sa mai)

    L'approccio a colpi di mazza funzionava ai tempi delle crociate (o di Exchange 5.5).

    Visto che Exchange per ora non viene utilizzato..... non lo avresti dovuto installare.
    Se lo ha installato qualcun altro, fai sempre in tempo a disinstallarlo e a reinstallarlo quando avrai le risorse per farlo.

    Vi chiedo solo due cose:

    1) Non marcate il fermo dei servizi come una risposta perché:

    • Non lo è
    • Qualcuno potrebbe anche pensare di seguire l'idea

    2) Se quando deciderai di far ripartire i servizi ti si riempirà di nuovo l'event viewer di errori, specifica di aver seguito questa procedura così almeno avremo idea di dove cominciare a fare troubleshooting.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    • Proposto come risposta Fabrizio-GMVP lunedì 18 novembre 2013 15:28
    • Contrassegnato come risposta Anca Popa martedì 19 novembre 2013 09:09
    lunedì 18 novembre 2013 00:35

Tutte le risposte

  • Se tu hai messo in disable solo MSExchangeADTopology, gli altri servizi che hanno una dipendenza tentano di avviarlo e danno errore, per ovviare devi mettere in disable tutti i servizi Exchange.

    Roberto


    Roberto Ferazzi

    IT Consultant | Microsoft MCTS MCITP MCSA MCSE MCT | http://www.ferazzi.it

    If you found my post helpful, please give it a Helpful vote

    If it answered your question, remember to mark it as an Answer

    mercoledì 13 novembre 2013 09:40
    Moderatore
  • Si infatti tutti gli altri sono in disable ovviamente.

    Ho arrestato il pool IIS relativo al default website (quello che contiene exchange) e l'errore non viene più notificato.

    Evidentemente il servizio web cerca exchange a livello di AD, non lo trova e segnala errore.

    Cosa ne pensi?

    mercoledì 13 novembre 2013 09:49
  • Si infatti tutti gli altri sono in disable ovviamente.

    Ho arrestato il pool IIS relativo al default website (quello che contiene exchange) e l'errore non viene più notificato.

    Evidentemente il servizio web cerca exchange a livello di AD, non lo trova e segnala errore.

    Cosa ne pensi?

    Confermo che gli eventi non vengono notificati arrestando il default web site front end di Exchange.

    venerdì 15 novembre 2013 08:32
  • Ciao,

    Negli ultimi tempi non ho seguito attentamente il forum perché sono perennemente in giro ma adesso vedo questo follow-up del tuo post per fermare i servizi di Exchange.

    Riassunto:

    Fase 1) Fermi tutti i servizi di Exchange mettendoli in disable (che equivale all'uso di una clava). Definirlo "La soluzione più veloce ed efficace" è come pensare di fare neurochirurgia con un machete.
    Fase 2) Data la prima clavata l'Event Viewer ti si riempie di errori. Pur sapendo che la causa del problema è stata la tua clava, decidi di risolvere la questione con un altro bel colpo (non si sa mai)

    L'approccio a colpi di mazza funzionava ai tempi delle crociate (o di Exchange 5.5).

    Visto che Exchange per ora non viene utilizzato..... non lo avresti dovuto installare.
    Se lo ha installato qualcun altro, fai sempre in tempo a disinstallarlo e a reinstallarlo quando avrai le risorse per farlo.

    Vi chiedo solo due cose:

    1) Non marcate il fermo dei servizi come una risposta perché:

    • Non lo è
    • Qualcuno potrebbe anche pensare di seguire l'idea

    2) Se quando deciderai di far ripartire i servizi ti si riempirà di nuovo l'event viewer di errori, specifica di aver seguito questa procedura così almeno avremo idea di dove cominciare a fare troubleshooting.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    • Proposto come risposta Fabrizio-GMVP lunedì 18 novembre 2013 15:28
    • Contrassegnato come risposta Anca Popa martedì 19 novembre 2013 09:09
    lunedì 18 novembre 2013 00:35
  • Gabriele buongiorno,

    In una piccola organizzazione che , temporaneamente, può fare a meno di exchange la soluzione di stoppare i servizi partendo dal topology, e poi lasciarli in disable, a parte il mark come risposta a me è sembrata la più razionale.

    A prescindere dallo spostamento infrastrutturale , permaneva l'errore 1005 (http://social.technet.microsoft.com/Forums/it-IT/exchangeit/thread/c3d0308d-4597-4de3-8912-8a6b7883fb09/#dd5123e4-8ce9-40b0-94e1-97f3f9141450 ) ancora irrisolto e che la disabilitazione dell' IPV6 non ha per nulla contribuito a risolvere. 

    Sarebbe stato meglio un manteinance mode, a tuo avviso?

    Grazie. Lucio

    martedì 3 dicembre 2013 12:23