none
Errore con PHP RRS feed

Risposte

Tutte le risposte

  • Se esegui php-cgi.exe da un prompt di dos funziona o ti riporta qualche errore?

    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    martedì 13 dicembre 2016 14:08
    Moderatore
  • Anch'io proverei ad eseguire l'applicazione da un prompt dei comandi come consigliato da Gastone.

    martedì 13 dicembre 2016 14:20
    Moderatore
  • se lancio il comando ricevo 

    provo a scaricare Visual C++ Redistributable for Visual Studio 2012 Update 4?

    martedì 13 dicembre 2016 14:34
  • L'hai lanciato dalla console del server, giusto? Se si, installa questo runtime:

    https://www.microsoft.com/it-it/download/details.aspx?id=30679


    martedì 13 dicembre 2016 14:38
    Moderatore
  • mi da errore, ecco il log:

    [31C4:1EB8][2016-12-13T15:39:43]: Burn v3.6.3542.0, Windows v6.3 (Build 9600: Service Pack 0), path: C:\Users\Administrator.TECNOVIDA\Downloads\vcredist_x64.exe, cmdline: '-burn.unelevated BurnPipe.{AD4008F9-1530-4839-8908-09D38BF3019A} {4C52ACA3-E596-44C0-A7C0-709E6CE6010B} 13284'
    [31C4:1EB8][2016-12-13T15:39:43]: Setting string variable 'WixBundleLog' to value 'C:\Users\ADMINI~1.TEC\AppData\Local\Temp\dd_vcredist_amd64_20161213153943.log'
    [31C4:1EB8][2016-12-13T15:39:43]: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\Administrator.TECNOVIDA\Downloads\vcredist_x64.exe'
    [31C4:1EB8][2016-12-13T15:39:44]: Setting string variable 'WixBundleName' to value 'Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030'
    [31C4:1EB8][2016-12-13T15:39:44]: Detect 2 packages
    [31C4:1EB8][2016-12-13T15:39:44]: Detected package: vcRuntimeMinimum_x64, state: Absent, cached: None
    [31C4:1EB8][2016-12-13T15:39:44]: Detected package: vcRuntimeAdditional_x64, state: Absent, cached: None
    [31C4:1EB8][2016-12-13T15:39:44]: Condition 'VersionNT64 >= v6.0 OR (VersionNT64 = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
    [31C4:1EB8][2016-12-13T15:39:44]: Detect complete, result: 0x0
    [31C4:1EB8][2016-12-13T15:39:45]: Plan 2 packages, action: Install
    [31C4:1EB8][2016-12-13T15:39:45]: Condition 'VersionNT64 AND (VersionNT > v6.2 OR (VersionNT = v6.2 AND (NTProductType = 1)) OR (VersionNT = v6.2 AND NOT (NTProductType = 1)) OR (VersionNT = v6.0 AND NOT (NTProductType = 1)) OR (VersionNT = v6.1 AND (NTProductType = 1)) OR (VersionNT = v6.1 AND NOT (NTProductType = 1)) OR (VersionNT = v6.0 AND (NTProductType = 1)) OR (VersionNT = v5.1) OR (VersionNT = v5.2 AND NOT (NTProductType = 1)) OR (VersionNT = v5.2 AND (NTProductType = 1)))' evaluates to true.
    [31C4:1EB8][2016-12-13T15:39:45]: Setting string variable 'WixBundleRollbackLog_vcRuntimeMinimum_x64' to value 'C:\Users\ADMINI~1.TEC\AppData\Local\Temp\dd_vcredist_amd64_20161213153943_0_vcRuntimeMinimum_x64_rollback.log'
    [31C4:1EB8][2016-12-13T15:39:45]: Setting string variable 'WixBundleLog_vcRuntimeMinimum_x64' to value 'C:\Users\ADMINI~1.TEC\AppData\Local\Temp\dd_vcredist_amd64_20161213153943_0_vcRuntimeMinimum_x64.log'
    [31C4:1EB8][2016-12-13T15:39:45]: Condition 'VersionNT64 AND (VersionNT > v6.2 OR (VersionNT = v6.2 AND (NTProductType = 1)) OR (VersionNT = v6.2 AND NOT (NTProductType = 1)) OR (VersionNT = v6.0 AND NOT (NTProductType = 1)) OR (VersionNT = v6.1 AND (NTProductType = 1)) OR (VersionNT = v6.1 AND NOT (NTProductType = 1)) OR (VersionNT = v6.0 AND (NTProductType = 1)) OR (VersionNT = v5.1) OR (VersionNT = v5.2 AND NOT (NTProductType = 1)) OR (VersionNT = v5.2 AND (NTProductType = 1)))' evaluates to true.
    [31C4:1EB8][2016-12-13T15:39:45]: Setting string variable 'WixBundleRollbackLog_vcRuntimeAdditional_x64' to value 'C:\Users\ADMINI~1.TEC\AppData\Local\Temp\dd_vcredist_amd64_20161213153943_1_vcRuntimeAdditional_x64_rollback.log'
    [31C4:1EB8][2016-12-13T15:39:45]: Setting string variable 'WixBundleLog_vcRuntimeAdditional_x64' to value 'C:\Users\ADMINI~1.TEC\AppData\Local\Temp\dd_vcredist_amd64_20161213153943_1_vcRuntimeAdditional_x64.log'
    [31C4:1EB8][2016-12-13T15:39:45]: Planned package: vcRuntimeMinimum_x64, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
    [31C4:1EB8][2016-12-13T15:39:45]: Planned package: vcRuntimeAdditional_x64, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
    [31C4:1EB8][2016-12-13T15:39:45]: Plan complete, result: 0x0
    [31C4:1EB8][2016-12-13T15:39:45]: Apply begin
    [33E4:1A64][2016-12-13T15:39:53]: Creating a system restore point.
    [33E4:1A64][2016-12-13T15:39:53]: System restore disabled, system restore point not created.
    [33E4:1A64][2016-12-13T15:39:53]: Caching bundle from: 'C:\Users\ADMINI~1.TEC\AppData\Local\Temp\1\{d61ab584-9b0a-404e-8a23-76032e6744c0}\.be\vcredist_x64.exe' to: 'C:\ProgramData\Package Cache\{d61ab584-9b0a-404e-8a23-76032e6744c0}\vcredist_x64.exe'
    [33E4:1A64][2016-12-13T15:39:59]: Error 0x80070005: Failed to cache bundle from: 'C:\Users\ADMINI~1.TEC\AppData\Local\Temp\1\{d61ab584-9b0a-404e-8a23-76032e6744c0}\.be\vcredist_x64.exe' to 'C:\ProgramData\Package Cache\{d61ab584-9b0a-404e-8a23-76032e6744c0}\vcredist_x64.exe'
    [33E4:1A64][2016-12-13T15:39:59]: Error 0x80070005: Failed to cache bundle from path: C:\Users\ADMINI~1.TEC\AppData\Local\Temp\1\{d61ab584-9b0a-404e-8a23-76032e6744c0}\.be\vcredist_x64.exe
    [33E4:1A64][2016-12-13T15:39:59]: Error 0x80070005: Failed to begin registration session.
    [31C4:1EB8][2016-12-13T15:39:59]: Error 0x80070005: Failed to begin registration session in per-machine process.
    [31C4:1EB8][2016-12-13T15:39:59]: Error 0x80070005: Failed to register bundle.
    [31C4:1EB8][2016-12-13T15:39:59]: Apply complete, result: 0x80070005, restart: None, ba requested restart:  No
    

    martedì 13 dicembre 2016 14:59
  • Ti trovi sul server giusto? Lo stai installando con privilegi amministrativi?
    Se hai software antivirus di terze parti installati, disinstallali momentaneamente.
    martedì 13 dicembre 2016 15:17
    Moderatore
  • si alle prime due e non ho antivirus attivi di terze parti. provo con un riavvio?
    martedì 13 dicembre 2016 15:38
  • Prova a eliminare tutti  file temporanei e a riavviare il server. L'installer non riesce a copiare dalla cartella temporanea al percorso Package Cache.
    martedì 13 dicembre 2016 16:59
    Moderatore
  • Ciao Andrea

    • che versione di php hai installato ?
    • 7.1?
    •  E' a 32 o 64 bit ?

    http://serverfault.com/questions/517694/cant-start-php-cgi-exe-msvcr110-dll-is-missing


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    martedì 13 dicembre 2016 21:33
    Moderatore
  • ho installato non la 7.1 perchè mi pare di aver visto un avviso che la data come instabile. 

    Ho installato questa: 

    venerdì 30 dicembre 2016 11:56
  • Hai utilizzato direttamente il Web Platform Installer oppure hai fatto manualmente?
    venerdì 30 dicembre 2016 13:52
    Moderatore
  • ho usato il WPI
    venerdì 30 dicembre 2016 15:32
  • La versione 7.1 di php è "stable"!

    Se non hai vincoli di applicativi che richiedano per forza una 5.6.x ti consiglio di optare per la versione 7.1


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    • Contrassegnato come risposta andrea vironda lunedì 9 gennaio 2017 08:12
    venerdì 30 dicembre 2016 22:13
    Moderatore