none
AutoDiscover non dunziona solo su alcuni utenti - impossibile trovare il nome. non è stato trovato un nome corrispondente nell'elenco indirizzi RRS feed

  • Domanda

  • Ciao,

    in una organizzazione exchange 2007 riesco correttamente ad utilizzare l' AutoDiscover  quando configuro un client outlook.

    su un  piccola percentuale di utenti (in particolare qulli delegati a ruoli di amministrazione o manutenzione) l' AutoDiscover  non funziona.

    se inserisco il nome del server e il nome utente clicco su controlla nome mi restituisce l'errore "impossibile trovare il nome. non è stato trovato un nome corrispondente nell'elenco indirizzi"

    ho gia verificato che l'utente non sia nascosto nell'elenco indirizzi: il flag non è presente ma l'indirizzo non compare comunque nella GAL.

    ho gia verificato questo articolo e non ci sono errori > http://support.microsoft.com/kb/297801/en-us

    l'account sta gia lavorando su un'atro pc configurato quindi direi che non ci sono problemi di password o di abilitazione alla posta o di permessi.

    sapete suggerirmi cosa altro controllare??

    -------------------------------------

    update: mi sembra di aver notato che se sposto l'utente in una OU diversa e aggiorno la GAL l'utente viene visualizzato.

    cosa puo essere ad influire a livello di OU di AD?

    venerdì 6 aprile 2012 09:22

Tutte le risposte

  • Anche usando il nome UPN?


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.

    si, stesso problema

    temo si tratti veramente di un problema di visualizzazione: l'utente non è visibile nelle GAL ma non riesco a capire come mai...


    venerdì 6 aprile 2012 12:59
  • update: mi sembra di aver notato che se sposto l'utente in una OU diversa e aggiorno la GAL l'utente viene visualizzato.

    cosa puo essere ad influire a livello di OU di AD?

    Ciao Bon Re,

    Se posso permettermi un suggerimento, associandomi ad Andrea, penso che un dump LDP dell'utente che non è visibile nella GAL potrebbe essere comparato con un dump degli altri utenti che sono visibili.

    Ti giro questo se non dovessi già conoscerlo: Using Ldp.exe to Find Data in the Active Directory

    Avevi anche provato con ExBPA?


    Anca Popa Follow ForumTechNetIt on Twitter

    La Conferenza Italiana sulla Virtualizzazione

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    mercoledì 11 aprile 2012 09:17
  • update: ho notato che se sposto l'utente in una OU diversa e aggiorno la GAL l'utente viene visualizzato.

    cosa puo essere ad influire a livello di OU di AD?

    mercoledì 18 aprile 2012 10:10
  • Ciao,

    Messa così mi verrebbero da dire 2 cose:

    1. La OU dove si trova l'utente quando la GAL non si aggiorna non ha i permessi corretti. Vai sulle proprietà e prova ad abilitare l'ereditrarietà dei permessi se non c'è già
    2. Il filtro associato alla GAL non include gli oggetti in quella OU (Estremamente improbabile). Se vieni da un'Organizzazione 2003 hai aggironato i filtri della GAL come da http://blogs.technet.com/b/exchange/archive/2007/01/11/3397719.aspx ?

    Se vuoi provare ad avere maggiori dettagli sui problemi di generazione della GAL abilita il Diagnostic Logging sul server che la dovrebbe generare.

    I counter da abilitare sono tutti quelli in MSExchangeAL a Maximum

    Dopo averlo fatto apri l'Exchange Management shell ed esegui il seguente cmdlet:

    get-globaladdresslist | update-globaladdresslist

    Probabilmente di GAL ne hai solo una ma così andiamo sul sicuro.

    Dopodichè armati di pazienza e leggiti l'infinità di eventi generati nell'Application log. Ci dovrebbero essere dei warning/errori relativi agli utenti incriminati.

    Ciao

    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"

    • Proposto come risposta Anca Popa mercoledì 2 maggio 2012 12:07
    martedì 1 maggio 2012 12:10
  • ciao,

    per escludere la seconda ipotesi già tempo fa avevo creato una nuova GAL senza nessun tipo di esclusioni (ovvero che includesse tutti gli indirizzi).

    in effetti ho verificato le permission sulle OU e su quella "strana" e c'è qualche piccola differenza: mancano il gruppo everyone e enterprise domain controller.

    potrebbe essere questo?

    mercoledì 2 maggio 2012 07:01
  • Se il serivizio che aggiorna la GAL non riesce ad accedere alla OU allora non può neanche aggiungere gli oggetti alla GAL.

    Prova ad abilitare l'ereditarietà dei permessi sulla OU

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"

    giovedì 3 maggio 2012 18:40