none
Gestione remota Windows : impossibile elaborare la richiesta. RRS feed

  • Domanda

  • Buongiorno a tutti,

    ho uno stranissimo problema con la gestione remota di un Hyper-V Server 2012 : da un client con windows 10 pro non riesco ad accedere!!

    Descrivo lo scenario completo : la macchina server fa parte di un gruppo di lavoro mentre i client fanno parte di un dominio, ho aggiunto entrambi i client come TrustedHosts nel winrm del server ma dal vecchio pc con windows 8.1 riesco ad accedere senza problemi mentre dal nuovo pc con windows 10 niente da fare, non riesco a gestire nemmeno il servizio di hypervisor.

    Ho appena scoperto che aggiungendo il pc al server manager installato sul client windows 10 si ottiene questo errore :

    "Errore    TX300S6: aggiornamento della configurazione non riuscito con l'errore seguente: Impossibile recuperare i metadati dal server a causa dell'errore seguente: Gestione remota Windows: impossibile elaborare la richiesta. Si è verificato l'errore seguente durante l'utilizzo dell'autenticazione Kerberos: impossibile trovare il computer TX300S6. Verificare che il computer esista nella rete e che il nome specificato sia digitato in modo corretto."

    ...eppure il server (TX300S6) è raggiungibilissimo dal client in questione e riesco ad utilizzarlo in desktop remoto.

    Grazie

    lunedì 16 maggio 2016 13:13

Risposte

Tutte le risposte

  • quali errori trovi nel registro eventi del client nel momento in cui tenti l'operazione ?

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    lunedì 16 maggio 2016 13:28
    Moderatore
  • Ti direi nessun errore nei registri di windows del client...se sai dirmi in quale registro "applicazione e servizi" in particolare devo controllare ti aggiorno
    lunedì 16 maggio 2016 14:05
  • Una precisazione : dal client windows 10 in questione uso server manager per gestire i due server 2008 r2 dello stesso dominio.
    lunedì 16 maggio 2016 14:13
  • da questo articolo

    https://technet.microsoft.com/it-it/library/ms156468%28v=sql.105%29.aspx?f=255&MSPPError=-2147217396

    e dalla mia esperienza ricordo che la console di gestione di hyper-v va in esecuzione nel contesto di sicurezza dell'account NT AUTHORITY\NETWORK SERVICE, account al quale va garantito l'accesso ad una macchina della rete qualora ad esempio si vogliano creare i dischi virtuali su altra macchina della rete che sia fuori dominio.

    questo account si presenta all'esterno con la denominazione "dominio\nomepc$" ed è a questo account che bisogna consentire l'accesso esplicito al server hyper-v.


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    lunedì 16 maggio 2016 14:31
    Moderatore
  • Solitamente se server e client si trovano in domini/workgroup diversi ci possono essere parecchi problemi per la gestione remota. Ti consiglio comunque di provare ad utilizzare anche HVRemote per eseguire la configurazione, penso che possa aiutare: https://code.msdn.microsoft.com/windowsdesktop/Hyper-V-Remote-Management-26d127c6
    lunedì 16 maggio 2016 14:33
    Moderatore
  • Grazie ad entrambi,

    hvremote l'ho già utilizzato inizialmente per configurare il server e con il client 8.1 infatti nessun problema, purtroppo non mi risolve il problema con win 10 anche perchè da un warning di compatibilità (in effetti w10 non è supportato, magari il problema è solo quello anche se mi sembra strano gestire i win2008 e non i 2012)

    Ho anche provato hvremote /show /target:TX300S6 su entrambi i client ma i risultati sono gli stessi, tutti i test passati

    Scusami Edoardo ma su windows 8.1 non ho dovuto fare nulla del genere...senza contare che non capisco in pratica cosa dovrei fare.

    lunedì 16 maggio 2016 15:30
  • Si, sapevo che lo script non era ancora ufficialmente supportato su Windows 10 ma ricordavo di averlo usato in passato (per sicurezza, stai utilizzando l'ultima versione?). Sicuramente avrai già verificato, ma la risoluzione del nome per TX300S6 è corretta? Hai eseguito anche "winrm quickconfig" sulla macchina remota?
    lunedì 16 maggio 2016 16:12
    Moderatore