locked
Autenticazione Samba con Windows 7 RRS feed

  • Domanda

  • Ciao a tutti!

    La rete della mia azienda utilizza, per l'autenticazione, un server Linux su cui gira il servizio Samba versione 3.4.2 con Winbind. Da quando ho installato Windows 7, posso effettuare il logon al dominio, ma non riesco più ad accedere agli share Samba. Mi vengono richiesti nome utente e password, ma qualunque valore inserisco, l'accesso non avviene. Le altre macchine della rete, con Windows XP, 2000, 2003 Server oppure Windows Vista riescono ad effettuare l'accesso senza problemi.

    Quale potrebbe essere la causa del problema?
    Marco Minerva, marco.minerva@gmail.com
    mercoledì 13 gennaio 2010 09:43

Risposte

  • La procedura l'ho provata sulle due versioni e mi da accesso tranquillamente.

    Prova a seguire qui:

    http://wiki.samba.org/index.php/Windows7

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    mercoledì 13 gennaio 2010 10:59
    Moderatore
  • Noi usiamo (per quel poco perchè il sistema principale è tutt'altro) la 3.4.4
    Penso che se poi passi ancora da un server 2003 per l'autenticazione allora la cosa diventa più complessa.
    Infatti mi pareva che le procedure fossero corrette.
    Devi autorizzare anche lì'.
    Ciao

    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    mercoledì 13 gennaio 2010 11:17
    Moderatore

Tutte le risposte

  • Windows 7 Home Premium:

    Start , digita regedit e apri il registro. 
    Vai alla chiave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    In  "Lsa" clicca destro nello spazio bianco a destra e crea una nuova chiave di registro DWORD 32bit (se 32 bit) e DWORD 64bit (se 64 bit).
    Rinomina la nuova chiave:
    LmCompatibilityLevel e dopo averla rinominata bicliccala ed inserisci il valore 1.
    Chiudi il registro e prova l'accesso.

    Windows 7 Professional e Ultimate:

    Start, digita:
    secpol.msc
    Clicca destro sull’icona del programma che apparirà in alto e seleziona Esegui come amministratore.
    Apri la sezione Criteri locali -> Opzioni di sicurezza 
    Biclicca su Sicurezza di rete: livello di autenticazione di LAN Manager e seleziona Invia LM e NTLM; usa sicurezza sessione NTLMv2 se negoziata.
    Biclicca su Sicurezza di rete: sicurezza sessione minima per client basati su NTLM SSP (incluso l’RPC sicuro) e togli la spunta alla voce Richiedi crittografia a 128 bit.
    Chiudi il registro e prova l'accesso.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    mercoledì 13 gennaio 2010 09:58
    Moderatore
  • Ciao!

    Grazie per la veloce risposta, ma purtroppo ho provato su due diverse macchine con Windows 7 Ultimate (sia a 32 sia a 64 bit), e su nessuna delle due la procedura che hai segnalato funziona (non è cambiato niente rispetto a prima, è come se le modifiche non avessero portato effetto, neanche dopo un riavvio della macchina).

    Hai altre idee? Sai se ci sono dei log da consultare in Windows, per avere maggiori dettagli sul problema? Mi sembra che nel Visualizzatore Eventi di Windows non ci siano informazioni a riguardo.
    Marco Minerva, marco.minerva@gmail.com
    mercoledì 13 gennaio 2010 10:38
  • La procedura l'ho provata sulle due versioni e mi da accesso tranquillamente.

    Prova a seguire qui:

    http://wiki.samba.org/index.php/Windows7

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    mercoledì 13 gennaio 2010 10:59
    Moderatore
  • Che versione di Samba stai usando? Io ho la 3.4.2 con Winbind, perché il server Linux utilizza a sua volta un server Windows 2003 per effettuare l'autenticazione dell'utente. Forse è questo ultimo particolare che causa il problema?


    Marco Minerva, marco.minerva@gmail.com
    mercoledì 13 gennaio 2010 11:12
  • Noi usiamo (per quel poco perchè il sistema principale è tutt'altro) la 3.4.4
    Penso che se poi passi ancora da un server 2003 per l'autenticazione allora la cosa diventa più complessa.
    Infatti mi pareva che le procedure fossero corrette.
    Devi autorizzare anche lì'.
    Ciao

    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    mercoledì 13 gennaio 2010 11:17
    Moderatore
  • Puoi essere più preciso quando dici che devo autorizzare anche lì? Perché per abilitare l'autenticazione sugli altri sistemi (XP, Server 2003, 2000, Vista), non sono state necessarie modifiche sul server che gestisce l'autenticazione vera e propria.


    Marco Minerva, marco.minerva@gmail.com
    mercoledì 13 gennaio 2010 11:56
  • Le modifiche su Windows 7 che occorreva fare te lo ho segnalate.
    E' probabile che la gestione dell'autenticazione non sia settata , sul server , con il corretto identificativo del pc con Windows 7.
    Ciao

    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    mercoledì 13 gennaio 2010 12:04
    Moderatore
  • Ciao!

    Alla fine il problema era legato alla versione di Samba: dopo l'aggiornamento alla versione 3.4.3 sul server, funziona tutto correttamente. Grazie per il supporto :-)
    Marco Minerva, marco.minerva@gmail.com
    mercoledì 20 gennaio 2010 08:25
  • Infatti le impostazioni le avevo testate sulla 3.4.4
    Sempre benvenuto.
    Ciao

    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    mercoledì 20 gennaio 2010 09:10
    Moderatore
  • Salve, piu' o meno ho anche io lo stesso problema di condivisione col protocollo samba.

    Ho varie macchine in rete dove è istallato xp o vista e tutte riescono ad accedere e a condividere i files con dei Network MediaPlayer tranne quella dove è istallato 7 versione 32 bit.

    Mi chiedevo se è possibile portare la versione di samba istallata in 7 alla precedente (Come quella istallata su vista o xp)

    giovedì 15 aprile 2010 12:58
  • Dopo settimane di prove purtroppo la conclusione è che Windows 7 non è compatibile con i media center e i dischi NAS, dove non si può installare l'ultima versione di Samba. Per la verità non è compatibile nemmeno con l'ultima versione di Samba (non la 4, quella prima) perchè se metti Windows 7 in rete con linux e Samba, Windows 7 va in crash con schermata blu. E senza fare nulla, basta metterlo attaccato al cavo di rete.

    Ho provato con almeno quattro versioni di ubuntu e samba e con almeno 4 diversi hardware per Windows 7 a 64 bit.

    Credo sia un problema noto, dato che capita a moltissimi. Tu Franco lo saprai certamente...

     

    lunedì 3 maggio 2010 23:22
  • Ciao a tutti

     

    sono appena giunto qui perchè ho bisogno di risolvere un problema con il mio Win 7 64 HomePremium. Ho letto tutto ma alla fine non sono riuscito a risolvere nulla. Io posseggo 2 PC in uno è installato win xp e nell'altro Win 7 64HomeP. In win xp e win 7 ho creato il gruppo casa e attraverso un router ( alice gate 2 wifi) sono collegati via cavo, si vedono e in win xp ho creato delle condivisioni a 2 Hard disk e poi l'unità di rete e non ci sono problemi, ho avuto dei problmi da win xp a win 7 ma utilizzo anche VNC e total Commander per il collegamento e trasferimento dei file quindi non è un problema. Il vero ed unico problema sorge con il mio PCH A-110 ( Popcorn Hour), che ha sempre funzionato bene ma ora non riesce proprio ad entrare nel PC con SO win 7, lo vede ma quando tento di collegarmi mi dice nessun contenuto trovato , la cosa è diversa da win 7, che viene visualizzato correttamente in rete e riesco ad entrare nelle cartelle del PCH. Ho letto molte guide e alla fine sono giunto qui, ho provato a creare la nuova chiave ma niente, ho provato a condividere le cartelle o l'intero disco dando diritti di scrittura e lettura praticamente a tutti ma niente da fare il PCH mi restituisce sempre la solita risposta nessun contenuto trovato . Ho letto anche in giro per il web che la versione home premium non può fare questi tipi di collegamento ( mi pare talmente assurdo) quindi alla fine sono disperato non perchè ho una necessità impellente ma perchè non riesco a venirne a capo e capire il perchè di questo errore.

    Con xp mi sono trovato sempre abbastanza bene qualche crasch e alle volte ho dovuto reinstallare l'immagine salvata del sistema, ma alla fine lo conoscevo abbastanza in profondo. Quando ho installato win 7 mi aspettavo inizialmenti problemi di deversa natura driver incompatibilità e altro ancora, ma alla fine sono sempre riuscito a risolvere e cosa più importante il sistema non ha problemi è stabile e veloce, ha dei componenti integrati molto validi ( masterizzazione, creazione dell'immagine e altro ancora)

    Per concludere visto che mi sono dilungato molto spero che mi possiate rispondere anche se il post è vecchio cosi da risolvere il problema.

    Grazie infinite.

    martedì 18 gennaio 2011 12:07
  • Forse questa è la vostra soluzione:

    Con me ha funzionato.

    http://www.tannerwilliamson.com/2009/09/windows-7-seven-network-file-sharing-fix-samba-smb/

     

    Ciao,

    cesare

    lunedì 7 marzo 2011 11:07
  • Salve a tutti. Mi inserisco nella discussione per un problema similare. Ho 2 pc, un fisso Windows Seven Ultimate 64 bit e un portatile Windows XP Professional SP3 32 bit, correttamente connessi tra loro per la condivisione di files  in wi-fi tramite il "gruppo di lavoro". Con il tablet Andorid, però, usando la connessione samba, riesco ad accedere solamente al pc XP, mentre se provo ad accedere al PC Seven mi vengono richiesti username e password (anche se la connessione è anonima). Naturalmente ho provato a dare tutti gli username e password logicamente possibili, compresi quelli di rete e di accesso ai due pc, ma nessuna viene accettata e la connessione non avviene.  Ho provato ad eseguire le modifiche che sono illustrate nei link che avete indicato, ma non ho ottenuto nulla. Come app per il tablet, ho provato con Astro, con File Expert, Andsmb...... con tutte è la stessa cosa. Sapete aiutarmi? Grazie. Ciao.

    martedì 15 novembre 2011 16:32