locked
SBS2003 - Remote web workplace troubleshooting RRS feed

  • Domanda

  • Ciao a tutti,
    da qualche giorno non riesco più ad accedere a RWW di un SBS 2003 che ha sempre funzionato bene.

    In realtà ho problemi sia con RWW che con OWA.

    Accedo senza problemi al sito https://remote.miodominio.it/remote e https://remote.miodominio.it/exchange ma poi non posso fare nulla.

    Dopo aver inserito le credenziali e fatto l'accesso alla home page di RWW, scegliendo di accedere alla sezione SERVER mi compare questa schermata:

    In OWA invece, dopo aver inserito le credenziali, compare l'errore: "Errore HTTP 404 - Impossibile trovare il file o la directory.
    Internet Information Services (IIS)"

    Dato che un gestionale dell'azienda lamenta, ad ogni riavvio del server, che un servizio ASP non è partito (devo digitare da CMD il comando Aspnet_regiis.exe mi sorge il dubbio che sia qualche problema al framework (4?). Se così fosse come faccio a reinstallarlo? Dove lo scarico per SBS 2003?

    Potrebbero essere problemi sul firewall di SBS (che però è disabilitato)??

    NOTE:

    1) Da un qualsiasi PC della LAN si accede senza problemi al server con desktop remoto

    2) Il server ha tutti i service pack e aggiornamenti rilasciati.

     

    Grazie a chi mi può dare una mano, non ne vengo fuori!

     


    Lorenzo
    • Spostato Anca Popa martedì 10 gennaio 2012 08:40 spostato nel forum piu' appropriato (Da:Microsoft Windows Server Forum)
    domenica 8 gennaio 2012 20:41

Risposte

  • AGGIORNAMENTO:

    Ho controllato le impostazioni dei siti di IIS..

    Il server SBS 2003 "guasto" ha i siti "Sito web predefinito", "Exchange", "Remote" con impostato nella sezione ASPNET il framework 4.

    L'SBS 2003 "funzionante" ha i siti sopra riportati con ASPNET impostato con framework versione 1.1.4322.

    Potrei aver trovato il problema. Dato che non ho messo mano a queste impostazioni, o l'ha fatto l'installazione del framework 4 oppure chi gestisce il gestionale ha fatto qualche mossa errata.

    Non credo che questi valori cambino da soli.. correggimi se sbaglio.


    Lorenzo
    lunedì 9 gennaio 2012 09:42
  • Ciao,

    non ho avuto molto tempo per cercare di risolvere il problema poichè impegnato da altri clienti.. Il registro non riporta errori particolari, non so a questo punto come venirne fuori.

    Lo tengo così com'è e fine. L'idea che mi sono fatto è che il sistema RWW, una volta loggato, non riesca a "traslare" le richieste di desktop remoto al server/pc verso la porta 3389. E quindi si blocca.

    Non sono solito arrendermi ma non posso passare ore su un sistema ormai vetusto, quando sarà ora il cliente passerà ad un SBS più recente..

    Grazie cmq per l'aiuto ricevuto. Ciao


    Lorenzo
    sabato 21 gennaio 2012 12:16

Tutte le risposte

  • è altamente probabile che i problemi siano collegati ad un malfunzionamento di IIS o del framework.

    per capire però quale sia la causa devi cercare quali errori sono presenti nel registro eventi di quel server nelle sezioni system e application (in particolare se sono connessi al framework o ad iis ma anche eventualmente altri errori su cui hai dei dubbi) e li posti qui.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 9 gennaio 2012 08:05
    Moderatore
  • Ciao Edoardo,

    grazie per la risposta. In realtà ho scoperto che:

    1) il framework 4 è installato in Inglese su SBS in italiano (credo o abbia messo la ditta che ha installato il gestionale). Ho altri server con SBS 2003 e il framework 4 è in italiano. Potrebbe essere un'incompatibilità?

    2) contrariamente a quanto da me affermato ci sono 4-5 aggiornamenti da fare sui framework da windows update. Purtroppo devo aspettare qualche giorno poichè il cliente deve produrre una dichiarazione fiscale e non vorrei interromperlo.

    3) trovo diversi errori nel registro di system per l'avvio del gestionale che evidentemente ha problemi con il framework. Inoltre non so perchè il servizio SMTP (impostato su automatico) era fermo. L'ho dovuto far ripartire manualmente

    Puoi intanto dirmi cosa ne pensi dei punto 1) e 3)?

    Grazie mille, ciao!

     


    Lorenzo
    lunedì 9 gennaio 2012 09:29
  • AGGIORNAMENTO:

    Ho controllato le impostazioni dei siti di IIS..

    Il server SBS 2003 "guasto" ha i siti "Sito web predefinito", "Exchange", "Remote" con impostato nella sezione ASPNET il framework 4.

    L'SBS 2003 "funzionante" ha i siti sopra riportati con ASPNET impostato con framework versione 1.1.4322.

    Potrei aver trovato il problema. Dato che non ho messo mano a queste impostazioni, o l'ha fatto l'installazione del framework 4 oppure chi gestisce il gestionale ha fatto qualche mossa errata.

    Non credo che questi valori cambino da soli.. correggimi se sbaglio.


    Lorenzo
    lunedì 9 gennaio 2012 09:42
  • hai trovato il problema, cambia la versione del framework mettendo la 1.1 al posto della 4 e tutto tornerà a funzionare.

    ciao.

     


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 9 gennaio 2012 11:27
    Moderatore
  • Non ho risolto... Ora non riesco nemmeno ad accedere alla home page di RWW.

    Compare una pagina web con l'errore:

    Applicazione server non disponibile

    OWA invece ora funziona regolarmente con tanto di accesso alla cassetta postale..



    lunedì 9 gennaio 2012 14:01
  • come hai cambiato la versione del framework ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 9 gennaio 2012 14:11
    Moderatore
  • Sono andato nei vari siti sotto "sito Web predefinito" e alla sezione ASPNET ognuno ho cambiato il framework mettendo l'1.1.xxxx.

    Alla conferma mi ha chiesto se volevo aggiornare IIS subito o manualmente tramite riga di comando per non riavviare ed io ho confermato riavviando poi il server.

    Ora infatti in ognuno risulta correttamente il framework 1.

    Ho provato ad utilizzare l'utility configura accesso remoto da Gestione Server ma non è servita a niente.


    Lorenzo
    lunedì 9 gennaio 2012 14:16
  • e OWA ora ti funziona ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 9 gennaio 2012 14:23
    Moderatore
  • Si...
    Lorenzo
    lunedì 9 gennaio 2012 14:28
  • allora il problema rimasto riguarda qualcos'altro. ricontrolla il registro eventi e riporta qui gli errori.
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 9 gennaio 2012 15:01
    Moderatore
  • Ciao,

    Sposto il thread nella sezione Small Business Server intanto, perché mi sembra il Forum più attinente al thread.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Versioni di valutazione gratuite dei software Microsoft

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    martedì 10 gennaio 2012 08:39
  • Ciao,

    non ho avuto molto tempo per cercare di risolvere il problema poichè impegnato da altri clienti.. Il registro non riporta errori particolari, non so a questo punto come venirne fuori.

    Lo tengo così com'è e fine. L'idea che mi sono fatto è che il sistema RWW, una volta loggato, non riesca a "traslare" le richieste di desktop remoto al server/pc verso la porta 3389. E quindi si blocca.

    Non sono solito arrendermi ma non posso passare ore su un sistema ormai vetusto, quando sarà ora il cliente passerà ad un SBS più recente..

    Grazie cmq per l'aiuto ricevuto. Ciao


    Lorenzo
    sabato 21 gennaio 2012 12:16
  • Grazie di essere tornato sul Forum per aggiornare il thread, Lorenzo.

    Anca Popa Follow ForumTechNetIt on Twitter

    Versioni di valutazione gratuite dei software Microsoft

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    lunedì 23 gennaio 2012 08:50