none
Exchange 2010 SP1 - problema con autodiscovery RRS feed

  • Discussione generale

  • Ciao a tutti, sono in questa situazione:
    exchange 2010 Sp1 installato su 4 server distitni
    1° Mailbox
    2° HubTransport
    3° ClientAccess
    4° Edge (in dmz)
    tutti i server sono installati su windows 2008 R2 e fanno solo quello.
    il dominio è su un'altra macchina ed è un windows 2008 R2 nativo.
    è presente un'ulteriore macchina con TServer sempre 2008 R2.
    su tutti i client (tserver comrpeso) è installato outlook 2007 (completamente aggiornato)
    tutti i client dono in DHCP

    configurando un nuovo pc viene correttamente rilevato il server (client access) e configurato l'account.

    su alcune macchine piu vecchie però ed in particolare sul Tserver configurando un nuovo profilo utente, l'autodiscover di outlook mi fa puntare sul server MailBox dove la procedura si blocca chiedendomi utente e password all'infinito.
    per risolvere devo bloccare la procedura manuale e configurare server e utente  a mano (dopodichè funziona)
    questa anomalia si presenta solo da un paio di settimane.... ha funzionato correttamente per mesi..

    Dato che sulla maggior parte delle macchine funziona direi che non dovrebbe essere un problema di exchange...
    ho verificato le configurazioni di rete ed è tutto ok.
    DNS è tutto ok..

    avete qualche suggerimento??

     

    grazie a tutti in anticipo.

     

    • Tipo modificato Anca Popa domenica 6 febbraio 2011 19:21 la soluzione non e stata postata sul Forum
    lunedì 27 dicembre 2010 08:29

Tutte le risposte

  • Ciao,

     io controllerei da subito il DNS,creando una zona anche per il dominio esterno, con il nome host dell'autodiscovery come record A, ed anche per OWA,che puntano agli indirizzi interni del tuo server CAS,così anche le virtual directory,e il relativo XML con l'FQDN degli URL.

    Prova a leggere questo articolo:

    http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2300-Outlook-continually-prompting-for-username-and-password.html

     

    Buona lavoro!


    Grazie e cordiali saluti
    lunedì 27 dicembre 2010 08:49
  • la zona interna sul dns è gia creata e contiene già il nome webmail.miodominopubblico.it .

    ... non ho capito questa parte ",così anche le virtual directory,e il relativo XML con l'FQDN degli URL."

    lunedì 27 dicembre 2010 10:27
  • Ciao,

     io controllerei da subito il DNS,creando una zona anche per il dominio esterno, con il nome host dell'autodiscovery come record A, ed anche per OWA,che puntano agli indirizzi interni del tuo server CAS,così anche le virtual directory,e il relativo XML con l'FQDN degli URL.

    Prova a leggere questo articolo:

    http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2300-Outlook-continually-prompting-for-username-and-password.html

     

    Buona lavoro!


    Grazie e cordiali saluti


    però ora che ci penso il server gestisce 2 domini... la zona dns l'ho creata per solo 1 dei 2.... dici che è meglio se metto anche l'altro???

    ... immagino di si...

    lunedì 27 dicembre 2010 10:33
  • > ... immagino di si...

    Specie se è nel certificato :) 


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 27 dicembre 2010 10:45
  • Ciao Bon Re,

    intendo che client ricerca l'autodiscover connection object sul domain controloller, dopodichè riceve l'FQDN del tuo CAS server nella forma https://CAS01/autodiscover/autodiscover.xml,in questo senso dico "url",se vai inoltre all'interno della virtual directory dell'autodiscover troverai il suddetto xml, il client una volta entrato in dominio riceverà attraverso questo processo l'indirizzo dei CAS nella lista dentro l'xml e avrà accesso in automatico alla mailbox relativa all'utente active directory.

    Ciao

     


    Grazie e cordiali saluti
    lunedì 27 dicembre 2010 13:49
  • > ... immagino di si...

    Specie se è nel certificato :) 


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.

    ho fatto ma non ho nessun miglioramento... e poi scusate... perche vanno quasi tutti i pc?? se il problema fosse a livello di dns ci dovrebbero essere molti piu errori no??
    lunedì 27 dicembre 2010 13:52
  • Non ho detto che con quello avresti risolto, ma è comunque un settaggio che è meglio fare :-)

    BTW, Verifica i web services per l'utente affetto dal problema e confrontane il risultato con uno non affetto.

    Test-OutlookWebServices -identity:utentecolproblema@dominio.com | ft * -AutoSize -Wrap 
    

    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 27 dicembre 2010 14:01
  • ora provo nel frattempo ho trovato un'anomalia con un test simile....

    RunspaceId : 05b5ba4f-dd1b-4f84-b7c1-175d8dacd390
    Id         : 1013
    Type       : Error
    Message    : Durante la connessione a https://mail.miodominio.it/ews/exchange.asmx è stato ricevuto l'errore Impossibi
                 le risolvere il nome remoto.: 'mail.miodominio.it'

     

    qui gia vedo un errore in quanto dovrebbe essere "webmail" e non "mail"

    credo che "mail" sia una vecchia configurazione...
    da dove si cambia??

     

    questo test lo devo lanciare per forza da un server exchange o posso lanciarlo anche da un pc che presenta il problema??

    lunedì 27 dicembre 2010 14:22
  • Non ho detto che con quello avresti risolto, ma è comunque un settaggio che è meglio fare :-)

    BTW, Verifica i web services per l'utente affetto dal problema e confrontane il risultato con uno non affetto.

    Test-OutlookWebServices -identity:utentecolproblema@dominio.com | ft * -AutoSize -Wrap 
    
    

    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.

     

    ps: temo di non essermi spiegato: il problema non è relativo agli utenti... è relativo alle macchine!

    da un pc che funziona, funziona con qualsiasi utente.
    dove non va...... non va con nessun utente!

     

    lunedì 27 dicembre 2010 14:29
  • Il test lo devi lanciare  dove hai i Management Tools e i permessi sull'Organizzazione

    Per settare l'url usa il comando di cui sotto

    Set-WebServicesVirtualDirectory -identity "CAS01\EWS (Default Web Site)" -externalurl https://mail.contoso.com/EWS/Exchange.asmx -BasicAuthentication:$True
    

    http://technet.microsoft.com/en-us/library/bb201695(EXCHG.80).aspx

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 27 dicembre 2010 14:29
  • In questo caso esegui il comando ipconfig /flushdns dal client problematico.

    Quel mail al posto di webmail deve essere da qualche parte .. o nella cache del client dns oppure il DNS è configurato in maniera errata. Controlla anche il file hosts


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Modificato Andreagx lunedì 27 dicembre 2010 14:35 add info
    lunedì 27 dicembre 2010 14:32
  • In questo caso esegui il comando ipconfig /flushdns dal client problematico.

    Quel mail al posto di webmail deve essere da qualche parte .. o nella cache del client dns oppure il DNS è configurato in maniera errata. Controlla anche il file hosts

    come dicevo sopra il dns ha la stessa configurazione delle altre macchine e il file host è vuoto...

    martedì 28 dicembre 2010 07:43
  • Penso di aver capito bene lo scenario e come dicevo sopra ti suggerisco un ipconfig /flushdns sul client problematico.

    Inoltre un prova a fare un pathping verso webmail.tudominio.xxx e verso mail.tuodominio.xxxx

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    martedì 28 dicembre 2010 08:20
  • Ciao a tutti, sono in questa situazione:
    exchange 2010 Sp1 installato su 4 server distitni
    1° Mailbox
    2° HubTransport
    3° ClientAccess
    4° Edge (in dmz)
    tutti i server sono installati su windows 2008 R2 e fanno solo quello.
    il dominio è su un'altra macchina ed è un windows 2008 R2 nativo.
    è presente un'ulteriore macchina con TServer sempre 2008 R2.
    su tutti i client (tserver comrpeso) è installato outlook 2007 (completamente aggiornato)
    tutti i client dono in DHCP

    configurando un nuovo pc viene correttamente rilevato il server (client access) e configurato l'account.

    su alcune macchine piu vecchie però ed in particolare sul Tserver configurando un nuovo profilo utente, l'autodiscover di outlook mi fa puntare sul server MailBox dove la procedura si blocca chiedendomi utente e password all'infinito.
    per risolvere devo bloccare la procedura manuale e configurare server e utente  a mano (dopodichè funziona)
    questa anomalia si presenta solo da un paio di settimane.... ha funzionato correttamente per mesi..

    Dato che sulla maggior parte delle macchine funziona direi che non dovrebbe essere un problema di exchange...
    ho verificato le configurazioni di rete ed è tutto ok.
    DNS è tutto ok..

    avete qualche suggerimento??

     

     

    ok... ripartiamo... pensavo fosse un problema solo di una macchina... invece appensa smosso le acque mi sono reso conto che il problema è generalizzato ovvero su tutte le macchine punta sul server sbagliato e su tutte mi chiede l'autenticazione all'infinito.
    quindi direi ri-affrontare da capo la situazione:
    ecco quello che ho fatto :

    aggiunto il record "autodiscover" nel dns
    aggiunto "autodiscover.miodominio.local" e "autodiscover.miodomino.it" ai nomi del certificato.
    con il comando
    Remove-AutodiscoverVirtualDirectory -Identity "exchange-client\Autodiscover (Default Web Site)"
    sono riuscito a rimuovere la virectory virtuale.
    ora dovrei lanciare il comando:
    New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -BasicAuthentication $true -WindowsAuthentication $true
    giusto??

    solo che questo comando mi da questo errore:

    Si è verificato un errore durante la creazione della directory virtuale IIS 'IIS://EXCHANGE-CLIENT.Gruppo-Pace.local/W3
    SVC/1/ROOT/Autodiscover' in 'EXCHANGE-CLIENT'.
        + CategoryInfo          : InvalidOperation: (EXCHANGE-CLIENT...fault Web Site):ADObjectId) [New-AutodiscoverVirtua
       lDirectory], InvalidOperationException
        + FullyQualifiedErrorId : 4E046946,Microsoft.Exchange.Management.SystemConfigurationTasks.NewAutodiscoverVirtualDi
       rectory

     

    e qui sono fermo... non so come risolvere... avere qualche suggerimento??

    martedì 28 dicembre 2010 17:09
  • In questo caso esegui il comando ipconfig /flushdns dal client problematico.

    Quel mail al posto di webmail deve essere da qualche parte .. o nella cache del client dns oppure il DNS è configurato in maniera errata. Controlla anche il file hosts

     

    mi sa che avevi ragione ... il problema era generalizzato e non su una sola macchina.
    ho riquotato e aggiornato il mio post principale....
    grazie... :)

    martedì 28 dicembre 2010 17:11
  • Anche in questo modo ?

    New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -InternalUrl "https://XXXX/Autodiscover/Autodiscover.xml" -BasicAuthentication 1 -WindowsAuthentication 1
    martedì 28 dicembre 2010 19:46
  • Anche in questo modo ?

    New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -InternalUrl "https://XXXX/Autodiscover/Autodiscover.xml" -BasicAuthentication 1 -WindowsAuthentication 1
    
    

     

    si .... stesso identico errore...

    mercoledì 29 dicembre 2010 08:00
  • ps : in rete ho trovato questo...

    Never mind.  Turns out the W3Svc needs to be stopped before you run the
    cmdlet.  It tries to stop it as part of the process, but apparently it was
    timing out before the service was shutdown cleanly, thus the error message.
    I manually stopped W3 then went back to Powershell and voila!

    solo che se spengo il servizio EMS non funziona piu... se non erro passa anche lui da IIS...
    poso usare il comando da powershell "normale" se si come si fa???

     

     

    ...... o sono fuori strada???

    mercoledì 29 dicembre 2010 08:16
  • mercoledì 29 dicembre 2010 08:19
  • ho trovato anche questo....

    I would like to reinstall the CAS role, but when I try that it start's up the SP1 setup.
    I used command: Setup.com /mode:uninstall /role:CA
    (tried setup.com form Exchange 2010 installation DVD and from SP1 setup-folder)
    And to my big surprise it started to perform the upgrade to SP1 and resulted in the same error as mentioned above.
    I think it's stuck in the setup somehow. What can I do to remove/re-install/repair CAS role?

    nella mia situazione di rete sarebbe applicabile se non trovo altra soluzione??
    o è meglio lasciarla come soluzione estrema??

    mercoledì 29 dicembre 2010 08:22
  • in IIS esiste "MSExchangeAutodiscoverAppPool" ?

    Non lo vedo...
    http://img413.imageshack.us/i/exchange01.jpg/

    dovrebbe essere qui giusto??

    mercoledì 29 dicembre 2010 08:27
  • Rispondi alla mia domanda precedente ..

    Reinstallare il CAS in produzione lo lascerei come ultima opzione.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 29 dicembre 2010 08:27
  • in IIS esiste "MSExchangeAutodiscoverAppPool" ?

    Non lo vedo...
    http://img413.imageshack.us/i/exchange01.jpg/

    dovrebbe essere qui giusto??

    mercoledì 29 dicembre 2010 08:46
  • Sotto Pool di applicazioni. Dato che è stata rimossa la VDIR da EMS il Pool di Autodiscover non deve essere presente .. se c'è rinominalo.

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 29 dicembre 2010 08:53
  • si hai ragione: l'ho trovato.

    se tento di rinominare mi dice che è impossibile perche è assegato a 2 applicazioni...

    che faccio??

    -----------

    la 2 applicazioni sono:

    /autodiscover/bin
    /autodiscover/help

     

    ------------------------

    dalla console di iis posso solo modificare il pool di applicazioni a cui sono assegnate... non vedo modo di rimuoverle...

    mercoledì 29 dicembre 2010 09:11
  • Ho fatto il test in una VM.

    Se rimuovo la VDIR di Autodiscover con cmdlet di cui sopra il pool viene eliminato automaticamente. Viceversa ricreando la VDIR.  Ne deduco che dato che è stata rimossa tramite EMS il pool non dovrebbe esistere.

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 29 dicembre 2010 09:21
  • non so dirti come mai a me ste cose soo rimaste...
    cmq ti dico quello che ho fatto:

    Ho ricreato a mano una VDIR "autodiscover"
    in utomanicto mi ha messo come Sotto-VDIR "bin" e "help"
    ho rimosso a mano queste 2 VDIR e poi "autodiscover"
    ora mi fa rinominare senza problemi "MSExchangeAutodiscoverAppPool"
    ora il comando mi da un errore leggermente diverso.... ma sempre un errore.

    [PS] C:\Windows\system32>New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -BasicAuthentication $true -Wi
    ndowsAuthentication $true
    Impossibile creare l'oggetto Active Directory per la directory virtuale 'IIS://EXCHANGE-CLIENT.MioDominio.local/W3SVC/
    1/ROOT/Autodiscover' in 'EXCHANGE-CLIENT'. Ciò può essere dovuto al fatto che esiste già in Active Directory. Rimuovere
     l'oggetto da Active Directory, quindi ricrearlo.
        + CategoryInfo          : InvalidOperation: (EXCHANGE-CLIENT...fault Web Site):ADObjectId) [New-AutodiscoverVirtua
       lDirectory], InvalidOperationException
        + FullyQualifiedErrorId : 7E4FCDC9,Microsoft.Exchange.Management.SystemConfigurationTasks.NewAutodiscoverVirtualDi
       rectory

    il messaggio mi sembrava simile a uno inziale cosi ho provato:
    [PS] C:\Windows\system32>Remove-AutodiscoverVirtualDirectory -Identity "exchange-client\Autodiscover (Default Web Site)"


    Conferma
    Eseguire l'operazione?
    Rimozione della directory virtuale di individuazione automatica.
    [S] Sì  [T] Sì a tutti  [N] No  [U] No a tutti  [?] Guida (il valore predefinito è "S"): u

    questo mi fa pensare che riesca a registrare qualcosa ma non a completare l'operazione......
    qualche idea??

    mercoledì 29 dicembre 2010 09:42
  • La faccenda si fa complicata :)


    1.Vedi se riesci ad installare l'hotfix seguente:

    A hotfix rollup is available for Windows Communication Foundation in the .NET Framework 3.5 SP1 for Windows 7 and Windows Server 2008 R2
    http://support.microsoft.com/kb/981002

    2.Esegui i comandi di cui sotto dalla cartella Framework e Framework64.

    Command was C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727 aspnet_regiis -config+
    Command was C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727 aspnet_regiis -config+
     
    3.Esegui IISRESET.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 29 dicembre 2010 10:06
  • download e installazione ok
    i comandi hanno girato correttamente ma il problema rimane invariato...

    mercoledì 29 dicembre 2010 10:29
  • mentre cercavo una soluzione al problema sono finito a verificare questa cosa...

    http://img840.imageshack.us/i/exchange02.jpg

    non è che magari va rimossa a mano?? stiamo parlando di AD... quindi ho i brividi... ma se serve... :)

    mercoledì 29 dicembre 2010 10:33
  • Ora sono OOF.

    Fammi prima verificare sulla mia VM se rimuovendo la VDIR viene rimosso anche quel container.

    ASAP faccio 2 test.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 29 dicembre 2010 10:39
  • grazie... attendo tue....

    mercoledì 29 dicembre 2010 10:42
  • Ciao Bon Re,

    In base ai feedback precedenti, ai miei tests e alle mie ricerche deduco che l'oggetto Autodiscover non viene completamente rimosso dal Metabase di IIS.

    Per risolvere il problema, è necessario individuare il file di configurazione di IIS e rimuovere manualmente l'oggetto di Autodiscover:
    1. Sul Server Exchange, vai in C:\Windows\system32\inetsrv\config, cerca il file ApplicationHost.config.
    2. Salva il file in una posizione sicura
    3. Apri il file con Notepad, cerca la voce  <application path="/Autodiscover"> e rimuovila.
    4. Salva
    5. IISRESET
    Riprova a creare la Vdir con il cmdlet visto in precedenza.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    giovedì 30 dicembre 2010 08:41
  • ciao... avevo trovato questa segnalazione su internet... nel file config ho solo questa voce con "autodiscover":

    <add name="old_MSExchangeAutodiscoverAppPool_old" autoStart="false" managedRuntimeVersion="v2.0" managedPipelineMode="Integrated">
                    <processModel identityType="LocalSystem" loadUserProfile="true" idleTimeout="00:00:00" />
                    <recycling>
                        <periodicRestart time="00:00:00" />
                    </recycling>
                </add>

     

     

    lunedì 3 gennaio 2011 10:43
  • Rinomina il pool come era prima (togli old) e fammi uno screenshot dell'errore


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 3 gennaio 2011 13:36
  • ti chiedo una cortesia,

    Date che la problematica non è semplice, potresti installare i language pack in inglese e postare qui l'output del cmdlet?

    Dovreti poterlo fare anche con Windows Server


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 3 gennaio 2011 14:49
  • si ci stavo pensando anche io...

    faccio e posto...

    lunedì 3 gennaio 2011 15:18
  • Ok, credo sia venuto il momento di lavorare a basso livello.

    Prima di procedere, esegui un backup di AD.

    1. Apri ADSI 
    2. Assicurati che CN=Autodiscover(Default Web Site) non esista sotto CN=HTTP  (cattura uno screenshot).
     
    Configuration Partition
    CN=Configuration,DC=domain,DC=com-->CN=Services-->CN=Microsoft Exchange-->CN=<Your Organization Name>-->CN=Administrative Groups-->CN=Exchange Administrative Groups-->CN=Servers-->CN=<Server Name>-- >CN=Protocols-->CN=HTTP
     
     
    3. Stoppa il servizio IIS admin .
    4. In Exchange Management Shell, esegui il solito cmdlet

    Remove-AutoDiscoverVirtualDirectory -Identity "XXX\Autodiscover (Default Web Site)"
     
    6. Start del servizio IIS admin service.

    7. Riprova a creare la vdir tramite il cmdlet New-Autodiscovery ..

    8. Spero che funzioni perchè ho quasi finito le mie cartucce :-)


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    martedì 4 gennaio 2011 07:46
  • ciao... prima di far dei danni ho preso questo snap

    http://img266.imageshack.us/i/exchange05eng.jpg/

    come si puo vedere ho autodiscover sia sotto protocol che sotto http (dove mi hai detto tu).

    devo rimuovere SOLO quello di http??

    martedì 4 gennaio 2011 08:27
  • ok intanto ti ringrazio... voglio prima fare un backup di AD e dei controller di dominio... guarda caso oggi ho il NAS in assistenza... mi ci vorrà un po...
    posto appena ho i risultati....

    per ora grazie mille.

    martedì 4 gennaio 2011 09:02
  • ciao,

    ho fatto tutto,

    rimane questo errore:

    [PS] C:\Windows\system32>New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -BasicAuthentication $true -Wi
    ndowsAuthentication $true
    The Active Directory object for virtual directory 'IIS://EXCHANGE-CLIENT.mydominio.local/W3SVC/1/ROOT/Autodiscover' o
    n 'EXCHANGE-CLIENT' could not be created. This might be because the object already exists in Active Directory. Remove t
    he object from Active Directory, then re-create it.
        + CategoryInfo          : InvalidOperation: (EXCHANGE-CLIENT...fault Web Site):ADObjectId) [New-AutodiscoverVirtua
       lDirectory], InvalidOperationException
        + FullyQualifiedErrorId : 638691A3,Microsoft.Exchange.Management.SystemConfigurationTasks.NewAutodiscoverVirtualDi
       rectory

     

    ho però notato che ora CN=Autodiscover(Default Web Site) viene correttamente creato e cancellato ogni volta che lancio il comando... (prima invece non veniva rimosso)

    mercoledì 5 gennaio 2011 10:33
  • Quale :-)

    scusami... mancava il copia incolla :)

    cmq è il solito errore a quanto posso capire...

    [PS] C:\Windows\system32>New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -BasicAuthentication $true -Wi
    ndowsAuthentication $true
    The Active Directory object for virtual directory 'IIS://EXCHANGE-CLIENT.mydominio.local/W3SVC/1/ROOT/Autodiscover' o
    n 'EXCHANGE-CLIENT' could not be created. This might be because the object already exists in Active Directory. Remove t
    he object from Active Directory, then re-create it.
        + CategoryInfo          : InvalidOperation: (EXCHANGE-CLIENT...fault Web Site):ADObjectId) [New-AutodiscoverVirtua
       lDirectory], InvalidOperationException
        + FullyQualifiedErrorId : 638691A3,Microsoft.Exchange.Management.SystemConfigurationTasks.NewAutodiscoverVirtualDi
       rectory

     

    mercoledì 5 gennaio 2011 11:00
  • Prova a ridare i comandi sopra.

    Subito dopo salva in un file gli eventi Windows Logs -> Applications. Comprimi e invia a NGC7771 at live dot com

     

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 5 gennaio 2011 15:53
  • sorry ma

    NGC7771 chiocciola  live.com

    mi diche che non esiste..

    mercoledì 5 gennaio 2011 16:15
  • Esiste, esiste .. mi sono appena mandato una mail  per test :)

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 5 gennaio 2011 16:22
  • Esiste, esiste .. mi sono appena mandato una mail  per test :)

     

    bho.. prima non andava... cmq ora li ho mandati... attendo trepidante  :)
    mercoledì 5 gennaio 2011 17:15
  • Esegui il BPA da Toolbox e posta i risultati

    inviami anche ApplicationHost.config 


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.

    mercoledì 5 gennaio 2011 20:34
  • ok... ti ho mandao tutto...
    non credo che interessi il caso ma il bpa continnua a dirmi che il server edge è inraggiungibile ma in realtà funziona senza problemi...

    venerdì 7 gennaio 2011 08:11
  • Ciao Bon Re, alcune domande

    • quanti DC hai?
    • Con repadmin puoi verificare che non ci siano problemi di replica?
    • il mailbox server è mai stato CAS? se si: hai provato a rimuovere la cache di un client problematico?
    • Quanti DNS hai in linea e quanti configurati nei clients?

    A me sembra come se un Domain Controller a cui fanno capo alcuni computers avesse degli oggetti obsoleti per un problema di replica e quindi facesse puntare ai percorsi sbagliati. Se non è AD potrebbe essere scritto da qualche parte nella cache degli outlook.

    Hai anche guardato l'IIS del mailbox server per verificare che la directory non ci sia lì?

    prova

    Get-AutodiscoverVirtualDirectory [-Identity <VirtualDirectoryIdParameter>] [-DomainController <Fqdn>]

    ed aggiungigli un bel:

    | fl -property *URL*

    cambiando DomainController con a rotazione ogni DC della tua rete. Verifica che sia gli INTERNALURL che gli EXTERNALURL puntino correttamente e che non ci siano differenze attestandosi su un DC piuttosto che su un'altro.

     

    speriamo di riuscire ad aiutarti...siamo a 53 posts...

    Ciao!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    venerdì 7 gennaio 2011 13:53
  • ciao  e grazie anche a te,

    ndiamo per ordine:

    - jo 2 dc: 1° DNS + DCHP + SERVER certificati 
                  2° DNS + FIle server
                  nessuna delle 2 macchine è esposta su internet  e non hanno altri software installati (nemmeno AV) e sono in update automatico la notte direttamente tramite windows update (quindi aggiornatissime).
    prblemi di replica non ne ho mai visti ad ogni modo tra poco provo

    - repadmin lo provo a breve poi posto

    - il mailbox server NON è mai stato CAS: si tratta di una macchina dedicata solo ed esclusivamente al servizio mailbox

    - i dns in linea sono 2 e sono i 2 DC di sopra

    - ho guardato l'IIS del mailbox server per verificare che la directory ma li non c'è niente. non c'è nemmeno l' app pool

    se lancio il comando ottendo (è identico su entrambi i DC)

    [PS] C:\Windows\system32>Get-AutodiscoverVirtualDirectory -DomainController file-server.mydom.local | fl -property
     *URL*
    WARNING: IIS://EXCHANGE-CLIENT.mydom.local/W3SVC/1/ROOT/Autodiscover wasn't found. Please make sure you've typed
    it correctly.


    InternalUrl :
    ExternalUrl :

     

    [PS] C:\Windows\system32>

    venerdì 7 gennaio 2011 15:16
  • Raga,

    Non credo si possa attribuire questo problema alle repliche. Suggerisco di non incasinare ulteriormente l'analisi :-)

    I log sono puliti e il cmdlet va fatto girare sul CAS o mettendo il prefisso di quest'ultimo.

    ASAP controllo i files di configurazione di IIS


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    venerdì 7 gennaio 2011 15:32
  • giusto per completezza visto che oramai sono controlli che ho gia fatto....

    non mi risultano problemi di replica...

    repadmin non restituisce errori...

    venerdì 7 gennaio 2011 15:43
  • Buongiorno,

    visto che la situazione si sta facendo moolto complicata mi chiedo se non sia il caso di valutare soluzioni alternative....
    premesso che i problemi sono iniziati intorno al 24 o max qualche gg prima...
    premesso che io ho iniziato a lavorarci il 27 e che quindi se ha fatto operazioni sbagliate io le ho fatte in quella data e non prima...
    premesso che ho un backup bare-metal del 18 e uno del 19....

    ... magari possono servire??
    chiedo lumi :)

    grazie e ciao..

    lunedì 10 gennaio 2011 08:14
  • Buongiorno,

    visto che la situazione si sta facendo moolto complicata mi chiedo se non sia il caso di valutare soluzioni alternative....
    premesso che i problemi sono iniziati intorno al 24 o max qualche gg prima...
    premesso che io ho iniziato a lavorarci il 27 e che quindi se ha fatto operazioni sbagliate io le ho fatte in quella data e non prima...
    premesso che ho un backup bare-metal del 18 e uno del 19....

    ... magari possono servire??
    chiedo lumi :)

    grazie e ciao..

    ps: ho anche a disposizione un server viruale... quindi mi costerebbe poco spegnere il CAS e fare un restore in virtuale da baremetal...
    solo che non ne conosco le implicazioni....
    lunedì 10 gennaio 2011 16:43
  • l'errore E' perchè devi usare ANCHE il parametro -identity.

    prova a fare solo get-autodiscover.... senza param, dovrebbe mostrare tutte le virtual dir presenti nella organizzazione, dopo prendi l'identity e mettila come parametro tra virgolette (se contiene spazi) con -identity "<identity ottenuta>".

     

    Ciao!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    martedì 11 gennaio 2011 09:20
  • l'errore E' perchè devi usare ANCHE il parametro -identity.

    prova a fare solo get-autodiscover.... senza param, dovrebbe mostrare tutte le virtual dir presenti nella organizzazione, dopo prendi l'identity e mettila come parametro tra virgolette (se contiene spazi) con -identity "<identity ottenuta>".

     

    ecco le risposte ai comandi:

    [PS] C:\Windows\system32>Get-AutodiscoverVirtualDirectory | fl
    WARNING: IIS://EXCHANGE-CLIENT.mydom.local/W3SVC/1/ROOT/Autodiscover wasn't found. Please make sure you've typed
    it correctly.

    RunspaceId                      : 8cc4cc4a-b789-4cc1-b7fe-d49aefe176da
    Name                            : Autodiscover (Default Web Site)
    InternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated}
    ExternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated}
    LiveIdSpNegoAuthentication      :
    WSSecurityAuthentication        :
    LiveIdBasicAuthentication       :
    BasicAuthentication             :
    DigestAuthentication            :
    WindowsAuthentication           :
    MetabasePath                    : IIS://EXCHANGE-CLIENT.mydominio.local/W3SVC/1/ROOT/Autodiscover
    Path                            :
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : EXCHANGE-CLIENT
    InternalUrl                     :
    ExternalUrl                     :
    AdminDisplayName                :
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN=EXCHANGE-CLIENT,CN=Servers
                                      ,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=my domino Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=mydominio
                                      ,DC=local
    Identity                        : EXCHANGE-CLIENT\Autodiscover (Default Web Site)
    Guid                            : 9e16702f-e9cd-4d09-94a7-8b05c14bdb50
    ObjectCategory                  : mydominio.local/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}
    WhenChanged                     : 05/01/2011 17:04:37
    WhenCreated                     : 05/01/2011 17:04:22
    WhenChangedUTC                  : 05/01/2011 16:04:37
    WhenCreatedUTC                  : 05/01/2011 16:04:22
    OrganizationId                  :
    OriginatingServer               : Dominio.mydominio.local
    IsValid                         : True

     

     

    Get-AutodiscoverVirtualDirectory -Identity "EXCHANGE-CLIENT\Autodiscover (Default Web Site)"

    [PS] C:\Windows\system32>Get-AutodiscoverVirtualDirectory -Identity "EXCHANGE-CLIENT\Autodiscover (Default Web Site)" |
    l
    WARNING: IIS://EXCHANGE-CLIENT.mydominio.local/W3SVC/1/ROOT/Autodiscover wasn't found. Please make sure you've typed
    it correctly.


    RunsmydominioId                      : 8cc4cc4a-b789-4cc1-b7fe-d49aefe176da
    Name                            : Autodiscover (Default Web Site)
    InternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated}
    ExternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated}
    LiveIdSpNegoAuthentication      :
    WSSecurityAuthentication        :
    LiveIdBasicAuthentication       :
    BasicAuthentication             :
    DigestAuthentication            :
    WindowsAuthentication           :
    MetabasePath                    : IIS://EXCHANGE-CLIENT.mydominio.local/W3SVC/1/ROOT/Autodiscover
    Path                            :
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : EXCHANGE-CLIENT
    InternalUrl                     :
    ExternalUrl                     :
    AdminDisplayName                :
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN=EXCHANGE-CLIENT,CN=Servers
                                      ,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Grupp
                                      o mydominio Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=mydominio
                                      ,DC=local
    Identity                        : EXCHANGE-CLIENT\Autodiscover (Default Web Site)
    Guid                            : 9e16702f-e9cd-4d09-94a7-8b05c14bdb50
    ObjectCategory                  : mydominio.local/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}
    WhenChanged                     : 05/01/2011 17:04:37
    WhenCreated                     : 05/01/2011 17:04:22
    WhenChangedUTC                  : 05/01/2011 16:04:37
    WhenCreatedUTC                  : 05/01/2011 16:04:22
    OrganizationId                  :
    OriginatingServer               : Dominio.mydominio.local
    IsValid                         : True

     

     

    martedì 11 gennaio 2011 09:50
  • .... solo che non ho capito a cosa serve questo comendo o come dovrebbe aiutarmi... :)

    attendo tue... grazie..

    martedì 11 gennaio 2011 09:51
  • OK, il comando ti deve aiutare perchè si evidenzia che gli internalURL e externalURL sono SBAGLIATI.

     

    usa Set-AutodiscoveryvirtualDirectory -Identity <id_come_sopra> -internalurl:<url_interno> -externalurl:<url_esterno> per risolvere il problema.

     

    per quanto concerne il

    WARNING: IIS://EXCHANGE-CLIENT.mydominio.local/W3SVC/1/ROOT/Autodiscover

    sembra come se non trovase la directory... Se le soluzioni di cui sopra non funzionano, potremmo cancellarla e ricrearla, ma stavolta non devi fare niente a mano (come il 29 dicembre): devi lasciare che exchange faccia le sue cose.

     

    Fammi sapere. Eventualmente ti ri-forniremo una step-by-step che punti ad essere error-safe al massimo, con i tempi di attesa per repliche oggetti etc etc...

    Ciao!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    martedì 11 gennaio 2011 11:15
  • Ciao,

    Ho controllato il file di configurazione di IIS e il Path /Autoscover non esiste. Ne consegue che non dovresti ricevere l'errore durante la creazione della virtual directory.

    Mi ricordi quanti DC e quanti GC ci sono (1 se non ricordo male)

    Prima di fare un restore dei Servers (AD ed Exchange) proverei la procedura seguente:

    1. Vai in C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727 (da prompt)

    2. Esegui il comando: aspnet_regiis -config+

    Prova anche ad installare il seguente hotfix

    http://support.microsoft.com/kb/981002

    Fai un restart e prova a ricreare la vdir.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    martedì 11 gennaio 2011 11:20
  • <blockquote><P>Ciao,</P>
    <P>Ho controllato il file di configurazione di IIS e il Path /Autoscover non esiste. Ne consegue che non dovresti ricevere l'errore durante la creazione della virtual directory.</P>
    <P>Mi ricordi quanti DC e quanti GC ci sono (1 se non ricordo male)</P>
    <P>Prima di fare un restore dei Servers (AD ed Exchange) proverei la procedura seguente:</P>
    <P>1.&nbsp;Vai in C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727 (da prompt)</P>
    <P>2.&nbsp;Esegui il comando:&nbsp;aspnet_regiis -config+</P>
    <P>Prova anche ad installare il seguente hotfix</P>
    <P><A href="http://support.microsoft.com/kb/981002">http://support.microsoft.com/kb/981002</A></P>
    <P>Fai un restart e prova a ricreare la vdir.</P>
    <HR class=sig>
    <STRONG>Andrea Gallazzi</STRONG> <BR><A href="http://www.andreagallazzi.com">http://www.andreagallazzi.com</A> <BR><A style="COLOR: rgb(153,153,153)">This posting is provided "AS IS" with no warranties, and confers no rights.</A></blockquote><br/>

     


    ciao, questo comando e questo kix me li avevi gia fatti lanciare il 29...
    cmq a scanso di equivoci ri-eseguo...
    ... e riavvio.

    i DC sono 2 e gli setssi sono anche GC
    entrambi 2008 R2


    C:\Windows\Microsoft.NET\Framework64\v2.0.50727>aspnet_regiis -config+
    Enabling remote access of this server's ASP.Net configuration files.
    Succeeded!

    [PS] C:\Windows\system32>New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -BasicAuthentication $true -Wi
    ndowsAuthentication $true
    The virtual directory 'Autodiscover' already exists under 'EXCHANGE-CLIENT.mydom.local/Default Web Site'.
    Parameter name: VirtualDirectoryName
        + CategoryInfo          : InvalidArgument: (EXCHANGE-CLIENT...fault Web Site):ADObjectId) [New-AutodiscoverVirtual
       Directory], ArgumentException
        + FullyQualifiedErrorId : 71BE297B,Microsoft.Exchange.Management.SystemConfigurationTasks.NewAutodiscoverVirtualDi
       rectory

    [PS] C:\Windows\system32>


    .... niente da fare....

     

    martedì 11 gennaio 2011 21:59
  • OK, il comando ti deve aiutare perchè si evidenzia che gli internalURL e externalURL sono SBAGLIATI.

     

    usa Set-AutodiscoveryvirtualDirectory -Identity <id_come_sopra> -internalurl:<url_interno> -externalurl:<url_esterno> per risolvere il problema.

     

    per quanto concerne il

    WARNING: IIS://EXCHANGE-CLIENT.mydominio.local/W3SVC/1/ROOT/Autodiscover

    sembra come se non trovase la directory... Se le soluzioni di cui sopra non funzionano, potremmo cancellarla e ricrearla, ma stavolta non devi fare niente a mano (come il 29 dicembre): devi lasciare che exchange faccia le sue cose.

     

    Fammi sapere. Eventualmente ti ri-forniremo una step-by-step che punti ad essere error-safe al massimo, con i tempi di attesa per repliche oggetti etc etc...

    Ciao!

    ciao,

    scusami ma non ho capito bene una cosa: cosa proponi di mettere come URL?
    nei post precendeti con Adrea abbiamo RIMOSSO la vdir di autodiscover dal server CAS.
    (per la precisione da IIS abbiamo rimosso anche l'appool)
    a cosa dovrei fare puntare gli url ora??

    scusami ma non mi è chiaro...

    grazie.

     

    martedì 11 gennaio 2011 22:09
  • Fammi fare ancora qualche ricerca, poi ti rimando al supporto professionale perchè onestamente non saprei più cosa farti fare.

    In alternativa si può tentare un restore di AD.

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 12 gennaio 2011 07:56
  • Fammi fare ancora qualche ricerca, poi ti rimando al supporto professionale perchè onestamente non saprei più cosa farti fare.

    In alternativa si può tentare un restore di AD.

     

     

    scusatemi se faccio una domanda banale... ma perche dite che si tratta di un problema di AD??

    a me quella sembra l'unica sosa che funziona correttamente...

    a me sembra tanto un problema di iis del server CAS...

    quando lancio i comandi su AD vengono correttamente elimiate e create le voci...
    viceversa sul server CAS non viene modificato iis, non vengono create le cartelle sul file sistem sotto IIS, non vengono modificati i file di configurazione di iis..

    sono fuori??

    mercoledì 12 gennaio 2011 08:37
  • Gli internalURL dovrebbe essere:

    https://<fqdn_interno_cas>/Autodiscovery

    eternalURL:

    https://<fqdn_esterno_cas>/Autodiscovery

     

    Per sicurezza, fai anche un Get-WebServicesVirtualDirectory -identity <la identity>. per rilevare la identity puoi lanciarlo senza param.

     

    Secondo me la autodiscovery si è corrotta durante il rifacimento, che ha presentato problemi, forse perchè:

    • non è stato atteso un tempo necessario tra la cancellazione e la ricreazione e quindi gli oggetti AD erano ancora presenti
    • Sono state fatte operazioni manuali che hanno interferito
    • o altri eventuali motivi

    comunque internalURL e ExternalURL sono parametri NECESSARI per il funzionamento dell'autodiscovery (come per tutti gli altri web services di exchange).

    HTH, ciao!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    mercoledì 12 gennaio 2011 09:16
  • Gli internalURL dovrebbe essere:

    https://<fqdn_interno_cas>/Autodiscovery

    eternalURL:

    https://<fqdn_esterno_cas>/Autodiscovery

     

    Per sicurezza, fai anche un Get-WebServicesVirtualDirectory -identity <la identity>. per rilevare la identity puoi lanciarlo senza param.

     

    Secondo me la autodiscovery si è corrotta durante il rifacimento, che ha presentato problemi, forse perchè:

    Frorse non mi sono spiegato..
    la dir su iis è stata rimossa!
    cedi questo snap : http://img145.imageshack.us/i/exchange03eng.jpg/

    se metto l'url che mi hai detto non risponde niente... ovvero errore!

    mercoledì 12 gennaio 2011 10:57
  • Riprendiamo il nostro discorso,

    Il problema è davvero strano ...  BTW:

    Cattura un S.S. di :

    a. Apri IIS manager sul CAS.
    b. Vai su Exchange Server, Sites, Default Web Site.

    Cattura un altro screenshot di:

    CN=Configuration,DC=domain,DC=com-->CN=Services-->CN=Microsoft Exchange-->CN=<Your Organization Name>-->CN=Administrative Groups-->CN=Exchange Administrative Groups-->CN=Servers-->CN=<Server Name>-- >CN=Protocols-->CN=HTTP

    Manda alla solita email oppure posta l'output di DCDIAG di entrambi i DC.

     

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    giovedì 13 gennaio 2011 13:09
  • ok..

    fermiamoci un secondo...
    ho chiesto supporto a untecnico locale che ha risolto quasi del tutto...

    dopo cosi tanto lavoro da parte vostra mi piacerebbe davvero postare un dettaglio delle operazioni eseguite ma ha lanciato comandi powershell e modificato AD a mano per 1 ora circa... sinceramente non ricordo tutto quello che ha fatto.

    Cmq per ora direi che sono a posto.
    mi rimane il problema originale su una singola macchina.... ma per questo mi sembra il caso di aprire un topic a parte :)

    giovedì 13 gennaio 2011 16:07
  • Data la lunghezza del 3D ed il tempo dedicatogli sarebbe davvero carino se potessimo sapere qual'era il problema.

    Una telefonatina/email al bravo tecnico non sarebbe una cattiva idea...

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    giovedì 13 gennaio 2011 16:35
  • ti mando una mail con tutto il trascritto di powershell...

    ovviamente ci sono decine di informazioni private che non è il caso di postare...
    se vuoi dare un'occhiata e risalire al problema e postarlo...

    ora cerco la chiave di AD che è stata rinominata... e poi la posto.

     

    giovedì 13 gennaio 2011 16:57
  • Ciao Bon Re,

    Ci tieni aggiornati su quella chiave di AD?

    Fiduciosa della tua collaborazione, ti ringrazio in anticipo!

    Ciao. 


    Anca Popa Follow ForumTechNetIt on Twitter

    Exchange 2007/2010: problemi con le cartelle pubbliche: “The Active Directory user wasn’t found” 

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft. 

    martedì 25 gennaio 2011 07:58