none
Exchange 2007 disinstallato da SBS 2008 RRS feed

  • Domanda

  • Salve a tutti,

    da un cliente dove è installato Small Business 2008, l'installazione del service pack 3 di Exchange 2007 il setup ha provveduto a rimuovere l'installazione del vecchio Exchange 2007 SP1 per installare la nuova con SP3. Dopo la rimozione il setup si è bloccato e l'unica cosa possibile è stato il riavvio del sistema. Ora mi trovo senza Exchange e senza possibilità di reinstallazione in quanto se tento di riapplicare il SP3 mi viene presentato il seguente messaggio di errore: "I file binari di Exchange non sono installati, tuttavia è presente la chiave del Registro di sistema relativa alle impostazioni di backup. È disponibile solo la modalità di aggiornamento da build a build."

    Ho provato anche con altri service pack ma la risposta è la stessa. Ho provato anche con l'opzione /mode:recoverserver ma nulla da fare!

    Non ho neanche la possibilità di fare un restore in quanto l'unico backup che mi vede il servizio di ripristino di SBS è successivo alla data del "disastro"...

    C'è qualche cosa da fare sui registri per fare in modo che il SP3 non si accorga di nulla e si possa finire l'installazione?

    Grazie a chi potrà aiutarmi...

     

    giovedì 19 maggio 2011 09:15

Risposte

Tutte le risposte

  •  
    Per localizzare la causa principale del problema dovresti leggere il log di installazione di Exchange ( ExchangeSetup.log ).
     
    Lo  trovi in C:\
     
     

    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    giovedì 19 maggio 2011 10:13
  • Grazie per la risposta.

    Ho controllato ma non trovo nulla di strano.

    Te lo riporto omettendo nomi/domini.

    [19/05/2011 12.54.45] [0] Setup version: 8.1.240.6.
    [19/05/2011 12.54.45] [0] Logged on user: ****
    [19/05/2011 12.54.45] [0] Command Line Parameter Name='mode', Value='Install'.
    [19/05/2011 12.54.45] [0] Command Line Parameter Name='sourcedir', Value='C:\Users\***\Desktop\e2k7sp1'.
    [19/05/2011 12.54.45] [0] Command Line Parameter Name='fromsetup', Value=''.
    [19/05/2011 12.54.45] [0] ExSetupUI was started with the following command: '-mode:install -sourcedir:C:\Users\****\Desktop\e2k7sp1 /FromSetup'.
    [19/05/2011 12.54.46] [0] Setup is choosing the domain controller to use
    [19/05/2011 12.54.46] [0] Setup is choosing a local domain controller...
    [19/05/2011 12.54.47] [0] Setup has chosen the local domain controller SERVERPOSTA.****.LOCALE for initial queries
    [19/05/2011 12.54.47] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use SERVERPOSTA.****.LOCALE
    [19/05/2011 12.54.47] [0] Setup is choosing a global catalog...
    [19/05/2011 12.54.47] [0] Setup has chosen the global catalog server SERVERPOSTA.****.LOCALE.
    [19/05/2011 12.54.47] [0] Setup will use the domain controller 'SERVERPOSTA.****.LOCALE'.
    [19/05/2011 12.54.47] [0] Setup will use the global catalog 'SERVERPOSTA.****.LOCALE'.
    [19/05/2011 12.54.47] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=****,DC=LOCALE'.
    [19/05/2011 12.54.47] [0] Exchange organization container for the organization is 'CN=prima organizzazione,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=****,DC=LOCALE'.
    [19/05/2011 12.54.48] [0] Setup will search for an Exchange Server object for the local machine with name 'SERVERPOSTA'.
    [19/05/2011 12.54.48] [0] Exchange Server object found : 'CN=SERVERPOSTA,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=prima organizzazione,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=****,DC=LOCALE'.
    [19/05/2011 12.54.48] [0] The following roles are unpacked:
    [19/05/2011 12.54.48] [0] The following roles are installed: BridgeheadRole ClientAccessRole MailboxRole
    [19/05/2011 12.54.48] [0] The local server does not have any Exchange files installed.
    [19/05/2011 12.54.48] [0] Setup will use the path 'C:\Users\****\Desktop\e2k7sp1' for installing Exchange.
    [19/05/2011 12.54.48] [0] Setup will discover the installed roles from server object 'CN=SERVERPOSTA,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=prima organizzazione,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=****,DC=LOCALE'.
    [19/05/2011 12.54.48] [0] 'BridgeheadRole' is installed on the server object.
    [19/05/2011 12.54.48] [0] 'ClientAccessRole' is installed on the server object.
    [19/05/2011 12.54.48] [0] 'MailboxRole' is installed on the server object.
    [19/05/2011 12.54.48] [0] The server is cluster type: 'None'.
    [19/05/2011 12.54.48] [0] The requested cluster type: 'None'.
    [19/05/2011 12.54.48] [0] The installation mode is set to: 'Install'.
    [19/05/2011 12.54.48] [0] An Exchange organization with name 'prima organizzazione' was found in this forest.
    [19/05/2011 12.54.48] [0] Active Directory Initialization status : 'True'.
    [19/05/2011 12.54.48] [0] Schema Update Required Status : 'False'.
    [19/05/2011 12.54.48] [0] Organization Configuration Update Required Status : 'False'.
    [19/05/2011 12.54.48] [0] Domain Configuration Update Required Status : 'False'.
    [19/05/2011 12.54.48] [0] The backup copy of the install path is 'C:\Program Files\Microsoft\Exchange Server'.
    [19/05/2011 12.54.48] [0] The backup copy of the previously installed version is '8.1.240.6'.
    [19/05/2011 12.54.48] [0] Applying default role selection state
    [19/05/2011 12.54.48] [0] Setup is determining what organization-level operations to perform.
    [19/05/2011 12.54.48] [0] Because the value was specified, setup is setting the argument OrganizationName to the value prima organizzazione.
    [19/05/2011 12.54.48] [0] Setup will run from path 'C:\Users\****\Desktop\e2k7sp1\Setup\ServerRoles\Common'.
    [19/05/2011 12.54.48] [0] InstallModeDataHandler has 2 DataHandlers
    [19/05/2011 12.54.48] [0] RootDataHandler has 1 DataHandlers

    La cosa simpatica è che i files nella cartella c:\program files\exchange ci sono tutti (anche i BIN). Ho confrontato con un'altra cartella di un altro cliente e mi sembra non manchi nulla...

    Grazie ancora per l'aiuto...


    Marco.
    giovedì 19 maggio 2011 11:12
  • Il log indica la presenza di Exchange SP1 RTM '8.1.240.6'.

    Piuttosto che lo switch recover in questo caso proverei "upgrade"

    Setup.com /mode:upgrade

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Contrassegnato come risposta Anca Popa mercoledì 25 maggio 2011 06:14
    venerdì 20 maggio 2011 05:50
  • Ciao Marco,

    Sei riuscito a dare uno sguardo alla risposta sopra, posso chiederti se hai fatto una prova?

    Senza nulla togliere al valido consiglio di Andrea, se ancora non hai risolto vorrei suggerirti anche questo articolo, è per il Service Pack 1 comunque in base alle mie ricerche si applica anche per il SP3:

    Ricezione di un messaggio che indica che è disponibile solo la modalità di aggiornamento da build a build quando si installa Exchange 2007 Service Pack 1

    Spero che possa risolvere, non esitare a postare sul Forum nel caso ti necessitasse ulteriore aiuto.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come calcolare la dimensione della Rubrica offline (OAB)

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    • Contrassegnato come risposta Anca Popa mercoledì 25 maggio 2011 06:14
    martedì 24 maggio 2011 07:10