none
GPO x Deploy package MSI+MST non funziona. Idee... ?? RRS feed

  • Domanda

  • Vorrei distribuire un pacchetto di installazione di un'applicazione di controllo remoto sui client di una lan.

    Ho seguto le indicazioni presenti in questi articoli :

    https://support-splashtopbusiness.splashtop.com/hc/en-us/articles/360021483952-Create-an-MST-file-via-Orca

    https://support-splashtopbusiness.splashtop.com/hc/en-us/articles/360022944312-Deploy-using-Group-Policy-with-MSI-and-MST-files

    Ho seguito fedelmente le istruzioni ma, dopo aver eseguito l'update delle policy sul client, non succede nulla.

    Ho inserito la nuova policy all'interno di una GPO già esistente (per essere certo che venisse elaborata) ma non c'è nessuna evidenza. La sezione relativa il deploy del pacchetto viene completamente ignorata (gpresult /r).

    Il GPO viene applicato ad una OU specifica contenente tutti gli utenti del dominio. E' abilitato sia per le impostazioni Computer che Utente. Non ci sono filtri WMI applicati e come filtro di sicurezza è abilitato per gli "Authenticated Users".

    Avete qualche idea sul perchè non passa... ?

    Grazie a tutti



    • Modificato Aldo_ mercoledì 2 ottobre 2019 17:53
    • Modificato Edoardo BenussiMVP, Moderator lunedì 7 ottobre 2019 08:46 il fatto che il problema è risolto non va scritto nel titolo
    martedì 1 ottobre 2019 10:14

Risposte

  • Mi rispondo da solo:

    La GPO veniva elaborata ma non succedeva nulla perchè il tanto amato UAC ne impediva l'esecuzione (ovviamente non si notava nulla perchè non compare nessun prompt).

    Si è reso necessario aggiungere un'ulteriore GPO per modificare l' UAC. Ho seguito questo tutorial:

    https://www.youtube.com/watch?v=jXAz6vrWMP0

    Magicamente tutto ha cominciato a funzionare.

    Chiaramente qualcuno di voi potrebbe pensare che ci potevo pensare (vero) ma, nello stesso tempo immagino che qualche altra milionata di persone si siano trovate a cozzare su questa cosa.

    Mi chiedo se è veramente così complicato indicare nella documentazione ufficiale:

    https://support.microsoft.com/it-it/help/816102/how-to-use-group-policy-to-remotely-install-software-in-windows-server

    questo piccolo dettaglio ?????

    Cioè.. basterebbe una piccola nota della serie: "Assicuratevi che l' UAC sia disabilitato se no ci potete morire a farlo funzionare".

    Vabbè... scusate lo sfogo... ma sono dietro a sta cosa da due giorni

    Buona serata a tutti

    • Contrassegnato come risposta Aldo_ mercoledì 2 ottobre 2019 17:53
    mercoledì 2 ottobre 2019 17:52