none
comportamento strano Outlook Anywhere su Exchange 2013 RRS feed

  • Domanda

  • Buonasera a tutti, ho un problema un po strano con una struttura in test. Stiamo vagliando l'idea di passare da 2010 a 2013.

    Ho configurato la struttura con un DC 2008R2 ed un Exchange 2013 su 2012 R2. Ho una CA interna con un certificato con 3 nomi exchange.nomeazienda.com, nomeserverinterno.nomezienda.local e autodiscover.nomeazienda.com. 

    Sui client interni tutto funziona correttamente, anche se configuro un client dall'esterno non ho problemi, quando però porto un client configurato da fuori all'interno, nelle impostazioni rpc over http proxy dell'account di outlook mi cambia il nome in nomerserverinterno.nomeazienda.local e se lo riporto fuori con quel nome il client non si connette più.

    Ricambio mettendo exchange.nomeazienda.com l'impostazione e tutto riparte ma è una cosa strana...ho una split zone interna che risolve comunque sempre il nome esterno...non riesco a capire perchè me lo cambi automaticamente quando lo porto dentro.

    Sbaglio qualcosa o esiste un modo per dirgli di usare sempre lo stesso nome nell'rpc over http proxy? cosa strana se flaggo la voce sotto "connetti sempre al server proxy con questo nome nel certificato" non funziona e mi da un errore di proxy non attendibile chiedendomi continuamente le credenziali...il certificato ssl e la catena di certificati sono correttamente installati in "fonti radice attendibili"

    Spero di essermi spiegato...grazie.

    Gian

    venerdì 10 gennaio 2014 15:18

Risposte

  • Ciao Gianmarco, ad occhio direi che il certificato contenete il .local ti genera questo giochetto. Lo sai che i nuovi certificati ufficiali non possono più contenere domini interni vero?

    Quando scrivi che i PC li configuri all'esterno (presumo fuori LAN) intendi comunque  PC associati al dominio .local o sono fuori dominio?

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    • Contrassegnato come risposta Anca Popa venerdì 17 gennaio 2014 08:21
    venerdì 10 gennaio 2014 18:09
  • Ciao Gianmarco,

    se nell'impostazione che hai verificato, hai il nome .local, l'autodiscover passa quell'impostazione al client, quindi se la cambi, avendo la risoluzione dns attiva anche internamente, per quel dominio, dovrebbe funzionare tutto.

    Occhio che Exchange 2013 non è ancora certificato su 2012 R2, lo sarà dall'uscita del SP1, prevista a breve:

    http://blogs.technet.com/b/exchange/archive/2013/11/20/exchange-server-2013-service-pack-1-coming-in-early-2014.aspx

    Roberto


    Roberto Ferazzi

    IT Consultant | Microsoft MCTS MCITP MCSA MCSE MCT | http://www.ferazzi.it

    If you found my post helpful, please give it a Helpful vote

    If it answered your question, remember to mark it as an Answer

    • Contrassegnato come risposta Anca Popa venerdì 17 gennaio 2014 08:21
    sabato 11 gennaio 2014 21:10
    Moderatore

Tutte le risposte

  • Ciao Gianmarco, ad occhio direi che il certificato contenete il .local ti genera questo giochetto. Lo sai che i nuovi certificati ufficiali non possono più contenere domini interni vero?

    Quando scrivi che i PC li configuri all'esterno (presumo fuori LAN) intendi comunque  PC associati al dominio .local o sono fuori dominio?

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    • Contrassegnato come risposta Anca Popa venerdì 17 gennaio 2014 08:21
    venerdì 10 gennaio 2014 18:09
  • Ciao Nino, grazie intanto...sapevo il discorso del .local ma solo per i certificati acquistati, se non sbaglio quando vado a fare una request di un nuovo cert per il nome interno sulle vdir interne me lo mette di default, devo quindi mettere quello esterno nel nome dell'anywhere e poi alla fine nel riepilogo togliere il .local? ho usato il deploiment automatico del cert via policy sui client, se lo cambio ho modo di togliere quello esistente e metterne un'altro o sostituirlo senza che i client diano segni di squilibrio o sono virtualmente morto? :)

    grazie mille per l'attenzione!

    venerdì 10 gennaio 2014 19:31
  • Nino penso di aver trovato l'inghippo: nella voce server\doppio click sotto "outlook anywhere" ho nel nome interno da utilizzare il .local se lo cambio li e lo metto come quello esterno (avendo la split zone non dovrebbe cambiare nulla direi) dovrei aver risolto i problemi senza toccare i client che dici?


    sabato 11 gennaio 2014 09:09
  • Il server di fatto non è .it ma .local non dovrebbe funzionare.

    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    sabato 11 gennaio 2014 19:45
  • Ciao Gianmarco,

    se nell'impostazione che hai verificato, hai il nome .local, l'autodiscover passa quell'impostazione al client, quindi se la cambi, avendo la risoluzione dns attiva anche internamente, per quel dominio, dovrebbe funzionare tutto.

    Occhio che Exchange 2013 non è ancora certificato su 2012 R2, lo sarà dall'uscita del SP1, prevista a breve:

    http://blogs.technet.com/b/exchange/archive/2013/11/20/exchange-server-2013-service-pack-1-coming-in-early-2014.aspx

    Roberto


    Roberto Ferazzi

    IT Consultant | Microsoft MCTS MCITP MCSA MCSE MCT | http://www.ferazzi.it

    If you found my post helpful, please give it a Helpful vote

    If it answered your question, remember to mark it as an Answer

    • Contrassegnato come risposta Anca Popa venerdì 17 gennaio 2014 08:21
    sabato 11 gennaio 2014 21:10
    Moderatore
  • Ciao Gianmarco,

    In attesa delle tue notizie, evidenzio i consigli qui sopra.

    Se c'e' un'altra soluzione che hai trovato nel frattempo, ti saremmo grati di condividerla anche qui (sarà sicuramente utile per gli altri utenti del forum che magari riscontrano problematiche simili).

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    venerdì 17 gennaio 2014 08:23
  • Ciao Anca, eccomi qui, dovevo avere il tempo di testare la cosa. Confermo che il fatto di cambiare solo il nome interno mettendo quello esterno funziona anche da dentro la lan, quindi la risposta di Roberto è giustissima.

    Grazie anche a Nino!

    Gian

    lunedì 20 gennaio 2014 15:26