none
Policy non viene applicata.. perchè ???? RRS feed

  • Domanda

  • SBS 2008 64 bit Standard + client Windows 7 Professional 32 bit

    Ho installato una stampante sul server con i relativi driver 32 e 64 bit
    (stessa versione scaricati dal sito del produttore).
    L'ho condivisa e pubblicata nel catalogo di AD.

    Faccio la solita procedura sul client: "Pannello di controllo\Hardware e
    suoni\Dispositivi e stampanti", "aggiungi stampante", "Stampante di rete",
    doppio click sulla stampante.

    Anziche' installarmi i driver, mi parte la procedura di ricerca automatica
    degli aggiornamenti dei drivers di Windows Update. Se la interrompo, la
    stampante non viene installata e se tento di ripetere nuovamente la
    procedura mi restituisce il seguente errore:

    Impossibile connettersi alla stampante - Operazione non riuscita Errore
    0x0000000a
    L'unico modo per uscire dal tunnel e' quello di riavviare il sistema.

    Ho deciso, quindi, di disabilitare le seguenti policy:

    Configurazione computer/Modelli amministrativi/Sistema/Installazione dei
    driver
    Configurazione utente/Modelli amministrativi/Sistema/Installazione dei
    driver

    riavviato i pc, ma non c'e' verso! Ogni volta che tento di reinstallare la
    stampante, parte lo stesso Windows Update.

    Qualcuno sa spiegarmi il motivo per cui la policy non viene applicata ???
    Oppure mi dite come cacchio si fa ad installare "a mano" un driver per una
    stampante condivisa su server ??

    Grazie



    mercoledì 23 febbraio 2011 11:43

Risposte

  • Porca zozza !!!!

    Non mi ero accorto che il server si era gia' preso in automatico una
    versione integrata del driver 64bit e l'aveva, giustamente, applicato alla
    stampante come default.

    Quando ho aggiunto i nuovi driver, mi sono dimenticato di associare il
    driver nuovo a 64 bit alla stampante.
    Ora funziona regolarmente e si installa il driver direttamente dal server
    senza problemi.

    Ne deduco, quindi, che quando il client a 32bit tentava di installare la
    stampante con il driver 32bit del server la versione non corrispondeva con
    quella a 64 e per questo andava a cercarsi il driver su Windows Update ?

    Pero'... scusa... anche se ho fatto casino con le versioni dei driver,
    perche' il client continua ad andare su windows update nonostante ho settato
    la policy ??

    Ciao e grazie

    <luca bartoccini> ha scritto nel messaggio
    news:feb4a033-e273-49f6-90d2-b7d54ce0374d@communitybridge.codeplex.com...
    > Ciao
    >
    > la prima cosa che mi viene in mente è di verificare se l'utente che fà
    > login al client W7 abbia i permessi per potersi collegare alla stampante
    > di rete.
    >
    > Questo lo verifichi sul tuo srv 2008 sbs tramite le propietà della
    > stampante che hai installato in dettaglio nelle propietà della stampante.
    >
    > Di solito per fare un buon lavoro si crea un gruppo di sicurezza e si
    > aggiunge alla security della stampante, successivamente si aggiunge
    > l'utente al gruppo abilitato alla stampa.
    >
    > la seconda cosa che mi viene in mente è quella di verificare nel sito del
    > produttore se i driver siano quelli corretti.
    >
    > Una volta verificato questo e verificato che il client si installi per
    > bene la stampante puoi pensare quello che in gergo si chiama deploy
    > tramite gpo.
    >
    > Luca
    >



    mercoledì 23 febbraio 2011 12:19

Tutte le risposte

  • Ciao

    la prima cosa che mi viene in mente è di verificare se l'utente che fà login al client W7 abbia i permessi per potersi collegare alla stampante di rete.

    Questo lo verifichi sul tuo srv 2008 sbs tramite le propRietà della stampante che hai installato in dettaglio nelle propRietà della stampante.

    Di solito per fare un buon lavoro si crea un gruppo di sicurezza e si aggiunge alla security della stampante, successivamente si aggiunge l'utente al gruppo abilitato alla stampa.

    la seconda cosa che mi viene in mente è quella di verificare nel sito del produttore se i driver siano quelli corretti.

    Una volta verificato questo e verificato che il client si installi per bene la stampante puoi pensare A quello che in gergo si chiama deploy tramite gpo.

    Luca

    mercoledì 23 febbraio 2011 12:07
  • Porca zozza !!!!

    Non mi ero accorto che il server si era gia' preso in automatico una
    versione integrata del driver 64bit e l'aveva, giustamente, applicato alla
    stampante come default.

    Quando ho aggiunto i nuovi driver, mi sono dimenticato di associare il
    driver nuovo a 64 bit alla stampante.
    Ora funziona regolarmente e si installa il driver direttamente dal server
    senza problemi.

    Ne deduco, quindi, che quando il client a 32bit tentava di installare la
    stampante con il driver 32bit del server la versione non corrispondeva con
    quella a 64 e per questo andava a cercarsi il driver su Windows Update ?

    Pero'... scusa... anche se ho fatto casino con le versioni dei driver,
    perche' il client continua ad andare su windows update nonostante ho settato
    la policy ??

    Ciao e grazie

    <luca bartoccini> ha scritto nel messaggio
    news:feb4a033-e273-49f6-90d2-b7d54ce0374d@communitybridge.codeplex.com...
    > Ciao
    >
    > la prima cosa che mi viene in mente è di verificare se l'utente che fà
    > login al client W7 abbia i permessi per potersi collegare alla stampante
    > di rete.
    >
    > Questo lo verifichi sul tuo srv 2008 sbs tramite le propietà della
    > stampante che hai installato in dettaglio nelle propietà della stampante.
    >
    > Di solito per fare un buon lavoro si crea un gruppo di sicurezza e si
    > aggiunge alla security della stampante, successivamente si aggiunge
    > l'utente al gruppo abilitato alla stampa.
    >
    > la seconda cosa che mi viene in mente è quella di verificare nel sito del
    > produttore se i driver siano quelli corretti.
    >
    > Una volta verificato questo e verificato che il client si installi per
    > bene la stampante puoi pensare quello che in gergo si chiama deploy
    > tramite gpo.
    >
    > Luca
    >



    mercoledì 23 febbraio 2011 12:19
  • Corretto per il driver 32 e 64 per il client. Se il client non trova il driver corretto nel server effettua ricerca su update.

    Nella maggior parte dei casi si finisce in un loop come il tuo.

    Per quanto riguarda la policy bisogna fare un po' di controlli.

    Innanzitutto dal client verificare che la policy applicata sia corretta e correttamente applicata e questo si fà tramite una finestra di prompt dei comandi in modalità amministratore dando il comando gpresult /R sul client.

    Mi raccomando per fare un buon lavoro mai modificare la Default Domain Policy ma farne sempre nuove e linkarle a questa o alle OU.

    A meno che non sia proprio una esigenza tipicamente corporate in cui si richiedono modifiche sulle default domain policy.

    Fai anche una prova a disabilitare questa Policy se è nuova o cmq a tornare alla configurazione della policy prima di questo problema.

    Ciao

    Luca

     

     

     

    mercoledì 23 febbraio 2011 12:59
  • Pero'... scusa... anche se ho fatto casino con le versioni dei driver,
    perche' il client continua ad andare su windows update nonostante ho settato
    la policy ??

    come ti ha scritto Luca, controlla con un RSOP se il client prende correttamente la policy.
    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    mercoledì 23 febbraio 2011 14:14
    Moderatore
  • Mi raccomando per fare un buon lavoro mai modificare la Default Domain Policy ma farne sempre nuove e linkarle a questa o alle OU.


    mmmhh.... effettivamente la policy l'ho messa nella Default del dominio.

    Provo a crearne una nuova e linkarla alla ou degli utenti.

    mercoledì 23 febbraio 2011 14:35