Web Service Connector Password Reset issues


  • Hi,

    I am using FIM 2010 R2 version 4.1.3419.0 and  version of Web Services Connector 5.3.407

    I've successfully configured FIM for Password Synchronization and I'm trying to reset a password in SAP using Web Service Connector MA. I am running MA in-proc.

    When resetting a password in FIM Password Reset Portal, I am able to reset it in AD, but when password notification is staged for synchronization, I received following error message from FIM Synchronization Service:

    BAIL: MMS(24932): d:\bt\800\private\source\miis\ma\core\passwordext.cpp(322): 0x80230729 (The extension could not be loaded.)

    In spite of having <supportedRuntime version="4.0"></supportedRuntime> in miiserver.exe.config startup configuration. Then I've tried to add WebService dlls to GAC (as proposed in, and got System.UnauthorizedAccessException. Extension tried to create a file "generated.config" in Microsoft.IdentityManagement.MA.WebServices.dll GAC location.

    Now, since I cannot have these dll's in GAC and apparently I am unable to load them from Extensions folder. I'd like to know how to diagnose why extension is not picked up by Synchronization Service. I've turned on Fusion log and apparently Microsoft.IdentityManagement.MA.WebServices.dll is loaded.

    Any ideas, suggestions?

    Thanks in advance.

    martedì 27 agosto 2013 08:21

Tutte le risposte

  • Hi,

    I should have updated that post.

    We had to un-register the DLLs from the GAC and I added a line to the miiserver.exe.config file after the <runtime> tag:

    <disableStackOverflowProbing enabled="true"/>

    That got us farther, but we noticed the password syncs would crash the FIM Sync Service if they were executed during a sync run. PSS provided us with a hotfix (via a download link, bot sure it's published) that seemed to fix it though it took a few tries to get it right. The config files did not get updated during the hotfix installation.

    Afraid I don't know the hotfix version... It was for a client that I've wrapped up with.



    • Modificato SamiVV martedì 27 agosto 2013 21:07 typo
    martedì 27 agosto 2013 21:03
  • Hi,

    Thank you for your response. The very temporary solution was, that I gave modify rights to that specific folder in GAC and FIM Sync Service was able to load that extension dll and perform password reset (regardless of whether there were any sync runs or not).

    I will try your approach and see whether I can get it working.

    Best Regards

    mercoledì 28 agosto 2013 08:53