none
invio ftp RRS feed

  • Domanda

  • Salve a tutti vorrei chiedervi un aiuto,

    spero di non essere ot.

    Comunque il problema è il seguente:

    ho un client con su win 7 64 bit che deve inviare dei dati via ftp a un server remoto, sia il server che il client cmq sono gestiti da me, ora lato server ho uno zywall che filtra i pacchetti verso un server 2008 r2 a 64 bit.

    Il servizio ftp l'ho implementato con filezilla, ora succede che dal client invio un file tramite gui cioè apro risorse del computer nell'url apro lìftp inserisco utenza e pwd e invio il file va tutto ok, se invece lo stesso file lo invio da riga di comando il trasferimento ad un certo punto si inchioda resta il socket aperto vedo la connessione ma non manda nulla poi dopo diversi minuti si sblocca e invia....

    premesso che non è un prob. di connettività perchè se conteporaneamente invio il file via cmd o via gui il secondo arriva subito ...il primo come detto sopra......

    qualche suggerimento??

    mercoledì 13 luglio 2011 14:15

Risposte

  • Buongiorno obiwan..scusa se rispondo adesso..

    Ho effettuato una connessione come da te specificata, questo è il risultato:

    C:\Users\admin>ftp
    ftp> debug
    Debug di On in corso...
    ftp> open 192.168.3.66
    Connesso a 192.168.3.66.
    220 ftp miosito
    Utente (192.168.3.66:(none)): test
    ---> USER test
    331 Password required for test
    Password:
    ---> PASS test
    230 Logged on
    ftp> hash
    Stampa del marcatore hash On ftp: (2048 byte/hash mark) .
    ftp> bin
    ---> TYPE I
    200 Type set to I
    ftp> put c:\905-656-2.pdf
    ---> PORT 192,168,222,37,223,36
    200 Port command successful
    ---> STOR 905-656-2.pdf
    150 Opening data channel for file transfer.
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ############################################################
    Connessione chiusa dall'host remoto.
    ftp>

     

    Per spostare questo file di 900Kb ha impiegato quasi 2 ore, nel frattempo hanno lavorato anche altri passando anche file di svariati mega senza avere problema.....

    Ciao, nessun problema, tutto sommato... ognuno di noi ha i propri impegni

    Tornando al discorso FTP; a quanto sembra la sessione viene avviata regolarmente ed il trasferimento parte correttamente (come evidenziato dai marcatori di trasferimento - comando "hash") solo che si verificano due problemi che, sospetto, siano correlati, ossia

    1. Il server disconnette il client, probabilmente a causa di timeout di sessione

    2. Il trasferimento tra il server e QUEL client è lentissimo mentre altri trasferimenti hanno una velocità normale e non hanno problemi

    ora, sospetto che il punto 2 causi poi il problema di cui al punto 1, ossia, data la lentezza del trasferimento ed il lungo tempo richiesto, il server forza la disconnessione del client causa timeout

    Sarebbe opportuno ripetere il test di cui sopra tenendo sotto controllo anche il log di filezilla server (avvia la console e controlla se la disconnessione avviene causa timeout o in ogni caso per quale motivo avvenga); inoltre, sempre in filezilla server, verifica quali siano le impostazioni relative ai timeouts e controlla inoltre se, relativamente all'IP di quel client o a quell'account utente (o gruppo) siano state impostate delle regole di limitazione di banda

     

    • Contrassegnato come risposta Anca Popa mercoledì 20 luglio 2011 06:47
    giovedì 14 luglio 2011 10:40
  • Già che ci siamo; in filezilla server console

    click su users, seleziona "add"

    nome utente "usrtest"

    gruppo utente nessuno

    conferma

    spunta su enable e su password

    imposta la password desiderata

    shared folders

    add, seleziona la cartella desiderata

    imposta la cartella come home, metti la spunta su tutti i diritti

    speed limits

    metti la spunta su "bypass" per upload e download

    conferma con ok

    clicca sulle impostazioni del server

    in "general" annotati i valori relativi ai timeouts (connection, no transfer e login), imposta connection e no transfer a zero, imposta login a 120 e conferma

    ora, ritenta il trasferimento (come da istruzioni precedenti) loggandoti con le credenziali dell'utente appena creato e tenendo anche sotto controllo la console di filezilla server in modo da vedere eventuali messaggi di timeout o errore relativi alla sessione

    fai sapere

     

    • Contrassegnato come risposta Anca Popa mercoledì 20 luglio 2011 06:47
    giovedì 14 luglio 2011 10:50

Tutte le risposte

  • L'FTP da riga di comando lo fai in modelità "attiva" (come di default) o in modalità passiva?

     

     


    Adriano - MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]adrsys.it
    mercoledì 13 luglio 2011 15:01
  • Scusa ma non capisco cosa intendi per modalità attiva??

    ti scrivo quello che faccio così forse mi è più facile descrive loperazione che faccio...:

    C:\Users\Administrator>ftp 192.168.3.66 (naturalemnte questo sarà un ip pubblico)
    Connesso a 192.168.3.66.
    220 ftp miasocietà
    Utente (192.168.3.66:(none)): test
    331 Password required for test
    Password:
    230 Logged on
    ftp> put c:\905-656-2.pdf
    200 Port command successful
    150 Opening data channel for file transfer.

    è poi mi resta così per svariati minuti....

    mercoledì 13 luglio 2011 15:31
  • e poi mi resta così per svariati minuti....

    Ok, prova come segue


    ftp debug open 192.168.3.66 utente password hash bin put c:\905-656-2.pdf

    e posta qui il "log" della sessione


    mercoledì 13 luglio 2011 16:03
  • L'FTP da riga di comando lo fai in modelità "attiva"
    (come di default) o in modalità passiva?

    Adriano... il client "ftp" standard (cmdline) di windows non supporta
    PASV :)

    mercoledì 13 luglio 2011 16:05
  • Scusa ma non capisco cosa intendi per modalità attiva??


    Cerchiamo di chiarire anche questo; leggi qui attentamente e capirai come funziona FTP e quale sia la differenza tra la modalità attiva e quella passiva
    mercoledì 13 luglio 2011 16:11
  • ...eppure l'avevi anche già spiegato qui:

    http://social.technet.microsoft.com/Forums/it/windowsserverit/thread/67406429-a833-48de-99c7-20371a167e62

    Chiedo venia....

    adr


    Adriano - MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]adrsys.it
    mercoledì 13 luglio 2011 21:07
  • ...eppure l'avevi anche già spiegato qui:

    http://social.technet.microsoft.com/Forums/it/windowsserverit/thread/67406429-a833-48de-99c7-20371a167e62

    Chiedo venia....

    Adriano, ci mancherebbe altro, nessun problema :) !

    A proposito, se a qualcuno servisse un client ftp commandline che supporti ftp, ftp passivo ed ftps (ftp su SSL), questo programma è un'ottima scelta, non solo è totalmente gratuito, ma può fungere da rimpiazzo per il client FTP normale aggiungendo diverse features (tra le quali quelle viste sopra)


    [edit]

    Dimenticavo, il programma esiste anche in versione "portable" in pratica uno zip contenente l'eseguibile ed un "readme" con le info; questa versione è la più comoda dato che non c'è bisogno di installare nulla, basta estrarre i files nella cartella desiderata ed iniziare ad usare il programma :)

     

    giovedì 14 luglio 2011 09:58
  • Buongiorno obiwan..scusa se rispondo adesso..

    Ho effettuato una connessione come da te specificata, questo è il risultato:

    C:\Users\admin>ftp
    ftp> debug
    Debug di On in corso...
    ftp> open 192.168.3.66
    Connesso a 192.168.3.66.
    220 ftp miosito
    Utente (192.168.3.66:(none)): test
    ---> USER test
    331 Password required for test
    Password:
    ---> PASS test
    230 Logged on
    ftp> hash
    Stampa del marcatore hash On ftp: (2048 byte/hash mark) .
    ftp> bin
    ---> TYPE I
    200 Type set to I
    ftp> put c:\905-656-2.pdf
    ---> PORT 192,168,222,37,223,36
    200 Port command successful
    ---> STOR 905-656-2.pdf
    150 Opening data channel for file transfer.
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ############################################################
    Connessione chiusa dall'host remoto.
    ftp>

     

    Per spostare questo file di 900Kb ha impiegato quasi 2 ore, nel frattempo hanno lavorato anche altri passando anche file di svariati mega senza avere problema.....

    giovedì 14 luglio 2011 10:27
  • Buongiorno obiwan..scusa se rispondo adesso..

    Ho effettuato una connessione come da te specificata, questo è il risultato:

    C:\Users\admin>ftp
    ftp> debug
    Debug di On in corso...
    ftp> open 192.168.3.66
    Connesso a 192.168.3.66.
    220 ftp miosito
    Utente (192.168.3.66:(none)): test
    ---> USER test
    331 Password required for test
    Password:
    ---> PASS test
    230 Logged on
    ftp> hash
    Stampa del marcatore hash On ftp: (2048 byte/hash mark) .
    ftp> bin
    ---> TYPE I
    200 Type set to I
    ftp> put c:\905-656-2.pdf
    ---> PORT 192,168,222,37,223,36
    200 Port command successful
    ---> STOR 905-656-2.pdf
    150 Opening data channel for file transfer.
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ############################################################
    Connessione chiusa dall'host remoto.
    ftp>

     

    Per spostare questo file di 900Kb ha impiegato quasi 2 ore, nel frattempo hanno lavorato anche altri passando anche file di svariati mega senza avere problema.....

    Ciao, nessun problema, tutto sommato... ognuno di noi ha i propri impegni

    Tornando al discorso FTP; a quanto sembra la sessione viene avviata regolarmente ed il trasferimento parte correttamente (come evidenziato dai marcatori di trasferimento - comando "hash") solo che si verificano due problemi che, sospetto, siano correlati, ossia

    1. Il server disconnette il client, probabilmente a causa di timeout di sessione

    2. Il trasferimento tra il server e QUEL client è lentissimo mentre altri trasferimenti hanno una velocità normale e non hanno problemi

    ora, sospetto che il punto 2 causi poi il problema di cui al punto 1, ossia, data la lentezza del trasferimento ed il lungo tempo richiesto, il server forza la disconnessione del client causa timeout

    Sarebbe opportuno ripetere il test di cui sopra tenendo sotto controllo anche il log di filezilla server (avvia la console e controlla se la disconnessione avviene causa timeout o in ogni caso per quale motivo avvenga); inoltre, sempre in filezilla server, verifica quali siano le impostazioni relative ai timeouts e controlla inoltre se, relativamente all'IP di quel client o a quell'account utente (o gruppo) siano state impostate delle regole di limitazione di banda

     

    • Contrassegnato come risposta Anca Popa mercoledì 20 luglio 2011 06:47
    giovedì 14 luglio 2011 10:40
  • Già che ci siamo; in filezilla server console

    click su users, seleziona "add"

    nome utente "usrtest"

    gruppo utente nessuno

    conferma

    spunta su enable e su password

    imposta la password desiderata

    shared folders

    add, seleziona la cartella desiderata

    imposta la cartella come home, metti la spunta su tutti i diritti

    speed limits

    metti la spunta su "bypass" per upload e download

    conferma con ok

    clicca sulle impostazioni del server

    in "general" annotati i valori relativi ai timeouts (connection, no transfer e login), imposta connection e no transfer a zero, imposta login a 120 e conferma

    ora, ritenta il trasferimento (come da istruzioni precedenti) loggandoti con le credenziali dell'utente appena creato e tenendo anche sotto controllo la console di filezilla server in modo da vedere eventuali messaggi di timeout o errore relativi alla sessione

    fai sapere

     

    • Contrassegnato come risposta Anca Popa mercoledì 20 luglio 2011 06:47
    giovedì 14 luglio 2011 10:50
  • Ciao francesco,
    Il tuo thread è ancora aperto. Sei riuscito a fare qualche prova, potresti per cortesia farci sapere com’è andata?

    Il tuo feedback potrebbe aiutare gli altri utenti del forum che si trovano nello stesso scenario.

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    lunedì 18 luglio 2011 08:29