locked
7x64 - Rimozione Sicura - Nel 90% dei casi mi è inutile... consigli ? RRS feed

  • Domanda

  • Ho trovato questo infinito thread tramite google ora bloccato:

    http://social.technet.microsoft.com/Forums/windows/it-IT/703d58e6-b7d1-4525-8985-6f6e2b99b6a2/cannot-eject-removable-usb-drive?Thread%3A703d58e6-b7d1-4525-8985-6f6e2b99b6a2=Microsoft.Forums.Data.Models.Discussion&ThreadViewModel%3A703d58e6-b7d1-4525-8985-6f6e2b99b6a2=Microsoft.Forums.CachedViewModels.ThreadPageViewModel&forum=w7itprogeneral

    Ho lo stesso identico problema con il mio WD Element 500GB... in pratica ogni volta che lo collego al PC e lo uso (tipo ci copio qualche file o roba del genere) poi la rimozione sicura non funziona affatto!

    Appunto dice che la periferica non può essere arrestata perchè è in uso da un'altro programma!!

    E' un pò di giorni che provo a cercare una soluzione e tutto quello che c'è in quel link che ho postato sopra è la stessa identica situazione... tramite process explorer noto che gli stessi processi bloccano la mia periferica usb e non rendono possibile la rimozione sicura!!

    Ho anche provato ad usare/installare "Usb Safely Remover" ultima versione e anche quest'ultimo mi dice che trova quei processi che ne rendono impossibile la rimozione.............

    Sempre leggendo quel link ho trovato che dalla "Gestione disco" all'interno del "Gestione Computer" posso mettere la periferica "Offline" e appunto poi posso rimuoverla. Unico problema è che se poi la ricollego per renderla riutilizzabile devo rimetterla "Online".... cosa particolarmente fastidiosa!

    Nelle impostazioni della periferica, come suggerito sempre all'interno del thread, è già impostato per la rimozione rapida.... e posso inoltre aggiungere appunto che i 500GB sono in NTFS e non credo che il problema sia questo.

    A livello di Windows 7 X64 è totalmente aggiornato..... ho provato anche ad usare l'hd con il mio hd disattivato (pensando che magari quest'ultimo potesse bloccare la periferica) ma la cosa non risolve. Avevo fatto questa prova prima di scoprire quello indicato sopra nel link cioè che non è niente di esterno che blocca la periferica ma gli stessi processi indicati in quella discussione.

    Quella discussione, come viene detto, è andata avanti per due anni senza trovare una soluzione........ ora spero invece che qualcosa sia stato trovato.

    Un'altra cosa ad esempio che ho trovato che al momento di collegare l'hd esterno... non viene riconosciuto come HD esterno (come ad esempio succede per diverse altre mie pen drive) ma anche da computer viene aggiunto come periferica di sistema e in "Computer" viene aggiunta sotto ai miei HD interni.

    Può essere questo il problema ? Sapete darmi qualche dritta ?

    martedì 21 gennaio 2014 15:30

Tutte le risposte

  • Personalmente non ho mai utilizzato la rimozione sicura delle periferiche USB, serve solo a svuotare la cache per evitare di perdere dati.

    Se aspetti che la scrittura sia finita e il led non denoti attività non avrai mai problemi.

    Ciao


    Andrea Sistarelli
    MCT-MCITP-MCSE-MCTS-CCNA

    martedì 21 gennaio 2014 15:59
  • Ti basta modificare i criteri del disco e togliere l'utilizzo della cache.

    Oppure attendere lo spegnimento del led di attività.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    martedì 21 gennaio 2014 16:01
    Moderatore
  • Ma nemmeno su HD in NTFS ?? Ho letto che c'è il rischio di perdere i dati partizione............
    mercoledì 22 gennaio 2014 14:39
  • Rispondo qua perchè magari il post lo può notare anche Andrea :)

    Allora come ti dicevo se per la cache intendi settare l'opzione in "Rimozione Rapida" nelle opzioni ho già controllato ed è già cosi settata (ho anche provato a attivare la cache poi disattivarla per assurdo).

    Sempre per Andrea appunto aggiungo che il led di attività, nel mio caso, lampeggia ed è lo stesso che segna l'alimentazione................ non è che mi fidi molto a staccare al volo la periferica soprattuto con il mio hd che già anni passati mi ha fatto perdere un bel pò di dati causa partizione saltata.

    mercoledì 22 gennaio 2014 14:42
  • Come ti ho risposto nella Community:

    La rimozione Rapida DEVE essere ATTIVATA , nei criteri , con il pallino relativo.

    Così NON ci sarà mai alcun problema di rimozione sicura.

    Né danno agli indici.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    mercoledì 22 gennaio 2014 14:43
    Moderatore