none
Windows Server 2008 problema visualizzazione Link Simbolici RRS feed

  • Domanda

  • Buongiorno, a seguito di una segnalazione di mancato backup su un DC WS2008 sono andato a verificare il problema. Dai log risulta un problema di accesso ad una cartella che, di fatto è un Link Simbolico.

    Ho notato che i due collegamenti, che normalmente sono nascosti, sono visibili e nonostante l'applicazione del flag "nascondi file di sistema..." rimangonovisibili. Le cartelle sono "Document and Setting" e "Programmi" come da screen di seguito.

    Se utilizzo il comando dir /aL vedo che i link sono corrispondenti alle relative cartelle ma non sono riuscito a trovare altro.

    Qualche sugerimento...

    Saluti

    Nino

    giovedì 30 agosto 2012 11:55
    Moderatore

Risposte

  • sarebbe utile verificare quali chiavi di registro modifica o aggiunge l'installer di questo TSplus


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Ottima idea. Eventualmente riparto da una snap e reinstallo l'applicativo.

    Saluti

    Nino

    ALL IN su  Edoardo.

    Quelli di TSplus hanno un prodotto free che avranno sicuramente introdotto in quello a pagamento... vedi sotto:

    TSplus Hide Server Drives tool enables the Terminal Services (TSE) or Citrix administrator to easily hide the server disk drives when users open a remote session. TSplus Hide Server Drives does more than just hide the TS server drives. It also hides all of the root folders and the user profile folders of the 2003/2008 TS server. Doing so, a user browsing files within a session will see nothing: neither the server drives, nor any of the other users "Document and Settings" folders, system and data files. TSplus Hide Server Drives is a very easy to use, efficient and smart program to secure your TSE or Citrix server drives (Windows 2008, Windows 2003 or W2000 servers).


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    sabato 15 settembre 2012 19:18
    Moderatore
  • sarebbe utile verificare quali chiavi di registro modifica o aggiunge l'installer di questo TSplus

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    sabato 15 settembre 2012 07:22
    Moderatore

Tutte le risposte

  • non ho ben capito.

    le cartelle rappresentate dal link simbolico sono quelle che dovrebbero essere backuppate ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    giovedì 30 agosto 2012 12:19
    Moderatore
  • Ciao Edoardo, Backup Exec segnala un problema di accesso alla cartella "Docum...and..", di fatto vorrei capire perche i due link rimangono visibili.

    Saluti

    Nino

    giovedì 30 agosto 2012 12:32
    Moderatore
  • non capisco il nesso che attribuisci al problema del backup rispetto al fatto che i link siano visibili comunque quali sono gli attributi dei link e quali quelli delle cartelle ?

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    venerdì 31 agosto 2012 07:53
    Moderatore
  • Ciao Edoardo, scusa il ritardo.

    In pratica il job dibackup si blocca, per problemi di accesso, sui collegamenti, che normalmente sono nascosti, Documents and Settings e Programmi. La cosa strana e che questi collegamenti rimangono sempre visibili.

    Di seguito le screen con i permessi delle cartelle.

    martedì 4 settembre 2012 10:41
    Moderatore
  • non capisco perchè dici che quei collegamenti dovrebbero essere non visibili.

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    mercoledì 5 settembre 2012 10:15
    Moderatore
  • Negli altri server, con stesso sistema operativo, i link possono essere nascosti (normalmente lo sono) su questi due server invece qualsiasi impostazione utilizzi rimangono semprevisibili. 

    mercoledì 5 settembre 2012 11:00
    Moderatore
  • l'immagine che hai inserito nel primo post da quale visualizzazione l'hai presa ? perchè io non mi trovo una situazione analoga sui miei server.

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    giovedì 6 settembre 2012 08:43
    Moderatore
  • Io ho la stessa situazione quando entro nel volume di boot ed abilito la visualizzazione dei file nascosti: quei junction points risultano effettivamente nascosti per impostazione predefinita.

    http://msdn.microsoft.com/en-us/library/windows/desktop/bb968829(v=vs.85).aspx

    Tuttavia potrebbe essere normale che Backup Exec non riesca ad accedere alla cartella perchè di default l'accesso è negato per tutti gli utenti, tuttavia è vero che teoricamente dovrebbe ignorare direttamente quei junction points, quindi potresti provare a ricostruirli seguendo le indicazioni contenute in questo articolo:

    http://support.microsoft.com/kb/968178

    Una volta ricostruiti e impostati i privilegi corretti Backup Exec dovrebbe ignorare i junction points come prima.




    giovedì 6 settembre 2012 12:34
    Moderatore
  • l'immagine che hai inserito nel primo post da quale visualizzazione l'hai presa ? perchè io non mi trovo una situazione analoga sui miei server.

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org


    E' la screen del disco di sistema da cui ho estrapolato le parti interessate (quelle evidenziate con la linea rossa)

    giovedì 6 settembre 2012 17:17
    Moderatore
  • Io ho la stessa situazione quando entro nel volume di boot ed abilito la visualizzazione dei file nascosti: quei junction points risultano effettivamente nascosti per impostazione predefinita.

    Il problema è proprio questo, pur attivando la spunta per nascondere i files di sistema rimangono visibili.

    Ho notato la cosa a seguito di una segnalazione di mancato accesso da parte di Backup Exec ( per ovviare ho momentaneamente eliminato la folder user dal backup :) ). Adesso verifico i link e martedì faccio qualche prova direttamente on-site e vi aggiorno.

    Saluti

    Nino

    giovedì 6 settembre 2012 17:24
    Moderatore
  • Aggiornamento: Avevvo un sospetto, quindi ieri mattina ho parzialmente replicato l'ambiente su una VM.

    Sistema Operativo WS2008R2 (quello del cliente è un WS2008), aggiornamenti ed attivazione dominio. A questo punto ho installato lo stesso programma che avevo installato dal cliente (ma la nuova versione) che permette di effettuare sessione RDS attraverso il client Microsoft o Browser. Il programma in questione si chiama TSPlus.

    Anche su questo server sono magicamente apparsi i punti di giunzione Document and Setting e Programmi.

    Ho chiesto al distributore italiano di informarsi con la casa madre se questo è un bug in quanto, anche disinstallando il programma i punti rimangono visibili come ho spiegato nei precedenti post.

    Saluti

    Nino

    sabato 15 settembre 2012 04:29
    Moderatore
  • sarebbe utile verificare quali chiavi di registro modifica o aggiunge l'installer di questo TSplus

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    sabato 15 settembre 2012 07:22
    Moderatore
  • Hai provato anche a ricreare i junction points seguendo l'articolo? Giusto per curiosità....
    sabato 15 settembre 2012 17:32
    Moderatore
  • Hai provato anche a ricreare i junction points seguendo l'articolo? Giusto per curiosità....

    Quel server gestisce due applicativi di un'intero stabilimento di produzione. Ho preferito prima simulare la situazione su un server di test installando l'ultimo applicativo, nei prossimigiorni aspetto qualche risposta dal produttore ed applico la correzione che mi hai suggerito.

    Saluti

    Nino

     
    sabato 15 settembre 2012 18:20
    Moderatore
  • sarebbe utile verificare quali chiavi di registro modifica o aggiunge l'installer di questo TSplus

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Ottima idea. Eventualmente riparto da una snap e reinstallo l'applicativo.

    Saluti

    Nino

    sabato 15 settembre 2012 18:22
    Moderatore
  • sarebbe utile verificare quali chiavi di registro modifica o aggiunge l'installer di questo TSplus


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    Ottima idea. Eventualmente riparto da una snap e reinstallo l'applicativo.

    Saluti

    Nino

    ALL IN su  Edoardo.

    Quelli di TSplus hanno un prodotto free che avranno sicuramente introdotto in quello a pagamento... vedi sotto:

    TSplus Hide Server Drives tool enables the Terminal Services (TSE) or Citrix administrator to easily hide the server disk drives when users open a remote session. TSplus Hide Server Drives does more than just hide the TS server drives. It also hides all of the root folders and the user profile folders of the 2003/2008 TS server. Doing so, a user browsing files within a session will see nothing: neither the server drives, nor any of the other users "Document and Settings" folders, system and data files. TSplus Hide Server Drives is a very easy to use, efficient and smart program to secure your TSE or Citrix server drives (Windows 2008, Windows 2003 or W2000 servers).


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    sabato 15 settembre 2012 19:18
    Moderatore
  • ALL IN su  Edoardo.


    siamo troppo in ambito "poker holdem" - cosa vinco ? :-D

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    sabato 15 settembre 2012 19:33
    Moderatore
  • ALL IN su  Edoardo.
    siamo troppo in ambito "poker holdem" - cosa vinco ? :-D


    Si parla di link simbolici, cosa vuoi che vinciamo se non dei regali simbolici. Anzi neanche quelli!  :(

    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    sabato 15 settembre 2012 20:10
    Moderatore
  • In effetti il programma si comporta cosi come riportato nella descrizione che hai postato. Mi sarei aspettato un ripristino dello stato precedente dopo la disinstallazione, invece mi ha bloccato i backup.

    Saluti

    Nino

    sabato 15 settembre 2012 20:26
    Moderatore
  • Nino riesci a chiudere il 3d?

    Io non riesco a marcare le risposte.

    Grazie e ciao

    Gas


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    lunedì 22 ottobre 2012 16:03
    Moderatore
  • Nino riesci a chiudere il 3d?

    Io non riesco a marcare le risposte.

    Fabrizio ha modificato il 3D ha modificato il 3D, credo sia questo il motivo.

    Saluti

    Nino 

    lunedì 22 ottobre 2012 16:20
    Moderatore
  • Si, lo avevo convertito in discussione in attesa di aggiornamenti. Ora lo riconverto in domanda.
    lunedì 22 ottobre 2012 16:52
    Moderatore
  • Grazie Nino!

    Io avevo fatto ALL IN su Edoardo e non su me!!

    Ciao

    Gas


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    lunedì 22 ottobre 2012 20:40
    Moderatore