none
Impossibile Accedere a Windows 2003 RRS feed

  • Domanda

  • Salve,

    ho un problema con l'appena trapassato W2k3 :-( 

    In un primo momento il sistema non si avvia. Appena apparso lo schermo grigio va per qualche decimo di secondo in BSOD con l'errore

    STOP: c000021a {Fatal System Error}
    The Windows Logon Process system process terminated unexpectedly with a status of 0xc0000080 (0x00000000 0x0000000)
    The system has been shutdown.

    Come suggerito su internet provo a sostituire Winlogon, Csrss ed Explorer.exe e .scf come unico risultato ottengo che non appare più lo schermo grigio e il BSOD ma diventa nero e rimane piantato cosi.

    Ho tentato alcune scansioni antivirus da Hiren's 15.2 ma senza alcun risultato.

    Qualcuno ha dei suggerimenti da darmi?

    Grazie in Anticipo

    Ciao

    Gonario


    • Modificato Gonario lunedì 20 luglio 2015 10:49
    lunedì 20 luglio 2015 09:48

Risposte

  • Purtroppo, come diceva anche Alessandro precedentemente, non sempre le cose si possono risolvere "facilmente". Secondo me devi cambiare host e se il problema persiste l'unica cosa da fare è ripristinare da un backup o reinstallare tutto recuperando i dati dal disco virtuale.

    In effetti con l'occasione puoi togliere il 2003 visto che è anche un'installazione virtuale.

    mercoledì 22 luglio 2015 11:39
    Moderatore

Tutte le risposte

  • Ciao,

    Hai provato in safe mode o la "last known good configuration"?

    Se non funziona neanche con quelle puoi provare una "repair installation". parti da CD, poi ad un certo punto ti chiede se vuoi riparare l'installazione


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti


    • Modificato aperelli lunedì 20 luglio 2015 09:52
    lunedì 20 luglio 2015 09:50
  • Ciao, perchè dai per scontato che sia un problema di sistema operativo? Io partirei prima di tutto dall'hardware...iniziando a staccare banchi di ram e compagnia bella...il BSOD è indicativo di qualcosa che non comunica correttamente con il livello zero...

    Secondo ma  il problema sta li e non sul sistema...

    ciao.

    A.

    lunedì 20 luglio 2015 10:06
    Moderatore
  • In effetti potrebbe, senza bugcheck code peró é difficie dirlo.

    @Gonario:

    potresti postare il codice di errore?


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    lunedì 20 luglio 2015 10:11
  • Ciao,

    Hai provato in safe mode o la "last known good configuration"?

    Se non funziona neanche con quelle puoi provare una "repair installation". parti da CD, poi ad un certo punto ti chiede se vuoi riparare l'installazione


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti


    Non mi da la possibilità di arrivarci, F8 non funziona.

    Ho paura a provare la repair installation soprattutto ora che il sistema operativo non ha più supporto; diciamo che la tengo come ultima arma disponibile

    lunedì 20 luglio 2015 10:11
  • Ciao, perchè dai per scontato che sia un problema di sistema operativo? Io partirei prima di tutto dall'hardware...iniziando a staccare banchi di ram e compagnia bella...il BSOD è indicativo di qualcosa che non comunica correttamente con il livello zero...

    Secondo ma  il problema sta li e non sul sistema...

    ciao.

    A.

    Dimenticavo di dire che è una macchina virtuale.
    lunedì 20 luglio 2015 10:12
  • In effetti potrebbe, senza bugcheck code peró é difficie dirlo.

    @Gonario:

    potresti postare il codice di errore?


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    Fatto, ho corretto il post iniziale, non mi ero accorto dell'errore; mi scuso

    lunedì 20 luglio 2015 10:50
  • Hai gia' visto questo articolo?

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    lunedì 20 luglio 2015 10:56
  • Hai gia' visto questo articolo?

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    si ne ho visto uno simile, ma il mio problema che il so non si avvia proprio, andando a guardare il registro con una live la dll GINA sembra apposto...
    lunedì 20 luglio 2015 11:58
  • Sull'host sono in esecuzione anche altre macchine virtuali oltre a questa? Se si, funzionano correttamente?


    lunedì 20 luglio 2015 12:24
    Moderatore
  • Visto che é una VM, non ti conviene montarti il vhd, prenderti i dati che ti servono e rifare la macchina? (o provare la repair)

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    lunedì 20 luglio 2015 12:24
  • ...scusa la domanda ovvia. Parlando di Macchina Virtuale non hai un backup? Altra domanda, sull'Host su cui è eseguita la Macchina Virtuale, o comunque dove è memorizzato il disco riscontri errori od eventi particolari?

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    lunedì 20 luglio 2015 12:25
    Moderatore
  • Sull'host sono in esecuzione anche altre macchine virtuali oltre a questa? Se si, funzionano correttamente?


    No solo questa
    lunedì 20 luglio 2015 12:35
  • Visto che é una VM, non ti conviene montarti il vhd, prenderti i dati che ti servono e rifare la macchina? (o provare la repair)

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    Ci sono diversi applicativi che non vorrei risettare da capo
    lunedì 20 luglio 2015 12:37
  • ...scusa la domanda ovvia. Parlando di Macchina Virtuale non hai un backup? Altra domanda, sull'Host su cui è eseguita la Macchina Virtuale, o comunque dove è memorizzato il disco riscontri errori od eventi particolari?

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    Purtroppo no, lo stavamo giusto preparando.

    No niente di anormale

    lunedì 20 luglio 2015 12:39
  • Sull'host sono in esecuzione anche altre macchine virtuali oltre a questa? Se si, funzionano correttamente?


    No solo questa

    Allora per prima cosa io proverei a copiare l'intera macchina virtuale su un altro host. Giusto per escludere eventuali problemi legati all'hardware fisico.

    Se il comportamento è esattamente lo stesso, prova ad eseguire su questa macchina virtuale di copia una installazione di Windows Server 2003 in modalità aggiornamento.

    lunedì 20 luglio 2015 13:30
    Moderatore
  • Sull'host sono in esecuzione anche altre macchine virtuali oltre a questa? Se si, funzionano correttamente?


    No solo questa

    Allora per prima cosa io proverei a copiare l'intera macchina virtuale su un altro host. Giusto per escludere eventuali problemi legati all'hardware fisico.

    Se il comportamento è esattamente lo stesso, prova ad eseguire su questa macchina virtuale di copia una installazione di Windows Server 2003 in modalità aggiornamento.

    Purtroppo non ho altri host con abbastanza spazio...
    martedì 21 luglio 2015 07:12
  • Gonario, abbiamo capito, però se non puoi mettere mano all'hardware, non puoi spostare host, non vuoi tentare il repair ci fermiamo qui. Noi possiamo dare suggerimenti, non fare miracoli. Con una VM bloccata in questo modo i passi da seguire sono quelli suggeriti. Poi siamo sistemisti se ci fermiamo davanti ad un reinstall degli applicativi di un server che non parte..un server non può vivere per sempre, se salta dobbiamo reinstallare e pace..è il nostro lavoro no?

    Ciao.

    A.

    martedì 21 luglio 2015 07:56
    Moderatore
  • Gonario, abbiamo capito, però se non puoi mettere mano all'hardware, non puoi spostare host, non vuoi tentare il repair ci fermiamo qui. Noi possiamo dare suggerimenti, non fare miracoli. Con una VM bloccata in questo modo i passi da seguire sono quelli suggeriti. Poi siamo sistemisti se ci fermiamo davanti ad un reinstall degli applicativi di un server che non parte..un server non può vivere per sempre, se salta dobbiamo reinstallare e pace..è il nostro lavoro no?

    Ciao.

    A.

    Hai ragione, ma la speranza di una soluzione indolore è sempre l'ultima a morire
    martedì 21 luglio 2015 08:16
  • ok...ma da solo non si sistema sicuro...se non segui qualche passo suggerito...di li non ti schiodi. 

    Vedi tu...

    Ciao!

    A.

    martedì 21 luglio 2015 08:19
    Moderatore
  • Ciao Gonario, ti posso consigliare di ripristinare i file che hai sostituito per rimetterti nelle condizioni iniziali. Poi rifarei la scansione del sistema con un livecd symantec, se hai licenza, o di altri produttori nominati che vorrai. La scansione e la rimozioni di eventuale software malevolo potrebbe già risolverti il problema. Parallelamente se drwatson è attivo nelle modalità corretta, preleva sempre con un livecd (visto che l'f8 non funziona) il file user.dmp ed analizzalo con userdump.exe; in effetti alcuni ransomware alterano su xp/2003 il funzionamento dell'f8.

    martedì 21 luglio 2015 08:29
  • Nel caso in cui il dump sia stato generato sarebbe c:\windows\memory.dmp, che puó essere un minidump (default su 2k3), un kernel dump o un full memory dump.

    userdump.exe per quanto ne so serve a ottenere il dump di un processo in user-space.


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti


    • Modificato aperelli martedì 21 luglio 2015 08:33
    martedì 21 luglio 2015 08:33
  • in questi casi, user.dmp viene creato da drwatson se attivo
    lo user.dmp si può analizzare con dumpexam

    inoltre, tirerei giu i file .dat presenti in %SystemRoot%\System32\Config\
    per capire se msgina.dll è stata sostituita

    martedì 21 luglio 2015 08:52
  • no, drwatson crea i dump per i crash applicativi in user-space, quando la macchina va in BSOD significa che il "crash" e' avvenuto nel kernel-space.

    "Dr. Watson for Windows is a program error debugger that gathers information about your computer when an error (or user-mode fault) occurs with a program."

    REF: https://support.microsoft.com/en-us/kb/308538

    A mio parere il modo migliore di analizzare un dump é utilizzare windbg


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti


    • Modificato aperelli martedì 21 luglio 2015 08:57
    martedì 21 luglio 2015 08:57
  • Purtroppo non ho altri host con abbastanza spazio...

    Nemmeno una workstation? Al limite va bene anche un portatile per fare i test di ripristino della VM.

    Se parli di spazio insufficiente temo che tu abbia un file di hard disk virtuale unico per dati e sistema operativo e questo non è il massimo della flessibilità....ma di quali dimensioni stiamo parlando?

    In ogni caso è rischioso agire direttamente su una VM così problematica, una copia in un ambiente separato in cui eseguire tutti i test a mio parere è d'obbligo. Soprattutto considerando che (se non sbaglio) avevi detto di non avere nemmeno un backup dei dati contenuti.

    Qual è l'hypervisor che utilizzi? Hyper-V, VMWare, ecc...

    martedì 21 luglio 2015 09:39
    Moderatore
  • lo stop 21a in bsod, viene generato dal kernel se i processi di logon tornano errore
    sui processi di logon drwatson, se attivato li dumpa

    questi sono primi step di troubleshooting
    anche consigliati da ms per lo stop 21a

    bye

    martedì 21 luglio 2015 10:20
  • in questo caso specifico hai ragione sul fatto che l'errore é in user-space:

    https://msdn.microsoft.com/en-us/library/windows/hardware/ff560177%28v=vs.85%29.aspx

    @Gonario: il link sopra ti puó essere utile

    correggo il mio statement "ma se winlogon e csrss non sono attivi dubito che drwatson possa partire", in effetti si parte dal presupposto che partano e POI vadano in crash, beh lascio l'articolo che spiega sicuramente meglio:


    REF: https://support.microsoft.com/en-us/kb/156669


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti





    • Modificato aperelli martedì 21 luglio 2015 10:44
    martedì 21 luglio 2015 10:27
  • Purtroppo non ho altri host con abbastanza spazio...

    Nemmeno una workstation? Al limite va bene anche un portatile per fare i test di ripristino della VM.

    Se parli di spazio insufficiente temo che tu abbia un file di hard disk virtuale unico per dati e sistema operativo e questo non è il massimo della flessibilità....ma di quali dimensioni stiamo parlando?

    In ogni caso è rischioso agire direttamente su una VM così problematica, una copia in un ambiente separato in cui eseguire tutti i test a mio parere è d'obbligo. Soprattutto considerando che (se non sbaglio) avevi detto di non avere nemmeno un backup dei dati contenuti.

    Qual è l'hypervisor che utilizzi? Hyper-V, VMWare, ecc...

    Un TB, VMWare...

    Ho tentato un repair ed ora, durante l'installazione, mi da come errore "numero di dati eccessivo per essere contenuti nel bufer specificato

    martedì 21 luglio 2015 10:47
  • ma non è che hai esaurito lo spazio nel datastore? o magari hai degli snapshots che te lo saturano?
    martedì 21 luglio 2015 10:50
    Moderatore
  • ma non è che hai esaurito lo spazio nel datastore? o magari hai degli snapshots che te lo saturano?
    no ho 500MB disponibili
    martedì 21 luglio 2015 11:06
  • guarda che non sono nulla 500mb su un datastore da 1Tb...per me la macchina non ha più spazio per i file di swap, ci deve essere almeno un 2-3% libero altrimenti si pianta tutto. Per me il problema è li.
    martedì 21 luglio 2015 11:10
    Moderatore
  • guarda che non sono nulla 500mb su un datastore da 1Tb...per me la macchina non ha più spazio per i file di swap, ci deve essere almeno un 2-3% libero altrimenti si pianta tutto. Per me il problema è li.
    Intendevo GB... scusa
    • Modificato Gonario martedì 21 luglio 2015 11:56
    martedì 21 luglio 2015 11:52
  • Rimetti i files originali (winlogon & Co.), probabilmente il nuovo comportamento é dovuto al fatto che sono una versione diversa rispetto a quelli originali.

    Una volta fatto aggiungi una linea la boot.ini identica a quella gia' presente aggiungendo "/safeboot:minimal /sos /bootlog /noguiboot"

    Cosi' facendo al riavvio dovresti avere la possibilita' di scegliere il safe mode dal boot menu.

    REF: Safe-Mode Boot Switches for Windows Boot.ini File



    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti


    • Modificato aperelli martedì 21 luglio 2015 12:24
    martedì 21 luglio 2015 12:23
  • Rimetti i files originali (winlogon & Co.), probabilmente il nuovo comportamento é dovuto al fatto che sono una versione diversa rispetto a quelli originali.

    Una volta fatto aggiungi una linea la boot.ini identica a quella gia' presente aggiungendo "/safeboot:minimal /sos /bootlog /noguiboot"

    Cosi' facendo al riavvio dovresti avere la possibilita' di scegliere il safe mode dal boot menu.

    REF: Safe-Mode Boot Switches for Windows Boot.ini File



    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti


    Provato anche in safe mode torno allo schermo blu
    mercoledì 22 luglio 2015 08:53
  • Potresti provare in safe mode con coomand prompt ma fossi in te farei una copia dei dischi virtuali anche su USB e proverei una repair, poco sopra dicevi che l'avresti lasciata come ultima arma disponibile, credo sia ora di usarla.

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    mercoledì 22 luglio 2015 09:03
  • Potresti provare in safe mode con coomand prompt ma fossi in te farei una copia dei dischi virtuali anche su USB e proverei una repair, poco sopra dicevi che l'avresti lasciata come ultima arma disponibile, credo sia ora di usarla.

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    Ho provato la repair ma ora mi da un errore  "numero di dati eccessivo per essere contenuti nel bufer specificato" e non prosegue con l'installazione
    mercoledì 22 luglio 2015 10:38
  • Rifai la macchina, potrebbe essere infetta

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    mercoledì 22 luglio 2015 11:12
  • Rifai la macchina, potrebbe essere infetta

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    :-) dopo lungo discutere...direi..dai anche un occhio all'hardware come suggerito da me e Fabrizio...e magari già che la rifai...manda in pensione il 2003...

    Ciao!

    A.

    mercoledì 22 luglio 2015 11:16
    Moderatore
  • Purtroppo, come diceva anche Alessandro precedentemente, non sempre le cose si possono risolvere "facilmente". Secondo me devi cambiare host e se il problema persiste l'unica cosa da fare è ripristinare da un backup o reinstallare tutto recuperando i dati dal disco virtuale.

    In effetti con l'occasione puoi togliere il 2003 visto che è anche un'installazione virtuale.

    mercoledì 22 luglio 2015 11:39
    Moderatore
  • Anche io temo ci sia poco da fare...

    Aspetto le licenze 2012, non dovrebbero tardare, per rifarla

    venerdì 24 luglio 2015 08:42
  • il vhd riesci a copiarlo su un supporto esterno oppure ottieni errore ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    venerdì 24 luglio 2015 16:45
    Moderatore