none
Autodiscover Url couldn't be located RRS feed

  • Discussione generale

  • Ciao a tutti, sto provando ad utilizzare l' exchange webservices client con Office 365

    Ho sviluppato una piccola parte di sorgente per collegarmi ad Office 365 tramite l'autodiscover, il codice funziona, ma dalla terza richiesta in poi mi esce questo error :

    Autodiscover Url couldn't be located

    Ho abilitato il Tracing, vi lascio il report

    AutodiscoverConfiguration

    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:47:33Z">
    Trying to call Autodiscover for test123@test123123.onmicrosoft.com on https://test123123.onmicrosoft.com/autodiscover/autodiscover.xml.
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:47:33Z">
     failed: WebException (The remote name could not be resolved: 'test123123.onmicrosoft.com')
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:47:33Z">
    Trying to call Autodiscover for test123@test123123.onmicrosoft.com on https://autodiscover.test123123.onmicrosoft.com/autodiscover/autodiscover.xml.
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:47:38Z">
     failed: WebException (Unable to connect to the remote server)
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:47:38Z">
    Trying to get Autodiscover redirection URL from http://autodiscover.test123123.onmicrosoft.com/autodiscover/autodiscover.xml.
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:49:18Z">
    Request error: The operation has timed out
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:49:18Z">
    No Autodiscover redirection URL was returned.
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:49:18Z">
    Trying to get Autodiscover host from DNS SRV record for test123123.onmicrosoft.com.
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:49:18Z">
    DnsQuery returned error error 'DNS name does not exist' error code 0x0000232B.
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:49:18Z">
    No appropriate SRV record was found.
    </Trace>
    <Trace Tag="AutodiscoverConfiguration" Tid="1" Time="2014-03-31 08:49:18Z">
    No matching Autodiscover DNS SRV records were found.
    </Trace> 

    Qualcuno sa come "fixare" questo problema?

    • Tipo modificato Anca Popa venerdì 11 aprile 2014 07:03 thread inattivo
    venerdì 4 aprile 2014 08:10

Tutte le risposte