none
File creati da Users non accessibili da altri Users RRS feed

  • Domanda

  • Ho un'installazione nuova di Windows 2019 su cui ho trasferito un dominio preesistente che stava su un server Windows 2012 R2. Quando un utente della rete appartenente al gruppo Users crea un file su una cartella condivisa con i permessi di everyone, gli altri non riescono ad aprire il file. Andando a vedere le proprietà del file, i permessi vi sono solo per l'utente che ha creato il file e per il gruppo Administrators, ma non il gruppo Users di cui fanno parte tutti gli utenti. E' la prima volta che mi capita, e non so dove andare a parare... Grazie! 


    Ing. Zuffi Massimiliano

    lunedì 24 agosto 2020 13:52

Risposte

  • I permessi sono a posto? verifichiamolo

    Riporta l'output dei seguenti comandi

    icacls c:\nome\della\share\condivisa 
    icacls c:\nome\della\share\condivisa\fileCreatodallutente.txt 

    icacls c:\nome\della\share\condivisa /T


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    lunedì 24 agosto 2020 21:12
    Moderatore
  • Lanciando i comandi che mi hai indicato ho visto che c'erano diverse cartelle che avevano solo il gruppo Administrators e l'utente che le aveva create. La cosa strana è che riapplicando i permessi di sicurezza dalle impostazione avanzate (aggiungendo i permessi per il gruppo Domain Users ed applicando la modifica ai tutti i i file e sottocartelle) solo il primo livello di cartelle prendeva i permessi giusti, mentre le sottocartelle no. Per risolvere, alla fine, sono andato in sicurezza, modifica, e li ho tolto e rimesso i permessi al gruppo Domain Users, e da li sembrerebbere che i permessi siano stati correttamente settati a tutte le cartelle dei livelli sottostanti al primo. Ho fatto fare delle prove al cliente e sembrebbe a posto.

    Grazie a tutti!

     

    Ing. Zuffi Massimiliano

    martedì 25 agosto 2020 15:47
  • Grazie, ma le permissions sono già a posto, sia a livello di share che a livello di file system. Il problema però lo ho quando vengono creati dei nuovi file da Users in rete: questi non prendono i permessi di Users o Everyone, ma solo dell'utente che l'ha creato e del gruppo Administrators. Se le permissions non fossero a posto, probabilmente nessun utente riuscirebbe a creare file su quelle condivisioni. Faccio il sistemista da quasi 20 anni, e una roba così non mi era mai capitata!

     

    Ing. Zuffi Massimiliano

    CVD i permission non erano corrette...

    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    martedì 25 agosto 2020 20:51
    Moderatore

Tutte le risposte

  • Devi cambiare i permessi ntfs della cartella condivisa.

    Ci sono due livelli di permessi quelli a livello share e quelli del File System

    Ecco quelli a livello di share

    questi sono quelli ntfs sul FS

    Premetto che non tollero le share everyone full control (almeno domain users...) se riesci a riprodurre la situazione come nelle img sopra, vedrai che la tuashare funzionerà "normalmente"

    Questa miniguida ti può aiutare a capire, non sembra fatta male

    https://exploitnetworking.com/microsoft/i-permessi-ntfs-in-windows


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    lunedì 24 agosto 2020 18:33
    Moderatore
  • Grazie, ma le permissions sono già a posto, sia a livello di share che a livello di file system. Il problema però lo ho quando vengono creati dei nuovi file da Users in rete: questi non prendono i permessi di Users o Everyone, ma solo dell'utente che l'ha creato e del gruppo Administrators. Se le permissions non fossero a posto, probabilmente nessun utente riuscirebbe a creare file su quelle condivisioni. Faccio il sistemista da quasi 20 anni, e una roba così non mi era mai capitata!

     

    Ing. Zuffi Massimiliano

    lunedì 24 agosto 2020 21:02
  • I permessi sono a posto? verifichiamolo

    Riporta l'output dei seguenti comandi

    icacls c:\nome\della\share\condivisa 
    icacls c:\nome\della\share\condivisa\fileCreatodallutente.txt 

    icacls c:\nome\della\share\condivisa /T


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    lunedì 24 agosto 2020 21:12
    Moderatore
  • Puoi utilizzare https://gallery.technet.microsoft.com/scriptcenter/Set-Owner-ff4db177 è uno script in PowerShell
    martedì 25 agosto 2020 14:04
  • Lanciando i comandi che mi hai indicato ho visto che c'erano diverse cartelle che avevano solo il gruppo Administrators e l'utente che le aveva create. La cosa strana è che riapplicando i permessi di sicurezza dalle impostazione avanzate (aggiungendo i permessi per il gruppo Domain Users ed applicando la modifica ai tutti i i file e sottocartelle) solo il primo livello di cartelle prendeva i permessi giusti, mentre le sottocartelle no. Per risolvere, alla fine, sono andato in sicurezza, modifica, e li ho tolto e rimesso i permessi al gruppo Domain Users, e da li sembrerebbere che i permessi siano stati correttamente settati a tutte le cartelle dei livelli sottostanti al primo. Ho fatto fare delle prove al cliente e sembrebbe a posto.

    Grazie a tutti!

     

    Ing. Zuffi Massimiliano

    martedì 25 agosto 2020 15:47
  • Grazie tanto per il consiglio, ma ho risolso da interfaccia grafica. Col comando che mi hai consigliato mi dava errore (non so se dovuto al fatto che dovevo dare la proprietà ad un gruppo di utenti di un dominio AD), ma credo che, nel caso in cui non fossi riuscito, sarebbe potuto essere risolutivo.

    Ing. Zuffi Massimiliano

    martedì 25 agosto 2020 15:49
  • Grazie, ma le permissions sono già a posto, sia a livello di share che a livello di file system. Il problema però lo ho quando vengono creati dei nuovi file da Users in rete: questi non prendono i permessi di Users o Everyone, ma solo dell'utente che l'ha creato e del gruppo Administrators. Se le permissions non fossero a posto, probabilmente nessun utente riuscirebbe a creare file su quelle condivisioni. Faccio il sistemista da quasi 20 anni, e una roba così non mi era mai capitata!

     

    Ing. Zuffi Massimiliano

    CVD i permission non erano corrette...

    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    martedì 25 agosto 2020 20:51
    Moderatore
  • Grazie tanto per il consiglio, ma ho risolso da interfaccia grafica. Col comando che mi hai consigliato mi dava errore (non so se dovuto al fatto che dovevo dare la proprietà ad un gruppo di utenti di un dominio AD), ma credo che, nel caso in cui non fossi riuscito, sarebbe potuto essere risolutivo.

    Ing. Zuffi Massimiliano

    I comandi suggeriti erano solo per VEDERE come erano settate le permission, non avrebbero midificato nulla e non avrebbero risolto nulla.

    Volevo verificare la se i permessi erano davvero corretti come da te affermato "Grazie, ma le permissions sono già a posto, sia a livello di share che a livello di file system.", sospettavo che da qualche parte ci fosse nei permessi il "creator owner" (il comportamento che per la prima volta hai visto nella tua carriera, si usa per rendere i file accessibili al solo proprietario), ma già la tua tua risposta "mi dava errore" è significativa che non ci fosse l'everyone...  quindi quanto affermato non fosse corretto

    Se hai everyone sul file system o domain users il comando funziona sempre, in caso di errore avresti dovuto usare un prompt elevato di un utente con i permessi almeno di lettura sul FS.


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    martedì 25 agosto 2020 21:08
    Moderatore