DFS folders are hidden when viewing locally on server, or via admin share.


  • I have two Windows Server 2008 servers setup with DFS replication.  This was installed in July 2009 and has been working perfectly since that time.  A few weeks ago I noticed that the replicated folders are no longer visible from the server itself or through the admin share.  The DFSRoots folder appears empty.  The folders within DFS roots are "deeply hidden", I assume the attributes "system" and "hidden" are set.  I have three folders; Admin, Public, Users.  All three folders have the same behavior, and this behavior is consistent on both servers.

    The DFS continues to work fine as the files and folders are visible through the share and namespace.  I have noticed, however, that our backup (Backup Exec) only shows "DFSRoots" but nothing under it.  I'm assuming that the files are there, because our backup size has not changed.  I'm assuming these hidden attributes prevent me from seeing the folders/files even on our backup.  Just in case I'm wrong I have set up a SyncBack Pro job that backs up the entire DFSRoots folder to disk daily.  I have no clue if this problem is serious or not, and I don't have the luxury of deleting and recreating the DFS as this is in a production environment.  Any help is greatly appreciated!!
    venerdì 5 marzo 2010 14:34

Tutte le risposte

  • Hello,

    What account are you loging on to? Check your system and make sure ABE is not enabled. Go to server manager, file management, right clik the root share and see if ABE box is checked
    Isaac Oben MCITP:EA, MCSE
    venerdì 5 marzo 2010 14:43
  • I'm logging onto a domain administrator account.  I checked and "Enable access based enumeration" is not checked on the root share or any of the subfolders that are also shared.

    Thanks for your help!
    venerdì 5 marzo 2010 15:09
  • I should clarify, ABE was not enabled.  So the issue isn't related to ABE.
    venerdì 5 marzo 2010 15:49
  • Hi,

    If I understand correctly, the DFSRoots folder is empty when you access it locally on the namespace server (DFS root server). However, the folders (links) are visible if you access the namespace by using DFS share path, such as \\\dfsroot.

    Please help check the following:

    1. Do all namespace server encounter the issue?
    2. Do the DFS objects exist in AD domain partition? You can verify it by using adsiedit.msc, then navigate to Default naming context\CN=System\CN=Dfs-Configuration  
    3. Does AD replication work properly in the domain?

    This posting is provided "AS IS" with no warranties, and confers no rights.
    giovedì 11 marzo 2010 06:29
  • Hi!

    I have encountered the same problem.
    I have 2 file servers w2k3 R2 on which i have DFS shares and the replication between them. The namespace servers are my two DCs (W2k8 R2).
    I have added another file server, this one on W2k8 R2. After i have added this server to DFS and started the replication, some (not all) folders
    became "very hidden". The folder are still accessible through the namespace name, but not directly. The problem is that some
    aplications are writing directly to d:\foldername\filename, which is not possible any more.
    I have tried with attrib -h, but I got: Not resetting system file - d:\foldername.

    In the mean time we have also raised the domain functional level to Windows 2008 R2 (thought it would help), the namespace is Domain-level Windows
    Server 2000 (i do not know why).

    Any help is appreciated.

    • Proposto come risposta em3601 martedì 30 marzo 2010 07:57
    martedì 16 marzo 2010 13:46
  • I have exactly the same issue. 

    A new replicated DFS share, the source folder on the hub server is no longer visible in the file system. I can get to it via the share, and the namespace though. Any suggestions?

    • Proposto come risposta iimmy giovedì 22 luglio 2010 06:08
    mercoledì 23 giugno 2010 14:10
  • I had the same issue with one of my File server. I tried the ATTRIB command to unhide it:


    attrib -r -h -s "G:\folder_name"




    • Proposto come risposta Cwestwell lunedì 25 luglio 2011 20:48
    giovedì 22 luglio 2010 06:09
  • iimmy - you cracked it.


    venerdì 15 ottobre 2010 16:34
  • thanks for the easy fix, this did it for me.....I was very confused


    lunedì 25 luglio 2011 20:48
  • I had this exact same issue, but after un-hiding it with the attrib command it happens again but only on a few folders. What is causing it to be hidden. Its happening every morning. 
    giovedì 10 gennaio 2013 22:59
  • Attrib works for me also.


    martedì 5 febbraio 2013 08:28
  • Attrib did work,

    but some hours later the dfs-shares are hidden again.

    Howto fix this permanent?


    mercoledì 6 febbraio 2013 06:58
  • It's happening with me too. Folders are getting hidden locally after editing the DFS replication schedule. Once changed, folders get messed up (My luck that users was not affected by this)

    Edited Specs:

    Windows Server 2012 std. Fully Updated

    MS Partner - MCP

    mercoledì 20 febbraio 2013 12:06
  • Anybody having a solution for this recuring issue?


    mercoledì 20 febbraio 2013 19:05
  • We had this problem in our company as well. We found out it was some malware on a users workstation that was causing the issue of the folders being hidden and attrib was the only way to get it back. One we found the malwared computer the issue never came back.
    martedì 5 marzo 2013 23:03
  • thank u buddy.its really amazing
    martedì 16 luglio 2013 11:17
  • Thanks Imran this did it for me
    • Modificato E_Leo giovedì 17 agosto 2017 07:14
    giovedì 17 agosto 2017 07:13
  • I had the same issue with one of my File server. I tried the ATTRIB command to unhide it:


    attrib -r -h -s "G:\folder_name"




    LEGEND !!!
    venerdì 18 maggio 2018 09:49