none
Problema di compatibilità tra RDS e Windows CE 4 RRS feed

  • Domanda

  • Buongiorno a tutti e grazie in anticipo a chi vorrà aiutarmi.

    Ad un Cliente ho fornito un Server con Windows Server 2008 Standard (non ho potuto fornire il 2012 per problemi di certificazione con il loro software gestionale).

    Il Cliente utilizza una decina di terminali/palmari a codice a barre (Symbol/Motorola MC3190) per le attività di magazzino collegandosi con Terminal Server (ora RDS) al gestionale tramite RDP.

    Alcuni di questi palmari hanno come sistema operativo Windows CE 4.2 che adotta RDP 5.2 il quale quando si tenta la connessione restituisce l'errore "Impossibile accedere al computer remoto, errore di protezione.". I terminali più nuovi con Windows CE 5 (e RDP 6.0) non hanno alcun problema.

    Ho notato che l'errore si verifica dal momento in cui si attiva il Server Licenze di RDS e che si verifica anche su PC con Windows XP e RDP con versione precedente alla 6. E' come se in quel momento vengano attivate delle policy che impediscono la connessione alle versioni anziane di RDP.

    Ovviamente sul precedente Windows Server 2013 e Terminal Server questo non si verifica.

    Capisco che la versione di RDP (che su Windows XP è aggiornabile ma su CE non lo è) sia obsoleta (5.2) ma non posso ovviamente imporre al Cliente  di sostituire circa 10 palmari che costano sui 900 euro / cad solo perchè Microsoft ha deciso di non supportare tale protocollo.

    Nella configurazione di RDS non è possibile configurare connessioni precedenti alla 6 (il menù a tendina relativo risulta sempre disattivato).

    Chiedo se c'è un modo di bypassare il problema o qualche workaround funzionante.

    Grazie a tutti.

    Simone Ferrari

    • Tipo modificato Anca Popa lunedì 13 gennaio 2014 17:12 in attesa di ulteriori feedback
    • Tipo modificato Anca Popa venerdì 24 gennaio 2014 12:57 domanda con risposta
    martedì 7 gennaio 2014 12:14

Risposte

Tutte le risposte

  • Nelle proprietà della connessione prova ad impostare come "Security layer" la voce "RDP Security Layer" e verifica che la voce "Allow connections only from computers running Remote Desktop with Network level Authentication" sia disabilitata. Prova inoltre ad impostare anche "Encryption level"su "Low".

    Considera però che queste impostazioni potrebbero causare dei rischi per sicurezza quindi ricorda di eseguirle in un ambiente di test o di utilizzarle per il tempo necessario all'esecuzione del test con i dispositivi in questione.

    Per ulteriori informazioni su queste impostazioni ti consiglio la lettura di queste pagine:

    http://technet.microsoft.com/it-it/library/cc770833.aspx

    http://technet.microsoft.com/it-it/library/cc732713.aspx


    martedì 7 gennaio 2014 14:35
    Moderatore
  • Purtroppo ho già provato tutte le combinazioni possibili di quelle impostazioni senza successo.

    La questione è che questo "blocco" si attiva nel momento in cui attivo il Server Licenze di RDS se disattivo il Server Licenze riprende a funzionare, quindi penso sia una policy di sicurezza legata a quella funzione.
    • Modificato atlinfo martedì 7 gennaio 2014 15:07
    martedì 7 gennaio 2014 15:01
    • Proposto come risposta Anca Popa lunedì 13 gennaio 2014 17:12
    • Contrassegnato come risposta Anca Popa venerdì 24 gennaio 2014 12:58
    martedì 7 gennaio 2014 15:38
    Moderatore
  • Ciao,

    Non abbiamo ricevuto alcun aggiornamento e mi chiedevo se possiamo aiutarti ulteriormente o se il tuo quesito è stato risolto.

    Se così fosse ti saremmo grati di condividere il feedback in questo spazio ricordandoti che altri membri della community potrebbero riscontrare comportamenti simili.

    Grazie in anticipo,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    lunedì 13 gennaio 2014 17:12
  • Ciao,

    non ho più scritto perché non ho aggiornamenti di rilievo. Al momento ho lasciato attivo il vecchio Server 2003 affiancato al nuovo per gestire le connessioni con i vecchi terminali CE4 e la situazione rimarrà così fino ad esaurimento degli stessi che progressivamente il Cliente sostituirà con i nuovi.

    Ho cercando ovunque e credo che questo sia un problema insormontabile di incompatibilità voluto da MS per eliminare i vecchi dispositivi (esattamente com'è avvenuto con Office 2013 e Exchange 2003..).

    Grazie a tutti comunque.

    Simone Ferrari



    giovedì 13 marzo 2014 15:22